[RESOLU] AntiX16 : il manque certains environnements

Tout concernant les autres distributions
Avatar du membre
Mia88
Messages : 128
Enregistré le : ven. 18 nov. 2016 08:42
Localisation : Lorraine

[RESOLU] AntiX16 : il manque certains environnements

Messagepar Mia88 » ven. 21 avr. 2017 12:04

Bonjour,
Si je compare avec la vidéo de f.x0, je n'ai pas les environnements MATE, LXDE que j'aimerais bien essayer, et d'autres.
Je lis dans son message qu'il y a eu une mise à jour vers Debian9, c'est peut pour cela ?
Mais je ne sais pas comment faire cette maj :oops:

Image

Pourriez-vous m'aider également à installer les additions invités svp ?
En mode graphique je n'ai pas les droits :

Image

J'ai lu (et déjà fait pour une autre VM) qu'il fallait entrer une commande spéciale si c'est basé sur Debian :
apt-get install build-essential dkms gcc linux-headers-`uname -r`
Je suis nulle en anglais, mais on dirait que ça ne convient pas :

Image

Si je fais l'impasse sur cette commande, voilà le résultat :

Image

Merci d'avance :)
Modifié en dernier par Mia88 le dim. 7 mai 2017 18:16, modifié 1 fois.
Multi boot Windows 7 / Windows 10 / Linux Mint 18.1 Cinnamon 64-bits version 3.2.7
Noyau Linux 4.4.0-21-generic / Processeur Intel Core 2 Quad CPU Q9450 @2.66Gz x 4 / Mémoire vive 3.9 Go / Carte graphique NVIDIA GeForce GT730
Virtualbox en 64 bits : Linux Poutoux / Peppermint / MX-16 / Antix16 / Debian / DFLinux / Manjaro

Avatar du membre
mpat
Messages : 5807
Enregistré le : mar. 25 août 2015 21:12
Localisation : Belgique

Re: AntiX16 : il manque certains environnements

Messagepar mpat » ven. 21 avr. 2017 14:05

salut mia j'ai refais mon poste plus bas
Modifié en dernier par mpat le ven. 21 avr. 2017 17:38, modifié 1 fois.
Asus x53sd, I5- 2.5/3.1 ghz, 8go ram,
dual gpu Intel/Nvidia pilotes 381.09, ssd 256 + hdd 750
Lmint 18.2 - Cinnamon 64-bit, kernel 4.11.1-041101

une connaissance de votre matériel sera un plus pour vous aider, devin c'est bien mais on va pas loin,
http://forum-francophone-linuxmint.fr/v ... f=2&t=1514

Avatar du membre
roromint
Messages : 1745
Enregistré le : dim. 28 févr. 2016 21:09
Localisation : Grandglise
Contact :

Re: AntiX16 : il manque certains environnements

Messagepar roromint » ven. 21 avr. 2017 15:59

alut marina
une chose que tu as dis

Code : Tout sélectionner

sudo cp -R /media/cdrom0/* /tmp/vboxadd/
sudo chmod +x VBoxLinuxAdditions.run
sudo sh ./VBoxLinuxAdditions.run
je suis malentendant cas une problème du dyslexique. merci vos respect :)
----------------------------------------------------
Image

Avatar du membre
mpat
Messages : 5807
Enregistré le : mar. 25 août 2015 21:12
Localisation : Belgique

Re: AntiX16 : il manque certains environnements

Messagepar mpat » ven. 21 avr. 2017 16:54

aller avant que roro ne te fasse faire des bêtises

Code : Tout sélectionner

sudo apt-get update ; apt-get upgrade

Code : Tout sélectionner

sudo apt-get install build-essential

Code : Tout sélectionner

sudo apt-get install build-essential module-assistant

Code : Tout sélectionner

sudo apt-get install build-essential dkms gcc linux-headers-`uname -r`

Code : Tout sélectionner

sudo mkdir /tmp/vboxadd

Code : Tout sélectionner

cd /tmp/vboxadd

Code : Tout sélectionner

wget http://ftp.us.debian.org/debian/pool/non-free/v/virtualbox-guest-additions-iso/virtualbox-guest-additions-iso_5.1.20-1_all.deb


ouvres files manager et rendez-vous dans /tmp/vboxadd .. ici monter l'image iso voir image ci-desous.
Image

Code : Tout sélectionner

mount /media/cdrom

Code : Tout sélectionner

sh /media/cdrom/VBoxLinuxAdditions.run

redémarrer ton système

pour les autres environnements comme mate, lxde, xfce etc .. et autres tu les trouves dans synaptic
Modifié en dernier par mpat le lun. 24 avr. 2017 15:49, modifié 1 fois.

Avatar du membre
Mia88
Messages : 128
Enregistré le : ven. 18 nov. 2016 08:42
Localisation : Lorraine

Re: AntiX16 : il manque certains environnements

Messagepar Mia88 » lun. 24 avr. 2017 10:54

Bonjour mpat et roro et merci beaucoup pour vos réponses ;)

Excusez ma réponse tardive, je n'ai pas eu le temps ce week-end.
La première commande, c'est ok :
sudo apt-get update ; apt-get upgrade

Là, c'est bon aussi :
sudo apt-get install build-essential

Image

Mais pour la 3ème, ça ne va pas :
sudo apt-get install build-essential module-assistant

Image

Je continue tout de même :
sudo apt-get install build-essential dkms gcc linux-headers-`uname -r`

Image

Ensuite :
mkdir /tmp/vboxadd
cd /tmp/vboxadd

Ça à l'air de passer.

Puis :
wget http://ftp.us.debian.org/debian/pool/no ... -1_all.deb

Je recopie tout à la main puisque je n'ai pas le presse-papier bi-directionnel, je me suis relue plusieurs fois, j'espère ne pas avoir loupé une erreur de saisie :

Image

Puis tu dis "ouvres files manager et rendez-vous dans /tmp/vboxadd .. ici monter l'image iso voir image ci-desous."

Je pense que je dois rencontrer un problème avec l'extention des additions, car tu parles d'image iso, alors que l'extension que j'ai est au format expack !
J'avais pu cependant l'ajouter à Virtualbox, c'est pour l'insérer dans les machines que ça ne va plus.

/home/mia/Téléchargements/Oracle_VM_VirtualBox_Extension_Pack-5.1.20.vbox-extpack

Sinon, pas de dossier vobxadd dans tmp de l'hôte:

Image

Dans le tmp de l'invité, c'est vide :

Image

Quand je veux insérer depuis Périphérique :

Image

Et pour la fin :
mount /media/cdrom
sh /media/cdrom/VBoxLinuxAdditions.run

Image

Là, je ne sais pas si je dois accepter ou pas :?

Encore merci :)
Modifié en dernier par Mia88 le lun. 24 avr. 2017 11:55, modifié 3 fois.
Multi boot Windows 7 / Windows 10 / Linux Mint 18.1 Cinnamon 64-bits version 3.2.7
Noyau Linux 4.4.0-21-generic / Processeur Intel Core 2 Quad CPU Q9450 @2.66Gz x 4 / Mémoire vive 3.9 Go / Carte graphique NVIDIA GeForce GT730
Virtualbox en 64 bits : Linux Poutoux / Peppermint / MX-16 / Antix16 / Debian / DFLinux / Manjaro

Avatar du membre
tyrry
Messages : 2276
Enregistré le : mar. 21 juil. 2015 07:42
Localisation : à l'ouest

Re: AntiX16 : il manque certains environnements

Messagepar tyrry » lun. 24 avr. 2017 11:05

Slt Mia88 ,
la 3ème commande ne fonctionne pas car tu as fait une erreur de frappe : tu as mis buid au lieux de build ;)
ce n'est pas important dans la mesure ou dans la 2ème commande build-essential est déjà installer ;)

@+
Image

Avatar du membre
Mia88
Messages : 128
Enregistré le : ven. 18 nov. 2016 08:42
Localisation : Lorraine

Re: AntiX16 : il manque certains environnements

Messagepar Mia88 » lun. 24 avr. 2017 11:16

Aïe, quelle mauvaise vue, merci tyrry :D
J'ai donc répondu non à la fin et je reprends à partir de là ;)

Edit :
Cette commande a bien fonctionné avec la correction, mais la suivante donne toujours la même réponse :
Virtual packages like 'linux-headers' can't be removed
E: Impossible de trouver le paquet uname -r

@roro : j'ai essayé aussi tes commandes, sans succès :

Image
Multi boot Windows 7 / Windows 10 / Linux Mint 18.1 Cinnamon 64-bits version 3.2.7
Noyau Linux 4.4.0-21-generic / Processeur Intel Core 2 Quad CPU Q9450 @2.66Gz x 4 / Mémoire vive 3.9 Go / Carte graphique NVIDIA GeForce GT730
Virtualbox en 64 bits : Linux Poutoux / Peppermint / MX-16 / Antix16 / Debian / DFLinux / Manjaro

Avatar du membre
roromint
Messages : 1745
Enregistré le : dim. 28 févr. 2016 21:09
Localisation : Grandglise
Contact :

Re: AntiX16 : il manque certains environnements

Messagepar roromint » lun. 24 avr. 2017 12:47

Mia88 a écrit :Bonjour mpat et roro et merci beaucoup pour vos réponses ;)

Excusez ma réponse tardive, je n'ai pas eu le temps ce week-end.
La première commande, c'est ok :
sudo apt-get update ; apt-get upgrade

Là, c'est bon aussi :
sudo apt-get install build-essential

Image

Mais pour la 3ème, ça ne va pas :
sudo apt-get install build-essential module-assistant

Image

Je continue tout de même :
sudo apt-get install build-essential dkms gcc linux-headers-`uname -r`

Image

Ensuite :
mkdir /tmp/vboxadd
cd /tmp/vboxadd

Ça à l'air de passer.

Puis :
wget http://ftp.us.debian.org/debian/pool/no ... -1_all.deb

Je recopie tout à la main puisque je n'ai pas le presse-papier bi-directionnel, je me suis relue plusieurs fois, j'espère ne pas avoir loupé une erreur de saisie :

Image

Puis tu dis "ouvres files manager et rendez-vous dans /tmp/vboxadd .. ici monter l'image iso voir image ci-desous."

Je pense que je dois rencontrer un problème avec l'extention des additions, car tu parles d'image iso, alors que l'extension que j'ai est au format expack !
J'avais pu cependant l'ajouter à Virtualbox, c'est pour l'insérer dans les machines que ça ne va plus.

/home/mia/Téléchargements/Oracle_VM_VirtualBox_Extension_Pack-5.1.20.vbox-extpack

Sinon, pas de dossier vobxadd dans tmp de l'hôte:

Image

Dans le tmp de l'invité, c'est vide :

Image

Quand je veux insérer depuis Périphérique :

Image

Et pour la fin :
mount /media/cdrom
sh /media/cdrom/VBoxLinuxAdditions.run

Image

Là, je ne sais pas si je dois accepter ou pas :?

Encore merci :)


ta encore une maque l comme build !
bah

Code : Tout sélectionner

sudo mkdir VBoxadd (dans le /tmp


et tu dis accepte que tu tapes "yes" :)
je suis malentendant cas une problème du dyslexique. merci vos respect :)
----------------------------------------------------
Image

Avatar du membre
mpat
Messages : 5807
Enregistré le : mar. 25 août 2015 21:12
Localisation : Belgique

Re: AntiX16 : il manque certains environnements

Messagepar mpat » lun. 24 avr. 2017 17:54

salut Mia, j'ai recommencer les manipulations dans une nouvelle vm, et j'ai pas eu de soucis, tu aurais plus de chance en faisant un copier coller des commandes, plutôt que de vouloir les taper toi-même, ça évite des erreurs.

Avatar du membre
débitant
Messages : 4493
Enregistré le : mar. 14 juil. 2015 18:22
Localisation : Lorraine France

Re: AntiX16 : il manque certains environnements

Messagepar débitant » lun. 24 avr. 2017 20:41

bonjour
conseil de présentation
plutôt que de faire une capture d'écran du terminal, faire un copier de celui-ci et le coller dans le message entre les balises "code", c'est plus simple et plus facile à suivre ;)
pour l'utilisation des balises voir ici
Aide pour une signature utile - Mettre un sujet comme résolu - Poster dans la bonne rubrique - tuto barre d'outils des messages - Poster une image, capture d'écran

desktop : Dell Dimension E520 /dual Xp pro LM17.3 Cinnamon 32b /3.16.0-38 /Intel pentium D CPU 2.80Ghz x2 /ram 3Go /dd 320Go(125Go pour LM) /CG Intel corp 82G965 Int Grap Cont
laptop:Dell inspiron 6400/LMDE 2 Cinnamon 64b/3.16-4-amd64/Int cor 2 cpu 1,66 x2/ram 1Go/dd 80Go/CG Int Corp mob 945GM/GMS Exp Int Grap Cont


Retourner vers « Autres distributions »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité