Raspberry Pi 4B + OpenPlotter

Tout concernant les autres distributions
Répondre
Avatar du membre
SylvieNew
Messages : 126
Enregistré le : mer. 16 mars 2022 17:44
Localisation : Port-De-Bouc (13)

Raspberry Pi 4B + OpenPlotter

Message par SylvieNew »

Bonjour à tous et bonne année 2024

J'ai un soucis : l'un des programmes de navigation de mon RPi (OpenCpn) ne fonctionne plus (il démarre, et se ferme tout seul aussitôt après le démarrage. J'ai récemment fait une MàJ qui a été fatale et je ne sais pas où chercher

Voilà ce que je peux afficher :

Code : Tout sélectionner

pi@openplotter:~ $ sudo apt update
Atteint :1 http://ppa.launchpad.net/opencpn/opencpn/ubuntu bionic InRelease
Atteint :2 http://ppa.launchpad.net/openplotter/openplotter/ubuntu bionic InRelease
Réception de :3 https://repos.influxdata.com/debian buster InRelease [7 047 B] 
Réception de :4 https://deb.nodesource.com/node_10.x buster InRelease [4 584 B]
Réception de :5 https://packages.grafana.com/oss/deb stable InRelease [5 983 B]
Atteint :6 http://archive.raspberrypi.org/debian buster InRelease              
Err :3 https://repos.influxdata.com/debian buster InRelease     
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY D8FF8E1F7DF8B07E
Err :5 https://packages.grafana.com/oss/deb stable InRelease
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 963FA27710458545
Atteint :7 http://raspbian.raspberrypi.org/raspbian buster InRelease
Atteint :8 https://www.free-x.de/deb4op buster InRelease
11,6 ko réceptionnés en 6s (1 988 o/s)           
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Tous les paquets sont à jour.
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : https://repos.influxdata.com/debian buster InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY D8FF8E1F7DF8B07E
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : https://packages.grafana.com/oss/deb stable InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 963FA27710458545
W: Impossible de récupérer https://repos.influxdata.com/debian/dists/buster/InRelease  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY D8FF8E1F7DF8B07E
W: Impossible de récupérer https://packages.grafana.com/oss/deb/dists/stable/InRelease  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 963FA27710458545
W: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
pi@openplotter:~ $
Je vous serais très reconnaissante de me venir en aide . A très vite
HP-Pavilion-dv7-Notebook-PC | Linux Mint 21.3 Virginia Cinnamon
CPU : Quad Core model: AMD Phenom II P960 bits: 64 type: MCP
CG : AMD RS880M [Mobility Radeon HD 4225/4250] driver: radeon | AMD Seymour [Radeon HD 6400M/7400M Series] driver: radeon
RAM : 5.56 GiB

Avatar du membre
cyrille
Administrateur du site
Messages : 12510
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nowhere
Contact :

Re: Raspberry Pi 4B + OpenPlotter

Message par cyrille »

Code : Tout sélectionner

W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : https://repos.influxdata.com/debian buster InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY D8FF8E1F7DF8B07E
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : https://packages.grafana.com/oss/deb stable InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 963FA27710458545
W: Impossible de récupérer https://repos.influxdata.com/debian/dists/buster/InRelease  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY D8FF8E1F7DF8B07E
W: Impossible de récupérer https://packages.grafana.com/oss/deb/dists/stable/InRelease  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 963FA27710458545
W: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
Tu as des soucis de clefs à régler
une recherche sur le forum devrait te donner des piste

Ensuite voir si les repos installés en complémentaire correspondent bien à la version de ta Mint

Désolé, je passe en très grand vitesse ;)

++
?séuqartéd sel ruoP / sécnoféd sel ruoP / sreiruréB sel ruoP / ?étéicos elleuQ

https://crust.ovh

Avatar du membre
SylvieNew
Messages : 126
Enregistré le : mer. 16 mars 2022 17:44
Localisation : Port-De-Bouc (13)

Re: Raspberry Pi 4B + OpenPlotter

Message par SylvieNew »

Bonjour à toutes et à tous, et bonne année.
Comme évoqué plus haut, j'ai des soucis.
Concernant OpenCpn, je l'ai désinstallé, puis ré-installé, et ça semble fonctionner.
Pour ce qui est des clefs ( merci Cyrille) :

Code : Tout sélectionner

Tu as des soucis de clefs à régler
une recherche sur le forum devrait te donner des piste

Ensuite voir si les repos installés en complémentaire correspondent bien à la version de ta Mint

Désolé, je passe en très grand vitesse ;)
1 Je ne sais pas à quoi servent ces fameuses clefs (ni où je vais pouvoir les trouver :lol:

2 Concernant les repos, là il y a un hic, parce que le RPi n'est pas à la menthe, mais à la Framboise
:l :l :lol:

En tout cas, j'ai voulu faire un "update" du RPi et j'ai donc fait ça:

Ctrl + At + "t", j'ai mon terminal qui s'ouvre, je lui demande sudo raspi-config, et il m'affiche ça :

Code : Tout sélectionner

Raspberry Pi 4 Model B Rev 1.4


┌─────────┤ Raspberry Pi Software Configuration Tool (raspi-config) ├──────────┐
│                                                                              │
│       1 System Options       Configure system settings                       │
│       2 Display Options      Configure display settings                      │
│       3 Interface Options    Configure connections to peripherals            │
│       4 Performance Options  Configure performance settings                  │
│       5 Localisation Options Configure language and regional settings        │
│       6 Advanced Options     Configure advanced settings                     │
│       8 Update               Update this tool to the latest version          │
│       9 About raspi-config   Information about this configuration tool       │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
│                                                                              │
│                     <Select>                     <Finish>                    │
│                                                                              │
└──────────────────────────────────────────────────────────────────────────────┘



Donc je mets la ligne "8" en surbrillance et "Entrée" et voilà ce qu'il m'affiche :

Code : Tout sélectionner

pi@openplotter:~ $ sudo raspi-config
Atteint :1 http://ppa.launchpad.net/opencpn/opencpn/ubuntu bionic InRelease
Réception de :2 http://raspbian.raspberrypi.org/raspbian buster InRelease [15,0 kB]
Atteint :3 http://archive.raspberrypi.org/debian buster InRelease              
Atteint :4 http://ppa.launchpad.net/openplotter/openplotter/ubuntu bionic InRelease
Réception de :5 https://repos.influxdata.com/debian buster InRelease [7 047 B] 
Atteint :6 https://www.free-x.de/deb4op buster InRelease                       
Réception de :7 https://packages.grafana.com/oss/deb stable InRelease [5 983 B]
Réception de :8 http://raspbian.raspberrypi.org/raspbian buster/main armhf Packages [13,0 MB]
Err :5 https://repos.influxdata.com/debian buster InRelease
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY D8FF8E1F7DF8B07E
Err :7 https://packages.grafana.com/oss/deb stable InRelease
  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 963FA27710458545
Réception de :9 https://deb.nodesource.com/node_10.x buster InRelease [4 584 B]
13,0 Mo réceptionnés en 13s (1 039 ko/s)                                       
Lecture des listes de paquets... Fait
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : https://repos.influxdata.com/debian buster InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY D8FF8E1F7DF8B07E
W: Une erreur s'est produite lors du contrôle de la signature. Le dépôt n'est pas mis à jour et les fichiers d'index précédents seront utilisés. Erreur de GPG : https://packages.grafana.com/oss/deb stable InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 963FA27710458545
W: Impossible de récupérer https://repos.influxdata.com/debian/dists/buster/InRelease  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY D8FF8E1F7DF8B07E
W: Impossible de récupérer https://packages.grafana.com/oss/deb/dists/stable/InRelease  Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 963FA27710458545
W: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
raspi-config est déjà la version la plus récente (20210212).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.
Sleeping 5 seconds before reloading raspi-config
pi@openplotter:~ $ 
Bon, et déjà là, je vois que Cyrille a raison, que j'ai des problèmes avec le double des clefs....... que le GPG est parti en cacahuètes etc. etc .

Mais ça ne m'arrange pas beaucoup, je ne sais pas où chercher ..... :cry:

Ah oui, et puis j'ai un autre problème et de taille celui-là : Je ne sais pas pourquoi, m'ai l'affichage à l'écran est très très, mais alors très très instable écran noir, puis allumé, noir puis allumé, à fréquences variables comme si c'était un faux contact, (alors que je suis certaine que ce n'en est pas un) (en bas de l'écran, qu'il soit noir ou normal, j'ai une alternance de "HDMI" ou "DVI" suivi de la valeur " 720p@60Hz", mais qui reste la même) Désolée, mais dans ces cas là je ne sais pas faire de copie d'écran ......

SOSSSSSS s'il vous plaît
HP-Pavilion-dv7-Notebook-PC | Linux Mint 21.3 Virginia Cinnamon
CPU : Quad Core model: AMD Phenom II P960 bits: 64 type: MCP
CG : AMD RS880M [Mobility Radeon HD 4225/4250] driver: radeon | AMD Seymour [Radeon HD 6400M/7400M Series] driver: radeon
RAM : 5.56 GiB

Avatar du membre
cyrille
Administrateur du site
Messages : 12510
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nowhere
Contact :

Re: Raspberry Pi 4B + OpenPlotter

Message par cyrille »

Pas sûr vu la variété des dépots, mais en général ça se règle en ajoutant les clefs nécessaires

Code : Tout sélectionner

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com D8FF8E1F7DF8B07E
sudo apt-get update
Pour chacune des clefs manquantes
Mais j'ai un sérieux doute vu que ce sont des repos debian

Sinon allez sur les repos officiels. Exemple et suivre procédure pour ajout des clefs
https://repos.influxdata.com/debian/

Code : Tout sélectionner

  wget -q https://repos.influxdata.com/influxdata-archive_compat.key
  echo '393e8779c89ac8d958f81f942f9ad7fb82a25e133faddaf92e15b16e6ac9ce4c influxdata-archive_compat.key' | sha256sum -c && cat influxdata-archive_compat.key | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/influxdata-archive_compat.gpg > /dev/null
  echo 'deb [signed-by=/etc/apt/trusted.gpg.d/influxdata-archive_compat.gpg] https://repos.influxdata.com/debian stable main' | sudo tee /etc/apt/sources.list.d/influxdata.list
?séuqartéd sel ruoP / sécnoféd sel ruoP / sreiruréB sel ruoP / ?étéicos elleuQ

https://crust.ovh

Avatar du membre
SylvieNew
Messages : 126
Enregistré le : mer. 16 mars 2022 17:44
Localisation : Port-De-Bouc (13)

Re: Raspberry Pi 4B + OpenPlotter

Message par SylvieNew »

Petite précision concernant les problèmes d'affichage,
" si lors de l'affichage à l'écran, il y a une fenêtre ouverte, c'est (entre autre ) à ce moment là que ça part en vrille "

Je ne sais pas pourquoi, mais c'est un symptôme que j'ai pu observé. En revanche, lorsque j'ai un écran comme ça, c'est stable :
(Ah ben zut ! je n'arrive pas à insérer une image !!!)

je ne sais pas si ça vous aide à comprendre .....

Ah ben non, il y a du nouveau: Dans la fameuse ligne du bas " HDMI " DVI " etc. la valeur change, de temps à autres, ça passe de 720p@60Hz à ---*720@60Hz ou ---*721@60Hz, et puis ça revient à 720p@60Hz, et puis un coup avec "HDMI" devant, ou "DVI", enfin bref c'est impossible de travailler avec ça !!!
HP-Pavilion-dv7-Notebook-PC | Linux Mint 21.3 Virginia Cinnamon
CPU : Quad Core model: AMD Phenom II P960 bits: 64 type: MCP
CG : AMD RS880M [Mobility Radeon HD 4225/4250] driver: radeon | AMD Seymour [Radeon HD 6400M/7400M Series] driver: radeon
RAM : 5.56 GiB

Avatar du membre
cyrille
Administrateur du site
Messages : 12510
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nowhere
Contact :

Re: Raspberry Pi 4B + OpenPlotter

Message par cyrille »

là j'avoue ne plus suivre la problématique ;) ....
?séuqartéd sel ruoP / sécnoféd sel ruoP / sreiruréB sel ruoP / ?étéicos elleuQ

https://crust.ovh

Avatar du membre
SylvieNew
Messages : 126
Enregistré le : mer. 16 mars 2022 17:44
Localisation : Port-De-Bouc (13)

Re: Raspberry Pi 4B + OpenPlotter

Message par SylvieNew »

Ah Cyrille, moi non plus je n'y comprends plus rien, l'affichage est tellement instable que là, je t'écris depuis le PC ( pas le RPi )
alors je vais essayer d'être plus méthodique: comment puis-je vérifier la stabilité de mon affichage sur le Rpi (j'ai le sentiment que cette instabilité est liée à un programme en cours, (en l'occurence en utilisant "Chromium" et en parcourant les post du FFLM, c'est infernal )
HP-Pavilion-dv7-Notebook-PC | Linux Mint 21.3 Virginia Cinnamon
CPU : Quad Core model: AMD Phenom II P960 bits: 64 type: MCP
CG : AMD RS880M [Mobility Radeon HD 4225/4250] driver: radeon | AMD Seymour [Radeon HD 6400M/7400M Series] driver: radeon
RAM : 5.56 GiB

Répondre