PB Impression/scan entre MINT19 et LEXMARK PRO705

Questions concernant les composants
zadigp33
Messages : 25
Enregistré le : jeu. 11 août 2016 21:47
Localisation : Gironde 33

PB Impression/scan entre MINT19 et LEXMARK PRO705

Message par zadigp33 » dim. 9 sept. 2018 16:37

Bonjour.

Je viens vers vous car suite à l’installation d’un nouveau PC (l’ancien est HS), depuis 1 mois, je n’arrive pas à faire fonctionner mon imprimante/scanner ‘LEXMARK Prévail PRO705’ ni en USB, ni en Wifi et ni même en fonction scanner.

Pour Info : cette imprimante fonctionnait parfaitement sur mon ancien PC en MINT18.3 et fonctionne toujours parfaitement sous Windows XP et Windows 7 PRO.

Donc sur mon nouveau PC (DELL E6540), j’ai installé MINT18.3 et impossible de la faire fonctionner. Puis sur une autre partition j’ai installé MINT 19 v2. Idem toujours le même PB, l’imprimante reste « Inactif - Rendering completed » et le document à imprimer passe à l’état « Arrêté » dans la file d’attente d’impression.

Précisions : j’avais déjà eu ce PB sur mon ancien PC Mint18.3 que j’avais résolu par toute la série de commandes et conseils suivants que j’avais trouvés ici et sur d’autres forums :
- Remplacement dans UMF.SH de ‘JAVA VERSION’ par ‘OPENJDK VERSION’ (script livré avec driver Lexmark Pro700).
sudo chmod 755 /usr/local/lexmark/v3/bin/printfilter
sudo chgrp bin /usr/local/lexmark/v3/bin/printfilter
sudo adduser pat lp (pat = mon nom utilisateur)
puis sudo /etc/init.d/cups restart pour redémarrer CUPS.
Rien n’y a fait.
J’ai aussi tenté d’imprimer via 'lpr -H localhost:631 fichier_à_imprimer' = idem

J’ai supprimé toutes les imprimantes et les ai recrées par le menu CUPS (localhost:631) en utilisant les fichiers ppd fournis par MINT19 = idem.

Dans le fichier « troubleshoot-logs.txt » je récupère ce message :’’ sept. 07 15:15:36 pat-E6540 /hpfax[3148]: [3148]: error: Failed to create /var/spool/cups/tmp/.hplip’’

Et dans le fichier troubleshoot.txt qui est généré par le débogage du pb intégré au gestionnaire d’imprimantes, j’ai plein de messages mais il est très gros et ne le mettrez ici qu’à votre demande.

Dernière info complémentaire, vu que mon imprimante ne fonctionnait plus ni sous MINT18.3, ni sous MINT19, j’ai reformatté mon HDD et y ai réinstallé Windows 7 Pro pour avoir des impressions qui fonctionnent et MINT19 sur lequel j’ai refait toutes les manips ci dessus avec les mêmes symptômes.

Je fais donc appel à vous car mes compétences LINUX sont très limitées et je tourne en rond.
Pardon d’avoir été long, et merci d’avance pour votre aide.
Laptop DELL Latitude E6540 - CPU Intel© Core™ i5-4200M CPU @ 2.50GHz × 2 - RAM 8Go - HDD 500 Go - graphique Intel 4600 4th Gen Core Processor Integrated Graphics Controller - Carte WIFI & Bluetooth Intel Centrino Advanced-N 6230 [Rainbow Peak].
OS: Linux Mint 19 'TARA' - Cinnamon 3.8.9 - Noyau 4.15.0-34-generic x86_64 (64 bit).
Imprimante/scanner LEXMARK Prevail PRO 705 (wifi & usb) QUAND ELLE FONCTIONNERA.

Avatar du membre
débitant
modérateur
Messages : 8669
Enregistré le : mar. 14 juil. 2015 18:22
Localisation : Lorraine France

Re: PB Impression/scan entre MINT19 et LEXMARK PRO705

Message par débitant » dim. 9 sept. 2018 21:50

bonjour,
sujet déplacé dans "compatibilité matériel" ;)

zadigp33
Messages : 25
Enregistré le : jeu. 11 août 2016 21:47
Localisation : Gironde 33

Re: PB Impression/scan entre MINT19 et LEXMARK PRO705

Message par zadigp33 » lun. 10 sept. 2018 09:47

Bonjour,
ok merci.
Laptop DELL Latitude E6540 - CPU Intel© Core™ i5-4200M CPU @ 2.50GHz × 2 - RAM 8Go - HDD 500 Go - graphique Intel 4600 4th Gen Core Processor Integrated Graphics Controller - Carte WIFI & Bluetooth Intel Centrino Advanced-N 6230 [Rainbow Peak].
OS: Linux Mint 19 'TARA' - Cinnamon 3.8.9 - Noyau 4.15.0-34-generic x86_64 (64 bit).
Imprimante/scanner LEXMARK Prevail PRO 705 (wifi & usb) QUAND ELLE FONCTIONNERA.

Avatar du membre
squid-f
Messages : 30
Enregistré le : jeu. 1 sept. 2016 21:02
Localisation : Lyon, FR

Re: PB Impression/scan entre MINT19 et LEXMARK PRO705

Message par squid-f » jeu. 13 sept. 2018 07:22

Bonjour

Questions basiques (mais cela m'est arrivé de me faire prendre aussi...) :

* Est-ce que ton firmware est à jour ? (le site de Lexmark semble proposer un update suite à des problèmes de détection mais la version date apparemment)
* As-tu essayé d'installer le pilote LM ou Ubuntu du site de Lexmark ? Désintsaller celui pour LM et installer le plus récent pour Ubuntu (ou vice-versa) pour voir.
* Très basique (désolé) : Clique de droit sur ton imprimante dans le gestionnaire d'imprimante : est-ce que le sous-menu Activé est bien sélectionné ?

Courage...
Linux Mint 19.1 Cinnamon - Noyau:4.15.dernier à jour
Desktop PC- CPU:i5-4590S, RAM:8Go DDR3, CM:GB GA-H97M-D3H, SSD:Samsung Evo850 250Go

zadigp33
Messages : 25
Enregistré le : jeu. 11 août 2016 21:47
Localisation : Gironde 33

Re: PB Impression/scan entre MINT19 et LEXMARK PRO705

Message par zadigp33 » jeu. 13 sept. 2018 21:40

Bonsoir et merci de t'interesser à mon pb.

* Est-ce que ton firmware est à jour ? (le site de Lexmark semble proposer un update suite à des problèmes de détection mais la version date apparemment) => oui (imprimante en mode de MàJ automatique firmware du 23/02/2012)

* As-tu essayé d'installer le pilote LM ou Ubuntu du site de Lexmark ? Désintsaller celui pour LM et installer le plus récent pour Ubuntu (ou vice-versa) pour voir. => oui c'est ce que j'essayais de dire en en disant que j'avais chargé les drivers Lexmark puis tester avec chgmt des drivers ubuntu (.ppd), et j'ai testé driver LM13 et Ubuntu 12.04.

* Très basique (désolé) : Clique de droit sur ton imprimante dans le gestionnaire d'imprimante : est-ce que le sous-menu Activé est bien sélectionné ? => oui et j'ai même testé avec option partagée cliquée et non cliquée.

J'ai peur que ça vienne d'une incompatibilité avec la version Java installée avec LM19.... ou bien qu'il me faille désinstaller puis réinstaller CUPS.
Mais j'ai fait une recherche sur 'cups' et il y a plein de choses qui l'utilisent, et il y a plein de modules au nom de CUPS-quelque chose et je ne sais pas lequel désinstaller pour le réinstaller.

Je ne sais plus où chercher.....et ce qui me manque, c'est la compréhension du fonctionnement interne des impressions sous Linux.

Je garde espoir.....
Laptop DELL Latitude E6540 - CPU Intel© Core™ i5-4200M CPU @ 2.50GHz × 2 - RAM 8Go - HDD 500 Go - graphique Intel 4600 4th Gen Core Processor Integrated Graphics Controller - Carte WIFI & Bluetooth Intel Centrino Advanced-N 6230 [Rainbow Peak].
OS: Linux Mint 19 'TARA' - Cinnamon 3.8.9 - Noyau 4.15.0-34-generic x86_64 (64 bit).
Imprimante/scanner LEXMARK Prevail PRO 705 (wifi & usb) QUAND ELLE FONCTIONNERA.

zadigp33
Messages : 25
Enregistré le : jeu. 11 août 2016 21:47
Localisation : Gironde 33

Re: PB Impression/scan entre MINT19 et LEXMARK PRO705

Message par zadigp33 » ven. 14 sept. 2018 17:08

Bonjour .
J'ai fait ce que j'hésitai à faire, à savoir:
désinstaller CUPS et ses fichiers de config via la commande:
sudo apt-get -y purge cups
Supprimer le .cups de mon home
Redémarrer le PC
Réinstaller cups par commande: sudo apt-get install cups --reinstall.
Recréer les imprimantes sans faire appel aux drivers LEXMARK, juste les drivers proposés par LM19.
Test: même problème.....

C'est quoi ce binz?
je ne vais tout de même pas revenir sous Windows à cause d'un pb d'impression!!!!!!!!
Help :x
Laptop DELL Latitude E6540 - CPU Intel© Core™ i5-4200M CPU @ 2.50GHz × 2 - RAM 8Go - HDD 500 Go - graphique Intel 4600 4th Gen Core Processor Integrated Graphics Controller - Carte WIFI & Bluetooth Intel Centrino Advanced-N 6230 [Rainbow Peak].
OS: Linux Mint 19 'TARA' - Cinnamon 3.8.9 - Noyau 4.15.0-34-generic x86_64 (64 bit).
Imprimante/scanner LEXMARK Prevail PRO 705 (wifi & usb) QUAND ELLE FONCTIONNERA.

Avatar du membre
débitant
modérateur
Messages : 8669
Enregistré le : mar. 14 juil. 2015 18:22
Localisation : Lorraine France

Re: PB Impression/scan entre MINT19 et LEXMARK PRO705

Message par débitant » ven. 14 sept. 2018 20:32

bonsoir,
je ne peux t'aider, mais as tu installé les pilotes linux voir https://fr.driverscollection.com/?H=Pre ... k&SS=Linux" onclick="window.open(this.href);return false;
;)

zadigp33
Messages : 25
Enregistré le : jeu. 11 août 2016 21:47
Localisation : Gironde 33

Re: PB Impression/scan entre MINT19 et LEXMARK PRO705

Message par zadigp33 » ven. 14 sept. 2018 21:22

Merci de ta réponse, mais oui, j'ai testé toutes les façons d'installer les pilotes (Linux Mint, UBUNTU et ceux livrés avec MINT 19 (.ppd)) en passant par l'interface graphique (Administration - Imprimantes) ou par CUPS (localhost:631).

Je ne pense pas que le pb vienne des drivers ou de la connexion/définition de l'imprimante car quelque soit la mèthode d'installation, l'imprimante est bien reconnue de façon automatique.
Je subodore que le PB se situe entre la sortie du spool et la fonction de gestion de l'impression.
Mais j'ai peut être le nez bouché :)
Laptop DELL Latitude E6540 - CPU Intel© Core™ i5-4200M CPU @ 2.50GHz × 2 - RAM 8Go - HDD 500 Go - graphique Intel 4600 4th Gen Core Processor Integrated Graphics Controller - Carte WIFI & Bluetooth Intel Centrino Advanced-N 6230 [Rainbow Peak].
OS: Linux Mint 19 'TARA' - Cinnamon 3.8.9 - Noyau 4.15.0-34-generic x86_64 (64 bit).
Imprimante/scanner LEXMARK Prevail PRO 705 (wifi & usb) QUAND ELLE FONCTIONNERA.

Avatar du membre
beldonne
Messages : 137
Enregistré le : lun. 13 juil. 2015 21:52
Localisation : grenoble-france

Re: PB Impression/scan entre MINT19 et LEXMARK PRO705

Message par beldonne » sam. 15 sept. 2018 05:13

bonjour,
n'est ce pas le mème pb,évoqué et réglé par papy 2228?
viewtopic.php?f=23&t=11078" onclick="window.open(this.href);return false;
bonne journée
:lol: :lol: :lol:
desktop:packard bell :linux-18.3-mate-64b -MX17 Horizon-64b
portable:msi cr61:MX17 Horizon-64b/lmde3 cindy
scanner ds620 brother + imprimande hp photosmart 4480

Avatar du membre
papy2228
Messages : 137
Enregistré le : lun. 30 oct. 2017 15:56
Localisation : Quelques part en France

Re: PB Impression/scan entre MINT19 et LEXMARK PRO705

Message par papy2228 » sam. 15 sept. 2018 07:31

Bonjour,
Juste une question as-tu dé-commenté et renseigner l'adresse IP de ton imprimante dans le fichier etc/sane.d lexmark.conf ?
J'avais oublié de le faire et impossible ni de scanné ni d'imprimer, bref c'est tellement c... :D
Laptop Acer Aspire F5-771
Linux Mint 19 Tara x64 bit Cinnamon, Noyau Linux 4.19.41-generic x86_64,
dual boot Ubuntu 18.04 noyau Linux 4.15.038
intel Core i5-7200U-CPU 2.50 GHZ x2 Memoire vive 7.70 Go
DD 160 Go
Nvidia Geforce GTX 950M sur pilote Nvidia 390.77
Intel corporation Device 620
Imprimante Epson XP-445 sur pilote Epson

Répondre