Résolu le 21-12-20 Plus de connexion wifi

Questions concernant les composants
Répondre
Quevain
Messages : 6
Enregistré le : lun. 21 déc. 2020 13:16

Plus de connexion wifi

Message par Quevain »

Bien le bonjour,

Bon je viens avec un problème qui ne me parait pas évident!
Sur le pc, que vous pouvez voir dans ma signature, j'ai installé Linux Mint depuis un certain temps déjà. Mais il y à quelque jours le wifi me pose soucis. A savoir que tout mes autres PC n'ont pas de problèmes pour se connecter dans la maison.

Ce qui se passe, c'est que je n'ai plus d'interface wifi.
Hier encore, je pouvais voir les interfaces, mais impossible de se connecter. La prise Ethernet fonctionne (j'y suis actuellement connecté.

Voilà quelques infos

Code : Tout sélectionner

~$lspci | grep -i wireless
03:00.0 Network controller: MEDIATEK Corp. MT7630e 802.11bgn Wireless Network Adapter

Code : Tout sélectionner

~$iwconfig
enp2s0    no wireless extensions.

lo        no wireless extensions.
Sachez que hier, en faisant le iwconfig, j'avais encore wlp3s0, plus maintenant. J'utilise un TP-link rw9980 (si ça peut aider).

Mes mis à jour sont ok.
J'ai déjà testé le

Code : Tout sélectionner

~$service network-manager restart
.
J'ai fouillé pas mal sur le net, mais aucun sujet ne correspondait vraiment. Et je suis pas au top niveau adminsys.

Voilà, quelqu'un aurait une piste ?
Si il faut d'autres infos/commandes, n'hésitez pas et merci d'avance !
PC : ASUSTek S301LA
Système : Linux Mint 19.3
Desk : Cinnamon 4.4.8
Kernel : 5.4.0-58-generic x86_64
CPU : Dual Core - Intel Core i3-4010U
CG : Intel Haswell-ULT integrated Graphics
RAM : 4gb

Avatar du membre
arghlub
Administrateur du site
Messages : 8905
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Plus de connexion wifi

Message par arghlub »

Salut,

Que donnent les retours de ces commandes (c'est juste pour info, ça ne résoudra pas ton souci dans l'immédiat) :

Code : Tout sélectionner

inxi -nz

Code : Tout sélectionner

sudo rfkill list
voir : viewtopic.php?f=18&t=4982
;)
Tour1 (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.3 | XFCE
Tour2 (custom)CM Gigabyte | CPU AMD Athlon 5200+ | CG Nvidia GTX 560 | RAM 6Go | FreeBSD 12.1 | XFCE
Portable1 MSI GF75 Thin 9SC | CPU Intel I7-9750H | CG Nvidia GTX 1650 | RAM 32Go | LMint 20.1 | XFCE
Portable2 Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot : LMint 18.3 | MXlinux 19 | LMint 19.3 | XFCE
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Quevain
Messages : 6
Enregistré le : lun. 21 déc. 2020 13:16

Re: Plus de connexion wifi

Message par Quevain »

Salut,

Alors pour

Code : Tout sélectionner

~$inxi -nz
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: MEDIATEK MT7630e 802.11bgn Wireless Network Adapter 
  driver: N/A 
Par contre le rfkill list ne donne absolument rien. Je l'ai testé hier, il donnait quelque chose, mais je ne m'en souviens plus.
PC : ASUSTek S301LA
Système : Linux Mint 19.3
Desk : Cinnamon 4.4.8
Kernel : 5.4.0-58-generic x86_64
CPU : Dual Core - Intel Core i3-4010U
CG : Intel Haswell-ULT integrated Graphics
RAM : 4gb

Quevain
Messages : 6
Enregistré le : lun. 21 déc. 2020 13:16

Re: Plus de connexion wifi

Message par Quevain »

Code : Tout sélectionner

sudo lshw -C network | grep -v "numéro de série"

 *-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 10
       serial: 78:24:af:6f:09:07
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8168g-3_0.0.1 04/23/13 ip=192.168.1.100 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:18 ioport:e000(size=256) memory:f7d04000-f7d04fff memory:f7d00000-f7d03fff
  *-network UNCLAIMED
       description: Network controller
       product: MT7630e 802.11bgn Wireless Network Adapter
       vendor: MEDIATEK Corp.
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:f7c00000-f7cfffff

PC : ASUSTek S301LA
Système : Linux Mint 19.3
Desk : Cinnamon 4.4.8
Kernel : 5.4.0-58-generic x86_64
CPU : Dual Core - Intel Core i3-4010U
CG : Intel Haswell-ULT integrated Graphics
RAM : 4gb

Avatar du membre
arghlub
Administrateur du site
Messages : 8905
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Plus de connexion wifi

Message par arghlub »

Quevain a écrit :
lun. 21 déc. 2020 14:11

Code : Tout sélectionner

~$inxi -nz
  Device-2: MEDIATEK MT7630e 802.11bgn Wireless Network Adapter 
  driver: N/A 
souci de driver/pilote à priori («driver: N/A») ...... faudrait essayer de te trouver un driver s'il n'est pas inclu dans le kernel/noyau...
je laisse la main à d'autres (là j'ai pas trop le temps de fouiller :oops:)
Tour1 (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.3 | XFCE
Tour2 (custom)CM Gigabyte | CPU AMD Athlon 5200+ | CG Nvidia GTX 560 | RAM 6Go | FreeBSD 12.1 | XFCE
Portable1 MSI GF75 Thin 9SC | CPU Intel I7-9750H | CG Nvidia GTX 1650 | RAM 32Go | LMint 20.1 | XFCE
Portable2 Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot : LMint 18.3 | MXlinux 19 | LMint 19.3 | XFCE
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Quevain
Messages : 6
Enregistré le : lun. 21 déc. 2020 13:16

Re: Plus de connexion wifi

Message par Quevain »

Ok.

Avec cette piste j'ai essayé ce tuto
https://community.linuxmint.com/tutorial/view/1796

Mais j'ai une erreur

Code : Tout sélectionner

$ sudo ./install
make -C /lib/modules/5.4.0-58-generic/build M=/home/menestrel/Téléchargements/MT7630E-release/rt2x00 modules
make[1]: Entering directory '/usr/src/linux-headers-5.4.0-58-generic'
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/rt2x00dev.o
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/rt2x00mac.o
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/rt2x00config.o
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/rt2x00queue.o
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/rt2x00link.o
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/mt_linux.o
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/rt2x00crypto.o
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/rt2x00firmware.o
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/rt2x00leds.o
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/rt2x00mmio.o
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/rt2800pci.o
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/rt2800lib.o
  CC [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/rt2x00pci.o
  LD [M]  /home/menestrel/Téléchargements/MT7630E-release/rt2x00/mt7630e.o
  Building modules, stage 2.
  MODPOST 1 modules
FATAL: parse error in symbol dump file
scripts/Makefile.modpost:93: recipe for target '__modpost' failed
make[2]: *** [__modpost] Error 1
Makefile:1670: recipe for target 'modules' failed
make[1]: *** [modules] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.4.0-58-generic'
Makefile:9: recipe for target 'all' failed
make: *** [all] Error 2
Je reboot pour voir !
PC : ASUSTek S301LA
Système : Linux Mint 19.3
Desk : Cinnamon 4.4.8
Kernel : 5.4.0-58-generic x86_64
CPU : Dual Core - Intel Core i3-4010U
CG : Intel Haswell-ULT integrated Graphics
RAM : 4gb

Quevain
Messages : 6
Enregistré le : lun. 21 déc. 2020 13:16

Re: Plus de connexion wifi

Message par Quevain »

Bon problème réglé.

Pour ceux qui auront éventuellement le même problème. Je pense que le problème est venu après la mise à jour du Kernel. Cela dit j'ai suivi le tuto ci dessus et j'ai installé le driver avec cette commande

Code : Tout sélectionner

pseudo@pseudo~Downloads/MT7630E-release$sudo make dkms
J'espère que ça va continuer à fonctionner.
Je passe le sujet en résolu même si il me semble que mon pc capte moins bien la fréquence wifi. Mais je devrais trouvé un tuto pas loin sur ce forum.

Merci pour le coup de main !
PC : ASUSTek S301LA
Système : Linux Mint 19.3
Desk : Cinnamon 4.4.8
Kernel : 5.4.0-58-generic x86_64
CPU : Dual Core - Intel Core i3-4010U
CG : Intel Haswell-ULT integrated Graphics
RAM : 4gb

Avatar du membre
alain
modérateur
Messages : 9406
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Plus de connexion wifi

Message par alain »

Bonjour.

Sujet archivé (en lecture seule) car résolu.
Si besoin de rouvrir faire un MP à un membre de l'équipe ;)
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 19.3 Tricia Xfce 4.14.1 | K: 4.15.0-88
PC2 :Core2 Quad Q9650 @ 3 GHz | CG: Radeon HD 4850 | OS: LM 19.3 Xfce 4.14.1 | K: 5.3.0-42
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19.0-6
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM17.3 KDE | K : 3.19

In a world without walls and fences, who needs windows and gates?

Répondre