Device communication error (5012)

Questions concernant les composants
Avatar du membre
Linuxing
Messages : 1160
Enregistré le : mar. 25 août 2015 01:28

Device communication error (5012)

Message par Linuxing » jeu. 5 juil. 2018 04:18

Bonjour,

Je dispose d'une imprimante-scanner HP Deskjet 2540 qui ne veut plus imprimer :evil:
En effet, je reçois le message suivant : Device communication error (5012) :roll:

Il y une semaine, tout roulait correctement :|

Merci pour toute idée ;)
Modifié en dernier par arghlub le mer. 12 sept. 2018 15:30, modifié 1 fois.
Raison : annulation de [résolu]
Laptop : Toshiba Satellite Pro S300-11F - Processeur Intel® Core™2 Duo T5870, Intel® GM45 Express chipset et Intel® WiFi Link 5100 - Disque dur 160 GB - 3,912 MB (mémoire maximale : 8,192 MB), DDR2 RAM (800 MHz) / Routeur B-BOX 3 avec clé WPA2 / OS : Linux Mint Sylvia 18.3 Mate Desktop (depuis le 15/02/18) - (Anciennement : LM 17.3)
Périphériques : 2 HD Western Digital - Imprimante HP Deskjet 2540 Tout-en-un / Scanner Canon Lide 110 - Navigateur : Firefox

Avatar du membre
alain
Messages : 5142
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Device communication error (5012)

Message par alain » jeu. 5 juil. 2018 06:35

Bonjour Linuxing.

Tu ne nous en dit pas beaucoup... :l

Vu le message, je suppose que ton imprimante est en réseau.
Dans ce cas, ton IP locale (de l'imprimante), n'aurait elle pas changé à la faveur d'un reboot de la box?
Vérifie déjà ça.
Si elle n'est pas en réseau, essaye la avec un autre câble usb.
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2018/09/ ... 8c173d.png

Avatar du membre
Linuxing
Messages : 1160
Enregistré le : mar. 25 août 2015 01:28

Re: Device communication error (5012)

Message par Linuxing » jeu. 5 juil. 2018 15:38

Salut alain ;)

Les reboots antérieurs de la BOX n'ont jamais changé l'adresse IP du périphérique :| Bien sûr, j'ai aussi essayé avec le câble USB, mais rien non plus :roll:

Sur l'écran digital de l'imprimante, je ne vois aucune alerte particulière :l

Merci
Laptop : Toshiba Satellite Pro S300-11F - Processeur Intel® Core™2 Duo T5870, Intel® GM45 Express chipset et Intel® WiFi Link 5100 - Disque dur 160 GB - 3,912 MB (mémoire maximale : 8,192 MB), DDR2 RAM (800 MHz) / Routeur B-BOX 3 avec clé WPA2 / OS : Linux Mint Sylvia 18.3 Mate Desktop (depuis le 15/02/18) - (Anciennement : LM 17.3)
Périphériques : 2 HD Western Digital - Imprimante HP Deskjet 2540 Tout-en-un / Scanner Canon Lide 110 - Navigateur : Firefox

Avatar du membre
Linuxing
Messages : 1160
Enregistré le : mar. 25 août 2015 01:28

Re: Device communication error (5012)

Message par Linuxing » ven. 6 juil. 2018 02:57

Complément d'information... :P

En fait, la fonction scan est opérationnelle avec ma HP, ce qui veut dire que la communication entre le périphérique et le PC n'est pas interrompue :)

Seule l'impression ne marche pas :evil: Lorsque je demande de m'imprimer une page, une infobulle signale :

Image

Ensuite, j'ai ceci :

Image

Mais en fait, rien ne sort ! :mrgreen:
Laptop : Toshiba Satellite Pro S300-11F - Processeur Intel® Core™2 Duo T5870, Intel® GM45 Express chipset et Intel® WiFi Link 5100 - Disque dur 160 GB - 3,912 MB (mémoire maximale : 8,192 MB), DDR2 RAM (800 MHz) / Routeur B-BOX 3 avec clé WPA2 / OS : Linux Mint Sylvia 18.3 Mate Desktop (depuis le 15/02/18) - (Anciennement : LM 17.3)
Périphériques : 2 HD Western Digital - Imprimante HP Deskjet 2540 Tout-en-un / Scanner Canon Lide 110 - Navigateur : Firefox

Avatar du membre
Lycaon
Messages : 729
Enregistré le : ven. 13 avr. 2018 00:53
Localisation : Belgique

Re: Device communication error (5012)

Message par Lycaon » ven. 6 juil. 2018 09:40

Bonjour,

Ça ressemble fort à un problème que je n'ai qu'épisodiquement. Juste une idée au cas où...

Dans Paramètres système → Imprimantes, vérifie en cliquant droit sur ton imprimante.

Si la tâche apparaît mais arrêtée ou en attente, clique à nouveau droit sur l"imprimante et va voir dans Propriétés. Dans État de l'imprimante, si ça indique "Arrêté - Unplugged or turned off" , va voir dans l'onglet suivant (Comportements) et re-coche "Activée", l'impression devrait reprendre.

Bon, ton imprimante est différente de la mienne, donc les options sont peut-être un peu différentes, il faudra alors chercher. C'est un problème qui arrive de temps en temps depuis que je suis passé à la 18.3, qui n'arrivait pas avant. Je n'ai jamais trouvé pourquoi, mais ça ne me paraît pas dramatique, il suffit de la réactiver.
CM Gigabyte 970A UD3 // Proc. AMD Phenom™Ⅱ X4 965 // RAM 2×4 Go DDR3 G.Skill Extreme3 Ripjaws 1600MHz-PC12800 // CG Nvidia GK208 (GeForce GT730) 9020MHz 2Go // Écran Philips 240V 24" 1920×1200 // SSD (sda) 120Go // HDD (sdb) 2To // Lecteur-graveur DVD noname // Impr. Brother DCP-J562DW (/USB) // LM 18.3 Cinnamon 64 bits, noyau 4.15.0-42-generic x86_64 (64 bit)

Avatar du membre
Linuxing
Messages : 1160
Enregistré le : mar. 25 août 2015 01:28

Re: Device communication error (5012)

Message par Linuxing » ven. 6 juil. 2018 17:38

Salut Lycaon ;)

Voici quelques screenshots :

Image

Image

Impossible d'imprimer une page de test et l'état de l'imprimante indique : Inactif - Rendering completed :twisted:
Dans «Comportements», il est pourtant mentionné que le périphérique est activé :

Image

Au passage, je remarque un petit truc, on ne sait jamais... La luminosité de l'ampoule du bouton ON/OFF de l'imprimante diminue quelques instants après allumage :roll: Je ne crois pas que ce soit une mesure d'économie d'énergie, surtout qu'avant ce n'était pas le cas :?

Merci 8-)
Laptop : Toshiba Satellite Pro S300-11F - Processeur Intel® Core™2 Duo T5870, Intel® GM45 Express chipset et Intel® WiFi Link 5100 - Disque dur 160 GB - 3,912 MB (mémoire maximale : 8,192 MB), DDR2 RAM (800 MHz) / Routeur B-BOX 3 avec clé WPA2 / OS : Linux Mint Sylvia 18.3 Mate Desktop (depuis le 15/02/18) - (Anciennement : LM 17.3)
Périphériques : 2 HD Western Digital - Imprimante HP Deskjet 2540 Tout-en-un / Scanner Canon Lide 110 - Navigateur : Firefox

Avatar du membre
Lycaon
Messages : 729
Enregistré le : ven. 13 avr. 2018 00:53
Localisation : Belgique

Re: Device communication error (5012)

Message par Lycaon » ven. 6 juil. 2018 19:21

Salut,

Bon, l'affichage des fenêtres est identique, ça facilite la compréhension.

Du côté logiciel, tout semble indiquer que c'est ok, donc j'ai d'abord eu l'idée de vérifier la connexion. Mais comme tu dis que la partie scanner fonctionne, ce n'est pas ça.

On doit donc en revenir à la vérificaion demandée par Alain :
alain a écrit :Vu le message, je suppose que ton imprimante est en réseau.
Dans ce cas, ton IP locale (de l'imprimante), n'aurait elle pas changé à la faveur d'un reboot de la box?
Vérifie déjà ça.
Je note aussi que dans l'onglet Paramètres, rien n'est indiqué dans la case Emplacement. Chez moi, c'est l'identifiant de la machine qui est indiqué.

De plus "Imprimer la page de test est possible chez moi depuis le premier bouton (Page de test Cups, entouré de vert sur mon printscreen), mais pas depuis le 2e bouton (Indique si tous les jets de tête d'impression et les mécanismes d'alimentation en papier sont fonctionnels, en rouge). Il en a toujours été ainsi avec cette imprimante qui utilise son osd et son écran internes, alors que ça fonctionnait avec la précédente.
Image
Vu que je n'ai jamais utilisé d'imprimante en réseau, je ne sais malheureusement pas trop par où chercher ces vérifications de l'IP de l'imprimante. :oops:
CM Gigabyte 970A UD3 // Proc. AMD Phenom™Ⅱ X4 965 // RAM 2×4 Go DDR3 G.Skill Extreme3 Ripjaws 1600MHz-PC12800 // CG Nvidia GK208 (GeForce GT730) 9020MHz 2Go // Écran Philips 240V 24" 1920×1200 // SSD (sda) 120Go // HDD (sdb) 2To // Lecteur-graveur DVD noname // Impr. Brother DCP-J562DW (/USB) // LM 18.3 Cinnamon 64 bits, noyau 4.15.0-42-generic x86_64 (64 bit)

Avatar du membre
Linuxing
Messages : 1160
Enregistré le : mar. 25 août 2015 01:28

Re: Device communication error (5012)

Message par Linuxing » ven. 6 juil. 2018 22:33

De retour... :lol:

J'ai refait quelques tests et :

Mon HP n'imprime ni ne numérise en réseau ; par contre, elle numérise (uniquement) connectée en USB au PC :|

Pour l'adresse IP, voici celle qui fut attribuée lorsque j'étais encore sous LM 17.3, mais qui est restée la même sous LM 18.3 ; un screenshot de 2015 lors de la configuration du WIFI :

Image

On y voit clairement l'adresse configurée il y a 3 ans ;) Cette adresse a fonctionné jusqu'à il y a une semaine, donc aussi sous LM Rosa 8-)

Pour vérifier si l'adresse actuelle est identique, il m'a suffit de regarder le tableau de bord :

Image

Provisoirement, je n'ai rien indiqué dans «Emplacement» :|

D'une certaine façon, peu importe le réseau s'il le fallait vraiment, mais ce qui est drôle c'est que la connexion en USB permet la numérisation et pas l'impression :mrgreen:

Merci
Laptop : Toshiba Satellite Pro S300-11F - Processeur Intel® Core™2 Duo T5870, Intel® GM45 Express chipset et Intel® WiFi Link 5100 - Disque dur 160 GB - 3,912 MB (mémoire maximale : 8,192 MB), DDR2 RAM (800 MHz) / Routeur B-BOX 3 avec clé WPA2 / OS : Linux Mint Sylvia 18.3 Mate Desktop (depuis le 15/02/18) - (Anciennement : LM 17.3)
Périphériques : 2 HD Western Digital - Imprimante HP Deskjet 2540 Tout-en-un / Scanner Canon Lide 110 - Navigateur : Firefox

Avatar du membre
Lycaon
Messages : 729
Enregistré le : ven. 13 avr. 2018 00:53
Localisation : Belgique

Re: Device communication error (5012)

Message par Lycaon » ven. 6 juil. 2018 22:46

Plus tu en dis, plus je suis circonspect ... :| :?:
Un truc comme ça, je désinstallerais totalement le driver puis je le réinstallerais. Mais j'ai un driver proprio de brother, je ne sais pas ce qu'il en est du tien.
CM Gigabyte 970A UD3 // Proc. AMD Phenom™Ⅱ X4 965 // RAM 2×4 Go DDR3 G.Skill Extreme3 Ripjaws 1600MHz-PC12800 // CG Nvidia GK208 (GeForce GT730) 9020MHz 2Go // Écran Philips 240V 24" 1920×1200 // SSD (sda) 120Go // HDD (sdb) 2To // Lecteur-graveur DVD noname // Impr. Brother DCP-J562DW (/USB) // LM 18.3 Cinnamon 64 bits, noyau 4.15.0-42-generic x86_64 (64 bit)

Avatar du membre
Lycaon
Messages : 729
Enregistré le : ven. 13 avr. 2018 00:53
Localisation : Belgique

Re: Device communication error (5012)

Message par Lycaon » sam. 7 juil. 2018 14:45

Il y a du neuf ? Tu as trouvé une solution ?
CM Gigabyte 970A UD3 // Proc. AMD Phenom™Ⅱ X4 965 // RAM 2×4 Go DDR3 G.Skill Extreme3 Ripjaws 1600MHz-PC12800 // CG Nvidia GK208 (GeForce GT730) 9020MHz 2Go // Écran Philips 240V 24" 1920×1200 // SSD (sda) 120Go // HDD (sdb) 2To // Lecteur-graveur DVD noname // Impr. Brother DCP-J562DW (/USB) // LM 18.3 Cinnamon 64 bits, noyau 4.15.0-42-generic x86_64 (64 bit)

Répondre