Résolu le 27-11-18 Installation Problematique de Scangear pour une Canon tr8550

Questions concernant les composants
Répondre
TicTacBoum
Messages : 2
Enregistré le : ven. 16 nov. 2018 23:19

Installation Problematique de Scangear pour une Canon tr8550

Message par TicTacBoum »

Bonjour à tous,

Etant un utilisateur semi débutant je vous expose mon problème auquel je butte depuis quelques jours..
J'ai une multifonction canon tr8550 branché en rj45 que je suis arrivé à faire fonctionner comme imprimante en installant les drivers officiels.
En revanche pour le coté scanner je butte. j'ai essayé pas mal de manips sans grand succès:

- Via le site de Canon: message d’erreur après l’exécution de l'install.sh

Code : Tout sélectionner

==================================================

ScanGear MP
Version 3.50
Copyright CANON INC. 2007-2017

==================================================
Commande exécutée = sudo dpkg -iG ./packages/scangearmp2_3.50-1_amd64.deb
(Lecture de la base de données... 368025 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../scangearmp2_3.50-1_amd64.deb ...
Dépaquetage de scangearmp2 (3.50-1) ...
dpkg: erreur de traitement de l'archive ./packages/scangearmp2_3.50-1_amd64.deb (--install) :
 tentative de remplacement de « /usr/lib/libcncpmslld2.so.3.0.0 », qui appartient aussi au paquet libcanon-proprio-bin 0.2+3.50-1804
dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 ./packages/scangearmp2_3.50-1_amd64.deb
Commande exécutée = sudo dpkg -P scangearmp2
dpkg : avertissement : requête ignorée : suppression de scangearmp2, qui n'est pas installé
- Via un dépot ppa ajouté (celui-ci: ppa:thierry-f/fork-michael-gruz)
Du coup avec cette manip j'ai accès à scangearmp2 et libcanon-proprio-bin via synaptic
Mais il me retourne ce méssage d'érreur lors de l'installation:

Code : Tout sélectionner

E: /var/cache/apt/archives/scangearmp2_3.50.9-1804_amd64.deb: tentative de remplacement de « /usr/lib/libcncpmslld2.so », qui appartient aussi au paquet libcanon-proprio-bin 0.2+3.50-1804
Informations détaillés:

Code : Tout sélectionner

Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita » at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 96, <> line 1.
Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita » at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 96, <> line 1.
Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita » at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 114, <> line 1.
Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « adwaita » at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 114, <> line 1.
(Lecture de la base de données... 368025 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../scangearmp2_3.50.9-1804_amd64.deb ...
Dépaquetage de scangearmp2 (3.50.9-1804) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/scangearmp2_3.50.9-1804_amd64.deb (--unpack) :
 tentative de remplacement de « /usr/lib/libcncpmslld2.so », qui appartient aussi au paquet libcanon-proprio-bin 0.2+3.50-1804
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/scangearmp2_3.50.9-1804_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de récupération :
A l'issue de cela il installe tout de même le paquet libcanon-proprio-bin correctement.

- J'ai aussi testé toute une procédure qui a presque aboutie, présente sur ce site :https://github.com/Ordissimo/scangearmp2 (domage car je crois que que ce bénévole linuxien du nom de Ordissimo en vaut la peine)

Voilà Voilà... cela dépasse maintenant ma patience de bidouillage et mes compétences...

Si quelqu'un à une idée je la prend!!!
Merci encore

Intel Core 2 Extreme CPU X9770 - Linux Mint 18.3 version KDE 64-bit

Avatar du membre
arghlub
Administrateur du site
Messages : 9255
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Installation Problematique de Scangear pour une Canon tr8550

Message par arghlub »

Salut,

Je n'ai pas de solution à te proposer, par contre je déplace ton sujet dans la rubrique «Compatibilité matériel». ;)
Tour1 (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.3 | XFCE
Tour2 (custom)CM Gigabyte | CPU AMD Athlon 5200+ | CG Nvidia GTX 560 | RAM 6Go | FreeBSD 12.1 | XFCE
Portable1 MSI GF75 Thin 9SC | CPU Intel I7-9750H | CG Nvidia GTX 1650 | RAM 32Go | LMint 20.1 | XFCE
Portable2 Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot : LMint 18.3 | MXlinux 19 | LMint 19.3 | XFCE
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Cyberdr3am
Messages : 90
Enregistré le : sam. 20 oct. 2018 00:07

Re: Installation Problematique de Scangear pour une Canon tr8550

Message par Cyberdr3am »

Coucou,

Voilà les explications pour ton multifonction

https://x0r.fr/blog/68

Bonne journée
Manjaro 18.00 KDE Desktop : Zsh Shell / Oh My Zsh - proco Pentium© Dual-Core CPU E6700 @ 3.20GHz × 2 - Ram 3 Go - HDD 333.6 Go - Carte graph Intel Corporation 82G33/G31 Express Integrated Graphics Controller

TicTacBoum
Messages : 2
Enregistré le : ven. 16 nov. 2018 23:19

Re: Installation Problematique de Scangear pour une Canon tr8550

Message par TicTacBoum »

Merci Cyberdr3am pour le lien.. cela ne ma pas servi directement mais ma permis de creuser.. En effet ~X0r ma suggérer d’approfondir le coté compilation etc. je pense qu'il y a un fond de vérité sur mon problème...

Mais allons au but cad la solution la plus simple:
Utiliser les pilotes d'Ordissimo!! (merci à lui)
https://github.com/Ordissimo/scangearmp2
En bas de la page il y a une liste d'imprimantes compatibles ainsi que la marche à suivre pour les utilisateurs debian (donc Ubuntu donc linuxmint)
la voici:

INSTALLATION
For debian systems :
Get sources :

Code : Tout sélectionner

git clone https://github.com/Ordissimo/scangearmp2.git
Get developement environnement :

Code : Tout sélectionner

apt-get update
apt-get install debhelper libglib2.0-dev libgtk2.0-dev libusb-1.0-0-dev libtool-bin libjpeg-dev
# or, if failure, use:
apt-get install debhelper libglib2.0-dev libgtk2.0-dev libusb-1.0-0-dev libtool libjpeg-dev
cp -a scangearmp2 scangearmp2-3.50
rm -rf scangearmp2-3.50/.git scangearmp2-3.50/debian/
tar cJvf scangearmp2_3.50.orig.tar.xz scangearmp2-3.50
Build Sources :

Code : Tout sélectionner

cd scangearmp2
debuild -tc
Install :

Code : Tout sélectionner

dpkg -i ../scangearmp2_3.50-1_amd64.deb
pour ma part la commande debuild -tc je l'ai transformé en debuild-d
et pour dpkg -i ../scangearmp2_3.50-1_amd64.deb je l'ai lancé en graphique.
De plus j'ai mis des "sudo" de partout car nous ne sommes pas sous debian et sa commande "su"

Une fois tout cela effectué j'ai lancé la commande scangearmp2 toujours dans le terminal pour lancer un scan!

Voilà Voilà
Conclusion merci à ~x0r et Ordissimo!

Avatar du membre
arghlub
Administrateur du site
Messages : 9255
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Installation Problematique de Scangear pour une Canon tr8550

Message par arghlub »

Salut TicTacBoum, merci pour le retour 8-)
Ça aidera sûrement d'autres utilisateurs de cette Canon ;)
Tour1 (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.3 | XFCE
Tour2 (custom)CM Gigabyte | CPU AMD Athlon 5200+ | CG Nvidia GTX 560 | RAM 6Go | FreeBSD 12.1 | XFCE
Portable1 MSI GF75 Thin 9SC | CPU Intel I7-9750H | CG Nvidia GTX 1650 | RAM 32Go | LMint 20.1 | XFCE
Portable2 Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot : LMint 18.3 | MXlinux 19 | LMint 19.3 | XFCE
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Répondre