Abandon le 28-01-20 problème de pilote avec Radeon RX 550

Questions concernant les composants
grandartisan
Messages : 36
Enregistré le : mar. 11 juin 2019 23:31

problème de pilote avec Radeon RX 550

Message par grandartisan »

Bonsoir
J'ai été suivi par ikwedu et astucien sur ce forum de pc astuces à l'adresse suivante à propos de l'impossibilité d'accéder à mint dans le menu grub.
https://forum.pcastuces.com/pas_de_déma ... 1&#6115216

Ikwedu écrivait dans sa réponse du 20 1 2020:
"Je me doutais que le pilote n'était pas le bon, mais je n'ai pas trouvé mieux dans cette page. Mieux vaut aller sur le forum Linux Mint et poster une demande d'aide dans une rubrique dédiée aux soucis de cartes graphiques. Moi, je ne traite pas ce genre de souci.... sauf sur mes PC si le souci se pose. Et je fais comme toi... Je passe par une aide si je ne m'en sors pas.

Tu aurais peut-être aussi la possibilité de revenir au noyau précédent qui fonctionnait bien avec ta carte si ce noyau a changé. C'est une autre piste à envisager..."

Je n'ai pas encore pris effectué ce que me propose "astucien" dans son intervention qui a suivi et je suis les conseils d'ikwedu en postant ici mon problème afin de voir si quelqu'un pouvait aider et conseiller en ce qui concerne mon problème.
Merci de votre attention.
Modifié en dernier par grandartisan le dim. 26 janv. 2020 10:57, modifié 1 fois.
PC assemblé, pc de bureau, Linux mint Dara en dual boot avec Windows 10 version 20H2 environnement cinamom 3 8 9 ,noyau 4.15.0.60-généric, processeur AMD RYZEN 5 2500, RAM: DD 4(2x8Go), stockage : 2 ssd M 2 NVMe de 500 Go; 2 ssd 1 To, carte graphique DADEON RX 570

Avatar du membre
alain
modérateur
Messages : 10785
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: le menu ubuntu dans grub ne lance plus linux mint

Message par alain »

Bonjour grandartisan.

J'ai lu ton lien vers PC-astuces... C'est pas clair (pour moi) et ton message ici n'apporte pas de clarification a ton problème.
J'explique pourquoi, ensuite je te proposerai ce que je crois comprendre de ton problème.

Pas clair parce que:
-Ici tu poste dans LMDE alors que je ne vois nul part une référence à LMDE.
-Tu parles ici et sur pc-astuce de Linux Mint (quelle version?) Puis tu mets un titre qui parle d'ubuntu.
-Dans ton titre ici tu parles d'un menu ubuntu dans le qui lancerai Linux Mint :shock: . Qu'est ce c'est que ce bintz?
-Ton titre dans pc astuce : "pas de démarrage sur linux mint dans le grub w10/linux mint" . Grub n'existe pas sur W10.
-Ensuite malgré cet imbbroglio de distris il appert que tu arrives a démarrer sur Linux Mint (lequel? lmde3? LM19.x?...). mais que
tu as un problème : «il y a simplement une mention concernant l'accélération de la carte graphique».
-s'en suis des modifications des options de démarrage, des questionnements sur le pilote (sans savoir lequel est utilisé)...etc...

Ce que je crois comprendre: (mais ta signature confirmera ou non).
-Tu as installé LM19.x cinnamon (et pas LMDE donc tu n'est pas dans la bonne rubrique) en dual boot avec W10 (certainement en uefi)
-Ton Grub ne s'affichait pas.
-Tu avais la possibilité de démarrer sur W10 depuis le gestionnaire de démarrage de ton bios. Gestionnaire, qui souvent donne
"ubuntu" à la place de "linux mint"
-Puis, mais vraiment pas clair, après l'ajout de nomodeset dans les options de démarrage, tu aurais récupérer ton grub :shock: ou
si ce n'est pas le cas au moins arrives tu a démarrer LM19.x cinnamon.

Alors avant d'aller plus loin. Dis nous si je suis dans le vrai et corrige mes erreurs d'interprétation.

Et surtout ! (c'est très important dans ton cas) fait ta signature comme indiqué ici : Aide pour une "signature utile"

Pour info:
J'ai déduis que c'est cinnamon car ce message (notification) "il y a simplement une mention concernant l'accélération de la carte graphique" est
un bug de cinnamon dont tu as peu de chances d'arriver a te débarrasser, mais si tout fonctionne bien comme ça, c'est pas grave.
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.1 Ulyssa Xfce 4.14 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.1 Xfce 4.14| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.1 XFCE 4.14 | K : 5.4
In a world without walls and fences, who needs windows and gates?

grandartisan
Messages : 36
Enregistré le : mar. 11 juin 2019 23:31

Re: le menu ubuntu dans grub ne lance plus linux mint

Message par grandartisan »

Bonsoir Alain
Merci pour cette réponse.
D'abord mes excuses pour n'avoir pas posté au bon endroit; ensuite pour mon absence de signature(je croyais pourtant l'avoir mise).
Je réponds à tes interrogations:
1) Tu as installé LM19.x cinnamon (et pas LMDE donc tu n'es pas dans la bonne rubrique) en dual boot avec W10 (certainement en uefi).
C'est exact.
2) -Ton Grub ne s'affichait pas.
Au départ oui, car je l'avais placé sur mon SSD M2 LDLC, ne sachant pas qu'avec l'UEFI, il fallait le placer sur la partition Windows dans la partition EFI (j'étais resté dans les recommandations concernant le MBR qui prévoyait de le placer sur le disque contenant ubuntu pour plus de sécurité).

3) Tu avais la possibilité de démarrer sur W10 depuis le gestionnaire de démarrage de ton bios. Gestionnaire, qui souvent donne"ubuntu" à la place de "linux mint";
Oui exactement.
Mais grâce à l'aide d'ikwedu, j'ai pu solutionner le problème et ensuite grub s'affichait bien au démarrage avec les deux choix Windows bootloader et Ubuntu opérationnels.
4) Puis, mais vraiment pas clair, après l'ajout de nomodeset dans les options de démarrage, tu aurais récupérer ton grub :shock: ou
si ce n'est pas le cas au moins arrives tu a démarrer LM19.x cinnamon.
Plus exactement le scénario a été le suivant:
Un beau matin, sur le menu grub en choisissant "Ubuntu" je n'ai obtenu qu'un écran noir; par contre en choisissant le bootloader Windows j'avais bien accés à Windows.
Et ikwedu sur le forum pc astuces a compris que Grub n'était pas en cause mais le pilote de la carte graphique et ses améliorations; aussi m'a t il fait ajouter "nomodeset" et aussi ""amdgpu.vm_fragment_size=9" après "quiet splash" en éditant le menu d'Ubuntu avec "e"; cela m'a permis d'obtenir MINT cinnamon avec la mention dans un message comme quoi les améliorations graphiques étaient désactivées.
Il me conseillait de poster sur le forum linux mint le problème pour voir si une solution pouvait être trouvée tout en suggérant quelques pistes.
Voilà donc pour quoi je pose ici le problème.
PC assemblé, pc de bureau, Linux mint Dara en dual boot avec Windows 10 version 20H2 environnement cinamom 3 8 9 ,noyau 4.15.0.60-généric, processeur AMD RYZEN 5 2500, RAM: DD 4(2x8Go), stockage : 2 ssd M 2 NVMe de 500 Go; 2 ssd 1 To, carte graphique DADEON RX 570

zeb
Messages : 16473
Enregistré le : ven. 19 juin 2015 22:13
Localisation : plus ici

Re: le menu ubuntu dans grub ne lance plus linux mint

Message par zeb »

Sujet déplacé LMDE→Générale

grandartisan
Messages : 36
Enregistré le : mar. 11 juin 2019 23:31

Re: le menu ubuntu dans grub ne lance plus linux mint

Message par grandartisan »

Bonsoir zeb
J'ai bien lu les conseils et je vais en tenir compte.
J'ai cru à la proposition de ikwedu et j'ai essayé de répondre au mieux à ce que me demandait Alain.

Je pense donc que je fais fausse route et que je vais essayer de me débrouiller seul sur ce problème en trouvant le bon pilote pour ma carte graphique et si cela ne résout rien de réinstaller Linux mint.
Merci pour votre attention
PC assemblé, pc de bureau, Linux mint Dara en dual boot avec Windows 10 version 20H2 environnement cinamom 3 8 9 ,noyau 4.15.0.60-généric, processeur AMD RYZEN 5 2500, RAM: DD 4(2x8Go), stockage : 2 ssd M 2 NVMe de 500 Go; 2 ssd 1 To, carte graphique DADEON RX 570

Avatar du membre
alain
modérateur
Messages : 10785
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: le menu ubuntu dans grub ne lance plus linux mint

Message par alain »

Bonjour Grandartisant.

Ok c'est plus clair et on a ton matériel.
Donc plus de problème de grub, ni de démarrage de LM19.3 cinnamon.

Reste un "potentiel" problème graphique.

Pour voir ou tu en est avec le pilote, donne nous le retour de:

Code : Tout sélectionner

inxi -G 
Et pour les modifications des options de démarrage:

Code : Tout sélectionner

cat /etc/default/grub
PS: t'inquiète pas le déplacement de ton sujet, c'est juste pour qu'il n'apparaisse plus dans LMDE, qui n'a rien a voir.
Après tu ne fais pas "fausse route" et ikwedu et eu raison de t'orienter vers un forum Linux Mint.
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.1 Ulyssa Xfce 4.14 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.1 Xfce 4.14| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.1 XFCE 4.14 | K : 5.4
In a world without walls and fences, who needs windows and gates?

grandartisan
Messages : 36
Enregistré le : mar. 11 juin 2019 23:31

Re: le menu ubuntu dans grub ne lance plus linux mint

Message par grandartisan »

Réponse des deux commandes:

Code : Tout sélectionner

max@PC-Max:~$ inxi -G
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Lexa PRO [Radeon RX 550/550X]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: fbdev,ati (unloaded: modesetting,vesa,radeon)
           Resolution: 1024x768@76.00hz
           OpenGL: renderer: llvmpipe (LLVM 9.0, 128 bits)
           version: 3.3 Mesa 19.2.1
max@PC-Max:~$

Code : Tout sélectionner

max@PC-Max:~$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="0"
#GRUB_TIMEOUT_STYLE="hidden"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE="640x480"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
$
Modifié en dernier par arghlub le mer. 22 janv. 2020 07:13, modifié 1 fois.
Raison : ajout de balises [code] aux commandes terminal
PC assemblé, pc de bureau, Linux mint Dara en dual boot avec Windows 10 version 20H2 environnement cinamom 3 8 9 ,noyau 4.15.0.60-généric, processeur AMD RYZEN 5 2500, RAM: DD 4(2x8Go), stockage : 2 ssd M 2 NVMe de 500 Go; 2 ssd 1 To, carte graphique DADEON RX 570

Avatar du membre
alain
modérateur
Messages : 10785
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: le menu ubuntu dans grub ne lance plus linux mint

Message par alain »

il faut mettre les retours de terminal entre balises "code" sinon tu vas te faire tirer les oreilles par les admin/modos :l
La balise "code" c'est ce truc la </> au dessus de la fenêtre de saisie dans la ligne d'outils.
Tu sélectionnes ton texte et tu clique sur </> . Modifies ton message en ajoutant les balises.
Exemple:

Code : Tout sélectionner

alain@alain-lmxfce:~$ inxi -G
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X] 
  driver: amdgpu v: kernel 
  Display: x11 server: X.Org 1.19.6 driver: ati FAILED: amdgpu 
  unloaded: fbdev,modesetting,radeon,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: Radeon RX 580 Series v: 4.6.13542 Core Profile Context 
alain@alain-lmxfce:~$ 
Tu vois c'est simple ;)

Revenons a nos moutons, quoique que je n'étais pas parti loin du troupeau si tu regardes le contenu de mon exemple. :l

Alors bonne nouvelle, ton grub, n'a pas souffert.
Mais mauvaise nouvelle, tu n'as pas de pilote pour ta carte graphique. Juste le minimum syndical : fbdev,ati et llvmpipe pour l'accélération
graphique. Ce qui doit charger pas mal ton CPU.
Comme tu vois dans mon retour, ici il s'agit d'une RX 580 (polaris 20) mais c'est le même pilote pour une RX 550 (polaris 12), il y a "amdgpu"
à driver.

Donc nous allons chercher pourquoi chez toi le pilote n'est pas utilisé. Normalement avec une carte AMD/ATI, c'est automatique
aucune intervention n'est nécessaire, il y a du y avoir un problème à l'installation ou l'installation a été faite avec une autre carte graphique.

Pour commencer donnes le retour de:

Code : Tout sélectionner

apt policy xserver-xorg-video-amdgpu
Bien entendu : Entre balises "code" le retour... :l
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.1 Ulyssa Xfce 4.14 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.1 Xfce 4.14| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.1 XFCE 4.14 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Avatar du membre
arghlub
Administrateur du site
Messages : 9596
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: le menu ubuntu dans grub ne lance plus linux mint

Message par arghlub »

Salut grandartisan,
alain a écrit :
mer. 22 janv. 2020 01:20
il faut mettre les retours de terminal entre balises "code" sinon tu vas te faire tirer les oreilles par les admin/modos :l
[...]
Pas de tirage d'oreille pour le moment :D
Cette fois-ci, j'ai mis les balises "code" à ta place dans ton message.
Ceci dit, comme le dit Alain, il faut utiliser ces balises (sélectionner le code et cliquer sur Image) pour tout ce qui concerne le terminal (commandes, retours de commandes, etc…), cela améliore grandement la lisibilité.
Voir tuto Barre d'outils des messages.
;)
Tour1 (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.3 | XFCE
Tour2 (custom)CM Gigabyte | CPU AMD Athlon 5200+ | CG Nvidia GTX 560 | RAM 6Go | FreeBSD 12.1 XFCE
Portable1 MSI GF75 Thin 9SC | CPU Intel I7-9750H | CG Nvidia GTX 1650 | RAM 32Go | dualBoot : LMint 20.2 | MXlinux 19.4 | XFCE
Portable2 MacBook Air A1466 (2015) | CPU Intel I5-5250U | CG Intel HD Graphics 6000 | RAM 8Go | dualBoot : macOS Sierra | MXlinux 19 XFCE
Pas d'aide par MP ! ─────( pour une informatique libre ! -membre de l' April.org )────────────────

grandartisan
Messages : 36
Enregistré le : mar. 11 juin 2019 23:31

problème de pilote avec Radeon RX 550

Message par grandartisan »

Voici avec retard le résultat de la commande; j'ai relevé les aides concernant la présentation du contenu des messages et je vais m'y appliquer.

Code : Tout sélectionner

max@PC-Max:~$ apt policy xserver-xorg-video-amdgpu
xserver-xorg-video-amdgpu:
  Installé : 18.0.1-1
  Candidat : 18.0.1-1
 Table de version :
 *** 18.0.1-1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
max@PC-Max:~$ 
Modifié en dernier par grandartisan le dim. 26 janv. 2020 10:56, modifié 1 fois.
PC assemblé, pc de bureau, Linux mint Dara en dual boot avec Windows 10 version 20H2 environnement cinamom 3 8 9 ,noyau 4.15.0.60-généric, processeur AMD RYZEN 5 2500, RAM: DD 4(2x8Go), stockage : 2 ssd M 2 NVMe de 500 Go; 2 ssd 1 To, carte graphique DADEON RX 570

Répondre