Probleme avec Dongle USB3 => RJ45

Questions concernant les composants
Répondre
Thork
Messages : 3
Enregistré le : lun. 21 sept. 2020 14:46

Probleme avec Dongle USB3 => RJ45

Message par Thork »

Bonjour, j'ai un dongle Ugreen USB3.0=>RJ45 que je n'arrive pas a le faire reconnaitre sur le port usb 3.0 de mon vieil Asus eeePC 1215B sous LM20 Xfce.
Sur les autres ports usb 2.0 pas de soucis mais le port USB 3.0 impossible d'établir une connexion entre le portable et la box internet.
Le port USB 3.0 marche pourtant bien, j'ai fait l'essai avec 2 disks du externes respectivement en usb2 et usb3 et pas de soucis ça marche (avec des débits de tranferts supérieurs sur le pot USB 3)
Pareil j'ai testé le dongle sur la tour de mon pc de bureau sous Win10 il marche nickel sur un port usb 30.
Voilà ce que ça donne avec le dongle connecté sur le port USB 3.0, si quelqu'un à une idée du problème, merci d'avance.

Code : Tout sélectionner

jipe@Asus-1215B:~$ uname -a
Linux Asus-1215B 5.4.0-47-generic #51-Ubuntu SMP Fri Sep 4 19:50:52 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Code : Tout sélectionner

jipe@Asus-1215B:~$ lsusb
Bus 006 Device 003: ID 0b95:1790 ASIX Electronics Corp. AX88179 Gigabit Ethernet
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 13d3:5711 IMC Networks USB 2.0 UVC VGA WebCam
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Code : Tout sélectionner

jipe@Asus-1215B:~$ inxi -F
System:    Host: Asus-1215B Kernel: 5.4.0-47-generic x86_64 bits: 64 Desktop: Xfce 4.14.2 Distro: Linux Mint 20 Ulyana 
Machine:   Type: Laptop System: ASUSTeK product: 1215B v: x.x serial: <superuser/root required> 
           Mobo: ASUSTeK model: 1215B v: x.xx serial: <superuser/root required> UEFI: American Megatrends v: 0503 
           date: 11/30/2011 
Battery:   ID-1: BAT0 charge: 40.5 Wh condition: 40.6/56.2 Wh (72%) 
CPU:       Topology: Dual Core model: AMD E-450 APU with Radeon HD Graphics bits: 64 type: MCP L2 cache: 512 KiB 
           Speed: 824 MHz min/max: 825/1650 MHz Core speeds (MHz): 1: 824 2: 824 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Wrestler [Radeon HD 6320] driver: radeon v: kernel 
           Display: x11 server: X.Org 1.20.8 driver: ati,radeon unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz 
           OpenGL: renderer: AMD PALM (DRM 2.50.0 / 5.4.0-47-generic LLVM 10.0.0) v: 3.3 Mesa 20.0.8 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Wrestler HDMI Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD/ATI] SBx00 Azalia driver: snd_hda_intel 
           Sound Server: ALSA v: k5.4.0-47-generic 
Network:   Device-1: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network Adapter driver: wl 
           IF: wlp1s0 state: up mac: 74:2f:68:d3:1e:02 
           Device-2: Qualcomm Atheros AR8152 v2.0 Fast Ethernet driver: atl1c 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: 54:04:a6:34:ed:15 
           Device-3: ASIX AX88179 Gigabit Ethernet type: USB driver: ax88179_178a 
           IF: enx000ec665002d state: up speed: 100 Mbps duplex: full mac: 00:0e:c6:65:00:2d 
Drives:    Local Storage: total: 465.76 GiB used: 13.53 GiB (2.9%) 
           ID-1: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
Partition: ID-1: / size: 456.01 GiB used: 13.52 GiB (3.0%) fs: ext4 dev: /dev/dm-0 
           ID-2: swap-1 size: 980.0 MiB used: 2.2 MiB (0.2%) fs: swap dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 62.2 C mobo: N/A gpu: radeon temp: 62 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 166 Uptime: 37m Memory: 3.46 GiB used: 1003.4 MiB (28.4%) Shell: bash inxi: 3.0.38 
jipe@Asus-1215B:~$ 
Portable : Asus EeePC 1215B LM20 Xfce

Thork
Messages : 3
Enregistré le : lun. 21 sept. 2020 14:46

Re: Probleme avec Dongle USB3 => RJ45

Message par Thork »

Bon, j'ai essayé d'avancer un peu sur le problème, sur le site du constructeur https://www.asix.com.tw/download.php?su ... ItemID=131,

j'ai pu récuperer les drivers, mais je ne sais pas si c'est ceux que propose LM20 de base.
Toujours est il que je n'arrive pas à les installer.

Voici la copie du readme.txt du package.

Code : Tout sélectionner

ASIX AX88179_178A USB 3.0/2.0 Gigabit Ethernet Network Adapter
Driver Compilation & Configuration on Linux
============================================================================

================
Prerequisites
================

Prepare to build the driver, you need the Linux kernel sources installed on the
build machine, and make sure that the version of the running kernel must match
the installed kernel sources. If you don't have the kernel sources, you can get
it from www.kernel.org or contact to your Linux distributor. If you don't know
how to do, please refer to KERNEL-HOWTO.

Note: Please make sure the kernel is built with one of the "Support for
       Host-side, EHCI, OHCI, or UHCI" option support.

================
File Description
================
README		This file
ax88179_178a.c	AX88179_178A Linux driver main file
ax88179_178a.h	AX88179_178A Linux driver header file
Makefile	AX88179_178A driver make file
COPYING	GNU GERNERAL LICENSE

===========================
Conditional Compilation Flag
===========================

================
Getting Start
================

1. Extract the compressed driver source file to your temporary directory by the
   following command:

	[root@localhost template]# tar -xf DRIVER_SOURCE_PACKAGE.tar.bz2

2. Now, the driver source files should be extracted under the current directory.
   Executing the following command to compile the driver:
 
	[root@localhost template]# make
			
3. If the compilation is done, the ax88179_178a.ko will be created under the current
   directory.
 
4. If you want to use modprobe command to mount the driver, executing the
   following command to install the driver into your Linux:

	[root@localhost template]# make install


================
Usage
================

1. If you want to load the driver manually, go to the driver directory and
   execute the following commands:

	[root@localhost template]# modprobe usbnet
	[root@localhost template]# insmod ax88179_178a.ko

If you want to unload the driver, just executing the following command:

	[root@localhost anywhere]# rmmod axax88179_178a

===============
DRIVER PARAMETERS
===============
The following parameters can be set when using insmod.

msg_enable=0xNNNNNNN
	specifies the msg_enable of usbnet.

example: insmod ax88179_178a.ko msg_enable=0x00000000


bsize=xx (0~24)
	specifies the the Rx Bulk In Queue size(KB).
	The maximum value for this parameters is 24. 
	The default value is -1 that will use the driver default setting (18K for USB3.0).

example: insmod ax88179_178a.ko bsize=12

ifg=xxx (0~255)
	specifies the the Rx Bulk In Queue Inter-Frame-Gap timer. (The timer's unit is 0.25us)
	The maximum value for this parameters is 255.
	The default value is -1 that will use the driver default setting (255 for USB3.0).

bEEE=x	(0 or 1)
	Enable/Disable the Ethernet EEE function.
	0: Disable the EEE
	1: Enalbe the EEE
	The default value is 0 that will disable the EEE function.

bGETH=x (0 or 1)
	Enable/Disable the Green Ethernet function.
	0: Disable the Green Ethernet
	1: Enalbe the Green Ethernet
	The default value is 0 that will disable the Green Ethernet function.
J'execute donc la commande : make

Code : Tout sélectionner

jipe@Asus-1215B:~/Téléchargements/AX88179_178A_Linux_Driver_v1.20.0_source$ sudo make
[sudo] Mot de passe de jipe :             
make -C /lib/modules/5.4.0-48-generic/build M=/home/jipe/Téléchargements/AX88179_178A_Linux_Driver_v1.20.0_source modules
make[1] : on entre dans le répertoire « /usr/src/linux-headers-5.4.0-48-generic »
  Building modules, stage 2.
  MODPOST 1 modules
make[1] : on quitte le répertoire « /usr/src/linux-headers-5.4.0-48-generic »
puis make install

Code : Tout sélectionner

jipe@Asus-1215B:~/Téléchargements/AX88179_178A_Linux_Driver_v1.20.0_source$ sudo make install
su -c "cp -v ax88179_178a.ko /lib/modules/5.4.0-48-generic/kernel/drivers/net/usb && /sbin/depmod -a"
'ax88179_178a.ko' -> '/lib/modules/5.4.0-48-generic/kernel/drivers/net/usb/ax88179_178a.ko'
jipe@Asus-1215B:~/Téléchargements/AX88179_178A_Linux_Driver_v1.20.0_source$ 
mais j'ai toujours pas de reseau par le port USB3 en ethernet.
Je n'ai pas de grosses connaissances sous Linux, si une âme charitable pouvait m'éclairer, merci d'avance.
Portable : Asus EeePC 1215B LM20 Xfce

Avatar du membre
alain
modérateur
Messages : 9486
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Probleme avec Dongle USB3 => RJ45

Message par alain »

Bonjour.

Sujet archivé (en lecture seule) car 2 mois sans réponse.
Si besoin de rouvrir faire un MP à un membre de l'équipe ;)
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 19.3 Tricia Xfce 4.14.1 | K: 4.15.0-88
PC2 :Core2 Quad Q9650 @ 3 GHz | CG: Radeon HD 4850 | OS: LM 19.3 Xfce 4.14.1 | K: 5.3.0-42
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19.0-6
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM17.3 KDE | K : 3.19

In a world without walls and fences, who needs windows and gates?

Répondre