Problème détection clé wifi Realtek RTL8191SU au démarrage

Questions concernant les composants
Dillharm
Messages : 5
Enregistré le : jeu. 28 sept. 2017 14:35

Problème détection clé wifi Realtek RTL8191SU au démarrage

Messagepar Dillharm » jeu. 28 sept. 2017 16:31

C'est en espérant ne pas faire d'erreur que je fais mon premier post ici.

Problème rencontré :
Lorsque le système démarre, il ne détecte pas, ou ne gère pas la clé wifi. Et, lorsque je débranche-rebranche cette clé elle est prise en compte et utilisée normalement.

Voici le résultat de quelques commandes pouvant être utiles :

La commande lsusb donne toujours la même réponse (avant et après débrangchement-rebranchement de la clé) :

Code : Tout sélectionner

$ lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 005: ID 046d:c225 Logitech, Inc. G11/G15 Keyboard / G keys
Bus 003 Device 004: ID 046d:c221 Logitech, Inc. G11/G15 Keyboard / Keyboard
Bus 003 Device 003: ID 046d:c223 Logitech, Inc. G11/G15 Keyboard / USB Hub
Bus 003 Device 002: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub



La comme iwconfig au démarrage machine :

Code : Tout sélectionner

$ iwconfig
lo        no wireless extensions.

enp4s0    no wireless extensions.

wlx0014d1d934d4  unassociated  Nickname:"rtl_wifi"
          Mode:Auto  Access Point: Not-Associated   Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


Lorsque le wifi est fonctionnel (après débranchement-rebranchement) :

Code : Tout sélectionner

$ iwconfig
wlx0014d1d934d4  IEEE 802.11bgn  ESSID:"Livebox-390E"  Nickname:"rtl_wifi"
          Mode:Managed  Frequency:2.412 GHz  Access Point: D0:84:B0:75:39:0E   
          Bit Rate:72 Mb/s   Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=75/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

enp4s0    no wireless extensions.


j'ai vu dans un post que cette info pouvait être utile alors :

Code : Tout sélectionner

$ lsmod
Module                  Size  Used by
cfg80211              602112  0
binfmt_misc            20480  1
r8712u                176128  0
...
...

$ modinfo r8712u -F description
rtl871x wireless lan driver


Pour être sûr j'ai consulté le Bios. La gestion usb2 est à "enable".
Par ailleurs, il est parfaitement fonctionnel sous windows.

J'espère être suffisamment précis, pour que vous puissiez m'aider.
Dans l'attente de vos réponses,
Dill
Asrock FM2A88M Extreme4+ ; AMD A10-7700k ; 8go ram
Geforce GTX960 ; SSD 250go ; HDD 1to

DB : Mint18.2 - Win10
--------------------------------------
La vie n'est que chagrin. Tout espoir est vain. Pour autant, rester les deux pieds dans le même sabot fait de nous de sombres idiots.

Avatar du membre
débitant
Messages : 5949
Enregistré le : mar. 14 juil. 2015 18:22
Localisation : Lorraine France

Re: Problème détection clé wifi Realtek RTL8191SU au démarrage

Messagepar débitant » jeu. 28 sept. 2017 17:22

Dillharm a écrit :C'est en espérant ne pas faire d'erreur que je fais mon premier post ici.
...

ben si :lol:
je déplace dans "compatibilité matériel" ;)

Dillharm
Messages : 5
Enregistré le : jeu. 28 sept. 2017 14:35

Re: Problème détection clé wifi Realtek RTL8191SU au démarrage

Messagepar Dillharm » jeu. 28 sept. 2017 17:26

Merci.
Asrock FM2A88M Extreme4+ ; AMD A10-7700k ; 8go ram
Geforce GTX960 ; SSD 250go ; HDD 1to

DB : Mint18.2 - Win10
--------------------------------------
La vie n'est que chagrin. Tout espoir est vain. Pour autant, rester les deux pieds dans le même sabot fait de nous de sombres idiots.

Avatar du membre
débitant
Messages : 5949
Enregistré le : mar. 14 juil. 2015 18:22
Localisation : Lorraine France

Re: Problème détection clé wifi Realtek RTL8191SU au démarrage

Messagepar débitant » jeu. 28 sept. 2017 17:34

ce sujet à déjà été traité sur le fofo,
donc fais une recherche en haut et à droite des pages
entre autre https://forum-francophone-linuxmint.fr/ ... =30#p89751
mais je pense qu'il y en a d'autres (pas fais la recherche :roll: ) à lire et voir si ça peut te guider ;)

Dillharm
Messages : 5
Enregistré le : jeu. 28 sept. 2017 14:35

Re: Problème détection clé wifi Realtek RTL8191SU au démarrage

Messagepar Dillharm » jeu. 28 sept. 2017 18:34

Merci pour ton aide, mais à vrai dire j'ai déjà lu ce post et même effectuer sans succès la manoeuvre de mpat citée par Malynou. Celle là et d'autres avant.

Avant de poster je passe toujours du temps à chercher ce qui existe déjà. La plupart du temps, cela est suffisant.
C'est d'ailleurs en lisant un bon nombre de posts que j'ai repérer les commandes qui sont souvent demandées que je les ai incluses directement.

S'il le faut je changerais de matériel, mais j'aimerais comprendre pourquoi dans ce cas précis il ne fonctionne qu'en connectant la clé à chaud...
Asrock FM2A88M Extreme4+ ; AMD A10-7700k ; 8go ram
Geforce GTX960 ; SSD 250go ; HDD 1to

DB : Mint18.2 - Win10
--------------------------------------
La vie n'est que chagrin. Tout espoir est vain. Pour autant, rester les deux pieds dans le même sabot fait de nous de sombres idiots.

Avatar du membre
débitant
Messages : 5949
Enregistré le : mar. 14 juil. 2015 18:22
Localisation : Lorraine France

Re: Problème détection clé wifi Realtek RTL8191SU au démarrage

Messagepar débitant » jeu. 28 sept. 2017 18:42

ok , pas de soucis, donc attends le passage des docs ;)


Retourner vers « Compatibilité matériel »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité