Résolu le 13-10-20 Installation en Legacy ou UEFI: bug de l'installeur de Mint 20

Des problemes avant ou pendant l'installation
Répondre
capdeframint
Messages : 1367
Enregistré le : jeu. 2 juin 2016 08:57

Installation en Legacy ou UEFI: bug de l'installeur de Mint 20

Message par capdeframint »

En fait d'installation de Mint en Legacy ou en UEFI je viens de voir un petit bug de l'installeur de Mint 20, à savoir :
- j'ai remplacé sur un ordi portable HP récent ( 2018), Windows 10 par LM20 XFCE et j'en ai profité pour passer le boot en mode Legacy dans le Bios. Puis j'ai lancé l'installation et j'ai choisi " autre" pour faire manuellement le choix des partitions, une pour la racine, une petite de Swap et une pour le Home.
Je n'ai volontairement pas gardé une partition de boot séparée de type MBR ou Boot/EFI et l'installeur m'a affiché à trois reprises que le démarrage ne serait pas possible car il n'y avait pas de partition boot/EFI. Je suis passé outre et j'ai validé ce partitionnement et la suite de l'installation et bien sûr, Linuxmint démarre parfaitement en Legacy sur cette machine.
Il ne faut donc pas hésiter à être un peu têtu lorsqu'on est certain de ce que l'on fait ! Bill Gates a dû donner quelques biftons par ci par là pour que le système UEFI devienne la règle partout, même avec Linux :lol:
PC1: ordi tour Packard Bell iXtreme M5140, proc AMD Phenom II 1035TX6,Ram12 Go,1 SSD de 250 Go+1 disque HDD de 1 To.Carte Video NVidia. LMDE4 XFCE
Double boot: Windows 10 Family (en totalité sur le SSD) + LMDE4 XFCE (/ sur le SSD et Home sur le HDD)
PC2:portable HP Pavilion DV7-3125ef, proc Intel i3, Ram8 Go, 1 SSD de 240 Go+ 1 disque HDD de 640 Go.Carte video NVidia GT218M, LM20 Cinnamon
Double boot: Windows 10 Pro (sur le SSD) et LM20 (/ sur le SSD et Home sur le HDD).

psix041
Messages : 26
Enregistré le : mer. 5 août 2020 21:26

Re: Installation en Legacy ou UEFI: bug de l'installeur de Mint 20

Message par psix041 »

C'est un problème similaire que j'ai rencontré lors de l'installation de LM20 Mate qui a réussi malgré un message d'erreur d'échec d'installation en dual boot.

viewtopic.php?f=33&t=16382
Linux Mint Mate 20 Ulyana en dual boot Windows 7
Modèle: Asus TP 300LA
Intel(R) Core(TM) i5-4210U CPU @ 1.70GHz
Memoire 12 GB
Samsung SSD 232,91 GiB sur /dev/sda
Noyau: 5.4.0-26-generic 64bits

capdeframint
Messages : 1367
Enregistré le : jeu. 2 juin 2016 08:57

Re: Installation en Legacy ou UEFI: bug de l'installeur de Mint 20

Message par capdeframint »

J'ai l'impression que, comme tous les ordinateurs actuels sont d'origine configurés en UEFI et que très peu d'utilisateurs pensent à modifier ce paramètre lors d'une installation de Linux, que l'installeur est configuré pour émettre une alerte dès qu'il détecte qui n'y a pas la petite partition boot /EFI de façon à ce que l'installation n'échoue pas. En fait, l'installation en mode Legacy est considérée comme marginale voire anormale :D Et pourtant elle reste parfaitement possible !
PC1: ordi tour Packard Bell iXtreme M5140, proc AMD Phenom II 1035TX6,Ram12 Go,1 SSD de 250 Go+1 disque HDD de 1 To.Carte Video NVidia. LMDE4 XFCE
Double boot: Windows 10 Family (en totalité sur le SSD) + LMDE4 XFCE (/ sur le SSD et Home sur le HDD)
PC2:portable HP Pavilion DV7-3125ef, proc Intel i3, Ram8 Go, 1 SSD de 240 Go+ 1 disque HDD de 640 Go.Carte video NVidia GT218M, LM20 Cinnamon
Double boot: Windows 10 Pro (sur le SSD) et LM20 (/ sur le SSD et Home sur le HDD).

Avatar du membre
alain
modérateur
Messages : 8560
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Installation en Legacy ou UEFI: bug de l'installeur de Mint 20

Message par alain »

Bonjour.

Sujet sujet archivé (en lecture seule) car résolu.
Si besoin de rouvrir faire un MP à un membre de l'équipe ;)
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 19.3 Tricia Xfce 4.14.1 | K: 4.15.0-88
PC2 :Core2 Quad Q9650 @ 3 GHz | CG: Radeon HD 4850 | OS: LM 19.3 Xfce 4.14.1 | K: 5.3.0-42
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19.0-6
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM17.3 KDE | K : 3.19

In a world without walls and fences, who needs windows and gates?

Répondre