x11vnc et lmde 3 cindy

Assistance Générale
Répondre
Mint_Alain
Messages : 3
Enregistré le : mer. 13 mars 2019 16:47

x11vnc et lmde 3 cindy

Message par Mint_Alain » mer. 20 mars 2019 09:49

bonjour :D

je suis tout nouveau sur le forum .

avec lmde , tout se passe généralement bien sauf ... pour x11vnc .

sur un ordi portable , j'ai installer lmde 3 cindy :

Code : Tout sélectionner

joel@joel:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	LinuxMint
Description:	LMDE 3 Cindy
Release:	3
Codename:	cindy
j'ai créé des alias :
joel@joel:~$ alias
alias assist='x11vnc -ncache 20 -many'
alias assistance='/usr/bin/x11vnc -auth guess -forever -loop -noxdamage -repeat -rfbauth /home/joel/.vnc_passwd -rfbport 5900 -shared'
alias ls='ls --color=auto'

que je lance au démarrage :

Code : Tout sélectionner

joel@joel:~/.config/autostart$ ls
x11vnc.desktop

joel@joel:~/.config/autostart$ cat *
[Desktop Entry]
Type=Application
Exec=assistance
X-GNOME-Autostart-enabled=true
NoDisplay=false
Hidden=false
Name[fr_FR]=x11vnc
Comment[fr_FR]=lancement x11vnc
X-GNOME-Autostart-Delay=5
et là : malheur ! x11vnc ne se lance pas !
dans le meilleur des cas , vnc est apparemment lancé (pid) mais le port 5900 ne s'ouvre pas .

un coup de main ?

je teste (sait on jamais) mais jusqu'ici , çà n'a jamais marché .

ni https://forums.linuxmint.com/viewtopic.php?t=210174
ni https://www.numetopia.fr/lancer-applica ... inux-mint/
ni https://doc.ubuntu-fr.org/x11vnc

par exemple , n'ont pu m'aider .

je désespère .
je viens de passer une nuit blanche sur ce problème .

sans solution .

Code : Tout sélectionner

alain@Alain-PC:~$ vncviewer 192.168.1.96:5900

TigerVNC Viewer 64-bit v1.9.0
Built on: 2018-12-01 21:51
Copyright (C) 1999-2018 TigerVNC Team and many others (see README.rst)
See http://www.tigervnc.org for information on TigerVNC.

Wed Mar 20 09:55:27 2019
 DecodeManager: Detected 16 CPU core(s)
 DecodeManager: Creating 4 decoder thread(s)
 CConn:       unable connect to socket: Connexion refusée (111)
je n'ai qu'un seul moyen : lancer x11vnc à la main en ssh ,
puis , lancer vncviewer , à la main , sur le port 5900 .

c'est pas ce que je veux .
Modifié en dernier par Mint_Alain le mer. 20 mars 2019 13:07, modifié 1 fois.

Mint_Alain
Messages : 3
Enregistré le : mer. 13 mars 2019 16:47

Re: x11vnc et lmde 3 cindy

Message par Mint_Alain » mer. 20 mars 2019 13:03

un collègue m'a donné la réponse :
nano /etc/systemd/system/x11vnc.service
2. Copier dans ce fichier :

[Unit]
Description=Service x11vnc
Requires=display-manager.service
After=display-manager.service

[Service]
Type=simple
ExecStart=/usr/bin/x11vnc -rfbauth /path/.vncpasswd -o /var/log/x11vnc.log -display :0 -auth /var/run/lightdm/root/:0 -forever -shared -rfbport 5900
Restart=on-failure
RestartSec=3

[Install]
WantedBy=multi-user.target

3. chmod 0644 /etc/systemd/system/x11vnc.service
4. systemctl enable x11vnc.service
5. systemctl start x11vnc.service
6. systemctl status x11vnc.service
et voilà , çà fonctionne ! problème résolu .

bon , maintenant , si qqun peut m'expiquer la manip' ???

parce que là , ça marche , c'est bien , mais j'ai rien compris à ce que j'ai fait ...

Avatar du membre
cyrille
Messages : 2931
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: x11vnc et lmde 3 cindy

Message par cyrille » mer. 20 mars 2019 13:40

tu as tuot simplement créé un service -appelé aussi demon- qui tourne en arrière plan

https://doc.ubuntu-fr.org/creer_un_service_avec_systemd

Sinon on en avait discuté aussi viewtopic.php?f=24&t=11952
# Me : DELL Lat E5430, SSD, 64-bit, RAM 8Go [ FreeBSD 12.0, xfce / Openbox ; DEBIAN SID via VirtualBox] | E7440, SSD, amd64, RAM 8Go [ DEBIAN SID, xfce]
# Me : VPS : 1 vCore 2 GHz , SSD, RAM 2Go, Local RAID, DEBIAN STABLE https://cbiot.fr
# Work : Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE | Parc DELL Lat E6* LINUX MINT, 18.3 Sylvia, amd64, XFCE.

All you need : #!/bin/bash | SVP les chiants pas de MP...

Répondre