Résolu le 9-05-19 Hibernation avec Xfce

Assistance concernant Linux Mint
Avatar du membre
Frosch
Messages : 9
Enregistré le : dim. 28 avr. 2019 22:12

Hibernation avec Xfce

Message par Frosch » dim. 28 avr. 2019 23:52

Salut,

Comment fait-on pour faire apparaitre l'option hibernation dans le menu de déconnexion de Xfce? J'ai l'habitude que l'option soit présente de base. Ma swap est activée et de taille suffisante.

Avatar du membre
cyrille
Messages : 2931
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Hibernation avec Xfce

Message par cyrille » lun. 29 avr. 2019 08:38

Bonjour
Ajout de l'applet "BOUTON D'ACTIONS" sur le tableau de bord (si ce n'est déjà pas fait)
Clic droit dessus et cocher les options désirées pour que les boutons Mise en veille et Mise en veille prolongée ne soient plus grisés
++C
# Me : DELL Lat E5430, SSD, 64-bit, RAM 8Go [ FreeBSD 12.0, xfce / Openbox ; DEBIAN SID via VirtualBox] | E7440, SSD, amd64, RAM 8Go [ DEBIAN SID, xfce]
# Me : VPS : 1 vCore 2 GHz , SSD, RAM 2Go, Local RAID, DEBIAN STABLE https://cbiot.fr
# Work : Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE | Parc DELL Lat E6* LINUX MINT, 18.3 Sylvia, amd64, XFCE.

All you need : #!/bin/bash | SVP les chiants pas de MP...

Avatar du membre
arghlub
modérateur
Messages : 7179
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Hibernation avec Xfce

Message par arghlub » lun. 29 avr. 2019 08:48

Salut,

Avec cette commande en terminal :

Code : Tout sélectionner

xfconf-query -c xfce4-session -p /shutdown/ShowHibernate --create --set true --type bool
Une fois cette commande passée, l'hibernation (mise en veille prolongée) devrait être de retour immédiatement (pas besoin de redémarrage ou autre) :
Image


Pour une p'tite explication de la commande, vas jeter un œil à ce post : viewtopic.php?f=12&t=8810&p=104536#p104536
il faut juste faire l'inverse (false->true) de ce que je raconte dans le post donné en lien.
;)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3GHz | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.2 Tina | XFCE
Portable Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LMint 18.3 Sylvia | MXlinux 19 | LMint 19.2 | XFCE
+ autres PCs + RaspberryPis + VMs ...
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Avatar du membre
Frosch
Messages : 9
Enregistré le : dim. 28 avr. 2019 22:12

Re: Hibernation avec Xfce

Message par Frosch » lun. 29 avr. 2019 14:07

Merci pour vos réponses, malheureusement ça ne fonctionne pas! Aucun changement dans la fenêtre de déconnexion, et si j'utilise les boutons d'action, l'entrée pour l'hibernation est grisée. Étrange... j'ai pourtant bien une swap de 4Gio pour une RAM de 3.8Gio et ça a toujours fonctionné ainsi. J'ai essayé de désactiver puis réactiver la swap, rien ne change.

Avatar du membre
arghlub
modérateur
Messages : 7179
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Hibernation avec Xfce

Message par arghlub » lun. 29 avr. 2019 14:26

euuuuuh très étrange, t'es avec quoi comme OS ???
(je ne suis pas avec LMint actuellement (j'suis en prod' en train de taffer avec MX) donc je ne peux pas vérifier ma commande mais j'aurais pensé que ça devrait rouler).

Pour plus de clarté dans le suivi de ton sujet et pour une aide la plus efficace possible, merci de mettre ton système d'exploitation (+environnement de bureau) et la configuration de ton matériel dans la signature.
Pour cela Aide pour une signature utile


Et pour qu'on connaisse ta version de GTK et de XFCE, donne nous le retour d'un :

Code : Tout sélectionner

inxi -Sxxx
;)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3GHz | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.2 Tina | XFCE
Portable Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LMint 18.3 Sylvia | MXlinux 19 | LMint 19.2 | XFCE
+ autres PCs + RaspberryPis + VMs ...
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Avatar du membre
cyrille
Messages : 2931
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Hibernation avec Xfce

Message par cyrille » lun. 29 avr. 2019 14:27

Code : Tout sélectionner

sudo -i
[sudo] Mot de passe de XXXX : 
 # cat /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla 
retourne quoi ?
# Me : DELL Lat E5430, SSD, 64-bit, RAM 8Go [ FreeBSD 12.0, xfce / Openbox ; DEBIAN SID via VirtualBox] | E7440, SSD, amd64, RAM 8Go [ DEBIAN SID, xfce]
# Me : VPS : 1 vCore 2 GHz , SSD, RAM 2Go, Local RAID, DEBIAN STABLE https://cbiot.fr
# Work : Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE | Parc DELL Lat E6* LINUX MINT, 18.3 Sylvia, amd64, XFCE.

All you need : #!/bin/bash | SVP les chiants pas de MP...

Avatar du membre
Frosch
Messages : 9
Enregistré le : dim. 28 avr. 2019 22:12

Re: Hibernation avec Xfce

Message par Frosch » lun. 29 avr. 2019 14:53

C'est bien sur Mint 19.1, avec donc Xfce 4.12.3 et GTK+ 2.24.31.

cat /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla
... me retourne "fichier introuvable". Je crois que tu as trouvé le problème!

Avatar du membre
cyrille
Messages : 2931
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Hibernation avec Xfce

Message par cyrille » lun. 29 avr. 2019 15:13

il devrait contenir un truc du style

Code : Tout sélectionner

 # cat /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla 
[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes
Rebooter ou réinitialiser le menu

Code : Tout sélectionner

killall unity-panel-service 
Il me semble avoir lu de tête que des fois, il fallait relancer un

Code : Tout sélectionner

sudo update-grub
(après avoir précisé la partoch de swap) mais jamais compris pourquoi, enfin si, mais jamais eu besoin en tout cas (???)
# Me : DELL Lat E5430, SSD, 64-bit, RAM 8Go [ FreeBSD 12.0, xfce / Openbox ; DEBIAN SID via VirtualBox] | E7440, SSD, amd64, RAM 8Go [ DEBIAN SID, xfce]
# Me : VPS : 1 vCore 2 GHz , SSD, RAM 2Go, Local RAID, DEBIAN STABLE https://cbiot.fr
# Work : Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE | Parc DELL Lat E6* LINUX MINT, 18.3 Sylvia, amd64, XFCE.

All you need : #!/bin/bash | SVP les chiants pas de MP...

Avatar du membre
cyrille
Messages : 2931
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Hibernation avec Xfce

Message par cyrille » lun. 29 avr. 2019 15:22

Sinon exemple également pour virer le suspend et hibernate

/etc/polkit-1/rules.d/10-disable-suspend.rules

Code : Tout sélectionner

polkit.addRule(function(action, subject) {
    if (action.id == "org.freedesktop.login1.suspend" ||
        action.id == "org.freedesktop.login1.suspend-multiple-sessions" ||
        action.id == "org.freedesktop.login1.hibernate" ||
        action.id == "org.freedesktop.login1.hibernate-multiple-sessions")
    {
        return polkit.Result.NO;
    }
});
Donc en claquant un YES à la place du NO ça devrait activer les 2 boutons
# Me : DELL Lat E5430, SSD, 64-bit, RAM 8Go [ FreeBSD 12.0, xfce / Openbox ; DEBIAN SID via VirtualBox] | E7440, SSD, amd64, RAM 8Go [ DEBIAN SID, xfce]
# Me : VPS : 1 vCore 2 GHz , SSD, RAM 2Go, Local RAID, DEBIAN STABLE https://cbiot.fr
# Work : Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE | Parc DELL Lat E6* LINUX MINT, 18.3 Sylvia, amd64, XFCE.

All you need : #!/bin/bash | SVP les chiants pas de MP...

Avatar du membre
cyrille
Messages : 2931
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Hibernation avec Xfce

Message par cyrille » lun. 29 avr. 2019 18:23

par contre avant de trifouiller à la config fine d'xfce, as tu jeté un oeil sur ce paquet et es tu sûr qu'il soit installé ?

Code : Tout sélectionner

libres09@libres09-Latitude-E6410 ~ $ aptitude show xfce4-power-manager
Paquet : xfce4-power-manager                            
État: installé
Automatiquement installé: non
Version : 1.4.4-5mint1
Priorité : optionnel
Section : xfce
Responsable : Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture : amd64
Taille décompressée : 377 k
Dépend: libc6 (>= 2.4), libcairo2 (>= 1.2.4), libdbus-1-3 (>= 1.9.14), libdbus-glib-1-2 (>= 0.88), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.41.1),
        libgtk2.0-0 (>= 2.24.0), libnotify4 (>= 0.7.0), libpango-1.0-0 (>= 1.14.0), libpangocairo-1.0-0 (>= 1.14.0), libupower-glib3 (>= 0.99.0), libx11-6,
        libxext6, libxfce4ui-1-0 (>= 4.11.1), libxfce4util7 (>= 4.9.0), libxfconf-0-2 (>= 4.6.0), libxrandr2 (>= 2:1.2.99.2), upower (>= 0.99),
        xfce4-power-manager-data (= 1.4.4-5mint1)
Recommande: libpam-systemd, xfce4-power-manager-plugins
Est en conflit: xfce4-power-manager:i386
Description : power manager for Xfce desktop
 This power manager for the Xfce desktop enables laptop users to set up a power profile for two different modes "on battery power" and "on ac power" while
 still allowing desktop users to at least change the DPMS settings and CPU frequency using the settings dialogue.. 
 
 It features: 
 * battery monitoring 
 * cpu frequency settings 
 * monitor DPMS settings 
 * suspend/Hibernate 
 * LCD brightness control 
 * Lid, sleep and power switches control
Site : http://goodies.xfce.org/projects/applications/xfce4-power-manager
# Me : DELL Lat E5430, SSD, 64-bit, RAM 8Go [ FreeBSD 12.0, xfce / Openbox ; DEBIAN SID via VirtualBox] | E7440, SSD, amd64, RAM 8Go [ DEBIAN SID, xfce]
# Me : VPS : 1 vCore 2 GHz , SSD, RAM 2Go, Local RAID, DEBIAN STABLE https://cbiot.fr
# Work : Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE | Parc DELL Lat E6* LINUX MINT, 18.3 Sylvia, amd64, XFCE.

All you need : #!/bin/bash | SVP les chiants pas de MP...

Répondre