En cours Linux Mint non présent dans le Bios, mais se lance....

Assistance concernant Linux Mint
capdeframint
Messages : 1348
Enregistré le : jeu. 2 juin 2016 08:57

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par capdeframint »

Dernier message de la page précédente :

Et bien les deux premières lignes suffisent à confirmer que tu as le boot de Windows sur le secteur de boot du premier disque (SDA) et le Grub de Linux installé sur le secteur de boot du second disque (SDB), d'où le bordel que tu constates.
Il te faut réinstaller proprement le Grub sur le secteur de boot de Sda, le même que celui pour Windows actuellement, de façon à ce que le Grub prenne en charge tes deux systèmes d'exploitation, Windows et Linux.
PC1: ordi tour Packard Bell iXtreme M5140, proc AMD Phenom II 1035TX6,Ram12 Go,1 SSD de 250 Go+1 disque HDD de 1 To.Carte Video NVidia. LMDE4 XFCE
Double boot: Windows 10 Family (en totalité sur le SSD) + LMDE4 XFCE (/ sur le SSD et Home sur le HDD)
PC2:portable HP Pavilion DV7-3125ef, proc Intel i3, Ram8 Go, 1 SSD de 240 Go+ 1 disque HDD de 640 Go.Carte video NVidia GT218M, LM20 Cinnamon
Double boot: Windows 10 Pro (sur le SSD) et LM20 (/ sur le SSD et Home sur le HDD).

Astriah
Messages : 11
Enregistré le : mer. 25 mars 2020 14:34

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par Astriah »

Euh.... okay.... et comment que je fais O_o ?

J'avoue que tout ca se rapproche du chinois pour moi :D
Système d'exploitation: Linux Mint 19.3 Cinnamon
Version: 4.4.8
Mémoire vive: 7.8 GO
Processeur: Intel© Core™ i7-2600K CPU @ 3.40GHz × 4
Carte Graphique: NVIDIA Corporation GF110 [GeForce GTX 580]

capdeframint
Messages : 1348
Enregistré le : jeu. 2 juin 2016 08:57

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par capdeframint »

De mémoire, dans Boot Repair, il doit y avoir la possibilité de réinstaller le Grub ( mais ça reste à vérifier). Tu ne risques rien à lancer Boot Repair depuis une clé USB et à regarder si ce choix existe. Si oui, tu choisis l'emplacement SDA dans le MBR pour le Grub.
Modifié en dernier par capdeframint le mer. 25 mars 2020 20:26, modifié 1 fois.
PC1: ordi tour Packard Bell iXtreme M5140, proc AMD Phenom II 1035TX6,Ram12 Go,1 SSD de 250 Go+1 disque HDD de 1 To.Carte Video NVidia. LMDE4 XFCE
Double boot: Windows 10 Family (en totalité sur le SSD) + LMDE4 XFCE (/ sur le SSD et Home sur le HDD)
PC2:portable HP Pavilion DV7-3125ef, proc Intel i3, Ram8 Go, 1 SSD de 240 Go+ 1 disque HDD de 640 Go.Carte video NVidia GT218M, LM20 Cinnamon
Double boot: Windows 10 Pro (sur le SSD) et LM20 (/ sur le SSD et Home sur le HDD).

Astriah
Messages : 11
Enregistré le : mer. 25 mars 2020 14:34

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par Astriah »

Je fais ça depuis Linux ?
Système d'exploitation: Linux Mint 19.3 Cinnamon
Version: 4.4.8
Mémoire vive: 7.8 GO
Processeur: Intel© Core™ i7-2600K CPU @ 3.40GHz × 4
Carte Graphique: NVIDIA Corporation GF110 [GeForce GTX 580]

Avatar du membre
alain
modérateur
Messages : 8249
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par alain »

Bonjour Astriah.

Capdeframint a répondu à ta question:
capdeframint a écrit :
mer. 25 mars 2020 18:52
lancer Boot Repair depuis une clé USB
Donc dans un sens oui, vu que Boot Repair c'est du linux, mais pas depuis ton linux installé, mais sur une clé usb avec un live de Boot Repair.
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 19.3 Tricia Xfce 4.14.1 | K: 4.15.0-88
PC2 :Core2 Quad Q9650 @ 3 GHz | CG: Radeon HD 4850 | OS: LM 19.3 Xfce 4.14.1 | K: 5.3.0-42
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19.0-6
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM17.3 KDE | K : 3.19

In a world without walls and fences, who needs windows and gates?

Astriah
Messages : 11
Enregistré le : mer. 25 mars 2020 14:34

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par Astriah »

Rebonjour à tous/toutes,

Après réflexion, je me dis qu'au final, je vais réinstaller Linux.

Pourriez-vous me renseigner la procédure à suivre, à la lettre, afin d'avoir l'OS sur un deuxième disque dur et avoir la fameux écran permettant de choisir de booter un système (SSD2 windows 10) ou l'autre (Linux Mint SSD1) au démarrage ?

A quoi dois-je faire attention lors de l'installation de Linux (via clef usb) ? Dois-je débrancher le SSD Windows ? une fois l'installation terminée, quelle est la première étape à suivre pour avoir l'écran de choix de l'OS au démarrage ?

D'avance, je vous remercie. Désolé de vous ennuyer, mais n'étant pas très sûr de moi lors des manipulations, je sollicite vos lumières afin d'éviter une installation mal réalisée (ce que j'ai apparemment pu faire jusqu'ici :/).
Système d'exploitation: Linux Mint 19.3 Cinnamon
Version: 4.4.8
Mémoire vive: 7.8 GO
Processeur: Intel© Core™ i7-2600K CPU @ 3.40GHz × 4
Carte Graphique: NVIDIA Corporation GF110 [GeForce GTX 580]

capdeframint
Messages : 1348
Enregistré le : jeu. 2 juin 2016 08:57

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par capdeframint »

Il ne faut surtout pas débrancher le disque qui a Windows sinon le système ne sera pas reconnu dans le Grub et le Grub sera à nouveau installé sur le disque B, ce qui reviendra exactement à ta situation actuelle :?
Il faut installer Linux avec ses partitions Swap, racine et Home sur ton Sdb, comme actuellement mais juste faire attention, au moment où l'installeur va te demander où il doit installer le Grub ,à choisir Sda (et carrément même, la partition de boot de Sda, celle qui contient actuellement les instructions de démarrage de Windows) et tout devrait très bien se passer.
Au redémarrage tu devrais avoir Linux proposé en premier et Windows en dernière ligne du menu du Grub.
PC1: ordi tour Packard Bell iXtreme M5140, proc AMD Phenom II 1035TX6,Ram12 Go,1 SSD de 250 Go+1 disque HDD de 1 To.Carte Video NVidia. LMDE4 XFCE
Double boot: Windows 10 Family (en totalité sur le SSD) + LMDE4 XFCE (/ sur le SSD et Home sur le HDD)
PC2:portable HP Pavilion DV7-3125ef, proc Intel i3, Ram8 Go, 1 SSD de 240 Go+ 1 disque HDD de 640 Go.Carte video NVidia GT218M, LM20 Cinnamon
Double boot: Windows 10 Pro (sur le SSD) et LM20 (/ sur le SSD et Home sur le HDD).

zeb
Messages : 16481
Enregistré le : ven. 19 juin 2015 22:13
Localisation : plus ici

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par zeb »

Bonjour,
Astriah a écrit :
jeu. 26 mars 2020 15:02
Pourriez-vous me renseigner la procédure à suivre, à la lettre, afin d'avoir l'OS sur un deuxième disque dur et ...
Ce n'est plus vraiment le même sujet.
Tu pourrais dans un premier temps faire une recherche dans le forum, beaucoup de sujets traite de cela ;)
Si tu ne trouves pas ton bonheur (j'en doute) ouvres un autre sujet (avec un beau et joli titre).
Marque celui ci en "réinstallation".
Merci.

Avatar du membre
Mia88
Messages : 992
Enregistré le : ven. 18 nov. 2016 08:42
Localisation : Lorraine

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par Mia88 »

Bonjour,

Il est tout à fait possible de débrancher les disques en procédant de cette façon, j'avais fait comme ça quand j'étais en dual-boot avec Windows dans une vie lointaine :D

Brancher le disque Windows au câble qui sur la carte mère correspond au SATA1 et configurer le bios éventuellement.
Formater le disque et installer Windows.

Débrancher le disque Windows et brancher le disque qui va recevoir Linux.

En fin d'installation de Linux, laisser le programme de démarrage s'installer à la racine du disque (par ex sda et non pas sda1)

Quand l'install de Linux est terminé, brancher le disque Linux sur le SATA1 et Windows sur le SATA2.
Le bios va booter dans l'ordre des SATA, donc il va démarrer sur Linux.

A l'ouverture de Mint, lancer un terminal et entrer la commande :

Code : Tout sélectionner

sudo update-grub
Le grub va alors détecter les disques qui contiennent un OS, et les ajouter au menu de démarrage.

Les 2 systèmes seront alors complètement indépendants et si un jour Linux a un problème, il suffira de de brancher le disque Windows sur SATA1.
Pareil si c'est Windows qui a un problème, Linux continuera à démarrer ;)
PC 1 - Mint Cinnamon 19.2 64-bits / Intel Xeon CPU E3-1270 V2 3.5GHz x 4 / Ram 15.6 Go / CG NVIDIA GF106GL [Quaro 2000]
PC 2 - Mint Cinnamon 18.3 64 bits / Intel Core i7-2600 CPU @ 3.40GHz x 4 / Ram 15.6 Go / CG Advanced Micro Devices, inc. [AMD/ATI] Hawaii XT [Radeon R9 290X] (prog-if 00[VGA controller])
VB : LMDE3, openSUSE, Solus, Nutyx, Slackware, Manjaro, TrueOS BSD, MX-17, Peppermint, Calculate, DFLinux, Debian, Mageia, ArchLinux, Antix, Fedora, Deepin, SolydX, Q4OS

capdeframint
Messages : 1348
Enregistré le : jeu. 2 juin 2016 08:57

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par capdeframint »

Bien sûr que tu as raison Mia88 mais c'est justement ce que Astriah n'a pas su faire jusqu'alors; c'est pourquoi je lui proposais de juste réinstaller Linuxmint sur son deuxième disque en faisant seulement attention à l'endroit où s'installera le Grub (sur le premier disque contenant Windows, si on veut que ça fonctionne bien en dual boot).
PC1: ordi tour Packard Bell iXtreme M5140, proc AMD Phenom II 1035TX6,Ram12 Go,1 SSD de 250 Go+1 disque HDD de 1 To.Carte Video NVidia. LMDE4 XFCE
Double boot: Windows 10 Family (en totalité sur le SSD) + LMDE4 XFCE (/ sur le SSD et Home sur le HDD)
PC2:portable HP Pavilion DV7-3125ef, proc Intel i3, Ram8 Go, 1 SSD de 240 Go+ 1 disque HDD de 640 Go.Carte video NVidia GT218M, LM20 Cinnamon
Double boot: Windows 10 Pro (sur le SSD) et LM20 (/ sur le SSD et Home sur le HDD).

Répondre