Résolu le 9-09-20 Problème de permissions sur le second disque dur

Assistance concernant Linux Mint
Répondre
Avatar du membre
Anon9
Messages : 7
Enregistré le : lun. 7 sept. 2020 18:49

Problème de permissions sur le second disque dur

Message par Anon9 »

Salut à tous !

C'est la galère, typique pour un débutant comme moi ! :D

Cela fait maintenant plusieurs jours que j'ai ce problème sur le dos et je n'arrive pas à m'en défaire ; ayant récemment migré sur Linux Mint, j'ai pris soin de placer tous mes dossiers importants sur le second disque dur interne, seulement voilà... il m'est impossible de renommer ou supprimer le moindre dossier contenu dans ce disque, il me refuse continuellement les permissions.

J'ai essayé cette commande pour tenter de m'accaparer les droits :

Code : Tout sélectionner

sudo -i chmod 777 /media/mon_nom/nom_du_disque
Résultat :

Code : Tout sélectionner

chmod: modification des droits de '/media/anon/2782ADDE1FDAC1FB': Système de fichiers accessible en lecture seulement
J'ai aussi tenté en rajoutant /* à la fin, même souci si ce n'est que le message d'erreur apparaît pour chaque dossier contenu dans le disque.

À noter que le nom du disque est quelque peu étrange, il ne s'agit pas d'un sdb, ou un sdc, c'est peut-être un alias ?
Dans les propriétés, j'ai set les permissions de toutes les façons possibles : Lecture seule, Lecture et écriture, ---, aucun effet peu importe l'option sélectionnée.

J'ai également essayé d'enlever le disque et de le remettre après redémarrage, rien n'y fait ; le système le verrouille automatiquement.

J'espère ne pas avoir été trop vague, je ne suis pas familier du vocabulaire technique donc je procède avec mes propres mots. Si vous avez des questions, n'hésitez pas.
Quoi qu'il en soit, merci d'avance !
Machine : Desktop ASUS monté manuellement | Distro : Linux Mint 20 Ulyana | Desk : Cinnamon 4.6.7 | Kernel : 5.4.0-47-generic | Processeur : Intel© Core™ i5-4670K CPU @ 3.40GHz × 4 | Carte graphique : NVIDIA GM206 [GeForce GTX 960] | Mémoire vive : 7.72 GiB

Avatar du membre
cyrille
modérateur
Messages : 5546
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Problème de permissions sur le second disque dur

Message par cyrille »

Faut monter ce disque via fstab avec les bons droits,
pas propre du tout ce chmod 777 (sécurité)
Et en plus ton chmod devrait être récursif (option-R)

Code : Tout sélectionner

sudo chmod -R 777

Code : Tout sélectionner

man chmod
https://doc.ubuntu-fr.org/mount_fstab
# HOME: FreeBSD 12.1, DEBIAN SID [XFCE, Fluxbox] # WORK : Mint 18.3 & 20 # VPS + SERVEUR ProLiant: DEBIAN STABLE
[ GIT : https://github.com/CyrilleBiot | Site : https://cbiot.fr ]

Avatar du membre
Anon9
Messages : 7
Enregistré le : lun. 7 sept. 2020 18:49

Re: Problème de permissions sur le second disque dur

Message par Anon9 »

J'ai donc suivi les indications contenues sur la page du mieux que possible.

Le disque dur semble déjà monté :

Code : Tout sélectionner

Mount is denied because the NTFS volume is already exclusively opened.
The volume may be already mounted, or another software may use it which
could be identified for example by the help of the 'fuser' command.
Malgré la saisie des commandes conseillées, aucun changement constatable en ce qui concerne la possibilité de disposer pleinement de ces fichiers. :(

Question sécuritaire je ne me fais pas de soucis là-dessus, le disque ne contient heureusement rien de sensible dans l'absolu ; seulement des cours et des sauvegardes de jeux (le tout copié ailleurs en cas de pépin). :)
Le chmod récursif ne fonctionne pas non plus ; le terminal passe en revue tous les fichiers situés dans le disque en mentionnant une modification des droits mais se borne à garder le système de fichiers accessible en lecture seulement...
Machine : Desktop ASUS monté manuellement | Distro : Linux Mint 20 Ulyana | Desk : Cinnamon 4.6.7 | Kernel : 5.4.0-47-generic | Processeur : Intel© Core™ i5-4670K CPU @ 3.40GHz × 4 | Carte graphique : NVIDIA GM206 [GeForce GTX 960] | Mémoire vive : 7.72 GiB

Avatar du membre
cyrille
modérateur
Messages : 5546
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Problème de permissions sur le second disque dur

Message par cyrille »

SI ton disque est déjà monter, il faut le démonter avant toute modification puis ré effectuer un montage avec les nouvelles options
C'est la commande

Code : Tout sélectionner

sudo umount  /point/de/montage
Lancer la commande suivante pour voir ce qui est monté sur ton système

Code : Tout sélectionner

mount
Sinon vu que c'est du ntfs je te conseille cette lecture
https://doc.ubuntu-fr.org/tutoriel/ntfs
# HOME: FreeBSD 12.1, DEBIAN SID [XFCE, Fluxbox] # WORK : Mint 18.3 & 20 # VPS + SERVEUR ProLiant: DEBIAN STABLE
[ GIT : https://github.com/CyrilleBiot | Site : https://cbiot.fr ]

Avatar du membre
Anon9
Messages : 7
Enregistré le : lun. 7 sept. 2020 18:49

Re: Problème de permissions sur le second disque dur

Message par Anon9 »

J'ai réussi !! Ce fut assez laborieux mais c'est gagné !

Je vais essayer de restituer au mieux la bonne solution.

J'ai tout d'abord tenté de démonter le disque puis de le remonter, mais le problème persistait. Quelques difficultés pour obtenir le bon paquet de configuration NTFS également (il s'agit de ntfs-3g présent dans Synaptic).

Sur le lien que tu m'as donné, figure un autre article portant sur disk-manager que j'ai consulté : https://doc.ubuntu-fr.org/disk-manager
Dans 4. Problèmes connus, il m'a été agréable de constater que le point 4.2 correspondait exactement au problème rencontré.

Puis suite à cette commande :

Code : Tout sélectionner

mount -t ntfs-3g /dev/sdb1 /mnt/sdb1
J'ai eu ceci :

Code : Tout sélectionner

The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)
Could not mount read-write, trying read-only
ntfs-3g-mount: failed to access mountpoint /mnt/sdb1: Aucun fichier ou dossier de ce type
Ce qui est assez curieux car je n'étais pas en Dual Boot, mon Windows était réinitialisé et placé dans son disque bien rangé dans un tiroir.

Le message d'erreur en question est parfaitement décrit dans la partie 3 du tuto relatif aux partitions NTFS : https://doc.ubuntu-fr.org/tutoriel/ntfs

J'ai donc dû, non sans dépit, réinstaller Windows 10 et suivre les instructions :
Appuyer simultanément sur les touches Windows et X.
Sélectionner Options d'alimentation.
Cliquer sur Paramètres d'alimentation supplémentaires.
Cliquer sur Choisir l'action des boutons d'alimentation.
Cliquer sur Modifier des paramètres actuellement non disponibles.
Décocher Activer le démarrage rapide (recommandé).
Cliquer sur Enregistrer les modifications.
Redémarrer l'ordinateur.


De retour sur Mint, les fichiers sont maintenant totalement accessibles !

Voilà, j'espère avoir été suffisamment clair et concis quant à la solution à adopter. :)

En tout cas, un immense merci à toi cyrille ! Ce fut un plaisir de t'avoir à mes côtés. Je ne pense pas que j'aurais pu y parvenir sans tes conseils pour m'aiguiller. :D
Machine : Desktop ASUS monté manuellement | Distro : Linux Mint 20 Ulyana | Desk : Cinnamon 4.6.7 | Kernel : 5.4.0-47-generic | Processeur : Intel© Core™ i5-4670K CPU @ 3.40GHz × 4 | Carte graphique : NVIDIA GM206 [GeForce GTX 960] | Mémoire vive : 7.72 GiB

Avatar du membre
alain
modérateur
Messages : 8526
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Problème de permissions sur le second disque dur

Message par alain »

Super Anon9 que tu ais réussi (avec l'aide de Cyrille) ;)

Oui c'est vrai cette sal*****ie de démarrage rapide, fut un temps où j'y pensais systématiquement pour ce genre de problème, j'avais même le lien vers un site qui explique comment l'enlever (beaucoup de windowsiens ne savent pas). Mais la comme ça fait un certain temps qu'on était tranquille avec les problèmes de dd pas accessibles, je n'ai pas tilté à la lecture de ton sujet.
Mais bon, pas grave, tu as trouvé, en plus c'est mieux de chercher et trouver soit même, c'est formateur ;)

Tu n’oublieras pas de mettre l'attribut "résolu" sur ton premier message? Merci ;)
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 19.3 Tricia Xfce 4.14.1 | K: 4.15.0-88
PC2 :Core2 Quad Q9650 @ 3 GHz | CG: Radeon HD 4850 | OS: LM 19.3 Xfce 4.14.1 | K: 5.3.0-42
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19.0-6
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM17.3 KDE | K : 3.19

In a world without walls and fences, who needs windows and gates?

Avatar du membre
alain
modérateur
Messages : 8526
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Problème de permissions sur le second disque dur

Message par alain »

Bonjour.

Sujet résolu.
Si besoin de rouvrir faire un MP à un membre de l'équipe ;)
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 19.3 Tricia Xfce 4.14.1 | K: 4.15.0-88
PC2 :Core2 Quad Q9650 @ 3 GHz | CG: Radeon HD 4850 | OS: LM 19.3 Xfce 4.14.1 | K: 5.3.0-42
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19.0-6
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM17.3 KDE | K : 3.19

In a world without walls and fences, who needs windows and gates?

Répondre