Résolu le 11-11-20 Impossible d'appliquer les changements. Réparez d'abord les paquets cassés

Assistance concernant Linux Mint
Répondre
FlanVicieux
Messages : 65
Enregistré le : lun. 5 juin 2017 19:48
Localisation : rennes

Impossible d'appliquer les changements. Réparez d'abord les paquets cassés

Message par FlanVicieux »

bonjour à tous,

Le gestionnaire de maj de linux mint 20 ne parvient pas à installer 2 maj (voir photo plus bas) et affiche Impossible d'appliquer les changements. Réparez d'abord les paquets cassés. J'ai essayé quelques commandes (voir plus bas) mais rien ne règle le problème. Dans synaptic, aucuns paquets cassés (filtre cassé).

Seules les 2 maj sur la capture posent problème. avec les commandes sudo apt-get clean
sudo apt-get autoclean, sudo apt-get autoremove, sudo apt-get update, sudo apt-get upgrade, j'ai pu installé firefox et d'autres maj hier soir.

J'ai essayé sudo apt-get clean sudo apt-get install -f et ça ne donne rien.

Retour de cat /etc/apt/sources.list

Code : Tout sélectionner

#deb cdrom:[Linux Mint 20 _Ulyana_ - Release amd64 20200624]/ focal contrib main

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
Retour ls -lha /etc/apt/sources.list.d

Code : Tout sélectionner

otal 56K
drwxr-xr-x 2 root root 4,0K oct.   6 00:45 .
drwxr-xr-x 7 root root 4,0K sept.  9 13:48 ..
-rw-r--r-- 1 root root   77 août  17 18:17 brave-browser-release.list
-rw-r--r-- 1 root root  142 juil. 14 16:00 graphics-drivers-ppa-focal.list
-rw-r--r-- 1 root root  132 juil. 12 12:37 iridium-browser.list
-rw-r--r-- 1 root root  134 août   6 16:41 libreoffice-ppa-focal.list
-rw-r--r-- 1 root root  170 juil. 25 16:57 maarten-baert-simplescreenrecorder-focal.list
-rw-r--r-- 1 root root  557 juin  24 20:50 official-package-repositories.list
-rw-r--r-- 1 root root  148 août   9 16:45 openshot_developers-ppa-focal.list
-rw-r--r-- 1 root root  130 août   5 22:28 persepolis-ppa-focal.list
-rw-r--r-- 1 root root  140 juin  27 16:52 phoerious-keepassxc-focal.list
-rw-r--r-- 1 root root   68 sept.  9 13:48 signal-xenial.list
-rw-r--r-- 1 root root  365 juin  24 12:36 steam.list
-rw-r--r-- 1 root root  156 août   9 19:19 stebbins-handbrake-releases-focal.lis
Retour cat /etc/apt/sources.list.d/*

Code : Tout sélectionner

deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main
deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal main
# deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal main
deb [arch=amd64] https://downloads.iridiumbrowser.de/deb/ stable main
#deb-src https://downloads.iridiumbrowser.de/deb/ stable main
# deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu focal main
# deb-src http://ppa.launchpad.net/libreoffice/ppa/ubuntu focal main
deb http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu focal main
# deb-src http://ppa.launchpad.net/maarten-baert/simplescreenrecorder/ubuntu focal main
# Do not edit this file manually, use Software Sources instead.

deb http://packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main

deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ focal partner
deb http://ppa.launchpad.net/openshot.developers/ppa/ubuntu focal main
# deb-src http://ppa.launchpad.net/openshot.developers/ppa/ubuntu focal main
deb http://ppa.launchpad.net/persepolis/ppa/ubuntu focal main
# deb-src http://ppa.launchpad.net/persepolis/ppa/ubuntu focal main
deb http://ppa.launchpad.net/phoerious/keepassxc/ubuntu focal main
# deb-src http://ppa.launchpad.net/phoerious/keepassxc/ubuntu focal main
deb [arch=amd64] https://updates.signal.org/desktop/apt xenial main
deb [arch=amd64,i386] https://repo.steampowered.com/steam/ stable steam
deb-src [arch=amd64,i386] https://repo.steampowered.com/steam/ stable steam

# Uncomment these lines to try the beta version of the Steam launcher
#deb [arch=amd64,i386] https://repo.steampowered.com/steam/ beta steam
#deb-src [arch=amd64,i386] https://repo.steampowered.com/steam/ beta steam
deb http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu focal main
# deb-src http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu focal main
Pas de retours avec les commandes suivantes :
apt search ?broken
sudo dpkg --configure -a

Quelqu'un à une idée ?

Image

Image
Modifié en dernier par FlanVicieux le mer. 11 nov. 2020 23:03, modifié 2 fois.
pc desktop
Linux Mint 20 (Cinnamon 4.6.7)
noyau 5.4.0-52-generic
Intel core i7-8700 3.2ghz
16 Go mémoire vive
stockage : 1 ssd intel windows 10 / 1 ssd crucial linux mint / 3 disques dur ntfs
GTX 1700

FlanVicieux
Messages : 65
Enregistré le : lun. 5 juin 2017 19:48
Localisation : rennes

Re: Impossible d'appliquer les changements. Réparez d'abord les paquets cassés

Message par FlanVicieux »

Résolu : il fallait installer les drivers nvidia via le gestionnaire de driver et faire le reste avec le gestionnaire de maj.
pc desktop
Linux Mint 20 (Cinnamon 4.6.7)
noyau 5.4.0-52-generic
Intel core i7-8700 3.2ghz
16 Go mémoire vive
stockage : 1 ssd intel windows 10 / 1 ssd crucial linux mint / 3 disques dur ntfs
GTX 1700

Avatar du membre
débitant
modérateur
Messages : 10503
Enregistré le : mar. 14 juil. 2015 18:22
Localisation : Lorraine France

Re: Impossible d'appliquer les changements. Réparez d'abord les paquets cassés

Message par débitant »

Bonjour,
si le sujet est résolu merci de mettre un attribut de sujet (résolu), voir tuto ici

Avatar du membre
cyrille
modérateur
Messages : 6316
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Impossible d'appliquer les changements. Réparez d'abord les paquets cassés

Message par cyrille »

Sinon, https://www.dz-techs.com/fr/fix-broken-packages-ubuntu

Et attention dans tes sources list, mélange de focal et de xenial ...
# HOME: FreeBSD 12.1, Debian SID [XFCE, Fluxbox] # WORK : Mint 18.3 & 20 # VPS Debian stable + Serveur Olimex A20 autohébergé Debian stable
[ GIT : https://github.com/CyrilleBiot | Sites : https://cbiot.fr https://crust.ovh]

FlanVicieux
Messages : 65
Enregistré le : lun. 5 juin 2017 19:48
Localisation : rennes

Re: Impossible d'appliquer les changements. Réparez d'abord les paquets cassés

Message par FlanVicieux »

Il n'y a que pour signal qu'il y a un dépôt xenial, je suppose que c'est normal, non ?
pc desktop
Linux Mint 20 (Cinnamon 4.6.7)
noyau 5.4.0-52-generic
Intel core i7-8700 3.2ghz
16 Go mémoire vive
stockage : 1 ssd intel windows 10 / 1 ssd crucial linux mint / 3 disques dur ntfs
GTX 1700

Avatar du membre
alain
modérateur
Messages : 9435
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Impossible d'appliquer les changements. Réparez d'abord les paquets cassés

Message par alain »

Bonjour.

Sujet archivé (en lecture seule) car résolu.
Si besoin de rouvrir faire un MP à un membre de l'équipe ;)
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 19.3 Tricia Xfce 4.14.1 | K: 4.15.0-88
PC2 :Core2 Quad Q9650 @ 3 GHz | CG: Radeon HD 4850 | OS: LM 19.3 Xfce 4.14.1 | K: 5.3.0-42
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19.0-6
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM17.3 KDE | K : 3.19

In a world without walls and fences, who needs windows and gates?

Répondre