Alternative le 24-11-20 Dépendance non satisfaite

Assistance concernant Linux Mint
Avatar du membre
ludo9474
Messages : 355
Enregistré le : mer. 17 août 2016 13:08
Localisation : Passy,74

Dépendance non satisfaite

Message par ludo9474 »

Bonjour,
J'essaie d'installer "radiotray" (qui n'est plus dans les dépot Mint 20)
Je télécharge le .deb
J'ai le message suivant
Image
Merci
PC de Bureau / Dual Boot - Linux Mint Mate 64 bits 20.1 Ulyssa - Noyau 5.4.0-62 - Linux Mint Cinnamon 64 bits 20.1 Ulyssa (test) - Noyau 5.4.0-62 / CPU: Intel© Core™ i7-4770 CPU @ 3.40GHz × 4 / Ram: 16GO / Carte Graphique: NVIDIA GeForce GT 630 - 2 écran 22" + 1 écran TV Samsung / Disques durs: 1 SSD 1To Systeme / 1 HDD 1To pour Données /

Jennatux
Messages : 549
Enregistré le : mer. 1 nov. 2017 01:59

Re: Dépendance non satisfaite

Message par Jennatux »

Bonjour

Effectivement Radio-tray ne fonctionne plus mais tu peux remplacer par radiotray-ng
Il ya fort longtemps que je n'ai pas utilisé mais il me semble que ce n'est pas tres différent
sinon il y a aussi Goodvibes dans les dépôts mais il n'y a pas d'icone dans la zone de notification , peut bien entendu etre lancé au démarrage
Clevo Intel Pentium 4405U @ 2.10GHz × 4 - Intel Graphics 510
Ubuntu 20.04.1 - Xubuntu 20.04.1 - Ubuntu Budgie 20.04 - Deepin 20.1 - Ubuntu 21.04
Tour Linuxmint Xfce 20 - LMDE4 - Xubuntu 20.04.1

Avatar du membre
philosophedesetoiles
Messages : 225
Enregistré le : jeu. 31 août 2017 12:26

Re: Dépendance non satisfaite

Message par philosophedesetoiles »

Mint 19-3 Noyau 5.4
Bureau Mate
Lenovo Thinkpad t520
icore5

Avatar du membre
ludo9474
Messages : 355
Enregistré le : mer. 17 août 2016 13:08
Localisation : Passy,74

Re: Dépendance non satisfaite

Message par ludo9474 »

Génial, c'est a peu près le mème et ça fonctionne!!!
Merci
PC de Bureau / Dual Boot - Linux Mint Mate 64 bits 20.1 Ulyssa - Noyau 5.4.0-62 - Linux Mint Cinnamon 64 bits 20.1 Ulyssa (test) - Noyau 5.4.0-62 / CPU: Intel© Core™ i7-4770 CPU @ 3.40GHz × 4 / Ram: 16GO / Carte Graphique: NVIDIA GeForce GT 630 - 2 écran 22" + 1 écran TV Samsung / Disques durs: 1 SSD 1To Systeme / 1 HDD 1To pour Données /

Avatar du membre
ludo9474
Messages : 355
Enregistré le : mer. 17 août 2016 13:08
Localisation : Passy,74

Re: Dépendance non satisfaite

Message par ludo9474 »

Je clos le message car j'ai trouvé léquivalent
PC de Bureau / Dual Boot - Linux Mint Mate 64 bits 20.1 Ulyssa - Noyau 5.4.0-62 - Linux Mint Cinnamon 64 bits 20.1 Ulyssa (test) - Noyau 5.4.0-62 / CPU: Intel© Core™ i7-4770 CPU @ 3.40GHz × 4 / Ram: 16GO / Carte Graphique: NVIDIA GeForce GT 630 - 2 écran 22" + 1 écran TV Samsung / Disques durs: 1 SSD 1To Systeme / 1 HDD 1To pour Données /

Avatar du membre
alain
modérateur
Messages : 10134
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Dépendance non satisfaite

Message par alain »

Bonjour Ludo.

Donc ce n'est pas un "abandon" mais une "alternative"...Je change l'attribut ;)
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.1 Ulyssa Xfce 4.14 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.1 Xfce 4.14| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.1 XFCE 4.14 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Avatar du membre
ludo9474
Messages : 355
Enregistré le : mer. 17 août 2016 13:08
Localisation : Passy,74

Re: Dépendance non satisfaite

Message par ludo9474 »

OK, merci
PC de Bureau / Dual Boot - Linux Mint Mate 64 bits 20.1 Ulyssa - Noyau 5.4.0-62 - Linux Mint Cinnamon 64 bits 20.1 Ulyssa (test) - Noyau 5.4.0-62 / CPU: Intel© Core™ i7-4770 CPU @ 3.40GHz × 4 / Ram: 16GO / Carte Graphique: NVIDIA GeForce GT 630 - 2 écran 22" + 1 écran TV Samsung / Disques durs: 1 SSD 1To Systeme / 1 HDD 1To pour Données /

Avatar du membre
ludo9474
Messages : 355
Enregistré le : mer. 17 août 2016 13:08
Localisation : Passy,74

Re: Dépendance non satisfaite

Message par ludo9474 »

Sauf que le problème de dépendance n'est pas résolu et qu’il pourrait réapparaître avec une autre application
PC de Bureau / Dual Boot - Linux Mint Mate 64 bits 20.1 Ulyssa - Noyau 5.4.0-62 - Linux Mint Cinnamon 64 bits 20.1 Ulyssa (test) - Noyau 5.4.0-62 / CPU: Intel© Core™ i7-4770 CPU @ 3.40GHz × 4 / Ram: 16GO / Carte Graphique: NVIDIA GeForce GT 630 - 2 écran 22" + 1 écran TV Samsung / Disques durs: 1 SSD 1To Systeme / 1 HDD 1To pour Données /

Avatar du membre
alain
modérateur
Messages : 10134
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Dépendance non satisfaite

Message par alain »

Il n'est pas résolu et ne le sera pas si radiotray, n'est plus mis à jour.
C'est sur qu'avec n'importe quel autre logiciel tu peux avoir un problème de version de dépendances, s'il n'est pas fait pour la version de linux mint.
Mais pour chacun ça sera une dépendance ou une version de dépendance différente.
Si le logiciel est à jour vs la distribution, il n' y a aucune raison que les dépendances soient mauvaises.
Donc ici il ne s'agit pas d'un problème de dépendance à cause de la distribution, mais seulement un problème de de dépendances à cause du logiciel qui n'est plus maintenu.
Dans ce cas les solutions, sont d'installer les versions de dépendances requises par le logiciel, mais c'est risqué et ça peut faire boule de neige (une dépendance en appelant une autre etc...) ou bien trouver la bonne version du logiciel vs celle de la distribution, ou bien prendre une alternative, c'est à dire un autre logiciel équivalent mais qui lui est fait par la distribution.
Dans ton cas c'était la meilleurs (seule?) solution. Tu as donc résolu ton problème par l'utilisation d'une alternative.

NB: bien entendu si tu tente d'installer un logiciel non à jour pour la distribution, tu risque de tomber sur la même dépendance non satisfaite, mais c'est très faible comme probabilité, tu auras plus de chance de tomber sur d'autres dépendances non satisfaite. Il faut bien comprendre que ce n'est pas un problème de Linux Mint, mais un problème de radiotray (ou tout autre logiciel non à jour). La preuve c'est que sur les versions plus anciennes de LM radiotray fonctionnait bien...
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.1 Ulyssa Xfce 4.14 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.1 Xfce 4.14| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.1 XFCE 4.14 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Avatar du membre
ludo9474
Messages : 355
Enregistré le : mer. 17 août 2016 13:08
Localisation : Passy,74

Re: Dépendance non satisfaite

Message par ludo9474 »

Merci pour l'info, c'est plus clair maintenant
PC de Bureau / Dual Boot - Linux Mint Mate 64 bits 20.1 Ulyssa - Noyau 5.4.0-62 - Linux Mint Cinnamon 64 bits 20.1 Ulyssa (test) - Noyau 5.4.0-62 / CPU: Intel© Core™ i7-4770 CPU @ 3.40GHz × 4 / Ram: 16GO / Carte Graphique: NVIDIA GeForce GT 630 - 2 écran 22" + 1 écran TV Samsung / Disques durs: 1 SSD 1To Systeme / 1 HDD 1To pour Données /

Répondre