Configuration d'affichage qui ne s'enregistre pas

Assistance concernant Linux Mint
Répondre
Ibiscus
Messages : 175
Enregistré le : mer. 30 nov. 2016 15:55

Configuration d'affichage qui ne s'enregistre pas

Message par Ibiscus »

Bonjour à tous,

Depuis que j'ai installé un deuxième écran, je suis confronté à un problème mineur mais pour le moment sans solution. A chaque démarrage, je retrouve les deux écrans superposés, ce qui réduit l'utilité des deux écrans et modifie l'emplacement des icones du bureau. Je change la configuration à chaque fois, mais Linux ne semble pas l'enregistrer.

Voilà ma configuration :

Code : Tout sélectionner

System:    Host: H20 Kernel: 4.13.0-38-generic i686 (32 bit gcc: 5.4.0)
           Desktop: MATE 1.18.0 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   System: Elonex PLC product: MS-6526
           Mobo: MICRO-STAR model: MS-6526 Bios: Award v: 6.00 PG date: 01/29/2004
CPU:       Single core Intel Pentium 4 (-UP-) cache: 512 KB
           flags: (pae sse sse2) bmips: 5599 speed: 2799 MHz (max)
Memory:    No dmidecode memory data: try newer kernel.
Graphics:  Card: NVIDIA NV44A [GeForce 6200] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1024x768@60.00hz, 1920x1080@60.00hz
           GLX Renderer: GeForce 6200/PCI/SSE2 GLX Version: 2.1.2 NVIDIA 304.135 Direct Rendering: Yes
Kernel : 4.x 32 bits
Distro : Linux Mint 18.3 "Sylvia" MATE
1 Single core Pentium III - RAM 2 Go
+
Linux Mint 18.3 "Sylvia" MATE 64 bits
Kernel~4.10.0-40-generic x86_64
CPU(s)~2 Single core Intel Xeons (-HT-SMP-) - RAM 4 Go

Ibiscus
Messages : 175
Enregistré le : mer. 30 nov. 2016 15:55

Re: Configuration d'affichage qui ne s'enregistre pas

Message par Ibiscus »

Cyrille m'a suggéré d'enregistrer ma session à la fermeture.

Je pensais que c'était automatique. Les autres changements dans les préférences sont préservés après redémarrage. Seul l'affichage retourne à sa configuration précédente. Cela dit, je ne sais pas comment forcer l'enregistrement de cette session.
Kernel : 4.x 32 bits
Distro : Linux Mint 18.3 "Sylvia" MATE
1 Single core Pentium III - RAM 2 Go
+
Linux Mint 18.3 "Sylvia" MATE 64 bits
Kernel~4.10.0-40-generic x86_64
CPU(s)~2 Single core Intel Xeons (-HT-SMP-) - RAM 4 Go

Avatar du membre
thierryR
Messages : 223
Enregistré le : ven. 28 juil. 2017 18:50
Contact :

Re: Configuration d'affichage qui ne s'enregistre pas

Message par thierryR »

J'ai constaté ça aussi sur plasma. Alors qu'il suffirait d'un seul écran pour démarrer puis connecter le 2e après. Ainsi on aurait un écran principal et un autre secondaire.
Désolé je n'ai pas trouvé de solution à ton problème.
Kernel: 4.13.0-37-generic x86_64 (64 bit) Desktop: KDE Plasma 5.8.9
Distro: Linux Mint 18.3 Sylvia
Graphics: Card: Intel Device 22b1
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1600x900@60.01hz
GLX Renderer: Mesa DRI Intel HD Graphics 405 (Braswell) GLX Version: 3.0 Mesa 17.2.8
Audio: Card-1 Intel Device 2284 driver: snd_hda_intel Sound: ALSA v: k4.13.0-37-generic
Card-2 C-Media driver: USB Audio

Ibiscus
Messages : 175
Enregistré le : mer. 30 nov. 2016 15:55

Re: Configuration d'affichage qui ne s'enregistre pas

Message par Ibiscus »

Le gestionnaire d'affichage (ou Préférences d'affichage plutôt) indique pourtant que l'un des écrans est l'écran principal (c'est lui qui affiche la barre d'état). Tout se passe plutôt bien. C'est uniquement la position qui ne va pas. Les deux écrans sont positionnées à 0,0.

J'ai lancé la commande xrandr et je ne vois rien non plus d'anormal.

Code : Tout sélectionner

Screen 0: minimum 8 x 8, current 2944 x 1080, maximum 4096 x 4096
VGA-0 connected 1024x768+0+312 (normal left inverted right x axis y axis) 304mm x 228mm
   1024x768      60.00*+
   1360x768      59.96    59.80  
   800x600       60.32    56.25  
   680x384       59.96    59.80  
   640x480       59.94  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  
DVI-I-0 disconnected (normal left inverted right x axis y axis)
TV-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 connected primary 1920x1080+1024+0 (normal left inverted right x axis y axis) 527mm x 296mm
   1920x1080     60.00*+  59.94    50.00    60.05    60.00    50.04  
   1680x1050     59.95  
   1600x1200     60.00  
   1600x900      60.00  
   1440x900      59.89  
   1400x1050     59.98  
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1280x720      60.00    59.94    50.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00    50.08  
   720x480       59.94    60.05  
   640x480       75.00    72.81    59.93  
Modifié en dernier par zeb le dim. 6 mai 2018 21:38, modifié 1 fois.
Raison : suppression d'une citation reprenant à 100% le message précédent.
Kernel : 4.x 32 bits
Distro : Linux Mint 18.3 "Sylvia" MATE
1 Single core Pentium III - RAM 2 Go
+
Linux Mint 18.3 "Sylvia" MATE 64 bits
Kernel~4.10.0-40-generic x86_64
CPU(s)~2 Single core Intel Xeons (-HT-SMP-) - RAM 4 Go

Ibiscus
Messages : 175
Enregistré le : mer. 30 nov. 2016 15:55

Re: Configuration d'affichage qui ne s'enregistre pas

Message par Ibiscus »

J'ignore toujours d'où vient le problème. Une fois sur deux (au moins), j'ai les deux écrans superposés et c'est de pire en pire : même en configurant les paramètres d'affichage, il arrive que la barre ne s'affiche pas au bon endroit et même que la position de la souris ne soit pas exactement ce qui est affiché (d'où l'impossibilité de cliquer sur les boutons ou icones). Cela n'arrive pas non plus systématiquement quand le noyau est mis à jour (ce que je ne fais pas constamment).

J'ai installé arandr, que je peux lancer en ligne de commande, quand tout va vraiment mal. Mais l'outil ne règle pas tout. Je ne sais vraiment pas pourquoi les deux écrans se retrouve placés à 0,0 (en bas à gauche). Comme je ne change pas tous les jours d'écran ou de disposition, je recherche toujours une manière de figer une fois pour toutes la position des moniteurs dans l'espace d'affichage.

Quelqu'un aurait une idée ? Ou une piste concernant l'origine du problème ? Ce problème ne survient pas avec Ubuntu et Windows 7.
Kernel : 4.x 32 bits
Distro : Linux Mint 18.3 "Sylvia" MATE
1 Single core Pentium III - RAM 2 Go
+
Linux Mint 18.3 "Sylvia" MATE 64 bits
Kernel~4.10.0-40-generic x86_64
CPU(s)~2 Single core Intel Xeons (-HT-SMP-) - RAM 4 Go

Ibiscus
Messages : 175
Enregistré le : mer. 30 nov. 2016 15:55

Re: Configuration d'affichage qui ne s'enregistre pas

Message par Ibiscus »

Je soupçonne le pilote de la carte graphique. Cela fait bientôt deux semaines que le problème, quasi-quotidien auparavant, ne s'est plus reproduit. A la suite d'une manipulation qui a permis de supprimer une série de noyaux anciens inutilisés, plusieurs paquets annexes ont été effacés. Et j'ai cru lire dans la liste un paquet en rapport avec l'affichage. Je n'ai pas pu conserver cette liste malheureusement. Toujours est-il que le problème de changement de configuration d'affichage semble réglé.

Dommage que je n'en sache pas plus sur l'origine ou la manière de résoudre le problème.
Kernel : 4.x 32 bits
Distro : Linux Mint 18.3 "Sylvia" MATE
1 Single core Pentium III - RAM 2 Go
+
Linux Mint 18.3 "Sylvia" MATE 64 bits
Kernel~4.10.0-40-generic x86_64
CPU(s)~2 Single core Intel Xeons (-HT-SMP-) - RAM 4 Go

Répondre