En cours STEAM ne demarre pas

Installation, configuration des logiciels que vous souhaitez installer.
Répondre
Bruceb78
Messages : 10
Enregistré le : mer. 13 mars 2019 10:52

STEAM ne demarre pas

Message par Bruceb78 » mer. 13 mars 2019 20:59

Bonjour,

Quand je lance steam via le menu, il ne se passe rien du tout.
Quand je lance steam dans un terminal, j'ai l'erreur ci-dessous:

Code : Tout sélectionner

pascal@PC ~ $ /usr/games/steam %U
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2019-03-13 20:48:15] Startup - updater built Nov 23 2016 01:05:42
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
Je précise que j'ai installé steam via les dépôts LM avec "sudo apt-get install steam" (désinstallé et réinstallé 2 fois) et que j'utilise les drivers nvidia propriétaire proposé par le Gestionnaire de pilotes pour ma GeForce GTX 660 :

nvidia-driver-390 (recommandé)
Version 390.116-0ubuntu0.18.04.1
NVIDIA driver metapackage

Des idées ?
Modifié en dernier par Bruceb78 le mar. 19 mars 2019 16:41, modifié 1 fois.
OS: Linux Mint 19 Mate
Hardware:
SSD crucial 500Go (dédié à linux en mode UEFI)
HDD 1 To (en NTFS en mode MBR)
RAM 8 Go
intel i5-2500K CPU @ 3.30GH
GeForce GTX 660

Avatar du membre
alain
Messages : 5931
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: STEAM ne demarre pas

Message par alain » jeu. 14 mars 2019 07:41

Bonjour Bruceb.

Une idée, oui peut être, mais rien de certain. cette nuit, j'étais justement dans la config de carte graphique.
et en testant avec glxgears (le truc avec les engrenages qui tournent), j'ai vu divers trucs.

Donc dans ton cas ça serait libGl qui coince, donc on pourrait tester avec glxgears voir ce que ça donne.
Donnes le retour de:

Code : Tout sélectionner

LIBGL_DEBUG=verbose glxgears

Tu t'arrêtes a 2 lignes de FPS, pas la peine d'en mettre 25 pages.
Peut être que ça confirmera mes doutes?

Pour tout te dire, j'ai l'impression qu'un lien vers libGl manque ou ne fonctionne pas (ne pointe pas sur la bonne version de libGl.so).
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2019/05/ ... iere09.png

Bruceb78
Messages : 10
Enregistré le : mer. 13 mars 2019 10:52

Re: STEAM ne demarre pas

Message par Bruceb78 » jeu. 14 mars 2019 08:18

Salut Alain,

Voici les infos demandées:

Code : Tout sélectionner

[code]pascal@PC ~ $ LIBGL_DEBUG=verbose glxgears
Running synchronized to the vertical refresh.  The framerate should be
approximately the same as the monitor refresh rate.
303 frames in 5.0 seconds = 60.501 FPS
301 frames in 5.0 seconds = 60.019 FPS
301 frames in 5.0 seconds = 60.021 FPS
OS: Linux Mint 19 Mate
Hardware:
SSD crucial 500Go (dédié à linux en mode UEFI)
HDD 1 To (en NTFS en mode MBR)
RAM 8 Go
intel i5-2500K CPU @ 3.30GH
GeForce GTX 660

Avatar du membre
alain
Messages : 5931
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: STEAM ne demarre pas

Message par alain » jeu. 14 mars 2019 08:35

Bon, ben non désolé, ça ne confirme rien, j'ai cru que ça renverrait une info sur libGl, mais non... :?
Après, je suis suis une quiche en commandes, peut être que je l'ai mal faite ou que glxgears n'utilise pas libgl...

Il faudrait voir quelle liglGl demande steam (je ne l'ai pas installé), et ensuite voir si le lien pointe vers la même version.
exemple:
/usr/lib/x86_64-linux-gnu/nvidia/current/libGL.so.1 -> libGL.so.1.7.0

Attention ça ce n'est qu'un exemple chez moi sur une debian 9.8 , les numéros seront peut être différents chez toi.

peut être aussi qu'une réinstallation du driver Nvidia solutionnerai la chose?

Code : Tout sélectionner

sudo apt install --reinstalle nvidia-driver
Puis redémarre pour prise en compte.
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2019/05/ ... iere09.png

Bruceb78
Messages : 10
Enregistré le : mer. 13 mars 2019 10:52

Re: STEAM ne demarre pas

Message par Bruceb78 » jeu. 14 mars 2019 09:43

Bon, j'ai fait la boulette, j'ai voulu essayer l'autre driver NVIDIA proposé par le gestionnaire de driver... Il a mouliné, l'opération a échoué et après reboot, je n'avais plus mon écran HDMI, une résolution de m***e et pas moyen de revenir en arrière 😒

Bref, j'ai voulu utilisé Timeshift, mais je n'avais qu'une save de la version Mint 18.3, je tente quand même une restoration, mais échec lamentable, le système ne redémarre plus, il reste bloqué sur un splash screen avec 4 petits points😩😩

C'est quand même triste que le programme sensé te sauver la vie agrave encore plus la situation !

On va dire que c'est a cause de l'écart de version entre le système a sauver et la sauvegarde qui est trop important, mais bon, maintenant je n'ai plus confiance.
OS: Linux Mint 19 Mate
Hardware:
SSD crucial 500Go (dédié à linux en mode UEFI)
HDD 1 To (en NTFS en mode MBR)
RAM 8 Go
intel i5-2500K CPU @ 3.30GH
GeForce GTX 660

Bruceb78
Messages : 10
Enregistré le : mer. 13 mars 2019 10:52

Re: STEAM ne demarre pas

Message par Bruceb78 » jeu. 14 mars 2019 23:19

Bon, reinstallation complete du system et grosse galère pour récupérer GRUB, mais ca fait toujours pareil, STEAM ne démarre pas :(
Même message d'erreur...

Code : Tout sélectionner

pascal@PC ~ $ /usr/games/steam %U
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2019-03-14 23:17:38] Startup - updater built Nov 23 2016 01:05:42
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)
OS: Linux Mint 19 Mate
Hardware:
SSD crucial 500Go (dédié à linux en mode UEFI)
HDD 1 To (en NTFS en mode MBR)
RAM 8 Go
intel i5-2500K CPU @ 3.30GH
GeForce GTX 660

Bruceb78
Messages : 10
Enregistré le : mer. 13 mars 2019 10:52

Re: STEAM ne demarre pas

Message par Bruceb78 » jeu. 14 mars 2019 23:25

Si ca peut aider:

Code : Tout sélectionner

pascal@PC ~ $ inxi -G
Graphics:  Card: NVIDIA GK106 [GeForce GTX 660]
           Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1280x1024@60.02hz, 1920x1080@60.00hz
           OpenGL: renderer: GeForce GTX 660/PCIe/SSE2 version: 4.6.0 NVIDIA 390.116
OS: Linux Mint 19 Mate
Hardware:
SSD crucial 500Go (dédié à linux en mode UEFI)
HDD 1 To (en NTFS en mode MBR)
RAM 8 Go
intel i5-2500K CPU @ 3.30GH
GeForce GTX 660

Bruceb78
Messages : 10
Enregistré le : mer. 13 mars 2019 10:52

Re: STEAM ne demarre pas

Message par Bruceb78 » mar. 19 mars 2019 16:37

Pas d'idées ?
OS: Linux Mint 19 Mate
Hardware:
SSD crucial 500Go (dédié à linux en mode UEFI)
HDD 1 To (en NTFS en mode MBR)
RAM 8 Go
intel i5-2500K CPU @ 3.30GH
GeForce GTX 660

Avatar du membre
alain
Messages : 5931
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: STEAM ne demarre pas

Message par alain » mar. 19 mars 2019 21:26

Bonjour Bruce.

Non a part ce que je t'ai dit sur l'absence du lien ou sa mauvaise destination de libGl:
libGL error: No matching fbConfigs or visuals found
(Erreur libGL: Aucun fichier fbConfigs ou visuel ne correspond)
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2019/05/ ... iere09.png

Répondre