Résolu le 10-02-19 PPA ou pas de PPA

Installation, configuration et utilisation des logiciels que vous souhaitez installer.
Répondre
Avatar du membre
thierryR
Messages : 227
Enregistré le : ven. 28 juil. 2017 18:50
Contact :

PPA ou pas de PPA

Message par thierryR » dim. 24 juin 2018 22:39

Bonjour. Je reviens de chez une personne qui a un vieux PC. C'est ma 5e installation.
Je lui ai mis la dernière Mint et tout fonctionne.
Mais quand j'ai voulu ajouté le PPA libreoffice j'ai eu ce mesage:

Code : Tout sélectionner

sudo add-apt-repository ppa:libreoffice/libreoffice-6-0
Cannot add PPA: 'No JSON object could be decoded'. 
(J'ai un doute à savoir si le dernier caractère y était ? )
Je n'ai pas pu lui résoudre ce problème.
Je suis passé par synaptic ou par console. Le problème reste le même.
Ce problème serait-il du à une mauvaise orthographe ?
Merci.
Modifié en dernier par thierryR le dim. 1 juil. 2018 10:50, modifié 1 fois.
Kernel: 4.13.0-37-generic x86_64 (64 bit) Desktop: KDE Plasma 5.8.9
Distro: Linux Mint 18.3 Sylvia
Graphics: Card: Intel Device 22b1
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1600x900@60.01hz
GLX Renderer: Mesa DRI Intel HD Graphics 405 (Braswell) GLX Version: 3.0 Mesa 17.2.8
Audio: Card-1 Intel Device 2284 driver: snd_hda_intel Sound: ALSA v: k4.13.0-37-generic
Card-2 C-Media driver: USB Audio

Avatar du membre
bedarcher
Messages : 168
Enregistré le : ven. 25 mars 2016 16:09
Localisation : Hérault

Re: problème JSON

Message par bedarcher » lun. 25 juin 2018 04:49

Code : Tout sélectionner

sudo add-apt-repository ppa:libreoffice/ppa
sudo apt-get update
voilà ce que j'ai trouvé
Dell Optiplex 740 enhance AMD Dual core 5000B 2.6 mhz 8 go pc2 5300
HD Radeon 6450 1GO

Imprimante réseau Epson SX 430W

Avatar du membre
alain
Messages : 6856
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: problème JSON

Message par alain » lun. 25 juin 2018 05:00

Bonjour ThierryR.

Tu devrais lire ce sujet, même s'il n'est pas en lien directe avec ton problème, je le trouve pertinent pour ton cas:
Blender n'est pas à jour.
Je t'en donne un extrait qui résume bien le fond de ma pensée:
victoria a écrit :Pourquoi cette manie de toujours vouloir les dernières versions des logiciels ???

Quand on veut des logiciels à jour on utilise une archlinux ou une manjaro.
Mais les ppa vu les soucis que ça peut occasionner...

Même sur le wiki de Ubuntu c'est bien écrit les ppa sont à utiliser d'en cas de besoin spécifique.
Comme les backport de debian d'ailleurs c'est la même.
Alors pose toi la question: Ton ami as t'il vraiment besoin de libre office 6? S'il pense que oui, demande lui
ce qu'il pourrait faire avec LO 6 et pas avec LO 5...
Si vraiment sa demande est légitime et justifiée, alors essaye de réparrer...

Je ne suis pas allé vérifié, mais es tu sûr de la syntaxe de : ppa:libreoffice/libreoffice-6-0
Est ce le seul ppa qui te répond ça? (non je ne t'incite pas a en installer d'autres :l , mais juste pour un essais et tu le vire après).

[edit}Ooops! Bedarcher tu as répondu pendant que je rédigeai mon roman :D (moi qui me croyai seul la nuit ici, ça fait plaisir de voir du monde ;) ) . Tu penses comme moi que c'est le ppa qui malfonctionne? Celui que tu donnes c'est Lo 6?
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2019/05/ ... iere09.png

Avatar du membre
victoria
Messages : 1049
Enregistré le : dim. 21 janv. 2018 20:10

Re: problème JSON

Message par victoria » lun. 25 juin 2018 08:09

Comme dit Alain, demande à ton ami pour quelle raison il veut L.O.6 ??
Si c'est un newbie, je suis sûre qu'il ne connaît même pas les changements entre les deux versions, et que pour lui au final ça ne lui apporte rien du tout hormis des soucis futurs.

Si c'est juste pour avoir la conscience tranquille d'avoir un logiciel à la mode, ça n'a aucun intérêt, à part flinguer le système sur le long terme..

Et on te reverra revenir parce que Apt va dérailler et que cette fois ci plus rien ne sera réparable.
Ce qui est le cas dans 90% quand on commence à utiliser les ppa sans savoir ce que l'on fait.

On copie colle des lignes de commande et on admire les dégâts par la suite..
Il y en a même qui utilise des ppa non maintenu depuis des années.....

Mais bon tout le monde pense que les ppa c'est bien, c'est une erreur, une grosse erreur.....
_____________________________________________________________________________
- Le silence aussi possède la violence des mots -

Avatar du membre
bedarcher
Messages : 168
Enregistré le : ven. 25 mars 2016 16:09
Localisation : Hérault

Re: problème JSON

Message par bedarcher » lun. 25 juin 2018 11:39

alain a écrit :Bonjour ThierryR.

Tu devrais lire ce sujet, même s'il n'est pas en lien directe avec ton problème, je le trouve pertinent pour ton cas:
Blender n'est pas à jour.
Je t'en donne un extrait qui résume bien le fond de ma pensée:
victoria a écrit :Pourquoi cette manie de toujours vouloir les dernières versions des logiciels ???

Quand on veut des logiciels à jour on utilise une archlinux ou une manjaro.
Mais les ppa vu les soucis que ça peut occasionner...

Même sur le wiki de Ubuntu c'est bien écrit les ppa sont à utiliser d'en cas de besoin spécifique.
Comme les backport de debian d'ailleurs c'est la même.
Alors pose toi la question: Ton ami as t'il vraiment besoin de libre office 6? S'il pense que oui, demande lui
ce qu'il pourrait faire avec LO 6 et pas avec LO 5...
Si vraiment sa demande est légitime et justifiée, alors essaye de réparrer...

Je ne suis pas allé vérifié, mais es tu sûr de la syntaxe de : ppa:libreoffice/libreoffice-6-0
Est ce le seul ppa qui te répond ça? (non je ne t'incite pas a en installer d'autres :l , mais juste pour un essais et tu le vire après).

[edit}Ooops! Bedarcher tu as répondu pendant que je rédigeai mon roman :D (moi qui me croyai seul la nuit ici, ça fait plaisir de voir du monde ;) ) . Tu penses comme moi que c'est le ppa qui malfonctionne? Celui que tu donnes c'est Lo 6?
je suis a peu près sur de ma synthaxe mais effectivement l’intérêt de LO 6 se pose. Pour ma part je suis le cycle de ma distribution.
Dell Optiplex 740 enhance AMD Dual core 5000B 2.6 mhz 8 go pc2 5300
HD Radeon 6450 1GO

Imprimante réseau Epson SX 430W

Avatar du membre
thierryR
Messages : 227
Enregistré le : ven. 28 juil. 2017 18:50
Contact :

Re: problème JSON

Message par thierryR » dim. 1 juil. 2018 10:50

être ou ne pas être.... chacun choisi son style. !!!!!!!!!!!!!!!! s'il ne faut pas utiliser les PPA, alors verrouillons les et laissons les aux seuls dev. Si par contre ils existent, ce n'est peut pas non plus pour rien. Si je ne suis pas sous wind.... c'est peut aussi pour ne pas suivre un schéma tout tracé qu'on voudrait m'imposer. On ne se connait pas, mais le conformisme; je le laisse aux autres. Merci tout de même de votre participation qui a permis de développer le sujet: PPA ou pas de PPA.
Kernel: 4.13.0-37-generic x86_64 (64 bit) Desktop: KDE Plasma 5.8.9
Distro: Linux Mint 18.3 Sylvia
Graphics: Card: Intel Device 22b1
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1600x900@60.01hz
GLX Renderer: Mesa DRI Intel HD Graphics 405 (Braswell) GLX Version: 3.0 Mesa 17.2.8
Audio: Card-1 Intel Device 2284 driver: snd_hda_intel Sound: ALSA v: k4.13.0-37-generic
Card-2 C-Media driver: USB Audio

Avatar du membre
victoria
Messages : 1049
Enregistré le : dim. 21 janv. 2018 20:10

Re: PPA ou pas de PPA

Message par victoria » dim. 1 juil. 2018 11:00

Chacun voit midi à sa porte avec les ppa :mrgreen:

Je suivais un de tes topics qui m'intéressait aussi, mais tu n'y as jamais donné de retour..
Dommage d'en ouvrir 50 mais de ne pas tous les suivre..

viewtopic.php?f=19&t=10103" onclick="window.open(this.href);return false;
_____________________________________________________________________________
- Le silence aussi possède la violence des mots -

Avatar du membre
david37
modérateur
Messages : 3285
Enregistré le : lun. 22 août 2016 05:06

Re: PPA ou pas de PPA

Message par david37 » mar. 3 juil. 2018 17:20

Bonjour,
si le sujet est résolu merci d'éditer le premier message du sujet, puis :
  1. mettre un petit Image, comme suit: voir tuto ici
  2. mettre un [résolu] (entre crochets et à gauche) dans le titre de ce premier message <--- il te reste celà à faire ;)
PC1: Hp pavilion g6 / 1.36 GHz AMD E2-1800 APU with Radeon(tm) HD Graphics / 500 GB hard drive / 4G RAM /
Debian 9.9 Xfce
PC2: Hp-Pavilion Slimline / 2.5 GHz AMD RV710 / 4GB RAM / 500 GB hard drive / LM 18.3 Xfce x64
PC3: Lenovo ThinkPad R61i / 1.87 GHz Intel T2390 / NVIDIA G86M / 2GB RAM / 100 GB Hard Drive / LMDE2-Mate x64
PC4: Dell-Latitude E7240 / 2GHz i5-4310U / Intel Haswell-ULT HD 4400 / 8GB RAM / 500 GB Hard Drive / LM 19.1 Xfce x64

Répondre