Résolu le 10-02-19 [Résolu] Problème des mises à jour

Installation, configuration et utilisation des logiciels que vous souhaitez installer.
Avatar du membre
Pingouindumint
Messages : 305
Enregistré le : ven. 6 janv. 2017 17:47
Contact :

[Résolu] Problème des mises à jour

Message par Pingouindumint »

Bonjour à tous,

Sur le pc (de mes amis donc à distance) en panne avec firefox, voir le sujet viewtopic.php?f=24&t=10354
et comme les réponses concernent différents sujets, je créé donc un nouveau post.

Des problèmes surviennent quand je lance la mise à jour après l'installation.
J'ai donc essayé d'installer différentes versions de mint (17.0, 18.3 et 19) et à chaque fois, Il y a des erreurs de fichier quand je lance la mise à jour après une nouvelle installation.
Sur la dernière install sur ce pc, le genre de message que je reçois :

Code : Tout sélectionner

 » : fin de fichier ou de flux inattendue
Préparation du dépaquetage de .../perl_5.26.1-6ubuntu0.1_amd64.deb ...
Dépaquetage de perl (5.26.1-6ubuntu0.1) sur (5.26.1-6) ...
Préparation du dépaquetage de .../perl-base_5.26.1-6ubuntu0.1_amd64.deb ...
Dépaquetage de perl-base (5.26.1-6ubuntu0.1) sur (5.26.1-6) ...
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libperl5.26_5.26.1-6ubuntu0.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de récupération :
Paramétrage de perl-base (5.26.1-6ubuntu0.1) ...
dpkg: des problèmes de dépendances empêchent la configuration de perl :
 perl dépend de perl-modules-5.26 (>= 5.26.1-6ubuntu0.1) ; cependant :
  La version de perl-modules-5.26 sur le système est 5.26.1-6.
 perl dépend de libperl5.26 (= 5.26.1-6ubuntu0.1) ; cependant :
  La version de libperl5.26:amd64 sur le système est 5.26.1-6.

dpkg: erreur de traitement du paquet perl (--configure) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour libc-bin (2.27-3ubuntu1) ...
Traitement des actions différées (« triggers ») pour man-db (2.8.3-2) ...
Des erreurs ont été rencontrées pendant l'exécution :
 perl
ou bien

Code : Tout sélectionner

E: /var/cache/apt/archives/language-pack-fr-base_1%3a14.04+20160720_all.deb: impossible de copier les données extraites pour « ./usr/share/locale-langpack/fr/LC_MESSAGES/gnupg2.mo » vers « /usr/share/locale-langpack/fr/LC_MESSAGES/gnupg2.mo.dpkg-new » : fin de fichier ou de flux inattendue
J'ai réinstallé la 18.3 sur mon second pc mais je ne rencontre pas du tout ce même problème.
Il est donc spécifique à ce pc : problème matériel ?
La config de ce pc :
1 processeur Intel Core i3-4130 (3.4 GHz) et carte mère Asus H87-PLUS, 8 Go de Ram et 1 clavier multimédia qui vient d'un ancien pc (détail peut-être important).

Ce qui est bizarre quand je démarre ave cla clé usb, il me propose d'aller dans le menu de boot uefi alors que je n'ai que win7 etmint installé en dual boot et 500 Go en hdd.

Merci d'avance.
Modifié en dernier par Pingouindumint le mar. 31 juil. 2018 21:11, modifié 1 fois.
PC1 : Kernel: 5.3.0-26-generic x86_64 bits: 64 Desktop: MATE 1.22.2 - Linux Mint 19.3 Tricia
CM ASRock AB350 Pro4 - CPU : AMD Ryzen 5 2600 - 64 - CG Sapphire Radeon HD 6450
Realtek RTL8111/8168/8411 PCI - Hdd : Seagate 1.82 TiB et Kingston SSD : 240 Go - RAM 2x 8 Go
Double boot : Win10-linuxmint

PC 2 : Linux Mint 19.2 Mate 64 - CM : Asus M3A - CPU: AMD Phenom 9350e - CG : MSI Radeon HD 5450 - Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter

Avatar du membre
alain
Messages : 7451
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Problème des mises à jour

Message par alain »

Bonjour Pingouindumint.
Pingouindumint a écrit :

Code : Tout sélectionner

 » : fin de fichier ou de flux inattendue
Tu as une interruption de la liaison avec le serveur.
Le reste des défauts en découle, car il manque des paquets ou même certains sont incomplets.

Fais tu les mises à jours en wifi? Ce message m'arrive souvent quand ma femme me bloque le wifi en passant
dans mon bureau.

Si tu fais les mises à jour en étant câblé avec le rj45, alors cela peu provenir de ta carte ethernet qui a des faiblesses. Ou le cable, ou la prise... (ça m'est arrivé aussi :( )
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 19.3 Tricia Xfce 4.14.1 | K: 4.15.0-88
PC2 :Core2 Quad Q9650 @ 3 GHz | CG: Radeon HD 4850 | OS: LM 19.3 Xfce 4.14.1 | K: 5.3.0-42
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19.0-6
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM17.3 KDE | K : 3.19

In a world without walls and fences, who needs windows and gates?

Avatar du membre
Pingouindumint
Messages : 305
Enregistré le : ven. 6 janv. 2017 17:47
Contact :

Re: Problème des mises à jour

Message par Pingouindumint »

Non, par câble en rj45.
Donc, ce serait un problème matériel réseau.
Le pc est relié directement à la box (livebox) par un câble rj45.
Donc, j'essaierai sans doute demain avec un autre câble et aussi une autre carte réseau. Il doit être branché directement sur la carte mère, il me semble.
Je vais regarder si je peux monter une carte réseau pci sur la carte mère en question.

Si c'était la carte ethernet défaillante, je lui en installerai une vieille en attendant d'en commander une d'actualité.
PC1 : Kernel: 5.3.0-26-generic x86_64 bits: 64 Desktop: MATE 1.22.2 - Linux Mint 19.3 Tricia
CM ASRock AB350 Pro4 - CPU : AMD Ryzen 5 2600 - 64 - CG Sapphire Radeon HD 6450
Realtek RTL8111/8168/8411 PCI - Hdd : Seagate 1.82 TiB et Kingston SSD : 240 Go - RAM 2x 8 Go
Double boot : Win10-linuxmint

PC 2 : Linux Mint 19.2 Mate 64 - CM : Asus M3A - CPU: AMD Phenom 9350e - CG : MSI Radeon HD 5450 - Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter

Avatar du membre
alain
Messages : 7451
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Problème des mises à jour

Message par alain »

Commence déjà par le câble et vérifie l'état des connecteurs, box/cm.
Pingouindumint a écrit : Je vais regarder si je peux monter une carte réseau pci sur la carte mère en question.
Si c'était la carte ethernet défaillante, je lui en installerai une vieille en attendant d'en commander une d'actualité.
Tu sais une vielle carte ethernet suffit souvent, pas forcément la peine d'en acheter une "up-to-date".
Sur l'ordi ou mon ethernet de la cm fonctionne mal, j'ai mis une vielle carte pci (2005)trouvée à la poubelle.
Bon ok elle est limité à 100 Mbps, mais il y a peu de gens qui on plus de 100Mps sur leur box...
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 19.3 Tricia Xfce 4.14.1 | K: 4.15.0-88
PC2 :Core2 Quad Q9650 @ 3 GHz | CG: Radeon HD 4850 | OS: LM 19.3 Xfce 4.14.1 | K: 5.3.0-42
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19.0-6
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM17.3 KDE | K : 3.19

In a world without walls and fences, who needs windows and gates?

Avatar du membre
Pingouindumint
Messages : 305
Enregistré le : ven. 6 janv. 2017 17:47
Contact :

Re: Problème des mises à jour

Message par Pingouindumint »

Ok. Je pensais que cela allait ralentir le débit.
On est en province. On n'en est pas encore à la fibre. Donc, je reste sur l'idée d'une vieille carte.

Sinon, je crois bien à ton explication du problème. Ce matin, avec différentes installs sur mon second pc, aucune erreur et cela quelque soit les réglages. J'en déduis donc à un problème matériel, donc la connexion réseau foireuse.

Je pense que j'irai demain pour dépanner mes amis. Je vous tiendrai au courant.

et merci beaucoup du coup de main. :)
PC1 : Kernel: 5.3.0-26-generic x86_64 bits: 64 Desktop: MATE 1.22.2 - Linux Mint 19.3 Tricia
CM ASRock AB350 Pro4 - CPU : AMD Ryzen 5 2600 - 64 - CG Sapphire Radeon HD 6450
Realtek RTL8111/8168/8411 PCI - Hdd : Seagate 1.82 TiB et Kingston SSD : 240 Go - RAM 2x 8 Go
Double boot : Win10-linuxmint

PC 2 : Linux Mint 19.2 Mate 64 - CM : Asus M3A - CPU: AMD Phenom 9350e - CG : MSI Radeon HD 5450 - Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter

Avatar du membre
Pingouindumint
Messages : 305
Enregistré le : ven. 6 janv. 2017 17:47
Contact :

Re: Problème des mises à jour

Message par Pingouindumint »

Sur la mint 19 mate 64 :
Bon, je suis allé cet après-midi pour essayer la connexion réseau :
1er test : avec une carte réseau : même problème.
2ème test : en changeant le câble rj45 : même problème
3ème test : j'ai ramené le pc et essai depuis chez moi : même problème

J'ai lancé le test d'intégrité sur la clé usb et il trouve 1 erreur de fichier à partir du menu de départ sur la clé : check integrity.
J'avais créé cette clé bootable avec unetbootin.

J'ai vérifié les isos 19.0 et 18.3 : ils sont bons.

J'essaie de vérifier la clé avec gparted mais il se ferme quand je lui demande de vérifier la clé.

Que conseillez-vous pour réparer ou créer une clé sans souci de lecture de fichiers ?
PC1 : Kernel: 5.3.0-26-generic x86_64 bits: 64 Desktop: MATE 1.22.2 - Linux Mint 19.3 Tricia
CM ASRock AB350 Pro4 - CPU : AMD Ryzen 5 2600 - 64 - CG Sapphire Radeon HD 6450
Realtek RTL8111/8168/8411 PCI - Hdd : Seagate 1.82 TiB et Kingston SSD : 240 Go - RAM 2x 8 Go
Double boot : Win10-linuxmint

PC 2 : Linux Mint 19.2 Mate 64 - CM : Asus M3A - CPU: AMD Phenom 9350e - CG : MSI Radeon HD 5450 - Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter

Avatar du membre
Pingouindumint
Messages : 305
Enregistré le : ven. 6 janv. 2017 17:47
Contact :

Re: Problème des mises à jour

Message par Pingouindumint »

Je suis allé un peu vite en besogne. Ce n'est pas la clé usb en cause pour plusieurs raisons :
- l'installation se déroule parfaitement sur le pc de mes amis ou sur mon second pc.
- j'ai testé la clé usb sur mon second pc et le test n'affiche pas d'erreur sur la clé.
- les erreurs de mise surviennent toujours après l'installation.

Je viens donc de tester la mémoire et ce n'est pas bon du tout.

Je vais essayer le test avec 1 barrette (il y en a 2).
Je vous tiens au courant.
PC1 : Kernel: 5.3.0-26-generic x86_64 bits: 64 Desktop: MATE 1.22.2 - Linux Mint 19.3 Tricia
CM ASRock AB350 Pro4 - CPU : AMD Ryzen 5 2600 - 64 - CG Sapphire Radeon HD 6450
Realtek RTL8111/8168/8411 PCI - Hdd : Seagate 1.82 TiB et Kingston SSD : 240 Go - RAM 2x 8 Go
Double boot : Win10-linuxmint

PC 2 : Linux Mint 19.2 Mate 64 - CM : Asus M3A - CPU: AMD Phenom 9350e - CG : MSI Radeon HD 5450 - Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter

Avatar du membre
zeb
Administrateur du site
Messages : 15918
Enregistré le : ven. 19 juin 2015 22:13
Localisation : Au pays du mistral

Re: Problème des mises à jour

Message par zeb »

:shock:
Et ce problème de barrettes te causerai des ennuis de mise a jour ? :-o
Je ne pense pas que cela vienne de là ;)
A lire avant de poster: https://www.cjoint.com/doc/19_12/ILAsoq ... -linux.pdf
Faire une signature: viewtopic.php?p=25608
Mettre l'attribut (résolu ou autre) a un sujet: viewtopic.php?f=2&t=2012&p=33386#p33386
Votre sujet n’apparaît pas: viewtopic.php?p=166241#p166241


LMDE4 Cinnamon sur tour perso

Avatar du membre
Pingouindumint
Messages : 305
Enregistré le : ven. 6 janv. 2017 17:47
Contact :

Re: Problème des mises à jour

Message par Pingouindumint »

J'ai testé avec memtest (qui se trouve dans le grub) les barrettes mémoire hier et aujourd'hui.
Hier, une était défectueuse sur 2 slots mémoire et l'autre bonne sur tous les slots.
Aujourd'hui, celle qui était défecteuse est maintenant ok : pas d'erreurs.
C'est à n'y rien comprendre.
J'ai retenté la mise à jour après install.
Je vous mets en copie les informations détaillées de la boîte de dialogue.
Peut-être que cela mettra quelqu'un sur une piste ?

Code : Tout sélectionner

E: lzma_read: Erreur de lecture (7)
E: Prior errors apply to /var/cache/apt/archives/distro-info-data_0.37ubuntu0.1_all.deb
E: Prior errors apply to /var/cache/apt/archives/libvte-2.91-common_0.52.2-1ubuntu1~18.04.1_all.deb
E: Prior errors apply to /var/cache/apt/archives/libvte-2.91-0_0.52.2-1ubuntu1~18.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/gir1.2-vte-2.91_0.52.2-1ubuntu1~18.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libcurl3-gnutls_7.58.0-2ubuntu3.2_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libgbm1_18.0.5-0ubuntu0~18.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libegl-mesa0_18.0.5-0ubuntu0~18.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libgl1-mesa-dri_18.0.5-0ubuntu0~18.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libglx-mesa0_18.0.5-0ubuntu0~18.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libglapi-mesa_18.0.5-0ubuntu0~18.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libsoup2.4-1_2.62.1-1ubuntu0.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libsoup-gnome2.4-1_2.62.1-1ubuntu0.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libgl1-mesa-glx_18.0.5-0ubuntu0~18.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libglx0_1.0.0-2ubuntu2.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libgl1_1.0.0-2ubuntu2.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libgles2-mesa_18.0.5-0ubuntu0~18.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libgles2_1.0.0-2ubuntu2.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libegl1-mesa_18.0.5-0ubuntu0~18.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libglvnd0_1.0.0-2ubuntu2.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libegl1_1.0.0-2ubuntu2.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libwayland-egl1-mesa_18.0.5-0ubuntu0~18.04.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/file_1%3a5.32-2ubuntu0.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libmagic1_1%3a5.32-2ubuntu0.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libmagic-mgc_1%3a5.32-2ubuntu0.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libisc-export169_1%3a9.11.3+dfsg-1ubuntu1.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/libdns-export1100_1%3a9.11.3+dfsg-1ubuntu1.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/netcat-openbsd_1.187-1ubuntu0.1_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/netplan.io_0.36.3_amd64.deb
E: Prior errors apply to /var/cache/apt/archives/networkd-dispatcher_1.7-0ubuntu3.2_all.deb
E: Prior errors apply to /var/cache/apt/archives/nplan_0.36.3_all.deb
debconf: Échec d'apt-extracttemplates : Resource temporarily unavailable
Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
dpkg-deb (sous-processus) : décompression du membre de l'archive : erreur LZMA : le format de fichier n'est pas reconnu
tar: Ceci ne ressemble pas à une archive de type « tar »
tar: Arrêt avec code d'échec à cause des erreurs précédentes
dpkg-deb: erreur: tar subprocess returned error exit status 2
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/distro-info-data_0.37ubuntu0.1_all.deb (--unpack) :
 dpkg-deb --control subprocess returned error exit status 2
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/distro-info-data_0.37ubuntu0.1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de récupération :
Problème de lecture sur les partitions ?

On est un peu dans le brouillard.
Existe-t-il une commande pour vérifier le bon fonctionnement du système ?

Merci d'avance.
PC1 : Kernel: 5.3.0-26-generic x86_64 bits: 64 Desktop: MATE 1.22.2 - Linux Mint 19.3 Tricia
CM ASRock AB350 Pro4 - CPU : AMD Ryzen 5 2600 - 64 - CG Sapphire Radeon HD 6450
Realtek RTL8111/8168/8411 PCI - Hdd : Seagate 1.82 TiB et Kingston SSD : 240 Go - RAM 2x 8 Go
Double boot : Win10-linuxmint

PC 2 : Linux Mint 19.2 Mate 64 - CM : Asus M3A - CPU: AMD Phenom 9350e - CG : MSI Radeon HD 5450 - Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter

Avatar du membre
Pingouindumint
Messages : 305
Enregistré le : ven. 6 janv. 2017 17:47
Contact :

Re: Problème des mises à jour

Message par Pingouindumint »

J'ai refait les tests des barrettes avec memtest. Elles sont bonnes toutes les 2 si j'en installe une seule à la fois et que je teste.
Si j'installe les 2, c'est la cata : c'est tout mauvais.

Je ne sais pas dire si les barrettes sont mauvaises ou si c'est les slots de la carte mère et donc la carte mère défectueuse.
Je pense que ce serait la carte mère.

Et vous, qu'en pensez-vous si vous avez une idée ?
PC1 : Kernel: 5.3.0-26-generic x86_64 bits: 64 Desktop: MATE 1.22.2 - Linux Mint 19.3 Tricia
CM ASRock AB350 Pro4 - CPU : AMD Ryzen 5 2600 - 64 - CG Sapphire Radeon HD 6450
Realtek RTL8111/8168/8411 PCI - Hdd : Seagate 1.82 TiB et Kingston SSD : 240 Go - RAM 2x 8 Go
Double boot : Win10-linuxmint

PC 2 : Linux Mint 19.2 Mate 64 - CM : Asus M3A - CPU: AMD Phenom 9350e - CG : MSI Radeon HD 5450 - Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter

Répondre