Résolu le 5-05-19 Désactivation forcée de toutes les extensions de Firefox (bogue)

Installation, configuration et utilisation des logiciels que vous souhaitez installer.
Avatar du membre
arghlub
modérateur
Messages : 6438
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: C'est quoi le problème avec Firefox?

Message par arghlub » sam. 4 mai 2019 11:20

Dernier message de la page précédente :

Salut noname,
noname a écrit :
sam. 4 mai 2019 09:43
ça marche également pour moi mais pas pour le français ...
Supprime le pack de langue français dans les modules complémentaires de Firefox (onglet Langues) et reinstalle-le à partir de ce lien : https://addons.mozilla.org/fr/firefox/a ... uage-pack/
Chez moi c'est repassé en français après redémarrage de FF. ;)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3GHz | tripleBoot : Debian 10 | MXlinux | LMint 19.2 Tina | XFCE
Portable Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LMint 18.3 Sylvia | MXlinux | LMint 19.2 | XFCE
+ autres PCs + RaspberryPis + VMs ...
─────( pour une informatique libre ! -membre de l' April.org )────────────────

noname
Messages : 303
Enregistré le : jeu. 18 août 2016 18:55

Re: C'est quoi le problème avec Firefox?

Message par noname » sam. 4 mai 2019 11:47

Hello,
Effectivement ça marche. Merci ;)
Modifié en dernier par Invité le sam. 4 mai 2019 11:50, modifié 1 fois.
Raison : suppression de la citation reprenant le message précédent à 100%
NUC Intel Skylake 6I5SYH (Intel Iris Graphics 540) - 16Go RAM - SSD CORSAIR Force MP510 NVMe PCIe
Linux Mint 19.1 cinnamon - noyau 4.15 - Intel Microcode

Avatar du membre
thyam
Messages : 4896
Enregistré le : mar. 14 juil. 2015 10:33
Localisation : Lille - Hauts de France

Re: C'est quoi le problème avec Firefox?

Message par thyam » sam. 4 mai 2019 11:49

pc principal : hp pavilion dv6 - core i5 - 8go ram - dd 1 to - CG dual Intel HD graphics 3000 / Amd Radeon HD 7400m
dual boot W$ (taf oblige) / LMDE Cindy et Cinnamon

« Seul, on va plus vite... Ensemble, on va plus loin ;) »

Avatar du membre
Mia88
Messages : 617
Enregistré le : ven. 18 nov. 2016 08:42
Localisation : Lorraine

Re: C'est quoi le problème avec Firefox?

Message par Mia88 » sam. 4 mai 2019 13:52

Bonjour,

Un grand merci à joel49 qui a résumé en 2 lignes comment récupérer ses extensions FF, ça fonctionne impec ;)
PC 1 - Mint Cinnamon 19.1 64-bits / Intel Xeon CPU E3-1270 V2 3.5GHz x 4 / Ram 15.6 Go / CG NVIDIA GF106GL [Quaro 2000]
PC 2 - Mint Cinnamon 18.3 64 bits / Intel Core i7-2600 CPU @ 3.40GHz x 4 / Ram 15.6 Go / CG Advanced Micro Devices, inc. [AMD/ATI] Hawaii XT [Radeon R9 290X] (prog-if 00[VGA controller])
VB : LMDE3, openSUSE, Solus, Nutyx, Slackware, Manjaro, TrueOS BSD, MX-17, Peppermint, Calculate, DFLinux, Debian, Mageia, ArchLinux, Antix, Fedora, Deepin, SolydX, Q4OS

noname
Messages : 303
Enregistré le : jeu. 18 août 2016 18:55

Re: C'est quoi le problème avec Firefox?

Message par noname » sam. 4 mai 2019 13:56

on dirait que ça remarche normalement ...
NUC Intel Skylake 6I5SYH (Intel Iris Graphics 540) - 16Go RAM - SSD CORSAIR Force MP510 NVMe PCIe
Linux Mint 19.1 cinnamon - noyau 4.15 - Intel Microcode

Avatar du membre
Scrat
Messages : 389
Enregistré le : lun. 6 août 2018 19:05
Localisation : île d'Oléron

Re: C'est quoi le problème avec Firefox?

Message par Scrat » sam. 4 mai 2019 16:33

noname a écrit :
sam. 4 mai 2019 13:56
on dirait que ça remarche normalement ...
Et non ! Je viens juste de me connecter, et après avoir fonctionné normalement quelques minutes, Firefox m'a tout désactivé lorsque j'ai changé d'URL !!!! :evil:

Heureusement, ouvrir "about:config", recherche des paramètres "signatures", double clic pour les passer à "false", redémarrage de FF et je retrouve mes extensions. Il m'a quand même fallu réactiver le thème qui était resté désactivé.

Comprends pas comment ils ont pu laisser passer une bourde pareille ! :? Ils ont fait leur apprentissage chez Micro$oft ? :lol:
Portable Lenovo Ideapad 320-17IKB - Linux Mint 19.2 Tina - Cinnamon 4.2.4
Noyau Linux 4.15.0-62-generic - CPU Intel© Core™ i5-7200U CPU @ 2.50GHz × 2
RAM 7.6 Go - Disque HDD 960.4 Go
Carte Graphique Nvidia GeForce 920MX 2 Go - Intel Corporation HD Graphics 620

On a toujours tort d'essayer d'avoir raison devant des gens qui ont toutes les bonnes raisons de croire qu'ils n'ont pas tort ! (Raymond Devos) :lol:

Avatar du membre
cyrille
Messages : 2931
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: C'est quoi le problème avec Firefox?

Message par cyrille » sam. 4 mai 2019 18:39

D'apres la liste debian, pas le seul module de desactivé mais aussi, qwant le cnrtl etc...
# Me : DELL Lat E5430, SSD, 64-bit, RAM 8Go [ FreeBSD 12.0, xfce / Openbox ; DEBIAN SID via VirtualBox] | E7440, SSD, amd64, RAM 8Go [ DEBIAN SID, xfce]
# Me : VPS : 1 vCore 2 GHz , SSD, RAM 2Go, Local RAID, DEBIAN STABLE https://cbiot.fr
# Work : Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE | Parc DELL Lat E6* LINUX MINT, 18.3 Sylvia, amd64, XFCE.

All you need : #!/bin/bash | SVP les chiants pas de MP...

Avatar du membre
Scrat
Messages : 389
Enregistré le : lun. 6 août 2018 19:05
Localisation : île d'Oléron

Re: C'est quoi le problème avec Firefox?

Message par Scrat » sam. 4 mai 2019 19:45

Une autre solution pour résoudre le problème indiquée ici:
https://www.generation-nt.com/firefox-e ... 64605.html

En résumé, il faut autoriser FF à installer et lancer des études dans les préférences "Sécurié et vie privée". Normalement, c'est activé par défaut:

Image

Ensuite, pour vérifier que le correctif est installé, relancez FF, attendez un peu et ouvrez dans un onglet "about:studies". Vous devez voir le correctif, ici encadré en rouge:

Image

Ensuite, j'ai rétabli les paramètres par défaut pour les signatures (true) et ça semble fonctionner. Si ça marche, vous pouvez supprimer l'autorisation donnée à FF.
Portable Lenovo Ideapad 320-17IKB - Linux Mint 19.2 Tina - Cinnamon 4.2.4
Noyau Linux 4.15.0-62-generic - CPU Intel© Core™ i5-7200U CPU @ 2.50GHz × 2
RAM 7.6 Go - Disque HDD 960.4 Go
Carte Graphique Nvidia GeForce 920MX 2 Go - Intel Corporation HD Graphics 620

On a toujours tort d'essayer d'avoir raison devant des gens qui ont toutes les bonnes raisons de croire qu'ils n'ont pas tort ! (Raymond Devos) :lol:

Asterix
Messages : 130
Enregistré le : lun. 2 janv. 2017 21:54

Re: C'est quoi le problème avec Firefox?

Message par Asterix » sam. 4 mai 2019 20:43

Salut à tous,

Même chose pour moi depuis 1/4 d'heure : quasiment plus d'extensions Firefox, dont UBlock origin... :evil:

Merci pour les explications ; de ce que je comprends, il suffit juste d'attendre un peu et tout va rentrer dans l'ordre...
Portable ASUS (X77 Series) de 2010 / Linux Mint 18.1 Cinnamon 64-bit / Cinnamon 3.2.7 / Noyau Linux 4.4.0-53-generic / Proc. Intel Core i3 CPU M 350 @ 2.27GHz x 2 / RAM 3.7 Go / d.d. 229.6 Go / c.g. Intel Corporation Core Processor Integrated Graphics Controller / C.g. NVIDIA Corporation GT216M [GeForce GT 325M] / carte son externe Asus

Avatar du membre
arghlub
modérateur
Messages : 6438
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: C'est quoi le problème avec Firefox?

Message par arghlub » sam. 4 mai 2019 20:55

Salut Asterix,

Ouvre un onglet et tape «about:config» dans la barre d'adresse.
Un message de mise en garde va apparaître, là tu cliques sur le bouton «Je prends le risque».
Ensuite dans le champ de recherche tu saisis «xpinstall.signatures.required» et tu double-cliques sur la ligne qui apparait pour passer sa valeur à «false».

En image :
Image
Et tes extensions devraient revenir instantanément.
;)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3GHz | tripleBoot : Debian 10 | MXlinux | LMint 19.2 Tina | XFCE
Portable Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LMint 18.3 Sylvia | MXlinux | LMint 19.2 | XFCE
+ autres PCs + RaspberryPis + VMs ...
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Avatar du membre
cyberbleuet
Messages : 210
Enregistré le : jeu. 5 janv. 2017 17:18
Localisation : Alma, Québec
Contact :

Re: C'est quoi le problème avec Firefox?

Message par cyberbleuet » dim. 5 mai 2019 01:11

la même m***e ce soir avec firefox :evil:
Portable HP AMD A-6, 8G mémoire, ssd-256G graphique AMD, converti en Desktop avec un écran LG 21'' ips (pc de récupération) ben quand t'a la fibre environnementale ;) Os/Linux sous XFCE
------------
Laptop: HP-Stream 14'' Celeron N3060@1.60 GHz, graphique Intel, eMMC 32Gb, 4G mémoire Os/Linux Deepin

Verrouillé