Résolu le 26-04-19 [Résolu]Jeu qui ne s'installe pas via Play.it

Pour tous les problèmes ou astuces concernant les jeux
Répondre
Ecila
Messages : 5
Enregistré le : dim. 29 avr. 2018 10:13

[Résolu]Jeu qui ne s'installe pas via Play.it

Message par Ecila » dim. 29 avr. 2018 11:08

Hello,

Je viens demander un peu d'aide ! Après être tomber sur le topic sur ./play.it, je me suis dit "Joie ! Testons !" mais..

Je suis sur LM Cinnamon 18.1 32bits. Détail qui a peut-être son importance : l'action se passe sur un vieux eeepc ! J'ai tenté d'installer deux jeux : Caesar III et Theme Hospital (oui, je joue à des vieux trucs euh :p), dans les deux cas, j'obtiens le même résultat, lorsqu'il génère les commandes à exécuter en root, j'obtiens

Code : Tout sélectionner

./play-theme-hospital.sh: 1744: [: apt: unexpected operator
./play-theme-hospital.sh: 1745: [: apt: unexpected operator

Code : Tout sélectionner

dpkg -i /home/alice/Bureau/TH/theme-hospital-data_1.0-gog2.0.0.7+20180331.3_all.deb /home/alice/Bureau/TH/theme-hospital-dosbox_1.0-gog2.0.0.7+20180331.3_i386.deb

Code : Tout sélectionner

apt-get install -f
J'exécute malgré tout les deux commandes et j'obtiens

Code : Tout sélectionner

Mini TH # dpkg -i /home/alice/Bureau/TH/theme-hospital-data_1.0-gog2.0.0.7+20180331.3_all.deb /home/alice/Bureau/TH/theme-hospital-dosbox_1.0-gog2.0.0.7+20180331.3_i386.deb
(Lecture de la base de données... 265517 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../theme-hospital-data_1.0-gog2.0.0.7+20180331.3_all.deb ...
Dépaquetage de theme-hospital-data (1.0-gog2.0.0.7+20180331.3) sur (1.0-gog2.0.0.7+20180331.3) ...
Préparation du dépaquetage de .../theme-hospital-dosbox_1.0-gog2.0.0.7+20180331.3_i386.deb ...
Dépaquetage de theme-hospital-dosbox (1.0-gog2.0.0.7+20180331.3) sur (1.0-gog2.0.0.7+20180331.3) ...
Paramétrage de theme-hospital-data (1.0-gog2.0.0.7+20180331.3) ...
Paramétrage de theme-hospital-dosbox (1.0-gog2.0.0.7+20180331.3) ...
Mini TH # apt-get install -f
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 270 non mis à jour.
Bref, rien qui s'installe et je ne sais pas trop quoi faire. J'ai peut-être loupé une étape mais je ne vois pas trop à quel niveau :/

Merci pour votre aide !
Modifié en dernier par Ecila le mar. 1 mai 2018 14:14, modifié 2 fois.

Avatar du membre
vv221
Messages : 67
Enregistré le : dim. 21 août 2016 16:52
Contact :

Re: Jeu qui ne s'installe pas via Play.it

Message par vv221 » lun. 30 avr. 2018 20:02

Ton jeu me paraît correctement installé, tu as vérifié si un lanceur pour Theme Hospital ne se trouve pas dans ton menu d’applications ?

La commande finale "apt-get install -f" n’installe de paquets que si certaines dépendances du jeu sont manquantes. Si toutes les dépendances sont déjà installées elle ne fait rien.

Ecila
Messages : 5
Enregistré le : dim. 29 avr. 2018 10:13

Re: Jeu qui ne s'installe pas via Play.it

Message par Ecila » mar. 1 mai 2018 05:11

...

C'est par où la sortie ??

Partant du principe que rien n'avait installé, je n'avais même vérifié ! Tu as raison, j'ai bien des lanceurs pour les deux jeux, je n'ai pas eu l'occasion de tester plus que ça mais les deux jeux se lancent et je peux commencer des parties, ce qui est déjà pas mal !

Désolée pour le dérangement :mrgreen: Et merci pour l'explication. Et merci pour Play.it parce que pour le coup, c'est vraiment très facile à utiliser et très pratique !

Avatar du membre
alain
Messages : 6587
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Jeu qui ne s'installe pas via Play.it

Message par alain » mar. 1 mai 2018 05:23

Bonjour Ecila.

Cool que ça fonctionne :D

En revanche, je ne pige pas ce qui t'a induit en erreur, qu'est ce qui a bien pu te faire penser que ça ne fonctionnait pas? :?
Et autre chose hors sujet donc balises spoiler:
Tu devrais faire tes mises à jour, c'est important pour avoir un system stable et sécurisé, parce que la... 270 :l :roll:
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2019/05/ ... iere09.png

Ecila
Messages : 5
Enregistré le : dim. 29 avr. 2018 10:13

Re: Jeu qui ne s'installe pas via Play.it

Message par Ecila » mar. 1 mai 2018 05:49

Je fais ce que le système me dit et le système me dit qu'il est à jour (ce qui est quand même curieux pour un pc qui n'a pas été allumé depuis 5 mois donc je vais revérifier ^^ )

Ce qui m'a induite en erreur c'est le fait qu'il n'installe rien tout simplement (je n'ai pas pensé que tout pouvait déjà être installé) Je ne suis pas une grosse utilisatrice de Linux, ceci explique certainement cela !

Avatar du membre
alain
Messages : 6587
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Jeu qui ne s'installe pas via Play.it

Message par alain » mar. 1 mai 2018 07:35

Ecila a écrit :Je fais ce que le système me dit et le système me dit qu'il est à jour
S'il le gestionnaire de Mise à jour, mintupdate (l’icône bouclier dans le tableau de bord en bas à gauche) te dit que c'est à jour, alors tu as un problème.
Car tu as 270 paquets non à jour, normal au bout de 5 mois.
Donc si c'est le cas je serai toi, j'ouvrirai un sujet dans "général" avec un titre du style "mintupdate ne fonctionne pas".
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2019/05/ ... iere09.png

Ecila
Messages : 5
Enregistré le : dim. 29 avr. 2018 10:13

Re: Jeu qui ne s'installe pas via Play.it

Message par Ecila » mar. 1 mai 2018 07:45

Après une màj de mindupdate, ça va mieux, il est en train de faire les màj là :)

Avatar du membre
alain
Messages : 6587
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Jeu qui ne s'installe pas via Play.it

Message par alain » mar. 1 mai 2018 07:51

:D
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2019/05/ ... iere09.png

Avatar du membre
arghlub
modérateur
Messages : 6700
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Jeu qui ne s'installe pas via Play.it

Message par arghlub » mar. 1 mai 2018 13:53

Salut,

Super si tout est rentré dans l'ordre 8-)

Si le sujet est résolu, merci d'éditer le premier message du sujet, puis :
  1. mettre un petit Image, comme suit : voir tuto ici
  2. mettre un [résolu] (entre crochets et à gauche) dans le titre de ce premier message
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3GHz | tripleBoot : Debian 10 | MXlinux | LMint 19.2 Tina | XFCE
Portable Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LMint 18.3 Sylvia | MXlinux | LMint 19.2 | XFCE
+ autres PCs + RaspberryPis + VMs ...
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Ecila
Messages : 5
Enregistré le : dim. 29 avr. 2018 10:13

Re: [Résolu]Jeu qui ne s'installe pas via Play.it

Message par Ecila » mar. 1 mai 2018 14:19

Merci à tous :)

Répondre