Résolu le 26-04-19 [RESOLU] Installation judicieuse d'une mise à jour de niveau 4

Tous les sujets touchant à la sécurité du système.
Avatar du membre
Linuxing
Messages : 1196
Enregistré le : mar. 25 août 2015 01:28

Re: Installation judicieuse d'une mise à jour de niveau 4

Message par Linuxing » ven. 11 mai 2018 01:09

Dernier message de la page précédente :

cyrille a écrit :Si c'est un paquet qui t'embete dans les mises à jour, gèle le et met à jour le système
cf

Code : Tout sélectionner

aptitude hold LePaquet
Salut cyrille ;)

Dans le cas présent comment le nom du paquet doit-il être précisément libellé dans la commande :?:
Laptop : Toshiba Satellite Pro S300-11F - Processeur Intel® Core™2 Duo T5870, Intel® GM45 Express chipset et Intel® WiFi Link 5100 - Disque dur 160 GB - 3,912 MB (mémoire maximale : 8,192 MB), DDR2 RAM (800 MHz) / Routeur B-BOX 3 avec clé WPA2 / OS : Linux Mint Sylvia 18.3 Mate Desktop (depuis le 15/02/18) - (Anciennement : LM 17.3)
Périphériques : 2 HD Western Digital - Imprimante HP Deskjet 2540 Tout-en-un / Scanner Canon Lide 110 - Navigateur : Firefox

Avatar du membre
bedarcher
Messages : 169
Enregistré le : ven. 25 mars 2016 16:09
Localisation : Hérault

Re: Installation judicieuse d'une mise à jour de niveau 4

Message par bedarcher » ven. 11 mai 2018 05:00

tu peux aussi aller dans gestionnaire de mise à jour clic droit sur le paquet incriminé et ensuite ignorer les mises à jour de ce paquet...
Dell Optiplex 740 enhance AMD Dual core 5000B 2.6 mhz 8 go pc2 5300
HD Radeon 6450 1GO

Imprimante réseau Epson SX 430W

mpedro
Messages : 1525
Enregistré le : dim. 8 nov. 2015 22:13
Contact :

Re: Installation judicieuse d'une mise à jour de niveau 4

Message par mpedro » ven. 11 mai 2018 09:35

Oui mais à ce petit jeu il faut bien savoir ce que l'on fait entre des paquets dépendants les uns des autres sur des mises à jour futures par exemple.
Stretch 32bits cinnamon/Fedora25/Sarah
Compaq 8510p/MSI GE70/Raspberry Pi2

Avatar du membre
cyrille
Messages : 2875
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Installation judicieuse d'une mise à jour de niveau 4

Message par cyrille » ven. 11 mai 2018 10:47

Dans le cas présent comment le nom du paquet doit-il être précisément libellé dans la commande
Si tu veux geler par exemple gelé le paquet bluefish pour garde la version actuelle, tout simplement

Code : Tout sélectionner

sudo aptitude hold bluefish
Aucune mise à jour du paquet ne sera réalisée jusqu'à ce que tu le "defreeze"

Code : Tout sélectionner

sudo aptitude unhold bluefish

VIA apt :

Code : Tout sélectionner

sudo apt-mark hold bluefish
sudo apt-mark unhold bluefish

Se rappeler des paquets que l'on a gelés, au choix

Code : Tout sélectionner

sudo aptitude search "~ahold"
sudo dpkg --list | grep ^hi
Oui mais à ce petit jeu il faut bien savoir ce que l'on fait entre des paquets dépendants les uns des autres sur des mises à jour futures par exemple.
Apt ou aptitude géreront ces dépendances ;)
# Me : DELL Lat E5430, SSD, 64-bit, RAM 8Go [ FreeBSD 12.0, xfce / Openbox ; DEBIAN SID via VirtualBox] | E7440, SSD, amd64, RAM 8Go [ DEBIAN SID, xfce]
# Me : VPS : 1 vCore 2 GHz , SSD, RAM 2Go, Local RAID, DEBIAN STABLE
# Work : Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE | Parc DELL Lat E6* LINUX MINT, 18.3 Sylvia, amd64, XFCE.

All you need : #!/bin/bash | SVP les chiants pas de MP...

mpedro
Messages : 1525
Enregistré le : dim. 8 nov. 2015 22:13
Contact :

Re: Installation judicieuse d'une mise à jour de niveau 4

Message par mpedro » ven. 11 mai 2018 12:40

Déjà qu'il y en a qui ont des pb avec les mises à jour on peut toujours bricoler car c'est aussi une solution non pérenne
Modifié en dernier par mpedro le ven. 11 mai 2018 22:50, modifié 1 fois.
Stretch 32bits cinnamon/Fedora25/Sarah
Compaq 8510p/MSI GE70/Raspberry Pi2

Avatar du membre
Linuxing
Messages : 1196
Enregistré le : mar. 25 août 2015 01:28

Re: Installation judicieuse d'une mise à jour de niveau 4

Message par Linuxing » ven. 11 mai 2018 19:23

cyrille a écrit :
Si tu veux geler par exemple gelé le paquet bluefish pour garde la version actuelle, tout simplement

Code : Tout sélectionner

sudo aptitude hold bluefish
Aucune mise à jour du paquet ne sera réalisée jusqu'à ce que tu le "defreeze"

Code : Tout sélectionner

sudo aptitude unhold bluefish
Dans mon cas, ce serait donc :

Code : Tout sélectionner

sudo aptitude hold linux-firmware
:?:
Laptop : Toshiba Satellite Pro S300-11F - Processeur Intel® Core™2 Duo T5870, Intel® GM45 Express chipset et Intel® WiFi Link 5100 - Disque dur 160 GB - 3,912 MB (mémoire maximale : 8,192 MB), DDR2 RAM (800 MHz) / Routeur B-BOX 3 avec clé WPA2 / OS : Linux Mint Sylvia 18.3 Mate Desktop (depuis le 15/02/18) - (Anciennement : LM 17.3)
Périphériques : 2 HD Western Digital - Imprimante HP Deskjet 2540 Tout-en-un / Scanner Canon Lide 110 - Navigateur : Firefox

Avatar du membre
cyrille
Messages : 2875
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Installation judicieuse d'une mise à jour de niveau 4

Message par cyrille » ven. 11 mai 2018 19:42

Si c'est lui qui pose problème oui
Esssaye ça ne risque rien (en sudo)

Code : Tout sélectionner

aptitude hold linux-firmware
aptitude update && aptitude upgrade
et tu verras qu'il ne sera pas mis à jour
# Me : DELL Lat E5430, SSD, 64-bit, RAM 8Go [ FreeBSD 12.0, xfce / Openbox ; DEBIAN SID via VirtualBox] | E7440, SSD, amd64, RAM 8Go [ DEBIAN SID, xfce]
# Me : VPS : 1 vCore 2 GHz , SSD, RAM 2Go, Local RAID, DEBIAN STABLE
# Work : Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE | Parc DELL Lat E6* LINUX MINT, 18.3 Sylvia, amd64, XFCE.

All you need : #!/bin/bash | SVP les chiants pas de MP...

Avatar du membre
Linuxing
Messages : 1196
Enregistré le : mar. 25 août 2015 01:28

Re: Installation judicieuse d'une mise à jour de niveau 4

Message par Linuxing » ven. 11 mai 2018 21:00

En fait, je te demandais ça parce que je ne suis pas sûr de la dénomination à utiliser :roll: Dans le gestionnaire, je vois ceci :

Image

La commande serait bien avec «linux-firmware» :?:

Mais ce «linux-firmware» comporte peut-être plusieurs choses dont certaines qui me seraient malgré tout utiles :?:
Laptop : Toshiba Satellite Pro S300-11F - Processeur Intel® Core™2 Duo T5870, Intel® GM45 Express chipset et Intel® WiFi Link 5100 - Disque dur 160 GB - 3,912 MB (mémoire maximale : 8,192 MB), DDR2 RAM (800 MHz) / Routeur B-BOX 3 avec clé WPA2 / OS : Linux Mint Sylvia 18.3 Mate Desktop (depuis le 15/02/18) - (Anciennement : LM 17.3)
Périphériques : 2 HD Western Digital - Imprimante HP Deskjet 2540 Tout-en-un / Scanner Canon Lide 110 - Navigateur : Firefox

Avatar du membre
cyrille
Messages : 2875
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Installation judicieuse d'une mise à jour de niveau 4

Message par cyrille » ven. 11 mai 2018 21:05

Geler n'est pas desinstaller le paquet
tu garderas ta version en cours, donc no pb
# Me : DELL Lat E5430, SSD, 64-bit, RAM 8Go [ FreeBSD 12.0, xfce / Openbox ; DEBIAN SID via VirtualBox] | E7440, SSD, amd64, RAM 8Go [ DEBIAN SID, xfce]
# Me : VPS : 1 vCore 2 GHz , SSD, RAM 2Go, Local RAID, DEBIAN STABLE
# Work : Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE | Parc DELL Lat E6* LINUX MINT, 18.3 Sylvia, amd64, XFCE.

All you need : #!/bin/bash | SVP les chiants pas de MP...

Berclav
Messages : 59
Enregistré le : dim. 11 mars 2018 13:00

Re: Installation judicieuse d'une mise à jour de niveau 4

Message par Berclav » sam. 12 mai 2018 10:56

Bonjour

Je fais les mises à jour de tous niveaux, mais pour celles qui touchent à des points clés dont le kernel, le firmware, la gestion graphique je fais une sauvegarde de ma partition système avant, comme ça si ça foire je n'aurai pas à ré-installer.
Donc autant je répugne à mettre les mains dans le cambouis pour des choses qui n'en valent pas la peine comme l'accès aux partitions et la capture d'écran qui sont très très mal gérés, autant utiliser une clé usb affectée en permanence au logiciel Clonezilla Live me paraît une très bonne chose.

Tuto une fois la clé installée
Booter dessus
Taper "Enter" de façon obsessionnelle jusqu'à ce qu'apparaisse la liste des partitions
Choisir une partition puis un dossier de sauvegarde de fichiers-images de sauvegarde, Z_Saveparts est un bon nom
Taper "Enter" encore jusqu'aux choix Débutant = OK puis choix partition image OK etc et save partition OK
Taper "Enter" encore jusqu'au choix de la partition à traiter et là choix avec la barre d'espace
Et enfin taper "Y" et Enter encore quand demandé

A un moment il y a le choix de nom de fichier mais moi je laisse le nom par défaut
PC Desktop homemade (tour mATX) - Alim Corsair CX430M
Dual boot Linux Mint 18.1 Serena 64bits / Windows XP SP3 - Cinnamon 3.2.7 - Kernel 4.4.0-124-generic x86_64
MSI A88XM-E35 V2 BIOS v : 6.0 en mode non UEFI - AMD A4 7300 APU - 2x 4 Go DDR3
APU with Radeon HD Graphics (8470 D) reconnu - Samsung Syncmaster B2430 - 1920x1080

Avatar du membre
cyrille
Messages : 2875
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Installation judicieuse d'une mise à jour de niveau 4

Message par cyrille » sam. 12 mai 2018 11:10

Si tu ne veux pas te prendre la tête, ne fais pas les mises à jour si le système fonctionne.
Un de mes fils à un PC sous un vieil ubuntu, il l'a configuré style gamer et n'a jamais fait de MAJ, il ne s'en porte pas plus mal...
Si ce n'est pas un serveur, pas trop embetant...
# Me : DELL Lat E5430, SSD, 64-bit, RAM 8Go [ FreeBSD 12.0, xfce / Openbox ; DEBIAN SID via VirtualBox] | E7440, SSD, amd64, RAM 8Go [ DEBIAN SID, xfce]
# Me : VPS : 1 vCore 2 GHz , SSD, RAM 2Go, Local RAID, DEBIAN STABLE
# Work : Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE | Parc DELL Lat E6* LINUX MINT, 18.3 Sylvia, amd64, XFCE.

All you need : #!/bin/bash | SVP les chiants pas de MP...

Répondre