Utilisation de RAM

Postez ici toutes vos demandes d’assistance.
Répondre
Asan
Messages : 23
Enregistré le : mar. 22 nov. 2022 12:16

Utilisation de RAM

Message par Asan »

Bonjour,

J'utilise l'applet Moniteur système pour suivre les performances de mon ordi car j'ai parfois des ralentissements, voire des freezes, malgré un processeur i7 et 32Go de RAM.
J'ai remarqué quelque chose d'étrange. La mémoire affichée sur le visuel de l'applet indique des valeurs très hautes (entre 10 et 15Go de RAM utilisée) alors que je ne fais parfois que de la bureautique. Même lorsque je ferme toutes les applis, la RAM utilisée affichée est environ de 10Go. Lorsque je parcours les processus ouverts cependant, la somme de la mémoire utilisée est plutôt de l'ordre de 3 à 5 Go (ce qui me paraît plus normal).

Mes questions :
- Quelles sont les bonnes pratiques / bons outils pour pour vérifier/optimiser les performances ?
- Peut-on vérifier le bon état de son matériel ?

Pour info, c'est un Lenovo P52 acheté sur TradeDiscount, donc reconditionné.

Merci pour vos avis,
Asan
Pc : Linux Mint 21.2 Victoria | Cinnamon 5.8.4 | 5.15.0-91-generic x86_64 | 6-core Intel Core i7-8750H | 32 GiB | Intel CoffeeLake-H GT2

Avatar du membre
Bateson
Messages : 770
Enregistré le : dim. 27 juin 2021 12:50
Localisation : Maine & Loire

Re: Utilisation de RAM

Message par Bateson »

Bonjour Asan,

Est ce ton problème de RAM est récent et postérieur à une modification quelconque ou bien d'origine ?

As tu vérifié la connexion de tes barrettes RAM ?
Peut être aussi vérifier avec Memory test (au démarrage à partir du grub), au cas ou tu aurais une barrette fichue, c'est rare mais ça arrive.

Installe Bpytop et laisse le tourner en tache de fond pour avoir des infos en continu sur l'utilisation de ta RAM et de tes processeurs. Bpytop est dans les dépôts de mint.

Code : Tout sélectionner

sudo apt install bpytop
ou par la logithèque

Tu ne peux le lancer que via le terminal

Code : Tout sélectionner

bpytop
tuto sur l'utilisation
https://www.youtube.com/watch?v=ph4E1MFUDGg

Mais bon i7 et 32 G de RAM, avant de saturer... :l
PC 1: LMDE 6 - XFCE, Noyau 6.1.0-16- CM Asus Z97-K/USB 3.1 Proc.: i5 4460 bits: 64 RAM: 32 GB CG: NV GeForce GTX 1050 C.Son: S. Blaster Core 3D/Z-Series DD: (Sys) SSD 1 TO + 4DD int 10 TB
PC 2: Mint 21 XFCE, Noyau 5.15.0-75- Virtualbox (Primtux) Proc.: i7 950 bits: 64 RAM: 12 GB CG: NV GeForce GTX 1060 DD: (Sys)SSD 500GB + DD int 500 GB
PC 3: Mint 20.3 XFCE, Noyau 5.4.0-109-Proc.: i3 3420 bits: 64 RAM: 8 GB CG: NV 117 DD: (Sys)SSD 500GB + DD int 500 GB

Avatar du membre
serged
Messages : 811
Enregistré le : jeu. 16 juil. 2015 07:59
Localisation : Montrouge (France)

Re: Utilisation de RAM

Message par serged »

Dès que tu as un peu de RAM, Linux l'utilise comme cache.
Que dit la commande free ?

Code : Tout sélectionner

$ free -h
               total       utilisé      libre     partagé tamp/cache   disponible
Mem:            15Gi       2,2Gi       2,7Gi        86Mi        10Gi        12Gi
Échange:       29Gi          0B        29Gi
(Ici avec 16 Go de RAM)
LinuxMint Virginia Cinnamon et d'autres machines en MATE, XFCE... 20.x , 21.x ou 19.x
Tour : Asus F2A55 / AMD A8-5600K APU 3,6GHz / RAM 16Go / Nvidia GeForce GT610 / LM21.1 Cinnamon
Portable : LDLC Mercure MH : Celeron N3450 /RAM 4Go / Intel HD graphics 500 i915 / biboot Win 10 (sur SSD) - LM21.1 MATE (sur HDD)

Avatar du membre
Bateson
Messages : 770
Enregistré le : dim. 27 juin 2021 12:50
Localisation : Maine & Loire

Re: Utilisation de RAM

Message par Bateson »

@ serged

Juste pour ma gouverne, histoire de comprendre
Qu'est ce qui fait que chez toi le cache en fasse 10G et chez moi:

Code : Tout sélectionner

~$ free -h
                 total       utilisé      libre     partagé tamp/cache   disponible
Mem:            31Gi       2,2Gi        26Gi        87Mi       3,4Gi        29Gi
Échange:       8,2Gi          0B       8,2Gi
PC 1: LMDE 6 - XFCE, Noyau 6.1.0-16- CM Asus Z97-K/USB 3.1 Proc.: i5 4460 bits: 64 RAM: 32 GB CG: NV GeForce GTX 1050 C.Son: S. Blaster Core 3D/Z-Series DD: (Sys) SSD 1 TO + 4DD int 10 TB
PC 2: Mint 21 XFCE, Noyau 5.15.0-75- Virtualbox (Primtux) Proc.: i7 950 bits: 64 RAM: 12 GB CG: NV GeForce GTX 1060 DD: (Sys)SSD 500GB + DD int 500 GB
PC 3: Mint 20.3 XFCE, Noyau 5.4.0-109-Proc.: i3 3420 bits: 64 RAM: 8 GB CG: NV 117 DD: (Sys)SSD 500GB + DD int 500 GB

Asan
Messages : 23
Enregistré le : mar. 22 nov. 2022 12:16

Re: Utilisation de RAM

Message par Asan »

Bonjour,
Désolé du délai de réponse !
Voici ce que retourne la commande

Code : Tout sélectionner

free -h
.

Code : Tout sélectionner

               total       utilisé      libre     partagé tamp/cache   disponible
Mem:            30Gi       9,6Gi        19Gi       746Mi       1,7Gi        20Gi
Échange:      2,0Gi          0B       2,0Gi
Je n'ai pas encore pris le temps de me plonger dans bpyTOP.

J'ai également remarqué que la batterie se vide très vite même lorsque l'ordi est en veille (même à 100% le soir, la batterie est vide le lendemain matin en veille). Est-ce que ça pourrait être lié ? Un truc qui tourne en fond ?

Merci,
Asan
Pc : Linux Mint 21.2 Victoria | Cinnamon 5.8.4 | 5.15.0-91-generic x86_64 | 6-core Intel Core i7-8750H | 32 GiB | Intel CoffeeLake-H GT2

Avatar du membre
Bateson
Messages : 770
Enregistré le : dim. 27 juin 2021 12:50
Localisation : Maine & Loire

Re: Utilisation de RAM

Message par Bateson »

Bonjour,

Quand tu as fait la commande:

Code : Tout sélectionner

free -h
te souviens tu si tu avais beaucoup de programmes lancés, parce que ton retour donne 9,6 Gi d'utilisés, ce qui me paraît beaucoup, mais fonction des processus qui tournent.

Peux tu refaire la commande, si tu ne sais plus, après démarrage de ton système sans rien lancer d'autre.

Si ton utilisation RAM reste trop forte, tu as peut être quand même intérêt à utiliser bpytop qui permettra d'identifier ce qui tourne, y compris les processus en tâche de fond. (utilisation du processeur et de la RAM)

As tu vérifié ta RAM avec Memory test ?
la batterie est vide le lendemain matin en veille). Est-ce que ça pourrait être lié ? Un truc qui tourne en fond ?
Probablement que ça pourrait jouer, mais je ne sais pas trop, en terme d'énergie ce qui pompe le plus, le proc, l'écran... Trop longtemps que je n'ai plus de portable et je n'ai jamais rencontré ce cas là. :?
PC 1: LMDE 6 - XFCE, Noyau 6.1.0-16- CM Asus Z97-K/USB 3.1 Proc.: i5 4460 bits: 64 RAM: 32 GB CG: NV GeForce GTX 1050 C.Son: S. Blaster Core 3D/Z-Series DD: (Sys) SSD 1 TO + 4DD int 10 TB
PC 2: Mint 21 XFCE, Noyau 5.15.0-75- Virtualbox (Primtux) Proc.: i7 950 bits: 64 RAM: 12 GB CG: NV GeForce GTX 1060 DD: (Sys)SSD 500GB + DD int 500 GB
PC 3: Mint 20.3 XFCE, Noyau 5.4.0-109-Proc.: i3 3420 bits: 64 RAM: 8 GB CG: NV 117 DD: (Sys)SSD 500GB + DD int 500 GB

Asan
Messages : 23
Enregistré le : mar. 22 nov. 2022 12:16

Re: Utilisation de RAM

Message par Asan »

Bonjour,

Je viens de lancer bpytop et j'observe la même incohérence sur la mémoire. La somme de la mémoire utilisée par tous les process ne correspond pas à la mémoire totale utilisée. Avez-vous également le même comportement ?

Image

Par ailleurs, sur ce screen, il n'y a aucun logiciel d'ouvert (à part Shutter pour faire le screen) et j'ai 6.8Go de mémoire utilisée... ce qui me semble anormal :| J'ai testé juste après un démarrage, je suis autour de 3Go (ce qui est déjà beaucoup je trouve).

Bonne soirée,
asan
Pc : Linux Mint 21.2 Victoria | Cinnamon 5.8.4 | 5.15.0-91-generic x86_64 | 6-core Intel Core i7-8750H | 32 GiB | Intel CoffeeLake-H GT2

Avatar du membre
Bateson
Messages : 770
Enregistré le : dim. 27 juin 2021 12:50
Localisation : Maine & Loire

Re: Utilisation de RAM

Message par Bateson »

Bonjour Asan,
La somme de la mémoire utilisée par tous les process ne correspond pas à la mémoire totale utilisée
Oui, mais si tu as calculé juste avec ce que tu as encadré en jaune c'est normal, les processus ne sont pas triés en fonction de l'utilisation de la RAM. Chez moi si tu descends tout en bas de la liste d'autres processus Ramivores sont là.

Par contre si tu utilises top, ils peuvent être classées par rapport à l'utilisation de la mémoire (ça doit pouvoir se faire aussi avec Bpytop , mais je sais pas :? ) :

Code : Tout sélectionner

top -o %MEM
il n'y a aucun logiciel d'ouvert (à part Shutter pour faire le screen) et j'ai 6.8Go de mémoire utilisée... ce qui me semble anormal
Je ne trouve pas ça normal non plus. Et même 3 G au démarrage, j'ai testé je tombe sur des valeurs entre 1,1 et 1,4 en fonction des machines et du Desktop.

Donc:
- As tu installé des applications qui tournent en permanence (mais pour bouffer autant ...)
- As tu vérifié et la connexion de ta RAM (bien qu'à mon avis ça donnerait pas ça) et son état (Mémory test)
- essaie peut-être de démarrer ton ordi sur un live usb et de lancer la commande:

Code : Tout sélectionner

free -h
ça dira au moins si ça vient de ton install ou pas.

Sinon, à voir, peut être quelqu'un d'autre du forum aura une piste.
PC 1: LMDE 6 - XFCE, Noyau 6.1.0-16- CM Asus Z97-K/USB 3.1 Proc.: i5 4460 bits: 64 RAM: 32 GB CG: NV GeForce GTX 1050 C.Son: S. Blaster Core 3D/Z-Series DD: (Sys) SSD 1 TO + 4DD int 10 TB
PC 2: Mint 21 XFCE, Noyau 5.15.0-75- Virtualbox (Primtux) Proc.: i7 950 bits: 64 RAM: 12 GB CG: NV GeForce GTX 1060 DD: (Sys)SSD 500GB + DD int 500 GB
PC 3: Mint 20.3 XFCE, Noyau 5.4.0-109-Proc.: i3 3420 bits: 64 RAM: 8 GB CG: NV 117 DD: (Sys)SSD 500GB + DD int 500 GB

Répondre