En cours écran noir pour la connexion avec pilote Nvidia

Questions concernant les composants
Avatar du membre
La Gaulle
Messages : 23
Enregistré le : mer. 18 déc. 2019 22:32
Localisation : Larçay ( 37 )

écran noir pour la connexion avec pilote Nvidia

Message par La Gaulle »

Bonjour.

J'ai un pc portable Asus avec un processeur I5 4210-U et une carte graphique Nvidia geforce 820M.
Lorsque je vais dans le gestionnaire de pilotes et que j'active le pilote Nvidia-340 qui est recommandé, lors du redémarrage du pc, j'ai un écran noir au moment de taper mon mot de passe.
Du coup je le tape à l'aveugle et là j'arrive sur mon bureau et tout fonctionne ensuite correctement ( jusqu'au prochain démarrage ).
Je n'ai pas du tout ce problème lorsque je laisse le pilote open source xserver-xorg-video-nouveau.
D'où peux venir le souci ?
C'est un peu dommage de devoir utiliser le GPU du CPU alors que j'ai un carte graphique Nvidia qui est là pour cela ( et surement plus performante en plus ).
Modifié en dernier par La Gaulle le ven. 26 juin 2020 13:23, modifié 2 fois.
Asus X751LD
CPU I5 4210U
Cinnamon 4.4.8
Graphics : device 1: intel haswell-ULT integrated graphics. Device 2: NVIDIA Gforce 117M ( 820M )
Mémoire: 12 giga

LMDE60
Messages : 215
Enregistré le : ven. 3 avr. 2020 18:08
Localisation : Nulle part

Re: Problème carte graphique

Message par LMDE60 »

1) Il faut remplir ta signature pour qu'on sache quel est ton matériel et parce que c'est la charte du forum, sinon pas de réponse.

2) exceptionnellement voila la réponse : le pilote propriétaire "Nvidia" ou le pilote libre "open source xserver-xorg-video-nouveau" ne change en rien sur la performance en faite, c'est une question de choix propriétaire ou libre. Après le pilote propriétaire peux apporter certaine options mais aussi du bug comparé a la version libre, ou amélioré certain bug de la version libre, en faite il faut tester.

Donc si le pilote libre est fonctionnel, tout va bien. 8-) t'inquiète pas tu peux rester sur le pilote libre, ta carte graphique est parfaitement pris en charge.

Avatar du membre
débitant
modérateur
Messages : 10305
Enregistré le : mar. 14 juil. 2015 18:22
Localisation : Lorraine France

Re: Problème carte graphique

Message par débitant »

LMDE60 a écrit :
dim. 21 juin 2020 19:23
1) Il faut remplir ta signature pour qu'on sache quel est ton matériel et parce que c'est la charte du forum, sinon pas de réponse.
...
+1
voir Aide pour une signature technique

Avatar du membre
thyam
modérateur
Messages : 6153
Enregistré le : mar. 14 juil. 2015 10:33
Localisation : Lille - Hauts de France

Re: Problème carte graphique

Message par thyam »

'Jour,
j'ajouterais également le titre, le mot problème ne veut rien dire !
Précise un peu plus sans 'problème', merci ;)
pc principal : hp pavilion dv6 - core i5 - 8go ram - dd 1 to - CG dual Intel HD graphics 3000 / Amd Radeon HD 7400m
dual boot W$ (taf oblige) / LMDE 4 'Debbie' et Cinnamon

« Seul, on va plus vite... Ensemble, on va plus loin ;) »

Avatar du membre
La Gaulle
Messages : 23
Enregistré le : mer. 18 déc. 2019 22:32
Localisation : Larçay ( 37 )

Re: Problème carte graphique

Message par La Gaulle »

Ma signature est faite ;)
J'ai 2 cartes graphiques dans mon pc portable, une intégrée à mon processeur I5 et une autre indépendante une Nvidia 820M avec la technologie Optimus.
J'aimerais que ma carte graphique active soit la Nvidia et non celle d'intel intégrée dans mon CPU.
Lorsque je fais la commande glxinfo | grep "OpenGL renderer" dans mon terminal, cela m'indique que la carte graphique active est justement l'intel du processeur I5.
Et comme je l'ai mentionné, lorsque je sélectionne le pilote Nvidia-340 qui est recommandé dans le gestionnaire de pilote, au redémarrage du pc je me retrouve avec un écran noir là où je dois rentrer mon mot de passe ( chose qui ne se produit pas si je sélectionne le pilote open source xserver-xorg-video-nouveau.
Asus X751LD
CPU I5 4210U
Cinnamon 4.4.8
Graphics : device 1: intel haswell-ULT integrated graphics. Device 2: NVIDIA Gforce 117M ( 820M )
Mémoire: 12 giga

Avatar du membre
alain
modérateur
Messages : 8285
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Problème carte graphique

Message par alain »

Bonjour La Gaulle.

Oui pour pouvoir "switcher" d'une carte a l'autre avec la technologie "optimus" via "prime" ou "bumblebee", il te faut obligatoirement le pilote Nvidia.
Voir ici : Wiki ubuntu : nVidia Optimus : la vidéo hybride

Mais dans ton cas, tu as des soucis avec le pilote Nvidia (ce n'est pas parce qu'il est "recommandé", que c'est le mieux pour ton matériel..), ce qui n'est pas rare, comme dit par LMDE60, avec le pilote propriétaire Nvidia, des fois c'est mieux, des fois c'est pire.

Alors si l'important pour toi n'est pas de pouvoir "switcher" d'une carte graphique à l'autre (nécessite un redémarrage), regarde dans ton BIOS si tu n'as pas la possibilité de désactiver la carte intel intégrée au CPU, c'est souvent le cas. Puis reste en Nvidia "only" avec le pilote libre "nouveau".
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 19.3 Tricia Xfce 4.14.1 | K: 4.15.0-88
PC2 :Core2 Quad Q9650 @ 3 GHz | CG: Radeon HD 4850 | OS: LM 19.3 Xfce 4.14.1 | K: 5.3.0-42
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19.0-6
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM17.3 KDE | K : 3.19

In a world without walls and fences, who needs windows and gates?

Avatar du membre
La Gaulle
Messages : 23
Enregistré le : mer. 18 déc. 2019 22:32
Localisation : Larçay ( 37 )

Re: Problème carte graphique

Message par La Gaulle »

Merci pour ta réponse.
Mais malheureusement, dans mon bios je ne peux rien modifier en ce qui concerne la carte graphique.
Je vais donc continuer à utiliser celle intégré dans mon processeur intel et mettre à la retraite forcée la Nvidia.
Asus X751LD
CPU I5 4210U
Cinnamon 4.4.8
Graphics : device 1: intel haswell-ULT integrated graphics. Device 2: NVIDIA Gforce 117M ( 820M )
Mémoire: 12 giga

zeb
Messages : 16481
Enregistré le : ven. 19 juin 2015 22:13
Localisation : plus ici

Re: Problème carte graphique

Message par zeb »

thyam a écrit :
lun. 22 juin 2020 08:06
'Jour,
j'ajouterais également le titre, le mot problème ne veut rien dire !
Précise un peu plus sans 'problème', merci ;)
Merci de ne pas ignorer la modération !

Avatar du membre
La Gaulle
Messages : 23
Enregistré le : mer. 18 déc. 2019 22:32
Localisation : Larçay ( 37 )

Re: Problème carte graphique

Message par La Gaulle »

?????
Asus X751LD
CPU I5 4210U
Cinnamon 4.4.8
Graphics : device 1: intel haswell-ULT integrated graphics. Device 2: NVIDIA Gforce 117M ( 820M )
Mémoire: 12 giga

Avatar du membre
thyam
modérateur
Messages : 6153
Enregistré le : mar. 14 juil. 2015 10:33
Localisation : Lille - Hauts de France

Re: Bug pilote Nvidia

Message par thyam »

Zeb veut simplement dire que tu n'as tjrs pas changé ton titre qui ne veut rien dire !!

edit : 'bug' :l
pc principal : hp pavilion dv6 - core i5 - 8go ram - dd 1 to - CG dual Intel HD graphics 3000 / Amd Radeon HD 7400m
dual boot W$ (taf oblige) / LMDE 4 'Debbie' et Cinnamon

« Seul, on va plus vite... Ensemble, on va plus loin ;) »

Répondre