Abandon le 24-02-21 Désactiver le mode BIOS-compatibility/CSM/Legacy dans le firmware UEFI

Questions concernant les composants
Avatar du membre
alain
modérateur
Messages : 10220
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Désactiver le mode BIOS-compatibility/CSM/Legacy dans le firmware UEFI

Message par alain »

Dernier message de la page précédente :

Bonjour Lobèze.

As tu démonté tes partitions avant d'essayé de les formater ?
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.1 Ulyssa Xfce 4.14 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.1 Xfce 4.14| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.1 XFCE 4.14 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Avatar du membre
Jennifer Lobèze
Messages : 44
Enregistré le : ven. 6 sept. 2019 13:28
Localisation : Lille - Hauts de France

Re: Désactiver le mode BIOS-compatibility/CSM/Legacy dans le firmware UEFI

Message par Jennifer Lobèze »

Bonjour Alain,
Euh non... c'est peut-être ça... J'essaie et vous rend compte. Merci ;)
Dell Inspiron 580 - Linux Mint 20.1 Ulyssa - Cinnamon 4.8.6 - Kernel 5.4.0-66-generic - CPU Intel Core i3 550 @ 3.20GHz × 2 - GPU NVIDIA GeForce GT 710 - pilote NVIDIA 390.141 - RAM 8 GB - Mobo Dell 0C2KJT - BIOS Legacy - GNU Grub 2.04 - Disque au format MBR - SSD Crucial MX500 250GB - 3 DDE

Avatar du membre
Jennifer Lobèze
Messages : 44
Enregistré le : ven. 6 sept. 2019 13:28
Localisation : Lille - Hauts de France

Re: Désactiver le mode BIOS-compatibility/CSM/Legacy dans le firmware UEFI

Message par Jennifer Lobèze »

Bonsoir,
Alors, voilà... pas grand chose... Je n'ai pas réussi à flasher le firmware (tant mieux ?) ni à formater le SSD et encore moins à démonter les partitions :oops: En revanche j'ai réinstallé deux fois le bouzin après avoir trouvé la bonne appli pour formater la clé USB (Etcher) et réussir enfin à utiliser Rufus pour graver l'ISO comme l'indiquait Mia. J'ai suivi les préconisations, à savoir BIOS + MBR, c'est à dire un système non UEFI. En aparté, j'ai beaucoup appris grâce à vous sur les disques et partitions. Malgré toutes ces précautions, l'install s'est faîte en EFI :x
Une image et Gparted et de la commande "lsblk"


Image
Image

Je me résigne jusqu'au moment où je ne supporterai plus ces problèmes de pilotes image et son, ces plantages à répétition,cette lenteur à l'allumage. Ce jour-là, j'irai chez un assembleur choisir un nouvel ordi qui fonctionnera sous le mode EFI :l
Merci vraiment beaucoup pour vos contributions et particulièrement Mia.
Il me semble donc, pour toutes ces raisons, qu'il est temps de clore le sujet en lui attribuant un courageux "abandon"
Dell Inspiron 580 - Linux Mint 20.1 Ulyssa - Cinnamon 4.8.6 - Kernel 5.4.0-66-generic - CPU Intel Core i3 550 @ 3.20GHz × 2 - GPU NVIDIA GeForce GT 710 - pilote NVIDIA 390.141 - RAM 8 GB - Mobo Dell 0C2KJT - BIOS Legacy - GNU Grub 2.04 - Disque au format MBR - SSD Crucial MX500 250GB - 3 DDE

Avatar du membre
Mia88
Messages : 1139
Enregistré le : ven. 18 nov. 2016 08:42
Localisation : Lorraine

Re: Désactiver le mode BIOS-compatibility/CSM/Legacy dans le firmware UEFI

Message par Mia88 »

Bonjour, j'avais zappé ton message...
Jennifer Lobèze a écrit :
mer. 24 févr. 2021 19:40
encore moins à démonter les partitions
On ne peut pas démonter une partition si le système l'utilise.
Il faut lancer Linux depuis une clé ou un dvd d'installation qui contient GParted ou depuis un CD de GParted :)
Mint Cinnamon 19.3 64-bits / Intel Xeon CPU E3-1270 V2 3.5GHz x 4 / Ram 15.6 Go / CG NVIDIA GF106GL [Quaro 2000]

Avatar du membre
Jennifer Lobèze
Messages : 44
Enregistré le : ven. 6 sept. 2019 13:28
Localisation : Lille - Hauts de France

Re: Désactiver le mode BIOS-compatibility/CSM/Legacy dans le firmware UEFI

Message par Jennifer Lobèze »

Salut Mia,
J'ai bien essayé avec Gparted sur Usb mais rien à faire... Je ne dois pas être très doué :geek:
Dell Inspiron 580 - Linux Mint 20.1 Ulyssa - Cinnamon 4.8.6 - Kernel 5.4.0-66-generic - CPU Intel Core i3 550 @ 3.20GHz × 2 - GPU NVIDIA GeForce GT 710 - pilote NVIDIA 390.141 - RAM 8 GB - Mobo Dell 0C2KJT - BIOS Legacy - GNU Grub 2.04 - Disque au format MBR - SSD Crucial MX500 250GB - 3 DDE

Avatar du membre
Mia88
Messages : 1139
Enregistré le : ven. 18 nov. 2016 08:42
Localisation : Lorraine

Re: Désactiver le mode BIOS-compatibility/CSM/Legacy dans le firmware UEFI

Message par Mia88 »

Bonjour,
Jennifer Lobèze a écrit :
ven. 26 févr. 2021 13:58
Je ne dois pas être très doué
Je pense plutôt que tu es confronté à un problème assez particulier.
Ne pas pouvoir démonter un disque depuis un Live USB, c'est fort tout de même ! :-o

Et cette partition EFI qui veut absolument s'installer sur un ordi qui n'est pas UEFI :roll:
Ton idée de formater le disque est sûrement la bonne, il doit être au format GPT.

J'ai trouvé un tuto pour le passer en MBR, si ça te tente d'essayer, il semblerait que ça se fasse depuis le système monté.

http://www.ordinateur.cc/Mat%C3%A9riel/ ... /6933.html

Et puis j'arrête de relancer le sujet alors qu'il est abandonnée :l :D
Mint Cinnamon 19.3 64-bits / Intel Xeon CPU E3-1270 V2 3.5GHz x 4 / Ram 15.6 Go / CG NVIDIA GF106GL [Quaro 2000]

Avatar du membre
Jennifer Lobèze
Messages : 44
Enregistré le : ven. 6 sept. 2019 13:28
Localisation : Lille - Hauts de France

Re: Désactiver le mode BIOS-compatibility/CSM/Legacy dans le firmware UEFI

Message par Jennifer Lobèze »

Tu es la magicienne des disques ! J'essaie ce week-end et te dis quoi (comme on dit chez nous ;) )
Dell Inspiron 580 - Linux Mint 20.1 Ulyssa - Cinnamon 4.8.6 - Kernel 5.4.0-66-generic - CPU Intel Core i3 550 @ 3.20GHz × 2 - GPU NVIDIA GeForce GT 710 - pilote NVIDIA 390.141 - RAM 8 GB - Mobo Dell 0C2KJT - BIOS Legacy - GNU Grub 2.04 - Disque au format MBR - SSD Crucial MX500 250GB - 3 DDE

Avatar du membre
Jennifer Lobèze
Messages : 44
Enregistré le : ven. 6 sept. 2019 13:28
Localisation : Lille - Hauts de France

Re: Désactiver le mode BIOS-compatibility/CSM/Legacy dans le firmware UEFI

Message par Jennifer Lobèze »

Disque effectivement en format GPT :!:
Voic ce que donne la commande gdisk

Code : Tout sélectionner

<pre>GPT fdisk (gdisk) version 1.0.5

Type device filename, or press &lt;Enter&gt; to exit: /dev/sda1
Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: not present


***************************************************************
Found invalid GPT and valid MBR; converting MBR to GPT format
in memory. THIS OPERATION IS POTENTIALLY DESTRUCTIVE! Exit by
typing &apos;q&apos; if you don&apos;t want to convert your MBR partitions
to GPT format!
***************************************************************


Command (? for help): ?
b	back up GPT data to a file
c	change a partition&apos;s name
d	delete a partition
i	show detailed information on a partition
l	list known partition types
n	add a new partition
o	create a new empty GUID partition table (GPT)
p	print the partition table
q	quit without saving changes
r	recovery and transformation options (experts only)
s	sort partitions
t	change a partition&apos;s type code
v	verify disk
w	write table to disk and exit
x	extra functionality (experts only)
?	print this menu

Command (? for help): r

Recovery/transformation command (? for help): ?
b	use backup GPT header (rebuilding main)
c	load backup partition table from disk (rebuilding main)
d	use main GPT header (rebuilding backup)
e	load main partition table from disk (rebuilding backup)
f	load MBR and build fresh GPT from it
g	convert GPT into MBR and exit
h	make hybrid MBR
i	show detailed information on a partition
l	load partition data from a backup file
m	return to main menu
o	print protective MBR data
p	print the partition table
q	quit without saving changes
t	transform BSD disklabel partition
v	verify disk
w	write table to disk and exit
x	extra functionality (experts only)
?	print this menu

Recovery/transformation command (? for help): g
</pre>
J'ai suivi le tuto jusqu'à la commande "g" : convert Gpt into MBR and exit mais il ne se passe plus rien et il n’apparaît pas les options mentionnées dans le tuto
5
Appuyez sur " r ", puis appuyez sur "Entrée " pour passer aux options de récupération et de transformation . Appuyez sur " g ", puis appuyez sur "Entrée " pour sélectionner l'option de convertir GPT en MBR sur Linux.
6
Appuyez sur " 0 ", puis appuyez sur "Entrée , "pour convertir GPT en MBR sur les partitions primaires. Appuyez sur "Y ", puis " Entrée", pour finaliser et quitter.
Manquerait-il une ligne de commande ???
Dell Inspiron 580 - Linux Mint 20.1 Ulyssa - Cinnamon 4.8.6 - Kernel 5.4.0-66-generic - CPU Intel Core i3 550 @ 3.20GHz × 2 - GPU NVIDIA GeForce GT 710 - pilote NVIDIA 390.141 - RAM 8 GB - Mobo Dell 0C2KJT - BIOS Legacy - GNU Grub 2.04 - Disque au format MBR - SSD Crucial MX500 250GB - 3 DDE

Avatar du membre
Mia88
Messages : 1139
Enregistré le : ven. 18 nov. 2016 08:42
Localisation : Lorraine

Re: Désactiver le mode BIOS-compatibility/CSM/Legacy dans le firmware UEFI

Message par Mia88 »

C'est pas très clair mais au point 2, l'exemple donné est sda, et pas sda1.

Il s'agirait plutôt du nom du périphérique qui contient l'amorçage et non pas de la partition qui le contient.
Ce qui semble logique, on ne peut pas convertir seulement une partition mais tout le disque, un disque ne peut pas être en partie gpt et en partie mbr il me semble.

Et d'ailleurs au point 4 c'est bien le mot périphérique qui est employé et non pas partition.

Je viens d'essayer sur une machine virtuelle LMDE :

Code : Tout sélectionner

mia@virtualbox-lmde:~$ sudo gdisk
GPT fdisk (gdisk) version 1.0.1

Type device filename, or press <Enter> to exit: /dev/sda
Partition table scan:
  MBR: MBR only
  BSD: not present
  APM: not present
  GPT: not present


***************************************************************
Found invalid GPT and valid MBR; converting MBR to GPT format
in memory. THIS OPERATION IS POTENTIALLY DESTRUCTIVE! Exit by
typing 'q' if you don't want to convert your MBR partitions
to GPT format!
***************************************************************


Warning! Secondary partition table overlaps the last partition by
33 blocks!
You will need to delete this partition or resize it in another utility.

Command (? for help): r

Recovery/transformation command (? for help): g

MBR command (? for help): ?
a	toggle the active/boot flag
c	recompute all CHS values
l	set partition as logical
o	omit partition
p	print the MBR partition table
q	quit without saving changes
r	set partition as primary
s	sort MBR partitions
t	change partition type code
w	write the MBR partition table to disk and exit

MBR command (? for help)
Contrairement à toi, j'arrive bien à passer le "g"

Mais ensuite on ne voit pas d'option zéro, c'est peut-être une version différente du logiciel ?
Il faut peut-être entrer "w" ?
Je ne valide pas pour vérifier, car j'ai pas trop envie de bousiller ma VM :D

Essaye avec sda plutôt que sda1, je ne vois rien d'autre...
Mint Cinnamon 19.3 64-bits / Intel Xeon CPU E3-1270 V2 3.5GHz x 4 / Ram 15.6 Go / CG NVIDIA GF106GL [Quaro 2000]

Avatar du membre
alain
modérateur
Messages : 10220
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Désactiver le mode BIOS-compatibility/CSM/Legacy dans le firmware UEFI

Message par alain »

Bonjour.

Sujet archivé (en lecture seule) car abandonné.
Si besoin de rouvrir faire un MP à un membre de l'équipe ;)
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.1 Ulyssa Xfce 4.14 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.1 Xfce 4.14| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.1 XFCE 4.14 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Répondre