Synaptic ne fonctionne pas sous LM 20.1

Postez ici toutes vos demandes d’assistance.
pjlt
Messages : 128
Enregistré le : lun. 22 mai 2017 16:16

Synaptic ne fonctionne pas sous LM 20.1

Message par pjlt »

Bonjour,
Je viens de réinstaller LM 20.1 et synaptic ne fonctionne pas. Il s'ouvre mais les boutons ne sont pas fonctionnels (mentions en grisé); Impossible de le refermer.
Quelqu'un aurait-il une idée?
Laptop Asus K73SJ ; 64 bits ; cpu: Intel(R) Pentium(R) CPU B950 @ 2.10GHz ;
Distribution : Linux Mint 20.1 Ulyssa
Desktop Environment : Cinnamon
Kernel : 5.4.0-58-generic x86_64
VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

Avatar du membre
cyrille
modérateur
Messages : 7042
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Synaptic ne fonctionne pas sous LM 20.1

Message par cyrille »

Essaie dans un premier temps de mettre à jour le système si c'est une nouvelle installation

Code : Tout sélectionner

sudo apt update
sudo apt upgrade
Et que renvoie la commande

Code : Tout sélectionner

groups
?

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
# bash the fash 2>/dev/null
# apt-get install anarchism

pjlt
Messages : 128
Enregistré le : lun. 22 mai 2017 16:16

Re: Synaptic ne fonctionne pas sous LM 20.1

Message par pjlt »

Bonjour,
contraint de m'absenter du réseau durant quelques jours, je reviens vers mon problème avec synaptic. Mon système est updaté et upgradé; La commande groups me renvoie:

Code : Tout sélectionner

juillet@juillet-K73SJ:~$ groups
juillet adm cdrom sudo dip plugdev lpadmin sambashare
juillet@juillet-K73SJ:~$ 
Laptop Asus K73SJ ; 64 bits ; cpu: Intel(R) Pentium(R) CPU B950 @ 2.10GHz ;
Distribution : Linux Mint 20.1 Ulyssa
Desktop Environment : Cinnamon
Kernel : 5.4.0-58-generic x86_64
VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

Avatar du membre
cyrille
modérateur
Messages : 7042
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Synaptic ne fonctionne pas sous LM 20.1

Message par cyrille »

Et ça passe via apt (update/upgrade) ?
Toujours pas via synaptic ?

Je serais tenté de dire utilise alors soit apt soit aptitude ... mais ça ne règle pas ton soucis...

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
# bash the fash 2>/dev/null
# apt-get install anarchism

pjlt
Messages : 128
Enregistré le : lun. 22 mai 2017 16:16

Re: Synaptic ne fonctionne pas sous LM 20.1

Message par pjlt »

j'arrive à installer des paquets par

Code : Tout sélectionner

sudo apt-get install ...
j'ai le renvoi suivant

Code : Tout sélectionner

juillet@juillet-K73SJ:~$ sudo synaptic
[sudo] Mot de passe de juillet :         

(synaptic:4168): Gtk-CRITICAL **: 14:19:08.243: gtk_widget_hide: assertion 'GTK_IS_WIDGET (widget)' failed

Laptop Asus K73SJ ; 64 bits ; cpu: Intel(R) Pentium(R) CPU B950 @ 2.10GHz ;
Distribution : Linux Mint 20.1 Ulyssa
Desktop Environment : Cinnamon
Kernel : 5.4.0-58-generic x86_64
VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

Avatar du membre
cyrille
modérateur
Messages : 7042
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Synaptic ne fonctionne pas sous LM 20.1

Message par cyrille »

Par hasard, tu n'aurais pas installé des repos additionnels (ex ppa) qui auraient mis le zouk dans la libgtk-3 ?

que retourne

Code : Tout sélectionner

 find /etc/apt -type f -name '*.list' -exec bash -c 'echo -e "\n$1"; nl -ba "$1"' _ '{}' \;
Si depot additionnel d'activés , desactive les . Relance un

Code : Tout sélectionner

sudo apt update
avant de retenter ta chance avec synaptic

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
# bash the fash 2>/dev/null
# apt-get install anarchism

Avatar du membre
tyrry
Messages : 5313
Enregistré le : mar. 21 juil. 2015 07:42
Localisation : à l'ouest

Re: Synaptic ne fonctionne pas sous LM 20.1

Message par tyrry »

Slt,
c'est pas/plus sudo synaptic qu'il faut lancer mais :

Code : Tout sélectionner

synaptic-pkexec
@+
Desktop: LXDE Distro: Debian 10.X Buster
Kernel: 4.19.0-15-amd64 SSD:SAMSUNG 860 EVO 250 go
CPU: Intel Core i7-8559U RAM: 12 go Graphics Card: Intel Iris Plus Graphics 655

Avatar du membre
cyrille
modérateur
Messages : 7042
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Synaptic ne fonctionne pas sous LM 20.1

Message par cyrille »

Et voilà tout bon pour Tyrry ;)

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
# bash the fash 2>/dev/null
# apt-get install anarchism

pjlt
Messages : 128
Enregistré le : lun. 22 mai 2017 16:16

Re: Synaptic ne fonctionne pas sous LM 20.1

Message par pjlt »

Retour de commande

Code : Tout sélectionner

juillet@juillet-K73SJ:~$ find /etc/apt -type f -name '*.list' -exec bash -c 'echo -e "\n$1"; nl -ba "$1"' _ '{}' \;

/etc/apt/sources.list
     1	#deb cdrom:[Linux Mint 20.1 _Ulyssa_ - Release amd64 20210103]/ focal contrib main
     2	
     3	# This system was installed using small removable media
     4	# (e.g. netinst, live or single CD). The matching "deb cdrom"
     5	# entries were disabled at the end of the installation process.
     6	# For information about how to configure apt package sources,
     7	# see the sources.list(5) manual.

/etc/apt/sources.list.d/official-package-repositories.list
     1	# Do not edit this file manually, use Software Sources instead.
     2	
     3	deb http://packages.linuxmint.com ulyssa main upstream import backport #id:linuxmint_main
     4	
     5	deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
     6	deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
     7	deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
     8	
     9	deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
    10	deb http://archive.canonical.com/ubuntu/ focal partner
juillet@juillet-K73SJ:~$ 
À quoi voit-on que des dépôts additionnels seraient activé?
Laptop Asus K73SJ ; 64 bits ; cpu: Intel(R) Pentium(R) CPU B950 @ 2.10GHz ;
Distribution : Linux Mint 20.1 Ulyssa
Desktop Environment : Cinnamon
Kernel : 5.4.0-58-generic x86_64
VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

Avatar du membre
cyrille
modérateur
Messages : 7042
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Synaptic ne fonctionne pas sous LM 20.1

Message par cyrille »

Laisse ton ma réponse et suis celle de tyrry ;)
(pas pensé car je n'utilise pas synpatic)

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
# bash the fash 2>/dev/null
# apt-get install anarchism

Répondre