Résolu le 28-04-22 Beep système

Postez ici toutes vos demandes d’assistance.
Avatar du membre
alain
modérateur
Messages : 12814
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Beep système

Message par alain »

Dernier message de la page précédente :

Bonjour Dkp.

Le .bashrc est utilisé dès que son utilisateur est connecté, pas besoin de le lancer au démarrage.

Après, je n'ai peut être pas bien compris ta question... :?
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.3 Uma Xfce 4.16 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.3 Xfce 4.16| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: Emmade4 Xfce 4.16.0 | K: 5.10
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.3 XFCE 4.16 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Avatar du membre
DkP
Messages : 54
Enregistré le : sam. 26 févr. 2022 14:35

Re: Beep système

Message par DkP »

Hello Alain,

En gros, j'ai créer un script "beep.sh" qui contient :

Code : Tout sélectionner

#!/bin/bash
 sudo modprobe -r pcspkr
Celui-ci coupe la beep système (quand je supprime un caractère inexistant par exemple). J'ai ajouté la commande

Code : Tout sélectionner

xset b off
dans le fichier /home/dkp, mais cela est sans effet.

J'ai donc essayer

Code : Tout sélectionner

modprobe -r pcspkr
dans le même fichier, mais celui-ci ne fonctionne pas.

J'ai donc l'impression que je ne peux pas lancer cette commande autrement qui via mon script, ce qui m'ennuie..
Modifié en dernier par Invité le jeu. 7 avr. 2022 21:57, modifié 1 fois.
Raison : reprise des balises
Pc : Lenovo IdeaPad 3 | LMDE 5 Elsie | Cinnamon 5.2.7 | 5.10.0-13-amd64 x86_64 | Quad Core model: AMD Ryzen 3 5300U with Radeon Graphics | 6.7 GiB | Radeon Graphics

Avatar du membre
alain
modérateur
Messages : 12814
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Beep système

Message par alain »

Bonjour DkP.

Désolé, je n'avait pas compris. :oops:
Ce qui est étrange c'est que qu'on dirai que ton .bashrc n'est pas pris en compte au démarrage. Normalement tu y mets une commande (même lancer un script) ça marche... :?

Tu es sous cinnamon, donc je pense que que dans : paramètres système==>accessibilité==>Clavier==>activer les alertes audios
si tu le décoche tu ne devrais plus avoir de bip lors de certaines frappes.
Je ne peux pas tester car je n'ai pas de speaker sur l'ordi avec cinnamon.
Sinon sur mes ordinateurs sous xfce je n'ai aucun sons car je désactive les sons système dans pavucontrol, pavucontrol est aussi sur cinnamon bien sur...
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.3 Uma Xfce 4.16 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.3 Xfce 4.16| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: Emmade4 Xfce 4.16.0 | K: 5.10
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.3 XFCE 4.16 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Avatar du membre
DkP
Messages : 54
Enregistré le : sam. 26 févr. 2022 14:35

Re: Beep système

Message par DkP »

Hello Alain,
T'es nocturne :p.

En-effet, c'est étrange, mais suite à l'ouverture de session, je rencontre le message suivant dans mon terminal :

Code : Tout sélectionner

modprobe: ERROR: ../libkmod/libkmod-module.c:799 kmod_module_remove_module() could not remove 'pcspkr': Operation not permitted
dkp@ideapad:~$ 
Dans paramètres système -> accessibilité -> clavier = alertes sonores désactivées

Pourtant, si dans l'explorateur je supprime l'adresse du dossier, une fois arrivé au bout, j'ai le beep & idem si je fais une sélection de fichier et que je suis à la fin.

Mais si je lance mon script, j'ai plus rien.. Et si dans le fichier bashrc de home/dkp j'indique mon

Code : Tout sélectionner

sudo modprobe -r pcspkr
le son n'est pas déverrouiller, mais le premier terminal lancé me demande le pw sudo pour lancer le script.

J'ai aussi tenté en allant dans le gestionnaire de speaker Alsamixer, mais je n'ai pas la rubrique beep ^^'

Dans l'absolu, j'ai un script qui fonctionne, mais je n'arrive pas à le lancer automatiquement sans devoir retaper le mdp..
Pc : Lenovo IdeaPad 3 | LMDE 5 Elsie | Cinnamon 5.2.7 | 5.10.0-13-amd64 x86_64 | Quad Core model: AMD Ryzen 3 5300U with Radeon Graphics | 6.7 GiB | Radeon Graphics

Avatar du membre
alain
modérateur
Messages : 12814
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Beep système

Message par alain »

suprimes "sudo", il te demandera pas le mot de passe.
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.3 Uma Xfce 4.16 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.3 Xfce 4.16| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: Emmade4 Xfce 4.16.0 | K: 5.10
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.3 XFCE 4.16 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Avatar du membre
DkP
Messages : 54
Enregistré le : sam. 26 févr. 2022 14:35

Re: Beep système

Message par DkP »

En-effet, j'y ai pensé, mais du coup, le beep existe toujours et quand j'ouvre le terminal, voici ce que je trouve :

Code : Tout sélectionner

modprobe: ERROR: ../libkmod/libkmod-module.c:799 kmod_module_remove_module() could not remove 'pcspkr': Operation not permitted
dkp@ideapad:~$ 
J'ai donc testé différentes méthode, mais actuellement seul le fait de lancer mon script désactive ce beep bien chiant :p
Pc : Lenovo IdeaPad 3 | LMDE 5 Elsie | Cinnamon 5.2.7 | 5.10.0-13-amd64 x86_64 | Quad Core model: AMD Ryzen 3 5300U with Radeon Graphics | 6.7 GiB | Radeon Graphics

Avatar du membre
alain
modérateur
Messages : 12814
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Beep système

Message par alain »

Je m'en doutais, c'était humoristique :D

Tu as essayé de l'ajouter aux applications à ouvrir au démarrage ? (je ne me rappelle plus et la flemme de tout relire :l )
dans les paramètres:
Image

[edit]Ha non! la aussi il faut le sudo :? [/edit]

Pas d'idée pour le moment, désolé :oops: :?
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.3 Uma Xfce 4.16 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.3 Xfce 4.16| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: Emmade4 Xfce 4.16.0 | K: 5.10
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.3 XFCE 4.16 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Avatar du membre
DkP
Messages : 54
Enregistré le : sam. 26 févr. 2022 14:35

Re: Beep système

Message par DkP »

Hahaha c'est donc du l'humour linuxien que je ne maîtrise pas encore :p

J'ai quand même tenté de l'ajouter au démarrage, sans le sudo, mais du coup, si tu me dis que c'est no way :p

J'ai implémenté ma commande dans le bon bashrc au moins ?
Pc : Lenovo IdeaPad 3 | LMDE 5 Elsie | Cinnamon 5.2.7 | 5.10.0-13-amd64 x86_64 | Quad Core model: AMD Ryzen 3 5300U with Radeon Graphics | 6.7 GiB | Radeon Graphics

Avatar du membre
alain
modérateur
Messages : 12814
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Beep système

Message par alain »

Oui je pense... Après je n'ai jamais essayer ce genre de truc dans le .bashrc :?

Sinon il me vient une nouvelle idée pour tes beeps:
Dans ton fichier : /etc/modprobe.d/blacklist.conf
supprime ce que tu y a mis et ajoute ça:

Code : Tout sélectionner

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.3 Uma Xfce 4.16 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.3 Xfce 4.16| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: Emmade4 Xfce 4.16.0 | K: 5.10
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.3 XFCE 4.16 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Avatar du membre
DkP
Messages : 54
Enregistré le : sam. 26 févr. 2022 14:35

Re: Beep système

Message par DkP »

Hum.. Mon principal soucis, c'est que je n'ai pas ce fichier..

Voici les fichiers qui se trouve dans le dossier :

Image

Par contre, à temps perdu si tu es disposé à m'expliquer les commandes du code précédent, je suis intéressé :)
Pc : Lenovo IdeaPad 3 | LMDE 5 Elsie | Cinnamon 5.2.7 | 5.10.0-13-amd64 x86_64 | Quad Core model: AMD Ryzen 3 5300U with Radeon Graphics | 6.7 GiB | Radeon Graphics

Avatar du membre
alain
modérateur
Messages : 12814
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Beep système

Message par alain »

J'ai cru que tu l'avais car dans ton premier post tu en a parlé.

Pas grave s'il n'existe pas il va se créé:

Code : Tout sélectionner

sudo nano /etc/modprobe.d/blacklist.conf
Dans la fenêtre qui s'ouvre tu copie/colle ce que j'ai mis précédemment.
Pour info, dans nano on se déplace avec les flèches, tout se fait au clavier. Une fois mis le texte dedans Tu fais ctrl+o et entrer pour mémoriser le fichier et enfin ctrl+x pour quitter nano.

En fait y a pas grand chose dans ce code. Tout ce qui est après un # c'est du blabla, du commentaire. On dit que la ligne est "commentée".
Les seul trucs important sont:

Code : Tout sélectionner

blacklist snd_pcsp
qui blackliste le module snd-pcsp (je pense qu'il s'agit de son du speaker du pc)
et:

Code : Tout sélectionner

blacklist pcspkr
qui blackliste le module pcspkr (la c'est sûr c'est le speaker du pc)

Attention, je ne dis pas que ça va marcher, c'est une idée que j'ai eu, c'est tout, tu ne risques rien a l'essayer.
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.3 Uma Xfce 4.16 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.3 Xfce 4.16| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: Emmade4 Xfce 4.16.0 | K: 5.10
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.3 XFCE 4.16 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Répondre