Résolu le 28-04-22 Beep système

Postez ici toutes vos demandes d’assistance.
Avatar du membre
DkP
Messages : 54
Enregistré le : sam. 26 févr. 2022 14:35

Re: Beep système

Message par DkP »

Dernier message de la page précédente :

Pas de soucis !

Merci beaucoup pour tes recherches !
Je vais continuer de checker régulièrement et si je finis par trouver une solution, je ne manque pas de la poster ici !
Pc : Lenovo IdeaPad 3 | LMDE 5 Elsie | Cinnamon 5.2.7 | 5.10.0-13-amd64 x86_64 | Quad Core model: AMD Ryzen 3 5300U with Radeon Graphics | 6.7 GiB | Radeon Graphics

Avatar du membre
alain
modérateur
Messages : 12815
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Beep système

Message par alain »

Oui ça serait cool. ;)
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.3 Uma Xfce 4.16 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.3 Xfce 4.16| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: Emmade4 Xfce 4.16.0 | K: 5.10
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.3 XFCE 4.16 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Avatar du membre
DkP
Messages : 54
Enregistré le : sam. 26 févr. 2022 14:35

Re: Beep système

Message par DkP »

Hello !

Bon, maintenant que j'ai un peu mieux cerné le concept, j'ai trouvé une solution (j'ai reboot une fois et ca fonctionne), mais je ne sais pas si c'est une méthode conventionnelle, vous me direz ce qu'il en est :p

La solution vient partiellement d'ici : A partir de : rc-local.service : opération compatibilité

Donc, comme indiqué précédemment, j'avais créer ce script :

Code : Tout sélectionner

#!/bin/bash

 sudo modprobe -r pcspkr
Grâce au lien en annexe, j'ai suivi le process, mais j'ai juste du personnaliser mon fichier service [/etc/systemd/system/boot-logger.service] de la sorte :

Code : Tout sélectionner

[UNIT]
Description=Turn off beep sys

[Service]
Type=simple

ExecStart=/beep.sh

[Install]
WantedBy=multi-user.target
Comme indiqué, j'ai ajouter les droits d'accès et activer le service et au reboot ca fonctionne.

Si c'est utile, je ferais un post de synthèse pour clarifier le processus utilisé, sait-on jamais que quelqu'un d'autre en aille besoin :)
Pc : Lenovo IdeaPad 3 | LMDE 5 Elsie | Cinnamon 5.2.7 | 5.10.0-13-amd64 x86_64 | Quad Core model: AMD Ryzen 3 5300U with Radeon Graphics | 6.7 GiB | Radeon Graphics

Avatar du membre
alain
modérateur
Messages : 12815
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Beep système

Message par alain »

Bonjour Dkp.

Merci pour le retour ;)

Non je ne pense pas que ça soit nécessaire de faire une synthèse. C'est assez clair comme ça. Si quelqu'un en a besoin et qu'il ne comprend pas, il posera la question, ne t'inquiète pas.

J'ai appris un truc du coup :D
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.3 Uma Xfce 4.16 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.3 Xfce 4.16| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: Emmade4 Xfce 4.16.0 | K: 5.10
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.3 XFCE 4.16 | K : 5.4
In a world without walls and fences, who needs windows and gates?

ptitjoz
Messages : 12
Enregistré le : mar. 28 juin 2022 14:12
Localisation : France
Contact :

Re: Beep système

Message par ptitjoz »

Bonjour,
j'avais aussi des beeps insupportables et avant de trouver ce billet j'avais procédé de cette façon:
j'ai créé un script :

Code : Tout sélectionner

#!/bin/bash
xset b off
je l'ai enregistré en beep_off.sh et dans propriétés je l'ai rendu executable
dans Paramètres systèmes / Applications au démarrage, j'ai créé une nouvelle entrée

Image
j'ai redémarré l'ordi et les beeps système ont disparus.

Cordialement
Pc n°3 : eMachines eME644G | LMDE 5 Elsie | Cinnamon 5.2.7 | 5.10.0-15-amd64 x86_64 bits: 64 | Dual Core AMD E-300 / 2 CPU 1.3Ghz | ram 3Go / SSD 250go | Radeon HD 6310

Répondre