Pour les impatients qui veulent Linux Mint 21 "Vanessa"

Postez ici toutes vos demandes d’assistance.
Répondre
Avatar du membre
herve
Messages : 27
Enregistré le : mer. 3 oct. 2018 20:57

Pour les impatients qui veulent Linux Mint 21 "Vanessa"

Message par herve »

Bonjour à tous,

Vanessa va bientôt sortir mais tarde un peu à montrer le bout de sa robe, la timide :) !
Peu importe, vous pouvez la forcer à venir dans votre bécane.
Faire à l'ancienne un upgrade de version majeure =>
En language français :
Il faut mettre à jour 20.3, sauver le dossier des sources, enlever les sources externes, la nettoyer.
Ensuite faire pointer les dépôts de Linux Mint vers Vanessa et jammy (Ubuntu 22.04)
Mettre à jour les sources, mettre à jour les paquets, nettoyer, résoudre les erreurs, mettre à jour le système.
Pour faire le pointilleux il y aura quelques petits détails comme :
Supprimer blueberry (gestionnaire bluetooth) et le remplacer par blueman

En language terminal :
(*) Vous pouvez enlever lupin-casper si existant ici (vérifier s'il existe) :

Code : Tout sélectionner

whereis lupin-casper

Code : Tout sélectionner

1. sudo apt update; sudo apt upgrade -y
2. sudo apt autoremove -y
# Normalement il n'y a rien dans sources.list
# Sinon faire : sudo sed -i 's/una/vanessa/g' /etc/apt/sources.list
3. sudo sed -i 's/una/vanessa/g' /etc/apt/sources.list.d/official-package-repositories.list
4. sudo sed -i 's/focal/jammy/g' /etc/apt/sources.list.d/official-package-repositories.list
# Pareil : sudo sed -i 's/focal/jammy/g' /etc/apt/sources.list
5. sudo apt update; sudo apt upgrade -y
6. sudo apt autoremove -y
(*) Si il y a un message d'erreur avec lupin-casper (je crois qu'il y a un message d'erreur car il n'est plus dans les dépôts) :

Code : Tout sélectionner

sudo apt remove lupin-casper
Avant ou après redémarrage remplacer blueberry par blueman (vous pourriez le faire avant le changement des sources) :

Code : Tout sélectionner

sudo apt remove blueberry -y; sudo apt-get install blueman -y
Et voilà !
Voici pour moi (dans le terminal, taper le mot : neofetch ) =>
Image
Et Cinnamon est bien en 5.4.2 :
Image

Si qulqu'un a déjà fait cette démarche et qu'il y a des précisions à apporter, merci :) :) !!!
Hervé.
Linux Mint 21 Cinnamon, 5.15.0-40-generic, Cinnamon 5.4.2.
Proc : Intel© Core™ i3-6100U CPU @ 2.30GHz × 2, RAM : 8Go, 2 Disques dur : 1er SSD de 120Go Kensington, 2e SSD de 500To, CG : Intel Corporation Skylake GT2 [HD Graphics 520].
Ordi : HP ProBook 430 G3.

Avatar du membre
herve
Messages : 27
Enregistré le : mer. 3 oct. 2018 20:57

Re: Pour les impatients qui veulent Linux Mint 21 "Vanessa"

Message par herve »

Je pense que la seule différence avec la mise à jour à la date de sortie officielle sera l'outil de mise à jour qui sera disponible et qui sera capable de faire tout cela en mode graphique (donc plus facile) ET avec la possibilité de conserver les sources extérieures sans causer de soucis...

Pour ma part, je n'ai eu aucun souci ; pour les sources externes, je ne les ai pas remises et j'avais même oublié d'enlever celles de Google et de TeamViewer : ça n'a pas déconné.
ATTENTION toutefois si vous passez d'une façon ou d'une autre à Mint 21 :
Le seul logiciel qui a cessé de fonctionner est Vmware WorkStation. MAIS je pense qu'il va couiner même avec la mise à jour officielle car il y a une histoire de compilation de certains de ses modules dans le nouveau noyau (5.15) - vmmon et vmnet il me semble...
Linux Mint 21 Cinnamon, 5.15.0-40-generic, Cinnamon 5.4.2.
Proc : Intel© Core™ i3-6100U CPU @ 2.30GHz × 2, RAM : 8Go, 2 Disques dur : 1er SSD de 120Go Kensington, 2e SSD de 500To, CG : Intel Corporation Skylake GT2 [HD Graphics 520].
Ordi : HP ProBook 430 G3.

Avatar du membre
alv37
Messages : 145
Enregistré le : mer. 26 août 2020 00:42
Localisation : France

Re: Pour les impatients qui veulent Linux Mint 21 "Vanessa"

Message par alv37 »

J'avais fait une vm pour faire ce même test ya quelques semaines afin de voir si on pouvait déjà voir des changements avant que la bêta sorte, perso j'avais eu 2 paquets problématique, le premier c'est celui que tu cite (lupin-casper) et le second c'était hypnotix.

J'avais supprimer hypnotix en me disant que je ré-installerais après l'upgrade mais lors de mon test après la ré-installation du paquet il refusait de s'ouvrir (un problème lié a une dépendance qui avait pas la bonne version requise il me semble).

Mais en dehors de ça, tous le reste fonctionnait niquel.
herve a écrit :
mar. 28 juin 2022 08:55
Le seul logiciel qui a cessé de fonctionner est Vmware WorkStation. MAIS je pense qu'il va couiner même avec la mise à jour officielle car il y a une histoire de compilation de certains de ses modules dans le nouveau noyau (5.15) - vmmon et vmnet il me semble...
Sur ma machine principal, j'ai 2 linux (tous les 2 des rolling-release) et c'est un problème que j'ai à chaque mise à jour du noyau mais qui se règle assez facilement, il y a une personne sur github (déso j'ai plus son nom) qui propose un patch pour corrigé l'erreur, qui suffit de mettre dans le dossier que VMware utilise pour ses modules et tada problème réglé ^^
PC Principal [Triple-Boot] (Custom) : MB: MS-7823 (MSI B85M-G43) | CPU: Intel i7 4790k | RAM: 8 Go | GPU: Nvidia Geforce GTX 970
  • OS: Windows 10 Pro 21H2
  • OS: VoidLinux | DE: Cinnamon v5.2.7 | Kernel: 5.18.16
  • OS: ArchLinux | DE: Cinnamon v5.4.9 | Kernel: 5.18.16
PC Secondaire (Custom) : OS: Linux Mint 21 | DE: Cinnamon v5.4.9 | Kernel: 5.15.0 | MB: Gigabyte GA-G31M-ES2L v2 | CPU: Intel Pentium D 915 | RAM: 4 Go | GPU: Intel 82G33/G31 Express Integrated Graphics

Avatar du membre
herve
Messages : 27
Enregistré le : mer. 3 oct. 2018 20:57

Re: Pour les impatients qui veulent Linux Mint 21 "Vanessa"

Message par herve »

Salut @alv37,
Avant de réinstaller tu peux faire une simulation d'installation avec l'option -s :

Code : Tout sélectionner

sudo apt-get install hypnotix -s
Étant sous 21, je l'ai fait et ça donne ça :

Code : Tout sélectionner

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Les paquets supplémentaires suivants seront installés : 
  python3-imdbpy python3-pycryptodome python3-pyxattr youtube-dl
Paquets suggérés :
  python3-sqlalchemy python3-sqlobject python3-psycopg2 python3-pyxattr-dbg
  python-pyxattr-doc libfribidi-bin | bidiv phantomjs
Les NOUVEAUX paquets suivants seront installés :
  hypnotix python3-imdbpy python3-pycryptodome python3-pyxattr youtube-dl
0 mis à jour, 5 nouvellement installés, 0 à enlever et 0 non mis à jour.
Inst python3-imdbpy (2021.04.18-3 Ubuntu:22.04/jammy [all])
Inst hypnotix (2.8 linuxmint:21/vanessa [all])
Inst python3-pycryptodome (3.11.0+dfsg1-3build1 Ubuntu:22.04/jammy [amd64])
Inst python3-pyxattr (0.7.2-2ubuntu2 Ubuntu:22.04/jammy [amd64])
Inst youtube-dl (2021.12.17-1 Ubuntu:22.04/jammy [all])
Conf python3-imdbpy (2021.04.18-3 Ubuntu:22.04/jammy [all])
Conf hypnotix (2.8 linuxmint:21/vanessa [all])
Conf python3-pycryptodome (3.11.0+dfsg1-3build1 Ubuntu:22.04/jammy [amd64])
Conf python3-pyxattr (0.7.2-2ubuntu2 Ubuntu:22.04/jammy [amd64])
Conf youtube-dl (2021.12.17-1 Ubuntu:22.04/jammy [all])
Il y a des paquets suggérés :

Code : Tout sélectionner

Paquets suggérés :
  python3-sqlalchemy python3-sqlobject python3-psycopg2 python3-pyxattr-dbg
Bien souvent il faut les installer :)
Linux Mint 21 Cinnamon, 5.15.0-40-generic, Cinnamon 5.4.2.
Proc : Intel© Core™ i3-6100U CPU @ 2.30GHz × 2, RAM : 8Go, 2 Disques dur : 1er SSD de 120Go Kensington, 2e SSD de 500To, CG : Intel Corporation Skylake GT2 [HD Graphics 520].
Ordi : HP ProBook 430 G3.

Avatar du membre
alv37
Messages : 145
Enregistré le : mer. 26 août 2020 00:42
Localisation : France

Re: Pour les impatients qui veulent Linux Mint 21 "Vanessa"

Message par alv37 »

Vu que c'était une vm de test j'ai pas était chercher plus loin surtout que même sur ma machine secondaire (qui est sous mint) j'utilise jamais hypnotix (si je veut regarder la tv je passe par molotov) du coup pour moi c'est pas gênant.^^
PC Principal [Triple-Boot] (Custom) : MB: MS-7823 (MSI B85M-G43) | CPU: Intel i7 4790k | RAM: 8 Go | GPU: Nvidia Geforce GTX 970
  • OS: Windows 10 Pro 21H2
  • OS: VoidLinux | DE: Cinnamon v5.2.7 | Kernel: 5.18.16
  • OS: ArchLinux | DE: Cinnamon v5.4.9 | Kernel: 5.18.16
PC Secondaire (Custom) : OS: Linux Mint 21 | DE: Cinnamon v5.4.9 | Kernel: 5.15.0 | MB: Gigabyte GA-G31M-ES2L v2 | CPU: Intel Pentium D 915 | RAM: 4 Go | GPU: Intel 82G33/G31 Express Integrated Graphics

Avatar du membre
cyrille
modérateur
Messages : 9047
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nowhere
Contact :

Re: Pour les impatients qui veulent Linux Mint 21 "Vanessa"

Message par cyrille »

Si qulqu'un a déjà fait cette démarche et qu'il y a des précisions à apporter, merci :) :) !!!
Perso J'aurais fait l'upgrade en 2 temps
(je n'ai pas testé avec La mint 21, mais expérience / upgrade debian)

Code : Tout sélectionner

sudo apt upgrade --without-new-pkgs

Code : Tout sélectionner

sudo apt full-upgrade
Puis nettoyage

Code : Tout sélectionner

sudo apt autoremove
sudo apt clean
Enfin, ça ne va pas changer grand chose ;)
# apt install anarchism

Debian SID - FreeBSD - https://cbiot.fr -- https://framagit.org/CyrilleBiot -- Il est grand temps que l’anarchie remette de l’ordre dans le chaos ! (Karim B. -LV88)

Répondre