[Résolu] Menu "Démarer" sans application

Pour un problème lié uniquement à MATE
Avatar du membre
mpat
Messages : 7226
Enregistré le : mar. 25 août 2015 21:12
Localisation : Belgique

Re: Menu "Démarer" sans application

Messagepar mpat » lun. 13 nov. 2017 21:04

Dernier message de la page précédente :

oui c'est ton fameux menu dans /.linuxmint/MintMenu/applications.list qui a disparu et que tu n'arrives pas a reconstruire


ok il y a un backup entre cp et usr + entre applications.list et /home il y a un espace

sudo cp /usr/lib/linuxmint/mintmenu/applications.list /home/ton_nom./linuxmint/mintmenu/applications.list


Image
Asus x53sd, I5- 2.5/3.1 ghz, 8go ram
dual gpu Intel/Nvidia pilotes 384.98, ssd evo-pro850 256go + hdd 750go
Lmint 18.2 - Cinnamon 64-bit, kernel 4.13.10-041315

caporal1952
Messages : 23
Enregistré le : lun. 27 févr. 2017 18:14
Localisation : Bourgogne - 21

Re: Menu "Démarer" sans application

Messagepar caporal1952 » lun. 13 nov. 2017 21:55

c'est pas ce fichier-là.

Je pense aussi que c'est un truc de ce genre.
Mais je crois que le fichier de référence (enfin celui vers lequel le menu de mate doit aller chercher) est "~/.local/share/applications/".
Là, tous les fichiers.desktop de mes applications (raccourcis) y sont.
Linux Mint 18.2 Sonya -
Machine : MSI Z77A-G41 - Quad core Intel Core i5-3470 - Graphics : NVIDIA GT218 [GeForce 210]

Avatar du membre
mpat
Messages : 7226
Enregistré le : mar. 25 août 2015 21:12
Localisation : Belgique

Re: Menu "Démarer" sans application

Messagepar mpat » lun. 13 nov. 2017 22:01

tu fais se que tu veux t'ai dit ou se trouvait le backup. j’arrête la je sais rien faire de plus
Asus x53sd, I5- 2.5/3.1 ghz, 8go ram
dual gpu Intel/Nvidia pilotes 384.98, ssd evo-pro850 256go + hdd 750go
Lmint 18.2 - Cinnamon 64-bit, kernel 4.13.10-041315

caporal1952
Messages : 23
Enregistré le : lun. 27 févr. 2017 18:14
Localisation : Bourgogne - 21

Re: Menu "Démarer" sans application

Messagepar caporal1952 » lun. 13 nov. 2017 22:16

j'ai fait le cp du fichier que tu as dit mais ça na rien fait.

C'est ce que j'ai voulu dire. Ce que tu m'as conseillé, je l'ai fait, mais que veux-tu, le résultat n'est pas là.

Je ferai autrement.
Comme je disais dans un post précédent :
Je vous remercie pour tous vos conseils, mais je crois que je vais retourner à Cinnamon.
Quand j'aurai un peu plus de temps, je creuserai à nouveau dans MATE pour essayer de comprendre.

Si je trouve quelque chose je reviendrai vers vous.

Encore Merci.
Linux Mint 18.2 Sonya -
Machine : MSI Z77A-G41 - Quad core Intel Core i5-3470 - Graphics : NVIDIA GT218 [GeForce 210]

caporal1952
Messages : 23
Enregistré le : lun. 27 févr. 2017 18:14
Localisation : Bourgogne - 21

Re: Menu "Démarer" sans application

Messagepar caporal1952 » mer. 15 nov. 2017 22:53

Re-bonsoir,

J'étais passé sous Cinnamon mais lors de l'édition du Menu, Cinnamon à planté et plus rien dans le Menu !!!
Même pas la possibilité de relancer l'éditeur de menu (clic droit sur menu / éditer le menu), rien ne se passe ... Quelle application (son nom) devrait être exécutée ?

Qui peut me dire quels fichiers sont utilisés dans la gestion et la sauvegarde des menus ?
Je voudrais bien essayer de comprendre la gestion et l'édition de menu.

Merci

Je précise que dans le menu, j'ai les favoris, mais si je clique sur "Toutes les applications", je n'ai rien. Apparemment l'application ne trouve pas le fichier ou sont stockés les raccourcis des applications.
Linux Mint 18.2 Sonya -
Machine : MSI Z77A-G41 - Quad core Intel Core i5-3470 - Graphics : NVIDIA GT218 [GeForce 210]

Avatar du membre
mpat
Messages : 7226
Enregistré le : mar. 25 août 2015 21:12
Localisation : Belgique

Re: Menu "Démarer" sans application

Messagepar mpat » jeu. 16 nov. 2017 00:56

Image
Asus x53sd, I5- 2.5/3.1 ghz, 8go ram
dual gpu Intel/Nvidia pilotes 384.98, ssd evo-pro850 256go + hdd 750go
Lmint 18.2 - Cinnamon 64-bit, kernel 4.13.10-041315

caporal1952
Messages : 23
Enregistré le : lun. 27 févr. 2017 18:14
Localisation : Bourgogne - 21

Re: Menu "Démarer" sans application

Messagepar caporal1952 » jeu. 16 nov. 2017 08:04

Bonjour mpat, et merci pour ta réponse.

L'écran que tu me montres est issu de Cinnamon et je suis sous MATE .
Mais c'est pas grave, le problème c'est que je ne peux plus accéder à l'éditeur de Menus. Donc même pas possible de restaurer.
Et je pense que si la restauration fonctionnait, je perdrais tous les raccourcis que j'avais précédemment.
Linux Mint 18.2 Sonya -
Machine : MSI Z77A-G41 - Quad core Intel Core i5-3470 - Graphics : NVIDIA GT218 [GeForce 210]

Avatar du membre
tyrry
Messages : 2735
Enregistré le : mar. 21 juil. 2015 07:42
Localisation : à l'ouest

Re: Menu "Démarer" sans application

Messagepar tyrry » jeu. 16 nov. 2017 08:19

Slt ,
dans ce cas peut-être qu'il te faut simplement réinstaller quelques "trucs" :

Code : Tout sélectionner

sudo apt update

Code : Tout sélectionner

sudo apt install -f

Code : Tout sélectionner

sudo apt install --reinstall mintdesktop mint-meta-mate menulibre libgnome-menu-3-0 gnome-menus desktop-file-utils alacarte

et redémarre ;)
@+
Desktop: Xfce 4.12.3 Distro: Linux Mint 18.2 Sonya
CPU~Dual core Pentium E5400 RAM -8 go Kernel: 4.13.0-16-generic x86_64

caporal1952
Messages : 23
Enregistré le : lun. 27 févr. 2017 18:14
Localisation : Bourgogne - 21

Re: Menu "Démarer" sans application

Messagepar caporal1952 » jeu. 16 nov. 2017 10:49

Bonjour tyrry,

J'ai fait ta réinstallation quelques "trucs", mais je n'ai pas d'amélioration.
Dans le menu, je vois bien les applications "Favoris" mais si je demande "Toutes les applications", c'est vide.

Avec le clic droit sur le Menu, tout ce qui est proposé fonctionne à l'exception de "Éditer le menu" qui ne fait rien.

Un autre truc : mintMenu n'utilise pas le paquet "alacarte" (fait partie des "trucs" à réinstaller) ?
Car en console, j'ai lancé "alacarte" et je me retrouve dans l'éditeur de menu avec toutes mes applications... Mais c'est pas pour autant que je les retrouve dans le menu à côté des favoris.
Linux Mint 18.2 Sonya -
Machine : MSI Z77A-G41 - Quad core Intel Core i5-3470 - Graphics : NVIDIA GT218 [GeForce 210]

Avatar du membre
mpat
Messages : 7226
Enregistré le : mar. 25 août 2015 21:12
Localisation : Belgique

Re: Menu "Démarer" sans application

Messagepar mpat » jeu. 16 nov. 2017 11:35

salut
je pense que tu ne sais pas te servir correctement de se qui t'es proposé, en plus une fois tu es sous Maté une fois sous Cinnamon, se serait bien d'être plus cohérent.7

je lis ton message rien ne me dit que tu as encore une fois changé d'avis.
Image

ensuite je viens de tester, ce qui me permet de dire que tu ne t'en sort pas quoi qu'on te dise, ceci sous Maté

j'ai installer alacarte et celui-ci propose bien une restauration, j'ai aussi installer l'applet advanced menu qui comporte tout les menus.

Image
Image

maintenant si tu relis ton sujet, je t'avais prévenu que même sous Cinnamon si tu vas trop vite avec l'éditeur , tu perds tout.

dans Cinnamon tu dois te servir de --> cinnamon-menu-editor
Asus x53sd, I5- 2.5/3.1 ghz, 8go ram
dual gpu Intel/Nvidia pilotes 384.98, ssd evo-pro850 256go + hdd 750go
Lmint 18.2 - Cinnamon 64-bit, kernel 4.13.10-041315

caporal1952
Messages : 23
Enregistré le : lun. 27 févr. 2017 18:14
Localisation : Bourgogne - 21

Re: Menu "Démarer" sans application

Messagepar caporal1952 » jeu. 16 nov. 2017 14:04

Salut mpat,

Désolé mais j'ai essayé ce qui m'était proposé, le problème c'est que pour l'instant cela n'a rien résolu.
J'ai essayé Cinnamon, mais si je poste dans le sujet "MATE" c'est parce que j'ai un pb sous MATE autrement je demanderais de l'aide dans Cinnamon.

Alacarte propose bien une restauration, mais pourquoi je ferais une restauration si alcarte fonctionne correctement. Bon ça ne fait rien, je ne comprends pas tout mais je fais et rien de changé.
J'ai aussi installer l'applet advanced menu mais je suis désolé, chez moi il ne comporte pas tous les menus ! Et c'est justement ça mon problème.
Modifié en dernier par caporal1952 le jeu. 16 nov. 2017 14:43, modifié 1 fois.
Linux Mint 18.2 Sonya -
Machine : MSI Z77A-G41 - Quad core Intel Core i5-3470 - Graphics : NVIDIA GT218 [GeForce 210]


Retourner vers « MATE »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité