Résolu le 21-01-21 Mint 20.1 - Atheros/ath9k - pas de connexion au wifi Bbox (uniquement)

Questions concernant les composants
Avatar du membre
Pulpo
Messages : 7
Enregistré le : lun. 18 janv. 2021 16:11

Mint 20.1 - Atheros/ath9k - pas de connexion au wifi Bbox (uniquement)

Message par Pulpo »

Bonjour,

J'ai installé Linux Mint 20.1 sur un PC portable Acer (voir ma signature) et le wifi de ma Bbox est détecté mais la connexion ne se fait pas du tout. "Connexion en cours" s'affiche pendant quelques secondes puis l'invite de mot de passe s'affiche à nouveau.

Pourtant, il se connecte sans problème à d'autres sources de wifi : en partageant la connexion de mon téléphone ou de mon PC fixe (relié alors en filaire), ça fonctionne parfaitement. Bien sûr la connexion filaire marche bien aussi.

Et mes autres appareils (PC fixe, téléphones) se connectent au wifi de la Bbox sans problème.

C'est vraiment spécifiquement le binôme PC portable + Bbox qui coince.

Pistes explorées sans succès :
  • vérifier que je ne me plantais pas de réseau ou de mot de passe... :)
  • n'activer que le WPA2 sur la Bbox (et non WPA1 + WPA2)
  • désactiver le Secure Boot dans les paramètres de mon bios
  • essayer avec ou sans Bluetooth actif (ça semble idiot mais ayant vu que certaines cartes gèrent à la fois wifi et bluetooth, on sait jamais, un bug chelou...)
  • créer un fichier ath9k.conf (il n'existait pas) et y ajouter une option (que je ne comprends pas, à vrai dire) :

    Code : Tout sélectionner

    echo "options ath9k nohwcrypt=1" | sudo tee  /etc/modprobe.d/ath9k.conf
Là, sans vos lumières, je dois m'avouer vaincu :) En espérant qu'il y ait une solution, merci de m'avoir lu !

(edit : je ne sais pas si j'ai bien fait de mettre le statut à "en cours" dès le début, en tous cas je vois que je ne peux plus laisser ce champ vierge)

Voici les infos demandées dans "à lire en cas de problème de wifi" :

Code : Tout sélectionner

inxi -nz

Code : Tout sélectionner

Network:
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  driver: ath9k 
  IF: wlp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>

Code : Tout sélectionner

sudo lshw -C network | grep -v "numéro de série"

Code : Tout sélectionner

  *-network                 
       description: Interface réseau sans fil
       produit: QCA9565 / AR9565 Wireless Network Adapter
       fabricant: Qualcomm Atheros
       identifiant matériel: 0
       information bus: pci@0000:02:00.0
       nom logique: wlp2s0
       version: 01
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuration : broadcast=yes driver=ath9k driverversion=5.4.0-62-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
       ressources : irq:18 mémoire:91100000-9117ffff mémoire:91180000-9118ffff
  *-network
       description: Ethernet interface
       produit: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabricant: Realtek Semiconductor Co., Ltd.
       identifiant matériel: 0
       information bus: pci@0000:03:00.0
       nom logique: enp3s0
       version: 15
       taille: 1Gbit/s
       capacité: 1Gbit/s
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration : autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=192.168.1.17 latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       ressources : irq:19 portE/S:1000(taille=256) mémoire:91004000-91004fff mémoire:91000000-91003fff

Code : Tout sélectionner

rfkill list

Code : Tout sélectionner

0: acer-wireless: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: acer-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
Modifié en dernier par Pulpo le jeu. 21 janv. 2021 15:32, modifié 1 fois.
Laptop : Acer Aspire ES1-731-P25X | Linux Mint 20.1 Ulyssa | Cinnamon 4.8.6 | 5.4.0-64-generic x86_64 | Intel Pentium N3700 Quad Core | Ram : 4 Go

Avatar du membre
cyrille
modérateur
Messages : 6569
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Mint 20.1 - Atheros/ath9k - pas de connexion au wifi Bbox (uniquement)

Message par cyrille »

suite à

Code : Tout sélectionner

echo "options ath9k nohwcrypt=1" | sudo tee  /etc/modprobe.d/ath9k.conf
Tu as bien passé ces commandes ?

Code : Tout sélectionner

sudo rmmod ath9k
sudo modprobe ath9k
sudo service network-manager restart
# HOME: FreeBSD 12.1, Debian SID [XFCE, Fluxbox] # WORK : Mint 18.3 & 20 # VPS Debian stable + Serveur Olimex A20 autohébergé Debian stable
[ GIT : https://github.com/CyrilleBiot | Sites : https://cbiot.fr https://crust.ovh]

Avatar du membre
Pulpo
Messages : 7
Enregistré le : lun. 18 janv. 2021 16:11

Re: Mint 20.1 - Atheros/ath9k - pas de connexion au wifi Bbox (uniquement)

Message par Pulpo »

Non, j'avais simplement rebooté. Là, je viens d'essayer, mais ça ne change rien, même après un nouveau reboot.
Laptop : Acer Aspire ES1-731-P25X | Linux Mint 20.1 Ulyssa | Cinnamon 4.8.6 | 5.4.0-64-generic x86_64 | Intel Pentium N3700 Quad Core | Ram : 4 Go

Avatar du membre
cyrille
modérateur
Messages : 6569
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Mint 20.1 - Atheros/ath9k - pas de connexion au wifi Bbox (uniquement)

Message par cyrille »

Code : Tout sélectionner

0: acer-wireless: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: acer-bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
Tu as 2 cartes wifi. As tu essayé de blacklister la carte acer-wmi ?

Code : Tout sélectionner

echo blacklist acer-wmi | sudo tee -a /etc/modprobe.d/blacklist-acer-wmi.conf
Afin qu'elle n'interagisse pas avec l'autre ?
# HOME: FreeBSD 12.1, Debian SID [XFCE, Fluxbox] # WORK : Mint 18.3 & 20 # VPS Debian stable + Serveur Olimex A20 autohébergé Debian stable
[ GIT : https://github.com/CyrilleBiot | Sites : https://cbiot.fr https://crust.ovh]

Avatar du membre
Pulpo
Messages : 7
Enregistré le : lun. 18 janv. 2021 16:11

Re: Mint 20.1 - Atheros/ath9k - pas de connexion au wifi Bbox (uniquement)

Message par Pulpo »

Je viens de l'essayer, mais ça ne change rien. "acer-wireless" a bien disparu de la liste, mais le problème reste le même.

Ce que je trouve déconcertant et que je ne crois pas avoir vu ailleurs dans mes recherches, c'est que ce PC arrive à se connecter aux autres wifi que j'ai pu essayer, et que de son côté le wifi de la Bbox fonctionne avec mes autres appareils.
Laptop : Acer Aspire ES1-731-P25X | Linux Mint 20.1 Ulyssa | Cinnamon 4.8.6 | 5.4.0-64-generic x86_64 | Intel Pentium N3700 Quad Core | Ram : 4 Go

Avatar du membre
cyrille
modérateur
Messages : 6569
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Mint 20.1 - Atheros/ath9k - pas de connexion au wifi Bbox (uniquement)

Message par cyrille »

s'il se connecte aux autres wifi c'est pas normal
Faudrait déjà vérfier cette information

Sinon tu peux aussi essayer de changer le canal wifi, on ne siat jamais (test depuis les canaux 6 à 11 ; ça se fait depuis la box (enfin jamais eu de bbox))
# HOME: FreeBSD 12.1, Debian SID [XFCE, Fluxbox] # WORK : Mint 18.3 & 20 # VPS Debian stable + Serveur Olimex A20 autohébergé Debian stable
[ GIT : https://github.com/CyrilleBiot | Sites : https://cbiot.fr https://crust.ovh]

Avatar du membre
Pulpo
Messages : 7
Enregistré le : lun. 18 janv. 2021 16:11

Re: Mint 20.1 - Atheros/ath9k - pas de connexion au wifi Bbox (uniquement)

Message par Pulpo »

cyrille a écrit :
jeu. 21 janv. 2021 13:15
s'il se connecte aux autres wifi c'est pas normal
Faudrait déjà vérfier cette information
J'ai vérifié après la dernière manip, le PC se connecte toujours sans souci au wifi de mon téléphone en mode point d'accès (mais je n'ai peut-être pas compris ce que tu voulais dire).

Je vais voir pour le coup des canaux, merci.
Laptop : Acer Aspire ES1-731-P25X | Linux Mint 20.1 Ulyssa | Cinnamon 4.8.6 | 5.4.0-64-generic x86_64 | Intel Pentium N3700 Quad Core | Ram : 4 Go

Avatar du membre
cyrille
modérateur
Messages : 6569
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Mint 20.1 - Atheros/ath9k - pas de connexion au wifi Bbox (uniquement)

Message par cyrille »

par hasard ce ne serait pas dû à un soucis d'association à la bbox ? Il ne faut pas appuyer 5 secondes sur le bouton association wifi pour tout nouveau appareil connecté à la box ?
# HOME: FreeBSD 12.1, Debian SID [XFCE, Fluxbox] # WORK : Mint 18.3 & 20 # VPS Debian stable + Serveur Olimex A20 autohébergé Debian stable
[ GIT : https://github.com/CyrilleBiot | Sites : https://cbiot.fr https://crust.ovh]

Avatar du membre
Pulpo
Messages : 7
Enregistré le : lun. 18 janv. 2021 16:11

Re: Mint 20.1 - Atheros/ath9k - pas de connexion au wifi Bbox (uniquement)

Message par Pulpo »

Non, je n'ai jamais eu à faire ça. Je connecte mes appareils classiquement en sélectionnant le réseau et en rentrant la clé WPA.

Mais j'ai trouvé l'option pour changer de canal. Dans l'encart "wifi" de l'écran l'accueil de l'admin Bbox, il faut cliquer sur "Réseaux wifi 2.4 GHz et 5 GHz", faut le savoir, ça ne saute pas aux yeux que c'est cliquable au premier abord. Ensuite sur le lien "paramètres avancés" lui même assez discret. Les deux réseaux étaient en canal automatique.

Le 2,4 GHz était sur le canal 6 au moment où j'ai testé, j'ai juste changé celui-là, en fixe sur le canal 11, et maintenant ça marche :)

Je vais passer le sujet en Résolu. Mais juste pour comprendre, qu'est-ce qui a pu faire qu'avant ce changement de canal, seul le PC portable ne pouvait pas se connecter ? Et le fait d'avoir fixé le canal peut-il créer d'autres problèmes par ailleurs ?

Merci beaucoup en tous cas ;)
Laptop : Acer Aspire ES1-731-P25X | Linux Mint 20.1 Ulyssa | Cinnamon 4.8.6 | 5.4.0-64-generic x86_64 | Intel Pentium N3700 Quad Core | Ram : 4 Go

Avatar du membre
cyrille
modérateur
Messages : 6569
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Mint 20.1 - Atheros/ath9k - pas de connexion au wifi Bbox (uniquement)

Message par cyrille »

certaines puces réagissent "aux ondes" de certains canaux. Rare mais ça arrive... Normalement les autres appareils s'adapteront sans rien avoir à faire ;)
Cool si résolu.
# HOME: FreeBSD 12.1, Debian SID [XFCE, Fluxbox] # WORK : Mint 18.3 & 20 # VPS Debian stable + Serveur Olimex A20 autohébergé Debian stable
[ GIT : https://github.com/CyrilleBiot | Sites : https://cbiot.fr https://crust.ovh]

Répondre