[résolu] activer les backports sous LMDE

Assistance Générale
Répondre
Avatar du membre
Grompf
Messages : 471
Enregistré le : ven. 8 janv. 2016 23:23
Localisation : Suisse (Canton de Vaud)

[résolu] activer les backports sous LMDE

Message par Grompf » dim. 12 févr. 2017 19:42

Hello !
J'ai besoin d'un paquet présent dans les backports : openjdk-8-jre (je dois télécharger un logiciel d'impôts qui ne fonctionne qu'avec Java 8 minimum).
Je voudrais être sûr de ne pas faire de bêtises. J'ai bien trouvé ceci :
https://wiki.debian.org/fr/Backports#Ut ... roportages" onclick="window.open(this.href);return false;

Mais j'ai Java 7 sur ma machine. Comment faire concrètement ? Je désinstalle Java 7, j'ajoute les backports, j'installe Java 8 ?
Modifié en dernier par Grompf le dim. 12 févr. 2017 23:42, modifié 1 fois.
CONFIGURATION :
  • 1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - KDE Neon User - noyau 4.13.0
    2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - Linux Mint Mate 19 - noyau 4.15.0

Avatar du membre
zeb
Administrateur du site
Messages : 13127
Enregistré le : ven. 19 juin 2015 22:13
Localisation : Au pays du mistral

Re: activer les backports sous LMDE

Message par zeb » dim. 12 févr. 2017 21:32

Salut Grompf ;)
Va voir par ici, martin a fait un tuto sur les backports ;)
https://www.forum-francophone-linuxmint ... =22&t=2206" onclick="window.open(this.href);return false;
LMDE3 cinnamon 64-bit + Lm 17.3 MATE.
Proc: intel I5 4440, Cm: Gigabyte GA-B85M-D3H, Alim: Corsair CX Bronze 430 W, Ram: Crucial Ballistix Sport, 2 x 2 Go.
SSD: 2.5 sandisk ultra+ 64 Go pour /+home, DD: Seagate Barracuda 500 Go pour mes données persos, DD maxtor 160 Go pour la sauvegarde ciblée via luckybackup.
Impr: HP Envy 4502.

Avatar du membre
Grompf
Messages : 471
Enregistré le : ven. 8 janv. 2016 23:23
Localisation : Suisse (Canton de Vaud)

Re: [résolu] activer les backports sous LMDE

Message par Grompf » dim. 12 févr. 2017 23:43

Merci !
J'ai rajouté les backports en passant par le gestionnaire de mises à jour.
Mais ensuite je n'arrivais pas à installer le paquet en question avec Synaptic (message d'erreur : paquets cassés...)
En ligne de commande l'installation s'est faite sans problèmes.
bizarre
CONFIGURATION :
  • 1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - KDE Neon User - noyau 4.13.0
    2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - Linux Mint Mate 19 - noyau 4.15.0

Avatar du membre
alain
Messages : 5149
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: [résolu] activer les backports sous LMDE

Message par alain » lun. 13 févr. 2017 01:41

Bonjour Grompf.

Dans synaptic tu peux vérifier s'il y a des paquets cassés:
Dans la colonne de gauche "filtres personnalisés" puis "cassés".
Pour les réparer:
En haut "édition" puis "réparer les paquets cassés".
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2018/09/ ... 8c173d.png

Avatar du membre
Grompf
Messages : 471
Enregistré le : ven. 8 janv. 2016 23:23
Localisation : Suisse (Canton de Vaud)

Re: [résolu] activer les backports sous LMDE

Message par Grompf » ven. 17 févr. 2017 13:08

@Alain :
J'ai essayé de réparer les paquets cassés avec Synaptic. Mais dès que je voulais installer, ça recommençait.

J'ai posé la question dans un autre forumet il semble que ce soit dû à des différences entre ce qui se fait sous Synaptic et ce qui se fait en ligne de commande.

Du coup, je me demande si je ne risque pas d'avoir des soucis avec les mises à jour au travers de l'outil graphique dédié de LMDE, lorsque ça touchera des paquets issus des backports.
CONFIGURATION :
  • 1. Lenovo Thinkpad X220 i5 - carte graphique Intel Corporation (2nd generation Core...) - KDE Neon User - noyau 4.13.0
    2. Lenovo Thinkpad T510 i7 - carte graphique : NVIDIA GT218M (NVS 3100M) - Linux Mint Mate 19 - noyau 4.15.0

Répondre