[Abandon] Mémoire vive qui ne se libère pas

Pour un problème lié uniquement à KDE
yves1953
Messages : 25
Enregistré le : lun. 18 sept. 2017 13:08

[Abandon] Mémoire vive qui ne se libère pas

Messagepar yves1953 » sam. 14 juil. 2018 10:02

Bonjour

Depuis mon récent changement de PC en mai dernier, je me heurte à l'anomalie suivante.

J'ai l'habitude de laisser mon ordinateur éclairé pendant plusieurs jours consécutifs. Or, au bout de quelque jours, le fonctionnement de la machine ralentit progressivement jusqu'au blocage. Je relance, et l'anomalie a disparu... pour un certain temps, car, au bout de quelques jours, le ralentissement est de retour, avec le même symptôme, etc.

Après avoir activé le logiciel "Surveillance du système", pour essayer de comprendre le phénomène, je constate, sur le panneau à onglet "Charge du système", dudit logiciel (zone "Historique de la mémoire") que le niveau affiché de la mémoire vive ne cesse d'augmenter, jusqu'à atteindre la limite maximale (les 8 Go dont je dispose).

Je tente alors une expérience : je ferme un à un tous les logiciels que j'utilise couramment, et que je laisse habituellement ouverts pendant toute la session (Thunderbird, Firefox LibreOffice...), mais cela n'a aucun effet sur le niveau indiqué qui refuse obstinément de baisser. En cas de blocage, seul le fait de relancer le PC permet de repartir à zéro, avec un niveau mémoire, situé au-dessous d'un Go.

Il semble donc que ce soit la mémoire vive qui refuse de se libérer au fur et à mesure que se déroule la session. J'ignore si l'anomalie vient de ma machine, de LinuxMint ou de KDE... Est-ce que quelqu'un a constaté chez lui un phénomène semblable ? Existe-t-il un "remède" ? Est-ce qu'il est possible de tenter une procédure quelconque pour éviter chaque fois de relancer la machine ?

Merci d'avance pour votre aide.
Modifié en dernier par yves1953 le mar. 24 juil. 2018 09:31, modifié 2 fois.
PC BUREAU 64 bits (mai 2018) ; CPU : Pentium dualcore G4400 ; RAM : 8 Go ; DD : SSD 120 Go + 240 Go.
SYSTÈME 1 : LinuxMint 18.3 KDE (noyau : 4.10.0-38-generic) ;
SYSTÈME 2 : LinuxMint 19 Cinnamon (noyau : 4.15.0-29-generic).

Avatar du membre
Lycaon
Messages : 555
Enregistré le : ven. 13 avr. 2018 00:53
Localisation : Belgique

Re: Mémoire vive qui (apparemment) ne se libère pas

Messagepar Lycaon » sam. 14 juil. 2018 10:51

Bonjour,

D'abord il faudrait, lorsque ça se présente, ouvrir un terminal et taper la commande

Ça permettrait, en regardant la colonne de niveau de mémoire utilisée, d'identifier le processus "coupable".

Edit : pour en sortir, il suffit de taper sur 'Q'.
CM Gigabyte 970A UD3 // Proc. AMD Phenom™Ⅱ X4 965 // RAM 2×4 Go DDR3 G.Skill Extreme3 Ripjaws 1600MHz-PC12800 // CG Nvidia GK208 (GeForce GT730) 9020MHz 2Go // Écran Philips 240V 24" 1920×1200 // SSD (sda) 120Go // HDD (sdb) 2To // Lecteur-graveur DVD noname // Impr. Brother DCP-J562DW (/USB) // LM 18.3 Cinnamon 64 bits, noyau 4.15.0-29-generic x86_64 (64 bit)

yves1953
Messages : 25
Enregistré le : lun. 18 sept. 2017 13:08

Re: Mémoire vive qui (apparemment) ne se libère pas

Messagepar yves1953 » sam. 14 juil. 2018 12:12

Merci pour ton aide, Lycaon

J'ai fait ce que tu m'as dit.

Dans la grille qui s'affiche alors, la première ligne indique Firefox, avec un pourcentage MEM = 9 à 10 %

J'ai alors fermé les différentes fenêtres de Firefox qui étaient ouvertes (sauf la présente fenêtre dédiée au forum), mais la ligne à laquelle je faisais allusion (dans "Surveillance du système") n'a guère baissé, et reste encore très au-dessus de sa position minimale (celle qui s'affiche immédiatement après un reboot)...

Que me suggères-tu ?
PC BUREAU 64 bits (mai 2018) ; CPU : Pentium dualcore G4400 ; RAM : 8 Go ; DD : SSD 120 Go + 240 Go.
SYSTÈME 1 : LinuxMint 18.3 KDE (noyau : 4.10.0-38-generic) ;
SYSTÈME 2 : LinuxMint 19 Cinnamon (noyau : 4.15.0-29-generic).

Avatar du membre
arghlub
modérateur
Messages : 3916
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence

Re: Mémoire vive qui (apparemment) ne se libère pas

Messagepar arghlub » sam. 14 juil. 2018 14:11

Salut,
Pour compléter le message de Lycaon à propos de «top».
Si tu veux trier les processus par rapport à la mémoire, une fois dans «top», tu tapes le raccourci : Maj+m
;)
Portable • Lenovo G50-80 | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LinuxMint 18.3 Sylvia | LinuxMint 19 Tara | Manjaro 17.1 | XFCE (pour les 3)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3000MHz | Debian 9 XFCE 4.12.3 (+ de multiples machines virtuelles)
────────────────────────────────────
... pour une informatique libre ! -membre de l'April

yves1953
Messages : 25
Enregistré le : lun. 18 sept. 2017 13:08

Re: Mémoire vive qui (apparemment) ne se libère pas

Messagepar yves1953 » sam. 14 juil. 2018 14:47

Merci pour ton intervention, Arghlub.

Les lignes sont bien triées par ordre décroissant d'utilisation de la mémoire. Mais à présent je ne sais pas trop de ce que je dois faire du résultat, et, surtout, quel enseignement je peux tirer de ce tableau.

En effet, le fait de connaître la liste des tâches qui utilisent la mémoire est une chose (je trouve aussi cette liste dans "Surveillance du système"), mais comprendre pourquoi la mémoire utilisée ne se libère pas en est une autre...

J'aimerais joindre une copie d'écran du résultat obtenu avec "top" (peut-être que ça permettrait à un membre du forum de m'orienter vers une solution), mais (nouvelle difficulté !), je n'arrive pas à trouver la commande pour joindre un fichier à mon post. J'ai bien parcouru le tutoriel "Poster une image..." mais je ne comprends pas comment faire pour sélectionner la copie d'écran *.png que j'ai faite, et qui se trouve sur mon ordinateur... Où se trouve donc le bouton "Envoyer une image" ou "Joindre une image" ?

Merci d'avance pour vos éclaircissements.
PC BUREAU 64 bits (mai 2018) ; CPU : Pentium dualcore G4400 ; RAM : 8 Go ; DD : SSD 120 Go + 240 Go.
SYSTÈME 1 : LinuxMint 18.3 KDE (noyau : 4.10.0-38-generic) ;
SYSTÈME 2 : LinuxMint 19 Cinnamon (noyau : 4.15.0-29-generic).

Avatar du membre
zebulon
Administrateur du site
Messages : 12603
Enregistré le : ven. 19 juin 2015 22:13
Localisation : Au pays du mistral

Re: Mémoire vive qui (apparemment) ne se libère pas

Messagepar zebulon » sam. 14 juil. 2018 15:04

Bonjour,
yves1953 a écrit :J'ai bien parcouru le tutoriel "Poster une image..." mais je ne comprends pas comment faire pour sélectionner la copie d'écran *.png que j'ai faite, et qui se trouve sur mon ordinateur... Où se trouve donc le bouton "Envoyer une image" ou "Joindre une image" ?
C'est que tu n'as pas bien lu le tuto ou alors tu l'as lu en diagonale.
Tout y est expliqué ;)
LMDE3 cinnamon 64-bit + Lm 17.3 MATE.
Proc: intel I5 4440, Cm: Gigabyte GA-B85M-D3H, Alim: Corsair CX Bronze 430 W, Ram: Crucial Ballistix Sport, 2 x 2 Go.
SSD: 2.5 sandisk ultra+ 64 Go pour /+home, DD: Seagate Barracuda 500 Go pour mes données persos, DD maxtor 160 Go pour la sauvegarde ciblée via luckybackup.
Impr: HP Envy 4502.

mpedro
Messages : 1526
Enregistré le : dim. 8 nov. 2015 22:13
Contact :

Re: Mémoire vive qui (apparemment) ne se libère pas

Messagepar mpedro » sam. 14 juil. 2018 15:28

Stretch 32bits cinnamon/Fedora25/Sarah
Compaq 8510p/MSI GE70/Raspberry Pi2

Avatar du membre
tanik
Messages : 60
Enregistré le : mar. 30 août 2016 07:45
Contact :

Re: Mémoire vive qui (apparemment) ne se libère pas

Messagepar tanik » sam. 14 juil. 2018 15:46

Comme dit à la fin de la page indiquée, il y a Bleachbit aussi.
il est efficace pour nettoyer le système.
même si on aura pas d'explication sur le pourquoi de cette ram qui se remplit bizarrement.

attention avec Bleachbit, il est assez complet. bien lire toutes les 'cases' et faire d'abord la simulation.
cela dit, perso, je n'ai jamais perdu mon système à cause de lui, c'est pas dangereux non plus. :D
pc1 : Asrock ab350m-pro4, AMD RYZEN 7 1700X, 16go ddr4 2666 cl14, ldlc 450w modulaire, Radeon RX 560 oc, 3*2To DD, 1*128Go SSD M.2, carte son Audiophonics U-sabre et Focusrite Scarlett 18I8, Linux Mint 19, et parfois win

pc 2 : Asus A320M-K prime, RyZen 3 2200G, 8go ddr4 2400, ssd Sandisk 120, dongle wifi (PI)

pc 3 : Asrock 960gs3, Phenom II X4 820, 8go ddr3 1600, Radeon HD 4350
pc 4 : PI3

a computer is like air conditionning system, it become useless if you open windows (Linus Torvalds) :D

yves1953
Messages : 25
Enregistré le : lun. 18 sept. 2017 13:08

Re: Mémoire vive qui (apparemment) ne se libère pas

Messagepar yves1953 » sam. 14 juil. 2018 18:07

Merci à mpedro et tanik pour votre aide.

Grâce à vos suggestions, j'ai compris comment faire pour nettoyer la mémoire. J'ai soigneusement enregistré le lien que vous m'avez indiqué pour de futures utilisations. Cela me permettra d'échapper à un reboot en plein travail (à condition de ne pas attendre le blocage total de mon PC)...

Cependant, je reste un peu sur ma faim et je me pose un certain nombre de questions au sujet de ce désagrément...

En effet, j'utilise Linux Mint depuis environ quatre ans, et c'est la première fois que je constate que la mémoire RAM enfle au point de bloquer le système et de m'obliger à relancer celui-ci.

J'aimerais bien savoir si l'origine est matérielle ou logicielle. Est-ce que cela a un rapport avec mon nouvel ordinateur (acheté en mai dernier) ? Ou bien avec cette version 18 de Linux Mint (l'ancienne machine, qui ne possédait que 4 Go de RAM, utilisait Mint 17) ? Car, mis à part ces changements, je travaille avec les mêmes logiciels : LibreOffice, Firefox et Thunderbird, pour l'essentiel. Et jusqu'à ce nouvel achat, je n'ai jamais eu besoin de nettoyer la mémoire RAM !

Depuis le changement de machine, l'anomalie se produit de manière récurrente, tous les deux, trois ou quatre jours (selon l'utilisation de mon PC). Quelle en est l'origine ? Est-ce qu'il n'existe pas une procédure qui me permettrait de mieux comprendre ce qui se passe, et peut-être, d'y trouver un remède ?
PC BUREAU 64 bits (mai 2018) ; CPU : Pentium dualcore G4400 ; RAM : 8 Go ; DD : SSD 120 Go + 240 Go.
SYSTÈME 1 : LinuxMint 18.3 KDE (noyau : 4.10.0-38-generic) ;
SYSTÈME 2 : LinuxMint 19 Cinnamon (noyau : 4.15.0-29-generic).

Avatar du membre
Lycaon
Messages : 555
Enregistré le : ven. 13 avr. 2018 00:53
Localisation : Belgique

Re: Mémoire vive qui (apparemment) ne se libère pas

Messagepar Lycaon » dim. 15 juil. 2018 02:40

Désolé, j'ai du partir. :oops:

Un problème matériel, j'en doute. Ça peut arriver si on monte son PC soi-même et qu'on choisit des barrettes de RAM qui ne sont pas compatibles avec ce qu'accepte la carte-mère (question de fréquences RAM acceptées). Mais si c'est une machine achetée telle quelle, c'est extrêmement rare, à moins d'un intégrateur de quartier affilié à la Pieds-Nickelés Incorporated™ ... :)

Pour l'impression d'écran du top, on en a besoin pour identifier le processus qui consomme trop ou sans libérer de la mémoire.
CM Gigabyte 970A UD3 // Proc. AMD Phenom™Ⅱ X4 965 // RAM 2×4 Go DDR3 G.Skill Extreme3 Ripjaws 1600MHz-PC12800 // CG Nvidia GK208 (GeForce GT730) 9020MHz 2Go // Écran Philips 240V 24" 1920×1200 // SSD (sda) 120Go // HDD (sdb) 2To // Lecteur-graveur DVD noname // Impr. Brother DCP-J562DW (/USB) // LM 18.3 Cinnamon 64 bits, noyau 4.15.0-29-generic x86_64 (64 bit)


Retourner vers « KDE »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité