[résolu] Reboot redémarrage du PC ne fonctionne pas correctement

Assistance concernant Linux Mint
Avatar du membre
arghlub
modérateur
Messages : 3926
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence

Re: Reboot redémarrage du PC ne fonctionne pas correctement

Messagepar arghlub » dim. 16 sept. 2018 19:57

Dernier message de la page précédente :

Pour savoir sur quel noyau (kernel) tu es, il te suffit de saisir dans un terminal :

Code : Tout sélectionner

inxi -S

Le noyau 4.15 pose quelques soucis à certains d'entre nous selon le matériel (perso pas de souci, mais ça dépend de chacun).
Pour rétrograder de noyau, redémarre et dans le grub au démarrage (appuie sur la touche <Maj> s'il n'apparaît pas), vas dans les «options avancées», sélectionne un noyau antérieur pour démarrer dessus.

Puis, si tout va bien, il faut désinstaller la dernière version du noyau qui mettait le souk.
Pour cela, dans ton gestionnaire de mises à jour, vas dans le menu «Vue > Noyaux Linux».

[EDIT] si tu veux installer des noyaux inferieur au 4.15 dans LM19, le plus simple est d'installer le logiciel ukuu :

Code : Tout sélectionner

sudo apt-add-repository -y ppa:teejee2008/ppa

Code : Tout sélectionner

sudo apt update

Code : Tout sélectionner

sudo apt install ukuu
;)
Portable • Lenovo G50-80 | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LinuxMint 18.3 Sylvia | LinuxMint 19 Tara | Manjaro 17.1 | XFCE (pour les 3)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3000MHz | Debian 9 XFCE 4.12.3 (+ de multiples machines virtuelles)
────────────────────────────────────
... pour une informatique libre ! -membre de l'April

Avatar du membre
karami
Messages : 441
Enregistré le : jeu. 11 janv. 2018 12:28

Re: Reboot redémarrage du PC ne fonctionne pas correctement

Messagepar karami » dim. 16 sept. 2018 20:09

Salut ;)

en lisant le retour de commande dmesg, vers la fin on tombe sur des lignes un peu suspectes qui parlent de "signature not signed with a trusted key", "nvidia: module license 'NVIDIA' taints kernel", "ACPI Warning", "ACPI requires [Package]" ....

C'est normal ?

Code : Tout sélectionner

[   14.054157] PKCS#7 signature not signed with a trusted key
[   14.054166] nvidia: loading out-of-tree module taints kernel.
[   14.054171] nvidia: module license 'NVIDIA' taints kernel.
[   14.054171] Disabling lock debugging due to kernel taint
[   14.058009] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[   14.065601] nvidia-nvlink: Nvlink Core is being initialized, major device number 240
[   14.065995] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  390.48  Thu Mar 22 00:42:57 PDT 2018 (using threaded interrupts)
[   14.339278] PKCS#7 signature not signed with a trusted key
[   14.340244] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  390.48  Wed Mar 21 23:48:34 PDT 2018
[   14.385424] PKCS#7 signature not signed with a trusted key
[   14.387025] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
(...)
[   15.271172] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170831/nsarguments-100)


Quand tu as fait ton install, est-ce que tu as bien mis tes pilotes à jour (notamment nvidia et le microcode Intel) ?
PC 1 = Giada i 33 (Free DOS) | CPU: Intel Atom D525 @ 1,80 GHz x 2 | RAM: 2 Go ddr2
OS = LM 17.1 64 bit | Cinnamon 2.4.8 | Noyau: 3.13.0-24-generic


PC 2 = DELL Optiplex 390 reconditionné | CPU: Intel Pentium G 630 @ 2,60 GHz x 2 | RAM: 4 Go ddr3
OS = LM 18.3 | Cinnamon 3.6.6 | Noyau: 4.13.0-45-generic

Avatar du membre
Dundee33
Messages : 41
Enregistré le : lun. 13 août 2018 21:49
Localisation : Gironde
Contact :

Re: Reboot redémarrage du PC ne fonctionne pas correctement

Messagepar Dundee33 » lun. 17 sept. 2018 19:23

Salut.

Voici le résulta de la commande

Code : Tout sélectionner

dundee@dundee-GL552VW:~$ inxi -S
System:    Host: dundee-GL552VW Kernel: 4.15.0-34-generic x86_64 bits: 64
           Desktop: MATE 1.20.1  Distro: Linux Mint 19 Tara
dundee@dundee-GL552VW:~$ 

Pour installer un précédent noyau et le sélectionner au démarrage, il faudrait que j'ai accès à Grub. Je suis en simple boot. ;) Je vais aller voir avec la touche <Maj> au démarrage. ;)

Du côté Intel et Nvidia, visiblement je serais à jour.

Image Image

intel-microcode | 3.20180807a.0ubuntu018.04.1
............
..........
......
nvidia-compute-utils- | 390.48-0ubuntu3
nvidia-kernel-comm-390 | 390.48-0ubuntu3
............
..........
......
PC portable 'ASUS GL552V' Processeur Intel® Core™ i7 quad-core 6e génération - carte graphique NVIDIA® GeForce® GTX™ avec Linux Mint 19 Mat 64b

Avatar du membre
Dundee33
Messages : 41
Enregistré le : lun. 13 août 2018 21:49
Localisation : Gironde
Contact :

Re: Reboot redémarrage du PC ne fonctionne pas correctement

Messagepar Dundee33 » lun. 17 sept. 2018 19:35

De retour.
Avec la touche <Maj> au démarrage je n'ai pas grub. Pourtant il y a quelque chose d'installer à ce niveau. Peut être pas tout ?

grub-common
grub-efi-amd64
grub-efi-amd64-bin
grub-efi-amd64-signed
grub2-common
PC portable 'ASUS GL552V' Processeur Intel® Core™ i7 quad-core 6e génération - carte graphique NVIDIA® GeForce® GTX™ avec Linux Mint 19 Mat 64b

Avatar du membre
arghlub
modérateur
Messages : 3926
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence

Re: Reboot redémarrage du PC ne fonctionne pas correctement

Messagepar arghlub » lun. 17 sept. 2018 19:40

Salut,

Pour rétablir l'affichage du grub au démarrage (on pourra facilement le refaire disparaître par la suite), donne-nous le retour de cette commande :

Code : Tout sélectionner

cat /etc/default/grub
Portable • Lenovo G50-80 | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LinuxMint 18.3 Sylvia | LinuxMint 19 Tara | Manjaro 17.1 | XFCE (pour les 3)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3000MHz | Debian 9 XFCE 4.12.3 (+ de multiples machines virtuelles)
────────────────────────────────────
... pour une informatique libre ! -membre de l'April

Avatar du membre
Dundee33
Messages : 41
Enregistré le : lun. 13 août 2018 21:49
Localisation : Gironde
Contact :

Re: Reboot redémarrage du PC ne fonctionne pas correctement

Messagepar Dundee33 » mar. 18 sept. 2018 05:53

Salut.

Ok.

Code : Tout sélectionner

dundee@dundee-GL552VW:~$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
dundee@dundee-GL552VW:~$ 

Réédite: Suite à cette ligne de commande j'ai fais un nouveau test au démarrage. Sur un mal entendu [...] :l
PC portable 'ASUS GL552V' Processeur Intel® Core™ i7 quad-core 6e génération - carte graphique NVIDIA® GeForce® GTX™ avec Linux Mint 19 Mat 64b

Avatar du membre
alain
Messages : 4686
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles

Re: Reboot redémarrage du PC ne fonctionne pas correctement

Messagepar alain » mar. 18 sept. 2018 06:54

bonjour Dundee.

Pour afficher ton grub, que tu as comme tout le monde, même si tu es en simple boot, tu fais d'abord ça:

Code : Tout sélectionner

sudo cp /etc/default/grub /etc/default/grub.bak

ceci est une sauvegarde de ton fichier grub actuel, en cas d'erreur.

Puis tu edite ton grub par:

Code : Tout sélectionner

sudo xed /etc/default/grub

Devant la ligne:
GRUB_TIMEOUT_STYLE=hidden

tu mets un # .
Si le temps d'affichage du grub ne te suffit pas tu peux mettre plus que 10 s à la ligne :
GRUB_TIMEOUT=10

Quand tu as fini tes modification, tu enregistre puis tu fais:

Code : Tout sélectionner

sudo update-grub

Ensuite tu éteint ton ordi et tu le démarre ((je ne te dis pas de faire "redémarrer" vu ton problème... :l ). Normalement tu vas
avoir le grub qui s'affiche pendant 10 s ou plus suivant le temps que tu auras mis.
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : http://www.fflmpics.fr/images/2018/09/0 ... 8c173d.png

Avatar du membre
Dundee33
Messages : 41
Enregistré le : lun. 13 août 2018 21:49
Localisation : Gironde
Contact :

Re: Reboot redémarrage du PC ne fonctionne pas correctement

Messagepar Dundee33 » mar. 18 sept. 2018 19:36

Salut.

Donc.

Code : Tout sélectionner

dundee@dundee-GL552VW:~$ sudo cp /etc/default/grub /etc/default/grub.bak
[sudo] Mot de passe de dundee :
dundee@dundee-GL552VW:~$ sudo xed /etc/default/grub

Avant d'aller plus loin, voici ce que j'ai dans le fichier Grub.

Code : Tout sélectionner

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_TIMEOUT est déjà à 10 et pourtant invisible (écran noir) du démarrage. (?!) Je pense qu'il y a quelque chose que je n'ai pas compris. ;)
PC portable 'ASUS GL552V' Processeur Intel® Core™ i7 quad-core 6e génération - carte graphique NVIDIA® GeForce® GTX™ avec Linux Mint 19 Mat 64b

Avatar du membre
alain
Messages : 4686
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles

Re: Reboot redémarrage du PC ne fonctionne pas correctement

Messagepar alain » mar. 18 sept. 2018 20:02

salut Dundee.
Dundee33 a écrit :GRUB_TIMEOUT est déjà à 10 et pourtant invisible (écran noir) du démarrage. (?!) Je pense qu'il y a quelque chose que je n'ai pas compris. ;)

Je pense aussi... :l
J'ai bien vu que ton timeout est a 10, tu l'as dis dans ton post précédent :l
alain a écrit :Si le temps d'affichage du grub ne te suffit pas tu peux mettre plus que 10 s à la ligne :
GRUB_TIMEOUT=10



Bon sinon est que tu as fait ça? :
alain a écrit :Devant la ligne:
GRUB_TIMEOUT_STYLE=hidden

tu mets un # .

Tu dois avoir cette ligne comme ça:

Code : Tout sélectionner

#GRUB_TIMEOUT_STYLE=hidden


J'aurai pas du te dire comment augmenter le temps d'affichage ça a du t'embrouiller, l'important c'est le # ...

Alors tu mets ce foutu # devant la ligne comme je viens de te l'indiqué, puis tu sauvegarde puis:

Code : Tout sélectionner

sudo update-grub

Ensuite tu éteint ton ordi et tu le démarre ((je ne te dis pas de faire "redémarrer" vu ton problème... :l )
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : http://www.fflmpics.fr/images/2018/09/0 ... 8c173d.png

Avatar du membre
Dundee33
Messages : 41
Enregistré le : lun. 13 août 2018 21:49
Localisation : Gironde
Contact :

Re: Reboot redémarrage du PC ne fonctionne pas correctement

Messagepar Dundee33 » ven. 21 sept. 2018 22:19

Salut.

Alors, oui je viens de le faire à l'instant.

Code : Tout sélectionner

dundee@dundee-GL552VW:~$ sudo xed /etc/default/grub
[sudo] Mot de passe de dundee :
sudo update-grub

** (xed:2258): WARNING **: 22:15:57.937: Set document metadata failed: La définition de l’attribut metadata::xed-position n’est pas prise en charge
dundee@dundee-GL552VW:~$ sudo update-grub
Création du fichier de configuration GRUB…
Image Linux trouvée : /boot/vmlinuz-4.15.0-34-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.15.0-34-generic
Image Linux trouvée : /boot/vmlinuz-4.15.0-33-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.15.0-33-generic
Image Linux trouvée : /boot/vmlinuz-4.15.0-20-generic
Image mémoire initiale trouvée : /boot/initrd.img-4.15.0-20-generic
Adding boot menu entry for EFI firmware configuration
fait
dundee@dundee-GL552VW:~$ 

Maintenant j'ai bien Grub au démarrage. Merci. ;)

Image Image

J'ai régler de délai à 03 secondes. C'est bien suffisant. :) La je suis au boulot. Je remontrais plus haut dans le sujet pour retrouver ou voir comment ajouter l'autre noyau à côté de celui d’origine.
Bon week-end. ;)
PC portable 'ASUS GL552V' Processeur Intel® Core™ i7 quad-core 6e génération - carte graphique NVIDIA® GeForce® GTX™ avec Linux Mint 19 Mat 64b

Avatar du membre
alain
Messages : 4686
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles

Re: Reboot redémarrage du PC ne fonctionne pas correctement

Messagepar alain » sam. 22 sept. 2018 00:03

Salut Dundee.
Dundee33 a écrit :Maintenant j'ai bien Grub au démarrage. Merci. ;)

Ouf ! :D ... De rien. ;)

Dundee33 a écrit :J'ai régler de délai à 03 secondes. C'est bien suffisant. :)

Hé ben! t'es un rapide toi :shock: :l . Moi j'ai réglé le mien sur 15 s et des fois j'ai pas le temps de sélectionner le noyau que je veux...

Je te rappelle que le grub doit te permettre de démarrer sur un autre noyau si celui que tu as installé ne convient pas.
3 s pour aller dans les option avancées et sélectionner le noyau voulu, ça me parait un peu short tout même :roll: ... Mais bon: "c'est vous qui voyez, y en a qu'on essayé, ils ont eu ....." :lol:

Bon week end a toi aussi ;)
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : http://www.fflmpics.fr/images/2018/09/0 ... 8c173d.png


Retourner vers « Générale »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité