[RESOLU]grub-efi n'a pas pu être installé. Nouvelle install sur disque neuf

Des problemes avant ou pendant l'installation
Répondre
lacaille
Messages : 8
Enregistré le : mer. 28 févr. 2018 09:48

[RESOLU]grub-efi n'a pas pu être installé. Nouvelle install sur disque neuf

Message par lacaille » dim. 16 sept. 2018 12:27

Bonjour à tous !
Je suis en train de réinstaller mint sur un hp probook et je ne comprends pas comment gérer le démarrage. J'espère donc trouver de l'aide ici, pour comprendre et résoudre ce soucis. Merci d'avance à vous !!

Après installation, j'ai un message de l'installateur :

Code : Tout sélectionner

Le paquet grub-efi-amd64-signed n'a pas pu être installé dans /target/ En l'absence du programme de démarrage GRUB le système installé ne pourra pas démarrer
Détails :
je viens d'installer mint 18.3 édition KDE, depuis une clé usb (session live démarrée en uefi) sur un disque neuf que je viens de recevoir, installé sur un ordi hp probook 4540S. (il contenait un disque d'origine avec windows et mint en dual boot, le windows était inutilisé et de toute façon non fonctionnel, jamais mis à jour, etc. J'avais ramé pour installer mint à l'époque)

Disque neuf : C'est un disque firecuda 1To, j'ai formaté comme suit : (avec le partition manager de mint en session live)
-partition fat 32 de 100 Mo
-partition ext4 root de 80 Go
-swap de 6 Go
-/home de ce qui reste soit environ 900 Go

j'ai pas mal cherché, je trouve plein de choses pas très claires, il me semble que cela peut provenir de l'installateur de mint mais je ne comprends pas pourquoi.

Cerise sur le gateau, pas moyen d'accéder au bios du 4540 qui semble verrouillé (et je ne retrouve pas le mot de passe)

Merci de vos suggestions

EDIT j'ai retrouvé le mot de passe admin du bios, et suis passé en mode legacy. Je fais donc un essai d'installation dans le mode de boot bios ancien. Je préciserai le résultat. Mais je voudrais bien comprendre comment utiliser l'EFI, et le sujet reste obscur et complexe pour moi, pour le moment.
Modifié en dernier par lacaille le dim. 16 sept. 2018 18:59, modifié 1 fois.
s'approprier les outils informatiques, que ce soit via le logiciel libre et gnu-linux, ou via du matériel libre et ouvert comme diskio pi (https://www.diskiopi.com/" onclick="window.open(this.href);return false;) est la seule solution pour éviter la catastrophe à très cour terme, tant en matière de liberté, qu'en matière de sauvegarde de notre vie privée

msi cr62-2M 264XFR core i7 5700HQ @2,7 Ghz, 8 G de ram, ssd 250 G sous linuxmint, debian, etc
autres machines de divers types, toutes sous debian et dérivées.

Avatar du membre
Gerinald
Messages : 879
Enregistré le : dim. 22 janv. 2017 10:40
Localisation : Manage (Belgique)

Re: grub-efi n'a pas pu être installé. Nouvelle install sur disque neuf

Message par Gerinald » dim. 16 sept. 2018 13:00

Salux,

En ce qui concerne l'UEFI ou EFI, je trouve que il y a déjà pas mal de tuto sur le net ainsi que de post sur ce forum, pour ne plus y revenir ..

Par contre, si je peut te donner un conseil .... laisse Mint géré les partitions .... je trouve que il le fait déjà très bien, et si tu n'a pas d'autres OS sur ton PC, il est inutile de créé des partitions manuellement ... :)

Laisse la case d'installation de Grub coché .... même si tu n'a pas d'autres OS, il peut toujours être utile de l'avoir pour différent dépannage ;)

Bat
Distro : LM-19 Tara - Cinnamon 3.8.8 - Kernel 4.18.5-041805-generic
PC : AMD Athlon II X2 250 duo, CG : NVIDIA GT218 [GeForce 210] sur pilote "Nouveau", 4 Go de mémoire vive

sandro
Messages : 37
Enregistré le : mer. 11 avr. 2018 15:37

Re: grub-efi n'a pas pu être installé. Nouvelle install sur disque neuf

Message par sandro » dim. 16 sept. 2018 13:41

bonjour,
j'ai eu ce PB il y a quelques jours, en tentent d'installer Mint sur un SSD puis j'ai testé sur un HDD IDEM.

mon post n'ayant pas trouvé de réponse j'ai trouvé un semblent de solution. viewtopic.php?f=20&t=11011

d’abord j'ai commencé par un formatage LOWLEVEL (je l'ai fait sous W10 avec HDDLLF) ça efface tout les fichiers résiduel du disque en le remettant a l'été sortie d'usine (moins les testes (paquets alléatoir en écriture et lectur)) j'ai vu qu'évidement il est possible de formater sous Mint en LLevel mais la je suis pas assé qualifier pour d'aider.

puis une fois Mint installé les 1er démarrages reste bizarre avec des messages d'erreur Grub inexistant, puis après quelques démarrages réussit tout rentre dans l'ordre.
pour le moment Mint fonctionne très bien sur mon SSD avec le SWAP sur le HDD.

sandro
PC portable ASUS R700 sauvé d'une une poubelle.
Système Installé : Mint 18.3, cinnamon 3.6.7, Kermel : 4.15.0-34
Intel I5 3210M 2.50X2 RAM 6Go installé
1 SDD 120Go OCZ 1 HDD 1To samsung
CG NVIDIA GF 108 M [GeForce GT 630M]

lacaille
Messages : 8
Enregistré le : mer. 28 févr. 2018 09:48

Re: grub-efi n'a pas pu être installé. Nouvelle install sur disque neuf

Message par lacaille » dim. 16 sept. 2018 16:57

Gerinald a écrit :Salux,

En ce qui concerne l'UEFI ou EFI, je trouve que il y a déjà pas mal de tuto sur le net ainsi que de post sur ce forum, pour ne plus y revenir ..

Par contre, si je peut te donner un conseil .... laisse Mint géré les partitions .... je trouve que il le fait déjà très bien, et si tu n'a pas d'autres OS sur ton PC, il est inutile de créé des partitions manuellement ... :)

Laisse la case d'installation de Grub coché .... même si tu n'a pas d'autres OS, il peut toujours être utile de l'avoir pour différent dépannage ;)

Bat
Hello

Merci pour cette réponse toute en nuances. Oui les forums regorgent de sujets sur EFI/UEFI et comme tu l'auras sans doute remarqué, il n'y a pas à ma connaissance en tous cas de tuto digne de ce nom, pas du type youtube, mais du type texte explicatif détaillé, qui donne des réponses claires, et la plupart des posts à ce sujet se terminent par des "youpi résolu" qui ne donnent aucune explication. (c'est quoi cette histoire de case grub coché rien de tel dans l'installation)

En fait, je cherche à contrôler mon ordinateur et son OS, et non pas à être contrôlé par lui : choix de gnulinux, etc, par conséquent je ne vois pas l'utilité de "laisser mint géré (sic) les partitions", car j'utilise une partition séparée pour le système. De plus, mint fut incapable de résoudre le dilemne posé : le boot loader ne s'installe pas... ni sur partition uefi, ni après avoir passé le disque en dos avec partitionnement classique :

Pour en revenir au sujet du jour, l'installation sur disque neuf posant visiblement problème à partir de l'installateur de l'iso mint 18.3-kde, sur un système bootant en uefi, j'ai finalement pu modifier le bios pour retourner en "legacy" (boot à l'ancienne) puis reformaté le disque neuf en msdos avec 3 partitions ext4 / (système) (drapeau de boot), swap (si si) et ext4 pour /home. J'ai ensuite relancé l'installation de mint depuis la clé usb, et à la fin de l'installation, le message me disant que je pouvais redémarrer est apparu... Et là eh ben, à nouveau, le bios ne trouve pas l'image de démarrage...

J'ai pu booter le nouveau système avec supergrubdisk installé sur une clé usb, qui a trouvé la partition, et a bien lancé la nouvelle install du système. Maintenant, il me faut comprendre comment réinstaller grub sur mon disque... Je viendrai dire où j'en suis plus tard...

Merki
s'approprier les outils informatiques, que ce soit via le logiciel libre et gnu-linux, ou via du matériel libre et ouvert comme diskio pi (https://www.diskiopi.com/" onclick="window.open(this.href);return false;) est la seule solution pour éviter la catastrophe à très cour terme, tant en matière de liberté, qu'en matière de sauvegarde de notre vie privée

msi cr62-2M 264XFR core i7 5700HQ @2,7 Ghz, 8 G de ram, ssd 250 G sous linuxmint, debian, etc
autres machines de divers types, toutes sous debian et dérivées.

lacaille
Messages : 8
Enregistré le : mer. 28 févr. 2018 09:48

Re: grub-efi n'a pas pu être installé. Nouvelle install sur disque neuf

Message par lacaille » dim. 16 sept. 2018 17:01

sandro a écrit :bonjour,
j'ai eu ce PB il y a quelques jours, en tentent d'installer Mint sur un SSD puis j'ai testé sur un HDD IDEM.

mon post n'ayant pas trouvé de réponse j'ai trouvé un semblent de solution. viewtopic.php?f=20&t=11011

d’abord j'ai commencé par un formatage LOWLEVEL (je l'ai fait sous W10 avec HDDLLF) ça efface tout les fichiers résiduel du disque en le remettant a l'été sortie d'usine (moins les testes (paquets alléatoir en écriture et lectur)) j'ai vu qu'évidement il est possible de formater sous Mint en LLevel mais la je suis pas assé qualifier pour d'aider.

puis une fois Mint installé les 1er démarrages reste bizarre avec des messages d'erreur Grub inexistant, puis après quelques démarrages réussit tout rentre dans l'ordre.
pour le moment Mint fonctionne très bien sur mon SSD avec le SWAP sur le HDD.

sandro
Hello bonjour et youpi

Merci des suggestions, (ton post cité) cela ne correspond pas à ma situation : j'utilise une clé live mint, et je n'ai pas de windows installé, cela fait des années que je n'utilise plus ce truc zinzin. J'installe sur un disque neuf pour un pc en boot legacy...

à plus merki quand même
s'approprier les outils informatiques, que ce soit via le logiciel libre et gnu-linux, ou via du matériel libre et ouvert comme diskio pi (https://www.diskiopi.com/" onclick="window.open(this.href);return false;) est la seule solution pour éviter la catastrophe à très cour terme, tant en matière de liberté, qu'en matière de sauvegarde de notre vie privée

msi cr62-2M 264XFR core i7 5700HQ @2,7 Ghz, 8 G de ram, ssd 250 G sous linuxmint, debian, etc
autres machines de divers types, toutes sous debian et dérivées.

Avatar du membre
zeb
Administrateur du site
Messages : 12927
Enregistré le : ven. 19 juin 2015 22:13
Localisation : Au pays du mistral

Re: grub-efi n'a pas pu être installé. Nouvelle install sur disque neuf

Message par zeb » dim. 16 sept. 2018 17:08

Bonjour,
Merci de ne pas faire un post par réponse, à 4 minutes d'intervalle, tu pouvais en faire qu'un seul ;)
LMDE3 cinnamon 64-bit + Lm 17.3 MATE.
Proc: intel I5 4440, Cm: Gigabyte GA-B85M-D3H, Alim: Corsair CX Bronze 430 W, Ram: Crucial Ballistix Sport, 2 x 2 Go.
SSD: 2.5 sandisk ultra+ 64 Go pour /+home, DD: Seagate Barracuda 500 Go pour mes données persos, DD maxtor 160 Go pour la sauvegarde ciblée via luckybackup.
Impr: HP Envy 4502.

Avatar du membre
Gerinald
Messages : 879
Enregistré le : dim. 22 janv. 2017 10:40
Localisation : Manage (Belgique)

Re: grub-efi n'a pas pu être installé. Nouvelle install sur disque neuf

Message par Gerinald » dim. 16 sept. 2018 17:18

Hello,

Je sait pas .... mais je te sent un brin ""moqueur" envers les personnes qui te répondent ....

Ici, on tente de t'aider, de ce côté, nous n'avons aucun souci ...

Ce que tu trouve sur le net concernant EFI / UEFI sont clair, limpide et très facilement compréhensible.

Nous te donnons aussi le lien d'un tutoriel d'installation de LinuxMint ... il serai quand même bien que tu le lise ...

Ou alors ... c'est comme ce que tu trouve sur EFI/UEFI, tu n'y trouve aucun intérêt ....

Lire un peu, et prendre soin des conseils que on te donne, serai déjà un bon point pour ton entrée dans Linux et sur ce forum :)
Distro : LM-19 Tara - Cinnamon 3.8.8 - Kernel 4.18.5-041805-generic
PC : AMD Athlon II X2 250 duo, CG : NVIDIA GT218 [GeForce 210] sur pilote "Nouveau", 4 Go de mémoire vive

lacaille
Messages : 8
Enregistré le : mer. 28 févr. 2018 09:48

Re: grub-efi n'a pas pu être installé. Nouvelle install sur disque neuf

Message par lacaille » dim. 16 sept. 2018 18:50

bonjour à tous,

Non, rien de moqueur. Je constate simplement que les réponses apportées à mon post "sont vagues" : tu parles de liens vers des réponses claires mais mais mais je ne les vois pas ?
Sur la liste des tutos du site, ici :
la recherche de la chaine "uefi" retourne zéro résultat, et enfin les posts du site sur uefi s'appliquent à des installations sur des ordis prééquipés d'un OS et je n'ai rien trouvé qui corresponde à ma situation (excuses moi mille pardons je ne les ai pas tous lus in extenso), et surtout qu'il y a bien plus de mots consacrés à contester la forme, que de mots consacrés à apporter une réponse constructive, ne serait-ce que de simples liens vers des choses instructives... ;) (relire mon post d'origine)

Je vous remercie donc humblement d'avoir pris la peine de vous pencher sur ma question, d'y apporter des réponse claires et précises, et de vous comporter comme une communauté accueillante et constructive.

Installation en legacy opérée manuellement par réinstallation de grub, cela fonctionne donc en mode démarrage à l'ancienne. Pour ce qui est du reste (les liens vers des explications très claires sur EFI/UEFi, etc) je chercherai ailleurs.

Bizoux merci bizoux :B
s'approprier les outils informatiques, que ce soit via le logiciel libre et gnu-linux, ou via du matériel libre et ouvert comme diskio pi (https://www.diskiopi.com/" onclick="window.open(this.href);return false;) est la seule solution pour éviter la catastrophe à très cour terme, tant en matière de liberté, qu'en matière de sauvegarde de notre vie privée

msi cr62-2M 264XFR core i7 5700HQ @2,7 Ghz, 8 G de ram, ssd 250 G sous linuxmint, debian, etc
autres machines de divers types, toutes sous debian et dérivées.

sandro
Messages : 37
Enregistré le : mer. 11 avr. 2018 15:37

Re: grub-efi n'a pas pu être installé. Nouvelle install sur disque neuf

Message par sandro » lun. 17 sept. 2018 11:54

lacaille a écrit : Je vous remercie donc humblement d'avoir pris la peine de vous pencher sur ma question, d'y apporter des réponse claires et précises, et de vous comporter comme une communauté accueillante et constructive. :B
je resent un peu la même chose ! mais c comme ça. et nous devons accepter les gens comme ils sont ou pas du tout !

pour ton UEFI je pense que tu te fourvois.
le mode LEGASY BIOS c'est pour installer sur de veille machine sans UEFI
UEFI remplace le BIOS depuis quelques années déjà !
Les PC moderne Y compris les pommes ont remplacé le BIOS par UEFI plus moderne et plus adapté aux PC moderne.
Le BIOS existe depuis les années 80 et a évolué au maxi des possibilité. (HDD limité à 2.1To rapiditée de démarage, prise en charge SSD SD eMMC USB en natif etc etc....)
https://fr.wikipedia.org/wiki/Unified_E ... _Interface
https://docs.oracle.com/cd/E50692_01/ht ... gnchj.html.
du coup depuis 2006 plus de BIOS remplacé par UEFI

et pour info ma machine sous Mint est en simple boot (pas de Windows)
sandro

Edit : as tu pencé a désactiver le "secure boot" ?
PC portable ASUS R700 sauvé d'une une poubelle.
Système Installé : Mint 18.3, cinnamon 3.6.7, Kermel : 4.15.0-34
Intel I5 3210M 2.50X2 RAM 6Go installé
1 SDD 120Go OCZ 1 HDD 1To samsung
CG NVIDIA GF 108 M [GeForce GT 630M]

lacaille
Messages : 8
Enregistré le : mer. 28 févr. 2018 09:48

Re: [RESOLU]grub-efi n'a pas pu être installé. Nouvelle install sur disque neuf

Message par lacaille » dim. 21 oct. 2018 17:48

Hello

Merci de ton message, oui bien entendu j'avais désactivé le secure boot. En fait il semblerait que le mode uefi soit verrouillé sur cette machine, et je n'ai pas trouvé comment contourner ça, par contre en utilisant le boot "legacy bios" (proposé en alternative dans le bios), aucun problème...

Merci pour les liens, infos claires et détaillées. J'avais déjà l'article lu sur le site de wikipédia, l'autre non... Toujours bon à lire !!!

A+
s'approprier les outils informatiques, que ce soit via le logiciel libre et gnu-linux, ou via du matériel libre et ouvert comme diskio pi (https://www.diskiopi.com/" onclick="window.open(this.href);return false;) est la seule solution pour éviter la catastrophe à très cour terme, tant en matière de liberté, qu'en matière de sauvegarde de notre vie privée

msi cr62-2M 264XFR core i7 5700HQ @2,7 Ghz, 8 G de ram, ssd 250 G sous linuxmint, debian, etc
autres machines de divers types, toutes sous debian et dérivées.

Répondre