Résolu le 19-04-19 Erreur de CPG avec sudo apt update

Assistance concernant Linux Mint
Bernie099
Messages : 5
Enregistré le : mer. 17 avr. 2019 03:49

Erreur de CPG avec sudo apt update

Message par Bernie099 » mer. 17 avr. 2019 04:46

Bonjour,

Problème avec les dépots....
Voici ma manip :

Code : Tout sélectionner

bernie@bernie-System-Product-Name:~$ sudo apt update
Et le retour :

Code : Tout sélectionner

Atteint :1 http://archive.ubuntu.mirror.rafal.ca/ubuntu bionic InRelease
Atteint :2 http://archive.canonical.com/ubuntu bionic InRelease                                                                                                                                                                              
Atteint :3 http://archive.ubuntu.mirror.rafal.ca/ubuntu bionic-updates InRelease                                                                                                                                                             
Ign :4 http://mirrors.evowise.com/linuxmint/packages tessa InRelease                                                                                                                                                                         
Atteint :5 http://archive.ubuntu.mirror.rafal.ca/ubuntu bionic-backports InRelease                                                                                                                                                           
Ign :6 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                                                                                
Atteint :7 https://repo.skype.com/deb stable InRelease                                                                                                                                                                                       
Atteint :8 http://mirrors.evowise.com/linuxmint/packages tessa Release                                                                                                                                                                       
Atteint :9 https://deb.opera.com/opera-stable stable InRelease                                                                                                                                                                               
Atteint :10 http://dl.google.com/linux/chrome/deb stable Release                                                                                                                                                                             
Atteint :11 http://repository.spotify.com stable InRelease                                                                                                                                                              
Ign :12 http://repo.vivaldi.com/stable/deb stable InRelease                                                                                                                                          
Atteint :13 http://repo.vivaldi.com/stable/deb stable Release                                                                                                      
Réception de :14 http://mirrors.ubuntu.com/mirrors.txt Mirrorlist [611 B]                                         
Réception de :17 http://mirror.cedille.club/ubuntu precise-backports InRelease [55,7 kB]        
Ign :15 http://ubuntu.ca-west.mirror.fullhost.io/ubuntu precise InRelease                                                                                            
Réception de :20 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]                                         
Réception de :16 http://mirror.it.ubc.ca/ubuntu precise-updates InRelease [55,7 kB]                                                                        
Ign :15 http://mirrors.layeronline.com/ubuntu precise InRelease                                        
Réception de :18 http://gpl.savoirfairelinux.net/pub/mirrors/ubuntu precise-security InRelease [55,7 kB]                                                     
Err :17 http://mirror.cedille.club/ubuntu precise-backports InRelease                                                                                        
  Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
Err :16 http://mirror.it.ubc.ca/ubuntu precise-updates InRelease
  Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
Err :18 http://gpl.savoirfairelinux.net/pub/mirrors/ubuntu precise-security InRelease
  Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
Ign :15 http://ubuntu.bhs.mirrors.ovh.net/ubuntu precise InRelease      
Ign :15 http://ubuntu.mirror.rafal.ca/ubuntu precise InRelease  
Ign :15 http://muug.ca/mirror/ubuntu precise InRelease
Ign :15 http://archive.ubuntu.mirror.rafal.ca/ubuntu precise InRelease
Ign :15 http://mirror.clibre.uqam.ca/ubuntu precise InRelease
Ign :15 http://ubuntu.mirror.iweb.ca precise InRelease   
Ign :15 http://gpl.savoirfairelinux.net/pub/mirrors/ubuntu precise InRelease
Ign :15 http://mirror.it.ubc.ca/ubuntu precise InRelease
Ign :15 http://mirror.csclub.uwaterloo.ca/ubuntu precise InRelease
Ign :15 http://ubuntu.mirror.globo.tech precise InRelease
Ign :15 http://mirror.cedille.club/ubuntu precise InRelease
Ign :15 http://mirror.its.sfu.ca/mirror/ubuntu precise InRelease
Ign :15 http://archive.ubuntu.com/ubuntu precise InRelease
Ign :15 http://mirror.its.dal.ca/ubuntu precise InRelease
Réception de :23 http://mirror.its.dal.ca/ubuntu precise Release [49,6 kB]
Réception de :24 http://mirror.its.dal.ca/ubuntu precise Release.gpg [198 B]
Ign :24 http://mirror.its.dal.ca/ubuntu precise Release.gpg
Lecture des listes de paquets... Fait
W: Erreur de GPG : http://mirror.cedille.club/ubuntu precise-backports InRelease : Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
E: Le dépôt mirror://mirrors.ubuntu.com/mirrors.txt precise-backports InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Erreur de GPG : http://mirror.it.ubc.ca/ubuntu precise-updates InRelease : Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
E: Le dépôt mirror://mirrors.ubuntu.com/mirrors.txt precise-updates InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Erreur de GPG : http://gpl.savoirfairelinux.net/pub/mirrors/ubuntu precise-security InRelease : Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
E: Le dépôt mirror://mirrors.ubuntu.com/mirrors.txt precise-security InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Erreur de GPG : http://mirror.its.dal.ca/ubuntu precise Release : Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
E: Le dépôt mirror://mirrors.ubuntu.com/mirrors.txt precise Release n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
bernie@bernie-System-Product-Name:~$ 
Qu'est ce qui provoque cette erreur de signature?
J'ai changé la source des dépots et toujours la même erreur.
Je me promène sur les forums mais je ne trouve pas de solution pour les signatures non valables.
Merci à l'avance.
Desktop
Linux Mint 19.1 Tessa Kernel: 4.15.0-47-generic x86_64
NVIDIA GK104 [GeForce GTX 670]
Western Digital model: WD1002FAEX-00Y9A0

Avatar du membre
alain
Messages : 5786
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Erreur de CPG avec sudo apt update

Message par alain » mer. 17 avr. 2019 05:06

Bonjour Bernie.

Il y a dépots "precise" dans ton sources.list. Je ne sais pas comment ils sont arrivé là, ce sont des dépots
d'une ancienne ubuntu plus supportée depuis très longtemps.
Donc on va nettoyer tout ça. Pour ce faire donnes nous les retours de:

Code : Tout sélectionner

ls /etc/apt/sources.list.d
et de:

Code : Tout sélectionner

cat /etc/apt/sources.list.d/official-package-repositories.list 
Avec ça nous devrions savoir quoi te dire...
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2018/09/ ... 8c173d.png

Bernie099
Messages : 5
Enregistré le : mer. 17 avr. 2019 03:49

Re: Erreur de CPG avec sudo apt update

Message par Bernie099 » mer. 17 avr. 2019 05:13

Bonjour,

Merci pour le support!
Voici pour la commande #1

Code : Tout sélectionner

bernie@bernie-System-Product-Name:~$ ls /etc/apt/sources.list.d
google-chrome.list  official-package-repositories.list  opera-stable.list  skype-stable.list  spotify.list  vivaldi.list
Et pour la 2 :

Code : Tout sélectionner

bernie@bernie-System-Product-Name:~$ cat /etc/apt/sources.list.d/official-package-repositories.list 
deb http://mirrors.evowise.com/linuxmint/packages tessa main upstream import backport 

deb http://archive.ubuntu.mirror.rafal.ca/ubuntu bionic main restricted universe multiverse
deb http://archive.ubuntu.mirror.rafal.ca/ubuntu bionic-updates main restricted universe multiverse
deb http://archive.ubuntu.mirror.rafal.ca/ubuntu bionic-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ bionic partner
bernie@bernie-System-Product-Name:~$ 
Thanx
Desktop
Linux Mint 19.1 Tessa Kernel: 4.15.0-47-generic x86_64
NVIDIA GK104 [GeForce GTX 670]
Western Digital model: WD1002FAEX-00Y9A0

Avatar du membre
alain
Messages : 5786
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Erreur de CPG avec sudo apt update

Message par alain » mer. 17 avr. 2019 05:51

Ton "official-package-repositories.list" est bon.
Cela vient donc d'un de tes dépôts additionnels.
Mais je ne vois pas du quel il s'agit (peut être que d'autres auront un meilleurs œil que le mien qui commence a fatigué en cette fin de nuit ;) ).
Nous allons donc éditer un par un tes dépôts additionnels:

Code : Tout sélectionner

cat /etc/apt/sources.list.d/google-chrome.list  

Code : Tout sélectionner

cat /etc/apt/sources.list.d/opera-stable.list

Code : Tout sélectionner

cat /etc/apt/sources.list.d/skype-stable.list

Code : Tout sélectionner

cat /etc/apt/sources.list.d/spotify.list
Et pendant qu'on y est, normalement ça ne peut être lui vu que vivaldi n'existait pas du temps de "precise". Mais comme on dit par chez nous:
"ça ne mange pas de pain" :l (remplace "pain" par "poutine" si tu veux :l :D )

Code : Tout sélectionner

cat /etc/apt/sources.list.d/vivaldi.list
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2018/09/ ... 8c173d.png

Bernie099
Messages : 5
Enregistré le : mer. 17 avr. 2019 03:49

Re: Erreur de CPG avec sudo apt update

Message par Bernie099 » mer. 17 avr. 2019 23:52

Bonjour,

J'espère que le repos a été bon!

Voici la 1ere commande :

Code : Tout sélectionner

bernie@bernie-System-Product-Name:~$ cat /etc/apt/sources.list.d/google-chrome.list  
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
bernie@bernie-System-Product-Name:~$ 
la 2e :

Code : Tout sélectionner

bernie@bernie-System-Product-Name:~$ cat /etc/apt/sources.list.d/opera-stable.list
# This file makes sure that Opera Browser is kept up-to-date
# as part of regular system upgrades

deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
bernie@bernie-System-Product-Name:~$ 
la 3e :

Code : Tout sélectionner

cat /etc/apt/sources.list.d/opera-stable.list
# This file makes sure that Opera Browser is kept up-to-date
# as part of regular system upgrades

deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
4e :

Code : Tout sélectionner

bernie@bernie-System-Product-Name:~$ cat /etc/apt/sources.list.d/spotify.list
deb http://repository.spotify.com stable non-free
bernie@bernie-System-Product-Name:~$ 
et pour la poutine :

Code : Tout sélectionner

bernie@bernie-System-Product-Name:~$ cat /etc/apt/sources.list.d/vivaldi.list
### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://repo.vivaldi.com/stable/deb/ stable main
bernie@bernie-System-Product-Name:~$ 
Voilà!
Qu'est ce qui indique qu'il y a un problème?

Merci pour le support.
Desktop
Linux Mint 19.1 Tessa Kernel: 4.15.0-47-generic x86_64
NVIDIA GK104 [GeForce GTX 670]
Western Digital model: WD1002FAEX-00Y9A0

Avatar du membre
alain
Messages : 5786
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Erreur de CPG avec sudo apt update

Message par alain » jeu. 18 avr. 2019 02:33

Bonjour Bernie.

Oui le repos a été bon, merci ;)
Bernie099 a écrit :
mer. 17 avr. 2019 23:52
Qu'est ce qui indique qu'il y a un problème?
Rien ! Je ne vois aucun problème :? C'est ça le problème :l
Nul part je ne vois de référence aux dépôts "precise" pourtant dans ton retour de "update", il est bien scanné...

Code : Tout sélectionner

Réception de :17 http://mirror.cedille.club/ubuntu precise-backports InRelease [55,7 kB]        
Ign :15 http://ubuntu.ca-west.mirror.fullhost.io/ubuntu precise InRelease
et:
Err :17 http://mirror.cedille.club/ubuntu precise-backports InRelease                                                                                        
  Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
Err :16 http://mirror.it.ubc.ca/ubuntu precise-updates InRelease
  Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
Err :18 http://gpl.savoirfairelinux.net/pub/mirrors/ubuntu precise-security InRelease
  Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
Ign :15 http://ubuntu.bhs.mirrors.ovh.net/ubuntu precise InRelease      
Ign :15 http://ubuntu.mirror.rafal.ca/ubuntu precise InRelease  
Ign :15 http://muug.ca/mirror/ubuntu precise InRelease
Ign :15 http://archive.ubuntu.mirror.rafal.ca/ubuntu precise InRelease
Ign :15 http://mirror.clibre.uqam.ca/ubuntu precise InRelease
Ign :15 http://ubuntu.mirror.iweb.ca precise InRelease   
Ign :15 http://gpl.savoirfairelinux.net/pub/mirrors/ubuntu precise InRelease
Ign :15 http://mirror.it.ubc.ca/ubuntu precise InRelease
Ign :15 http://mirror.csclub.uwaterloo.ca/ubuntu precise InRelease
Ign :15 http://ubuntu.mirror.globo.tech precise InRelease
Ign :15 http://mirror.cedille.club/ubuntu precise InRelease
Ign :15 http://mirror.its.sfu.ca/mirror/ubuntu precise InRelease
Ign :15 http://archive.ubuntu.com/ubuntu precise InRelease
Ign :15 http://mirror.its.dal.ca/ubuntu precise InRelease
Réception de :23 http://mirror.its.dal.ca/ubuntu precise Release [49,6 kB]
Réception de :24 http://mirror.its.dal.ca/ubuntu precise Release.gpg [198 B]
Ign :24 http://mirror.its.dal.ca/ubuntu precise Release.gpg
Lecture des listes de paquets... Fait
W: Erreur de GPG : http://mirror.cedille.club/ubuntu precise-backports InRelease : Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
E: Le dépôt mirror://mirrors.ubuntu.com/mirrors.txt precise-backports InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Erreur de GPG : http://mirror.it.ubc.ca/ubuntu precise-updates InRelease : Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
E: Le dépôt mirror://mirrors.ubuntu.com/mirrors.txt precise-updates InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Erreur de GPG : http://gpl.savoirfairelinux.net/pub/mirrors/ubuntu precise-security InRelease : Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
E: Le dépôt mirror://mirrors.ubuntu.com/mirrors.txt precise-security InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
W: Erreur de GPG : http://mirror.its.dal.ca/ubuntu precise Release : Les signatures suivantes ne sont pas valables : 630239CC130E1A7FD81A27B140976EAF437D05B5
E: Le dépôt mirror://mirrors.ubuntu.com/mirrors.txt precise Release n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
Je ne rêve pas (quoique... :l )
Ça vient bien de quelque part... Oui mais d'où? seul toi le sait.

Bon on va essayer des choses:
Tu vas ouvrir "mintupdate" (le bouclier dans le tableau de bord).
Puis tu fais comme sur l'image.
1) edition ===>source de logiciles
2) maintenance
3) résoudre les problèmes de MergeLlist
4) purger la configuration résiduelle
5) recharger le cache.
Image

Ensuite tu fermes "mintupdate" et tu refais un

Code : Tout sélectionner

sudo apt update
Si tu n'as plus de défaut, tant mieux...
Si c'est pareil la dernière chose que je vois c'est de faire:

Code : Tout sélectionner

sudo apt-get clean 
puis re:

Code : Tout sélectionner

sudo apt update
J'espère que ça sera bon, parce que sinon, je ne vois pas autre chose :?

[edit] Je viens de voir que dans tes retours, il manque skype. Il y a deux fois opera, mais pas skype.... c'est la dernière chance :l [/edit]
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2018/09/ ... 8c173d.png

Avatar du membre
f.x0
Messages : 286
Enregistré le : mar. 28 mars 2017 18:32

Re: Erreur de CPG avec sudo apt update

Message par f.x0 » jeu. 18 avr. 2019 15:40

Bonjour,

si cela ne fonctionne toujours pas
postes le retour ENTIER de

Code : Tout sélectionner

find /etc/apt -type f -name '*.list' -exec bash -c 'echo -e "\n$1\n"; nl -ba "$1"' _ '{}' \;
SOPI

Avatar du membre
alain
Messages : 5786
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Erreur de CPG avec sudo apt update

Message par alain » ven. 19 avr. 2019 01:15

Super ta ligne de commandes f.x0 !
Je te la pique à défaut de bien la comprendre... :l
Comme les problèmes de sources sont récurrents, tu permets que je l'utilise ?
Elle est bien sous licence GNU GPL? :D
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2018/09/ ... 8c173d.png

Avatar du membre
tyrry
Messages : 4438
Enregistré le : mar. 21 juil. 2015 07:42
Localisation : à l'ouest

Re: Erreur de CPG avec sudo apt update

Message par tyrry » ven. 19 avr. 2019 12:37

Slt ,
en fait il y a erreur de dépôts ajouter :
tu es sous mint 19.x = base ubuntu 18.04 bionic
tu as ajouter des dépôts "precise" = ubuntu 12.04 precise = mint 17.x
du coup tu as ajouter des dépôts ou "PPA" non compatible avec ta version , d'ou l'erreur des clés gpg ;)
En bref , il faut que tu effaces les dépôts ou "PPA" , "precise"
ensuite un sudo apt update te remettra cela en ordre ;)
@+
Desktop: XFCE (Gtk 2.24.32) (Gtk 3.22.30) Distro: Mint 19.1 (Tessa)
Kernel: 4.15.0-46-generic x86_64 SSD:Samsung_SSD_860 evo
CPU: Intel Core i3-2130 RAM: -8 go Graphics Card: Intel 2nd Gen Core Proc Sandybridge

Bernie099
Messages : 5
Enregistré le : mer. 17 avr. 2019 03:49

Re: Erreur de CPG avec sudo apt update

Message par Bernie099 » ven. 19 avr. 2019 15:42

Bonjour/Bonsoir les amis

Merci pour les solutions proposées.
J'ai tenté de résoudre mon problème avec vos solutions et finalement le conseil de tyrry a fonctionné.
J'ai décoché les PPA qui portaient la mention precise.

Image

Tout semble avoir rentré dans l'ordre,
Est-ce que je peux les supprimer sans créer d'autres problèmes?
Merci
Desktop
Linux Mint 19.1 Tessa Kernel: 4.15.0-47-generic x86_64
NVIDIA GK104 [GeForce GTX 670]
Western Digital model: WD1002FAEX-00Y9A0

Répondre