Résolu le 30-06-20 Detected version of Boost is too old

Postez ici toutes vos demandes d’assistance.
Répondre
vlad1138
Messages : 5
Enregistré le : jeu. 25 juin 2020 20:18

Detected version of Boost is too old

Message par vlad1138 »

Bonjour,

Je viens d'installer Mint sur un ordi principalement pour faire de l'audionumérique, j'essaye actuellement d'installer un séquenceur mais je rencontre un problème pour poursuivre l'installation, on me dit que la version du boost est trop vieille mais je ne sais pas vraiement ce que c'est... J'ai pas mal cherché sur le net mais il n'y a pas de solution unique et je préfère éviter d'en tenter une au hasard. C'est pour ça que je viens demander à la communauté si quelqu'un aurait un piste pour résoudre ça.
Voici le lien avec les commandes pour build le sequenceur : https://harmonyseq.wordpress.com/downlo ... tructions/
Voilà les résultats de la commande :

Code : Tout sélectionner

mkdir build && cd build
cmake -DCMAKE_BUILD_TYPE=Release ..
CMake Error at /usr/share/cmake-3.10/Modules/FindBoost.cmake:1947 (message):
  Unable to find the requested Boost libraries.

  Boost version: 1.65.1

  Boost include path: /usr/include

  Detected version of Boost is too old.  Requested version was 1.67 (or
  newer).
Call Stack (most recent call first):
  src/CMakeLists.txt:11 (find_package)


-- Release mode
-- Configuring incomplete, errors occurred!
See also "/home/dennis/Téléchargements/harmonySEQ-0.17/build/CMakeFiles/CMakeOutput.log".
See also "/home/dennis/Téléchargements/harmonySEQ-0.17/build/CMakeFiles/CMakeError.log".
Merci d'avance
Modifié en dernier par vlad1138 le mar. 30 juin 2020 11:11, modifié 2 fois.
PC : Toshiba Satellite-A660 | Linux Mint 19.3 Tricia | Cinnamon 4.4.5 | 5.0.0-32-generic x86_64| Quad Core Intel Core i7 Q 720 | 4 GiB RAM | NVIDIA GT216M [GeForce GT 330M]

Avatar du membre
cyrille
Messages : 4834
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Detected version of Boost is too old

Message par cyrille »

Pas de mint sous la main, mais ce doit etre kif kif
Mais à mon avis il te parle de la lib "boost" pour l'environnement de déveppement.
Installe le paquet -dev si tu veut compiler
Sous mint , tu auras sans douote une version plus récente qu'ici sous debian stable

Code : Tout sélectionner

serveurProliant@~# aptitude show libboost-all-dev
Paquet : libboost-all-dev
Version : 1.62.0.1
État: installé
Automatiquement installé: non
Priorité : optionnel
Section : libdevel
Responsable : Debian Boost Team <pkg-boost-devel@lists.alioth.debian.org>
Architecture : amd64
Taille décompressée : 10,2 k
Dépend: libboost-dev, libboost-tools-dev, libboost-atomic-dev, libboost-chrono-dev, libboost-context-dev, libboost-coroutine-dev, libboost-date-time-dev, libboost-exception-dev, libboost-fiber-dev, libboost-filesystem-dev,
        libboost-graph-dev, libboost-graph-parallel-dev, libboost-iostreams-dev, libboost-locale-dev, libboost-log-dev, libboost-math-dev, libboost-mpi-dev, libboost-mpi-python-dev, libboost-program-options-dev, libboost-python-dev,
        libboost-random-dev, libboost-regex-dev, libboost-serialization-dev, libboost-signals-dev, libboost-system-dev, libboost-test-dev, libboost-thread-dev, libboost-timer-dev, libboost-type-erasure-dev, libboost-wave-dev
Est en conflit: libboost-all-dev:i386
Description : Boost C++ Libraries development files (ALL) (default version)
 The Boost web site provides free, peer-reviewed, portable C++ source libraries. The emphasis is on libraries which work well with the C++ Standard Library. One goal is to establish "existing practice" and provide reference
 implementations so that the Boost libraries are suitable for eventual standardization. Some of the libraries have already been proposed for inclusion in the C++ Standards Committee's upcoming C++ Standard Library Technical Report.

 This metapackage provides the complete Boost development environment, including all separately-packaged libraries.

 This package is a dependency package, which depends on Debian's default Boost version (currently 1.62).
Site : http://www.boost.org/
Étiquettes: devel::library, role::metapackage
# Laptops DELL Latitude : FreeBSD 12.1 xfce / Openbox ; DEBIAN SID xfce / Fluxbox # Work : parc de laptop Mint 18.3 xfce
# VPS : 1 vCore 2 GHz , SSD, RAM 4Go, Local RAID, DEBIAN OLDSTABLE # Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE
[ GIT : https://github.com/CyrilleBiot | Site : https://cbiot.fr ]

Avatar du membre
cyrille
Messages : 4834
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Detected version of Boost is too old

Message par cyrille »

Musicien aussi, j'ai parcouru vite fait ton lien, il semble que dans ton cas, le paquet en question est :

Code : Tout sélectionner

 libboost-signals-dev
# Laptops DELL Latitude : FreeBSD 12.1 xfce / Openbox ; DEBIAN SID xfce / Fluxbox # Work : parc de laptop Mint 18.3 xfce
# VPS : 1 vCore 2 GHz , SSD, RAM 4Go, Local RAID, DEBIAN OLDSTABLE # Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE
[ GIT : https://github.com/CyrilleBiot | Site : https://cbiot.fr ]

vlad1138
Messages : 5
Enregistré le : jeu. 25 juin 2020 20:18

Re: Detected version of Boost is too old

Message par vlad1138 »

Merci de ta réponse Cyrille, en fait j'ai déjà installé ce paquet puisque d'après les instructions il était nécessaire pour la compilation. Du coup j'ai tenté d'installé toute la librairie boost, j'espère que ça n'est pas une bêtise...en tout cas ça n'a rien changé, j'ai toujours le même message. Donc même pour la librairie entière j'ai la version 1.65.1, j'ai tenté un apt-get update mais ça n'a pas fonctionné ( on ne sait jamais :mrgreen: ), voilà le résultat de la commande aptitude :

Code : Tout sélectionner

aptitude show libboost-all-dev
Paquet : libboost-all-dev                               
Version : 1.65.1.0ubuntu1
État: installé
Automatiquement installé: non
Priorité : optionnel
Section : universe/libdevel
Responsable : Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture : amd64
Taille décompressée : 10,2 k
Dépend: libboost-dev, libboost-tools-dev, libboost-atomic-dev,
        libboost-chrono-dev, libboost-container-dev, libboost-context-dev,
        libboost-coroutine-dev, libboost-date-time-dev, libboost-exception-dev,
        libboost-fiber-dev, libboost-filesystem-dev, libboost-graph-dev,
        libboost-graph-parallel-dev, libboost-iostreams-dev,
        libboost-locale-dev, libboost-log-dev, libboost-math-dev,
        libboost-mpi-dev, libboost-mpi-python-dev, libboost-numpy-dev,
        libboost-program-options-dev, libboost-python-dev, libboost-random-dev,
        libboost-regex-dev, libboost-serialization-dev, libboost-signals-dev,
        libboost-stacktrace-dev, libboost-system-dev, libboost-test-dev,
        libboost-thread-dev, libboost-timer-dev, libboost-type-erasure-dev,
        libboost-wave-dev
Est en conflit: libboost-all-dev:i386
Description : Boost C++ Libraries development files (ALL) (default version)
 The Boost web site provides free, peer-reviewed, portable C++ source libraries.
 The emphasis is on libraries which work well with the C++ Standard Library. One
 goal is to establish "existing practice" and provide reference implementations
 so that the Boost libraries are suitable for eventual standardization. Some of
 the libraries have already been proposed for inclusion in the C++ Standards
 Committee's upcoming C++ Standard Library Technical Report. 
 
 This metapackage provides the complete Boost development environment, including
 all separately-packaged libraries. 
 
 This package is a dependency package, which depends on Debian's default Boost
 version (currently 1.65).
Site : http://www.boost.org/
PC : Toshiba Satellite-A660 | Linux Mint 19.3 Tricia | Cinnamon 4.4.5 | 5.0.0-32-generic x86_64| Quad Core Intel Core i7 Q 720 | 4 GiB RAM | NVIDIA GT216M [GeForce GT 330M]

Avatar du membre
cyrille
Messages : 4834
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Detected version of Boost is too old

Message par cyrille »

Non t'inquiète pas de risque si tu as installé libboost ;)

Le hic c'est que la version que tu recherches est très récente en 1.67
Dispo sous ubuntu 19 (eoan)
https://packages.ubuntu.com/eoan/libboost-signals-dev

Sous debian, seulement en testing pour ta version (1.67)
https://packages.debian.org/buster/libboost-signals-dev

Mais pas encore sous arch amd64 sous la SID

Donc, pas 10 000 solutions, essayer d'installer le paquet en version demandée à la main, mais ça peut passer tout seul ou être chaud au niveau des dépendances...

Sinon installer Mint 20 qui est basée sur ubuntu 19

Ou trouver un backport ou un ppa avec les desavantages que ça implique. Perso je regarderai si il n'y a pas moyen de compiler soi même.
Reste ensuite le faux lien symbolique de la version souhaitée vers celle installée, mais s'il demande une version mini précise, je doute que ça passe
# Laptops DELL Latitude : FreeBSD 12.1 xfce / Openbox ; DEBIAN SID xfce / Fluxbox # Work : parc de laptop Mint 18.3 xfce
# VPS : 1 vCore 2 GHz , SSD, RAM 4Go, Local RAID, DEBIAN OLDSTABLE # Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE
[ GIT : https://github.com/CyrilleBiot | Site : https://cbiot.fr ]

Avatar du membre
cyrille
Messages : 4834
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Detected version of Boost is too old

Message par cyrille »

Au fait as tu testé le paquet .deb mis à dispo sur leur site ?
https://harmonyseq.wordpress.com/downloads/
https://github.com/rafalcieslak/harmony ... -Linux.deb
?
# Laptops DELL Latitude : FreeBSD 12.1 xfce / Openbox ; DEBIAN SID xfce / Fluxbox # Work : parc de laptop Mint 18.3 xfce
# VPS : 1 vCore 2 GHz , SSD, RAM 4Go, Local RAID, DEBIAN OLDSTABLE # Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE
[ GIT : https://github.com/CyrilleBiot | Site : https://cbiot.fr ]

vlad1138
Messages : 5
Enregistré le : jeu. 25 juin 2020 20:18

Re: Detected version of Boost is too old

Message par vlad1138 »

En effet je ne sais même pas pourquoi je n'ai pas essayé ça d'abord, mais ça a fonctionné :D ...parfois on préfère se compliquer la tâche c'est dingue. Bon on aura pas résolu le problème de la version de boost pour l'autre procédure mais le séquenceur est opérationnel !
Merci Cyrille pour ton aide et désolé d'avoir créé un sujet pour si peu.
PC : Toshiba Satellite-A660 | Linux Mint 19.3 Tricia | Cinnamon 4.4.5 | 5.0.0-32-generic x86_64| Quad Core Intel Core i7 Q 720 | 4 GiB RAM | NVIDIA GT216M [GeForce GT 330M]

Avatar du membre
cyrille
Messages : 4834
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Detected version of Boost is too old

Message par cyrille »

La compilation passe avec les bonnes libraires (je l'ai tentée tenté hier depuis ma SID par du pinning sur la testing)
Mais si un deb est déjà présent, autant l'utiliser ;)
Ensuite on apprend plein de choses en compilant ses paquets

Mais attention : mettre à jour un paquet compilé n'est pas toujours aisé, la mise à jour à jour d'un .deb et plus simple
C'est pour cela qu'il faut après compilation créer ses propres paquets au format debian, bien plus simples à maintenir (via debuild (debuild -us -uc))
# Laptops DELL Latitude : FreeBSD 12.1 xfce / Openbox ; DEBIAN SID xfce / Fluxbox # Work : parc de laptop Mint 18.3 xfce
# VPS : 1 vCore 2 GHz , SSD, RAM 4Go, Local RAID, DEBIAN OLDSTABLE # Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE
[ GIT : https://github.com/CyrilleBiot | Site : https://cbiot.fr ]

Avatar du membre
serged
Messages : 226
Enregistré le : jeu. 16 juil. 2015 07:59
Localisation : Montrouge (France)

Re: Detected version of Boost is too old

Message par serged »

cyrille a écrit :
lun. 29 juin 2020 16:40
Pas de mint sous la main, mais ce doit etre kif kif
Mais à mon avis il te parle de la lib "boost" pour l'environnement de déveppement.
Installe le paquet -dev si tu veut compiler
Sous mint , tu auras sans douote une version plus récente qu'ici sous debian stable
Bah non ! Chez moi (LM 19.3) les libboost sont au maxi 1.65 !
LinuxMint Tricia Cinnamon 64 bits et d'autres machines en MATE

Avatar du membre
cyrille
Messages : 4834
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Detected version of Boost is too old

Message par cyrille »

@serged oui je précise ensuite qu'il faut une mint 20, debian testing ou une base ubuntu 19 (désolé j'étais au taf et pas trop le temps...)
# Laptops DELL Latitude : FreeBSD 12.1 xfce / Openbox ; DEBIAN SID xfce / Fluxbox # Work : parc de laptop Mint 18.3 xfce
# VPS : 1 vCore 2 GHz , SSD, RAM 4Go, Local RAID, DEBIAN OLDSTABLE # Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE
[ GIT : https://github.com/CyrilleBiot | Site : https://cbiot.fr ]

Répondre