histoires de paquets cassés

Postez ici toutes vos demandes d’assistance.
Noobix
Messages : 7
Enregistré le : dim. 21 févr. 2021 09:51

Re: histoires de paquets cassés

Message par Noobix »

Dernier message de la page précédente :

Alors, me revoilou!
Les paquets cassés sont toujours bien là
J'ai écouté que l'ordinateur de bord de Perseverance était équipé d'un Linux, pour aller aussi loin il doit être fiable donc j'ai plein d'espoir dans la résolution de mon petit problème terrien! :D


sudo apt install --fix-broken

Code : Tout sélectionner

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  firewalld libclass-data-inheritable-perl libcrypt-openssl-bignum-perl
  libcrypt-openssl-rsa-perl libdata-random-perl libdbus-glib1.0-cil libdbus1.0-cil
  libfile-which-perl libgdata2.1-cil libgkeyfile1.0-cil libgnome2-canvas-perl
  libgnome2-gconf-perl libgnome2-perl libgnome2-vfs-perl libgnome2-wnck-perl
  libgtk-sharp-beans-cil libgtk2-imageview-perl libgtk2-unique-perl libgtkimageview0
  libgudev1.0-cil libhttp-server-simple-perl libjson-perl libllvm8:i386 libmono-data-tds4.0-cil
  libmono-system-data4.0-cil libmono-system-enterpriseservices4.0-cil
  libmono-system-numerics4.0-cil libmono-system-runtime-serialization4.0-cil
  libmono-system-servicemodel-internals0.0-cil libmono-system-transactions4.0-cil
  libmono-system-xml-linq4.0-cil libmono-zeroconf1.0-cil libmouse-perl libnet-dropbox-api-perl
  libnet-oauth-perl libnewtonsoft-json5.0-cil libnotify0.4-cil libpath-class-perl libphonon4
  libproc-processtable-perl libproc-simple-perl libqt4-dbus libqt4-declarative libqt4-network
  libqt4-opengl libqt4-script libqt4-sql libqt4-sql-sqlite libqt4-xml libqt4-xmlpatterns
  libqtcore4 libqtdbus4 libqtgui4 libsort-naturally-perl libtaglib2.1-cil libwnck-common
  libwnck22 libwww-mechanize-perl libx11-protocol-other-perl phonon phonon-backend-gstreamer
  phonon-backend-gstreamer-common python3-decorator python3-selinux python3-slip
  python3-slip-dbus qdbus qtchooser qtcore4-l10n
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  libreoffice-common
Les NOUVEAUX paquets suivants seront installés :
  libreoffice-common
0 mis à jour, 1 nouvellement installés, 0 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 0 o/24,7 Mo dans les archives.
Après cette opération, 79,2 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 360820 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libreoffice-common_1%3a6.0.7-0ubuntu0.18.04.10_all.deb ...
Dépaquetage de libreoffice-common (1:6.0.7-0ubuntu0.18.04.10) ...
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libreoffice-common_1%3a6.0.7-0ubuntu0.18.04.10_all.deb (--unpack) :
 tentative de remplacement de « /usr/bin/soffice », qui appartient aussi au paquet openoffice-debian-menus 4.1.6-9790
rmdir: impossible de supprimer '/var/lib/libreoffice/share/prereg/': Aucun fichier ou dossier de ce type
rmdir: impossible de supprimer '/var/lib/libreoffice/share/': Aucun fichier ou dossier de ce type
rmdir: impossible de supprimer '/var/lib/libreoffice/program/': Aucun fichier ou dossier de ce type
rmdir: impossible de supprimer '/var/lib/libreoffice': Aucun fichier ou dossier de ce type
rmdir: impossible de supprimer '/var/lib/libreoffice': Aucun fichier ou dossier de ce type
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libreoffice-common_1%3a6.0.7-0ubuntu0.18.04.10_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo apt update

Code : Tout sélectionner

Réception de :1 http://ubuntu.mirrors.ovh.net/ubuntu bionic InRelease [242 kB]
Réception de :2 http://ubuntu.mirrors.ovh.net/ubuntu bionic-updates InRelease [88,7 kB]          
Réception de :3 http://ubuntu.mirrors.ovh.net/ubuntu bionic-backports InRelease [74,6 kB]        
Ign :4 http://mirror6.layerjet.com/linuxmint/packages tina InRelease                             
Atteint :5 http://mirror6.layerjet.com/linuxmint/packages tina Release                           
Réception de :6 http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu bionic InRelease [20,8 kB]
Atteint :7 https://repo.skype.com/deb stable InRelease                                           
Atteint :8 http://archive.canonical.com/ubuntu bionic InRelease                                  
Réception de :9 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]           
Réception de :10 http://ubuntu.mirrors.ovh.net/ubuntu bionic-updates/main amd64 Packages [1 885 kB]
Réception de :11 http://ubuntu.mirrors.ovh.net/ubuntu bionic-updates/main i386 Packages [1 221 kB]
Réception de :13 http://ubuntu.mirrors.ovh.net/ubuntu bionic-updates/main amd64 DEP-11 Metadata [295 kB]
Réception de :14 http://ubuntu.mirrors.ovh.net/ubuntu bionic-updates/universe i386 Packages [1 561 kB]
Réception de :15 http://ubuntu.mirrors.ovh.net/ubuntu bionic-updates/universe amd64 Packages [1 718 kB]
Réception de :16 http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu bionic/main amd64 Packages [13,2 kB]
Réception de :17 http://ubuntu.mirrors.ovh.net/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [289 kB]
Réception de :18 http://ubuntu.mirrors.ovh.net/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2 464 B]
Réception de :19 http://ubuntu.mirrors.ovh.net/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [9 288 B]
Réception de :20 http://security.ubuntu.com/ubuntu bionic-security/main i386 Packages [916 kB]
Réception de :21 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages [1 545 kB]
Réception de :22 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [49,0 kB]
Réception de :23 http://security.ubuntu.com/ubuntu bionic-security/universe i386 Packages [975 kB]
Réception de :24 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 Packages [1 109 kB]
Réception de :25 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [59,7 kB]
Réception de :26 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2 464 B]
12,2 Mo réceptionnés en 4s (2 728 ko/s)                                    
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
16 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.

sudo apt upgrade

Code : Tout sélectionner

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libreoffice-core : Dépend: libreoffice-common (> 1:6.0.7) mais il n'est pas installé
 libreoffice-style-galaxy : Dépend: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.10) mais il n'est pas installé
 libreoffice-style-tango : Dépend: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.10) mais il n'est pas installé
 libreofficekit-data : Dépend: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.10) mais il n'est pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
Portable : Linux Mint 19.2 Tina 64-bit Noyau Linux 4.15.0-54-generic x86_64 MATE 1.22.0
Intel® Core™ i3 CPU M 350 @ 2.27GHz × 4 Mémoire 3,7 Gio
Modele portable Aspire 7741G

falke
Messages : 67
Enregistré le : mar. 3 oct. 2017 21:28

Re: histoires de paquets cassés

Message par falke »

salut,

j'ai l'impression que c'est le serpent qui se mord la queue :
libreoffice-core : Dépend: libreoffice-common (> 1:6.0.7) mais il n'est pas installé
libreoffice-style-galaxy : Dépend: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.10) mais il n'est pas installé
libreoffice-style-tango : Dépend: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.10) mais il n'est pas installé
libreofficekit-data : Dépend: libreoffice-common (= 1:6.0.7-0ubuntu0.18.04.10) mais il n'est pas installé
c'est une dépendance cyclique comme on dit sous Arch , un paquet flagué dépendant d'un autre qui n'est pas installé. a

A priori, les autres membre intervenu sur ton post confirmeront ou pas , que pour résoudre le problème il faudrait ,

d'abord enlever ces quatre paquets en gras, puis réinstaller le paquett libreoffice-common (ou pas) si c'est celui là que tu voulais installer

apt --purge <nompaquet>
...
....
puis
apt install libreoffice-common

falke
System:
Host: falke-MacBookAir Kernel: 5.4.0-65-generic x86_64 bits: 64
Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 Ulyssa
Machine:
Type: Laptop System: Apple product: MacBookAir7,2 v: 1.0

Avatar du membre
arghlub
Administrateur du site
Messages : 9078
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: histoires de paquets cassés

Message par arghlub »

Salut,
falke a écrit :
mar. 23 févr. 2021 18:54
d'abord enlever ces quatre paquets en gras, puis réinstaller le paquett libreoffice-common (ou pas) si c'est celui là que tu voulais installer
et réparer les dépendances qui pourraient être cassées :

Code : Tout sélectionner

sudo apt install -f
@Mia : Les paquets en ppa sont à proscrire si l'on peut les éviter et les .deb provenant de nulle part aussi.

Pour connaitre la version d'un paquet qui est dans les dépots :

Code : Tout sélectionner

apt policy Nom_Paquet
exemple avec Gimp qui est présent dans les dépôts :

Code : Tout sélectionner

⌚21:22:48 ▶ arghlub@msiDragon-LM20xfce ▷ ~
$ apt policy gimp
gimp:
  Installé : 2.10.18-1
  Candidat : 2.10.18-1
 Table de version :
 *** 2.10.18-1 500
        500 http://mirrors.ircam.fr/pub/ubuntu/archive focal/universe amd64 Packages
        100 /var/lib/dpkg/status
⌚21:23:56 ▶ arghlub@msiDragon-LM20xfce ▷ ~

autre exemple avec un ppa, on voit que la source n'est pas la même, c'est un ppa et on voit que je ne l'ai pas installé :

Code : Tout sélectionner

⌚21:24:51 ▶ arghlub@msiDragon-LM20xfce ▷ ~
$ apt policy woeusb
woeusb:
  Installé : (aucun)
  Candidat : 3.3.1-2~lmdetr
 Table de version :
     3.3.1-2~lmdetr 500
        500 http://ppa.launchpad.net/linuxmint-tr/araclar/ubuntu focal/main amd64 Packages
⌚21:25:11 ▶ arghlub@msiDragon-LM20xfce ▷ ~
Tour1 (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.3 | XFCE
Tour2 (custom)CM Gigabyte | CPU AMD Athlon 5200+ | CG Nvidia GTX 560 | RAM 6Go | FreeBSD 12.1 | XFCE
Portable1 MSI GF75 Thin 9SC | CPU Intel I7-9750H | CG Nvidia GTX 1650 | RAM 32Go | LMint 20.1 | XFCE
Portable2 Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot : LMint 18.3 | MXlinux 19 | LMint 19.3 | XFCE
─────( pour une informatique libre ! -membre de l' April.org )────────────────

falke
Messages : 67
Enregistré le : mar. 3 oct. 2017 21:28

Re: histoires de paquets cassés

Message par falke »

@arglub

Code : Tout sélectionner

@Mia : Les paquets apt sont à proscrire si l'on peut et les .deb provenant de nulle part aussi.
tu veux pas dire plutôt les dépôts ppa ?
System:
Host: falke-MacBookAir Kernel: 5.4.0-65-generic x86_64 bits: 64
Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 Ulyssa
Machine:
Type: Laptop System: Apple product: MacBookAir7,2 v: 1.0

Avatar du membre
arghlub
Administrateur du site
Messages : 9078
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: histoires de paquets cassés

Message par arghlub »

@fake : oui me suis trompé (tapé trop vite, quand on est virtuose du clavier des fois ça dérape :roll: :D )
j'ai corrigé dans la minute qui a suivie ......
laisse moi respirer :l :l :lol: ;)

------------------
@fake : vu que tu "t'attaques" au chef, je voudrais juste te signaler de ne pas confondre les balises "code" et les balises "quote" :l :l :l

-----------------
@fake : et vu que tu as zappé une lettre de mon pseudo (le "h" c'est primordial), je me permets de faire pareil et de t'appeler "fake" :l
je rigole évidemment ;)
Tour1 (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.3 | XFCE
Tour2 (custom)CM Gigabyte | CPU AMD Athlon 5200+ | CG Nvidia GTX 560 | RAM 6Go | FreeBSD 12.1 | XFCE
Portable1 MSI GF75 Thin 9SC | CPU Intel I7-9750H | CG Nvidia GTX 1650 | RAM 32Go | LMint 20.1 | XFCE
Portable2 Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot : LMint 18.3 | MXlinux 19 | LMint 19.3 | XFCE
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Avatar du membre
Mia88
Messages : 1107
Enregistré le : ven. 18 nov. 2016 08:42
Localisation : Lorraine

Re: histoires de paquets cassés

Message par Mia88 »

Salut arghlub,
arghlub a écrit :
mar. 23 févr. 2021 21:26
@Mia : Les paquets en ppa sont à proscrire si l'on peut les éviter et les .deb provenant de nulle part aussi.
Je sais bien, mais pourquoi tu me dis cela ici, je ne suis à aucun moment intervenue dans ce sujet :l :lol: :B
Je n'ai qu'un dépôt additionnel pour Multisystem, pas de PPA, et les .deb pour Shutter.
Je ne surcharge pas pour éviter les galères lors des changements de version.
En tout cas merci pour tes explications.
PC 1 - Mint Cinnamon 19.3 64-bits / Intel Xeon CPU E3-1270 V2 3.5GHz x 4 / Ram 15.6 Go / CG NVIDIA GF106GL [Quaro 2000]
Une partition dédiée aux machines virtuelles
PC 2 - Mint Cinnamon 18.3 64 bits / Intel Core i7-2600 CPU @ 3.40GHz x 4 / Ram 15.6 Go / CG Advanced Micro Devices, inc. [AMD/ATI] Hawaii XT [Radeon R9 290X] (prog-if 00[VGA controller])

Avatar du membre
arghlub
Administrateur du site
Messages : 9078
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: histoires de paquets cassés

Message par arghlub »

salut Mia,
c'est que dans mon neurone j'ai fait un mix (shake your head) avec un autre sujet : viewtopic.php?f=33&t=17554&p=192828 ...
sorry :oops: ;)
Tour1 (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.3 | XFCE
Tour2 (custom)CM Gigabyte | CPU AMD Athlon 5200+ | CG Nvidia GTX 560 | RAM 6Go | FreeBSD 12.1 | XFCE
Portable1 MSI GF75 Thin 9SC | CPU Intel I7-9750H | CG Nvidia GTX 1650 | RAM 32Go | LMint 20.1 | XFCE
Portable2 Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot : LMint 18.3 | MXlinux 19 | LMint 19.3 | XFCE
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Répondre