Mint 18.3 : installation Ok mais PC parfois bloqué durant le boot [Ryzen 3 2200G]

Toutes les demandes concernant l'installation de LinuxMint
Avatar du membre
alain
Messages : 4057
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles

Re: Mint 18.3 : installation Ok mais PC parfois bloqué durant le boot [Ryzen 3 2200G]

Messagepar alain » mar. 15 mai 2018 19:57

Dernier message de la page précédente :

Bonjour Maleba.

Madeba a écrit :C'est l'APU du Ryzen 3 2200G, avec le pilote libre amdgpu+mesa 18.2.

Madeba a écrit :En fait c'est un Ryzen 3, mais 2200G, architecture Raven Ridge

Ooops ! j'ai pas percuté pour le "2200G", pourtant c'est dans le titre :oops:

Donc, bien ce que je pensais tu es avec amdgpu (libre) ...

Suis les indications et le lien de Yomane.

Ensuite si pas d'améliorations avec changement de kernel et iommu, peut être essayer le pilote propriétaire "amdgpu-pro" ?

@Yoname:
yomane a écrit :

Code : Tout sélectionner

$ ps -ef | grep iommu

Code : Tout sélectionner

$ lsmod | grep iommu


Tu devrais enlever les "$" devant les commandes ;)
Image
In a world without walls and fences, who needs windows and gates?

Madeba
Messages : 7
Enregistré le : dim. 13 mai 2018 15:27

Re: Mint 18.3 : installation Ok mais PC parfois bloqué durant le boot [Ryzen 3 2200G]

Messagepar Madeba » mar. 15 mai 2018 22:29

yomane a écrit :J'irai dans le sens d'@alain, avec un test en + (l'un n'empêchant pas l'autre)

- ton kernel 4.17 à reçu une MAJ pour les AMD récent
( http://www.global-informatique-securite.com/2018/05/les-nombreuses-fonctionnalites-et-changements-importants-pour-le-noyau-linux-4.17.html )


Je suis un peu ça, je viens de mettre à jour en 4.17-rc5. Ca ne change rien à la stabilité du système, donc rien de négatif, mais le problème persiste au boot.

yomane a écrit :que te donne les commandes suivantes pour la prise en compte d'iommu ? (sur les forums anglophones on parle de ce bug)
@+


Code : Tout sélectionner

Mat@lebowski-mint ~ $  ps -ef | grep iommu
root       212     2  0 22:02 ?        00:00:00 [amd_iommu_v2]
Mat   3761  3744  0 22:14 pts/0    00:00:00 grep --color=auto iommu
Mat@lebowski-mint ~ $ lsmod | grep iommu
amd_iommu_v2           20480  1 amdkfd
Mat@lebowski-mint ~ $ dmesg | grep IOMMU
[    0.752384] AMD-Vi: Unable to write to IOMMU perf counter.
[    0.760812] AMD-Vi: Found IOMMU at 0000:00:00.2 cap 0x40
[    1.199173] AMD IOMMUv2 driver by Joerg Roedel <jroedel@suse.de>


A vue de nez, je dirais que tout fonctionne bien, malgré l'avertissement.

alain a écrit :peut être essayer le pilote propriétaire "amdgpu-pro" ?


En effet, c'est un des rares trucs que je n'ai pas encore essayé, mais ça me désole un peu vue la performance des pilotes libres.

Je suspecte un problème de firmware. Je suis tombé sur ce sujet ou quelqu'un fait tourner sans problème la même config, mais avec un paquet linux-firmware très récent.
Asrock AB350M (Desktop), Bios 4.50, Ryzen 3 2200G (GPU intégré vega 8, Raven), SSD Samsung 850/ 256 Go,
Linux Mint 18.3, noyau 4.17rc5, Mesa 18.2-devel, DRM 3.25.0, pilote amdgpu, LLVM 6.0

Avatar du membre
alain
Messages : 4057
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles

Re: Mint 18.3 : installation Ok mais PC parfois bloqué durant le boot [Ryzen 3 2200G]

Messagepar alain » mer. 16 mai 2018 01:02

Iommu me semble ok aussi vu les retours.

J'ai lu ton lien.

Oui effectivement le gars parle du linux-firmware 20180314, il ne spécifie pas s'il utilise amdgpu ou amdgpu-pro, mais il est sous arch kde, kernel 4.15 avec
le paramètre amdgpu.dc = 1 ...

Je n'ai pas d'expérience d'installation sur des pc équipés de ryzen avec GPU intégré, donc désolé je ne pourrais pas t'être d'une grande aide.
Mais tu peux toujours essayer de te mettre dans les mêmes condition que ce gars la. Et puis si ça marche toujours pas...Passer à Arch Linux kde.
Image
In a world without walls and fences, who needs windows and gates?

Avatar du membre
david37
modérateur
Messages : 1962
Enregistré le : lun. 22 août 2016 05:06

Re: Mint 18.3 : installation Ok mais PC parfois bloqué durant le boot [Ryzen 3 2200G]

Messagepar david37 » mer. 16 mai 2018 02:06

Salut Maleba,

Alors tout d'abord, est-ce tu pourrais nous renseigner une petite signature: Aide pour une signature utile

Après un brain storming jusqu'a 02h00 du matin avec l'ensemble du staff de FFLM, voici ce qu'il en est sorti ( :l :lol: ... le hibou de FFLM se reconnaitra)
Peux tu nous éclairer sur la séquence des installations que tu as fait ?
Est-ce que tu as fait dans ce sens là ?
1) installer LM
2) suivi le tuto: http://lacouleurdubruit.free.fr/index.p ... aven-Ridge
3) upgrader en 4.17

La question est de savoir si tu as installé le pilote avant ou après l'upgrade en 4.17 ? Dans un cas comme dans l'autre, tu peux avoir un souci dans le fait que le pilote ne se charge pas correctement au démarrage du kernel.

Ensuite, sur ton tuto, il n'y a pas de référence d'un quelconque support pour le 4.17. (notamment avec le dépot Git pour installer le microcode récent). Sur ce dépôt, leur derniers update concerne le 4.16 et pas le 4.17. As tu rentré les lignes de commandes comme indiqué sur ton tuto ?

Par ailleurs, ta version de GLX n'indique pas "devel" comparé à celle du tuto.... est-ce pourtant la même ? ou pas ? J'avoue que ça dépasse mes compétences. Mais bon apparemment, tu fonctionnes en rendu matériel et non-software ce qui est déjà bien ;)

Voilà ce qu'il nous vient en tête pour le moment, mais sans connaitre la façon précise dont tu as fait cette installation, c'est difficile de pouvoir se prononcer.

Bon courage,
David
PC1: Hp pavilion g6 / 1.36 GHz AMD E2-1800 APU with Radeon(tm) HD Graphics / 500 GB hard drive / 4G RAM /
LM 18.2 Mate x64
PC2: Hp-Pavilion Slimline / 2.5 GHz AMD RV710 / 4GB RAM / 500 GB hard drive / LM 18.2 Mate x64 & LM 18.2 Cinnamon x64
PC3: Lenovo ThinkPad R61i / 1.87 GHz Intel T2390 / NVIDIA G86M / 2GB RAM / 100 GB Hard Drive / LMDE2-Mate x64

Madeba
Messages : 7
Enregistré le : dim. 13 mai 2018 15:27

Re: Mint 18.3 : installation Ok mais PC parfois bloqué durant le boot [Ryzen 3 2200G]

Messagepar Madeba » jeu. 17 mai 2018 22:29

david37 a écrit :Salut Madeba,

Alors tout d'abord, est-ce tu pourrais nous renseigner une petite signature: Aide pour une signature utile


C'est fait,


david37 a écrit :Est-ce que tu as fait dans ce sens là ?
1) installer LM
2) suivi le tuto: http://lacouleurdubruit.free.fr/index.p ... aven-Ridge
3) upgrader en 4.17

La question est de savoir si tu as installé le pilote avant ou après l'upgrade en 4.17 ? Dans un cas comme dans l'autre, tu peux avoir un souci dans le fait que le pilote ne se charge pas correctement au démarrage du kernel.

Ensuite, sur ton tuto, il n'y a pas de référence d'un quelconque support pour le 4.17. (notamment avec le dépot Git pour installer le microcode récent). Sur ce dépôt, leur derniers update concerne le 4.16 et pas le 4.17. As tu rentré les lignes de commandes comme indiqué sur ton tuto ?


J'ai suivi quasiment cet ordre, avec ces commandes, mais en passant d'abord par le noyau 4.10 puis 4.15, 4.16 et enfin 4.17.

david37 a écrit :Par ailleurs, ta version de GLX n'indique pas "devel" comparé à celle du tuto.... est-ce pourtant la même ?


Oui, j'ai dû tronquer un peu brutalement le premier copier coller. Je suis bien en Mesa 18.2.0-devel

david37 a écrit :Mais bon apparemment, tu fonctionnes en rendu matériel et non-software ce qui est déjà bien ;)


Oui, le système fonctionne vraiment bien une fois démarrer, ce qui rend encore plus frustrant les plantages au boot.
Comme je l'ai déjà dit, j'ai testé avec pas mal de jeux et c'est assez performant pour du GPU intégré.



Je suis persuadé que le problème sera réglé avec les prochaines mises à jour (noyau/mesa/firmware), mais c'est dommage de
ne pas pouvoir trouver au moins une solution alternative.
Asrock AB350M (Desktop), Bios 4.50, Ryzen 3 2200G (GPU intégré vega 8, Raven), SSD Samsung 850/ 256 Go,
Linux Mint 18.3, noyau 4.17rc5, Mesa 18.2-devel, DRM 3.25.0, pilote amdgpu, LLVM 6.0

Avatar du membre
alain
Messages : 4057
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles

Re: Mint 18.3 : installation Ok mais PC parfois bloqué durant le boot [Ryzen 3 2200G]

Messagepar alain » ven. 18 mai 2018 02:54

Bonjour Madeba.
Madeba a écrit :Je suis persuadé que le problème sera réglé avec les prochaines mises à jour (noyau/mesa/firmware)

Franchement je n'en suis pas persuadé moi :?

Suite à ma lecture du lien que tu as donné dans ton 1er message et aux recherches que nous avons effectué (oui on s'y est mis à plusieurs ;) ).
Il apparaît que ce micro processeur est bien géré par les noyaux 4.15 et donc 4.16, et les versions de mesa et du micro code sont OK aussi.
Plusieurs exemples de gars ayant réussi à faire une installe stable.
Toi même tu dis que quand c'est démarré ça fonctionne super bien...donc si pb de noyau ou version mesa, ça ne fonctionnerai pas... cqfd.

Moi, (la je suis seul à le dire :mrgreen: ) Je m'orienterai plus vers un problème de configuration bios ou voir même un souci matériel.
J'ai eu l'expérience d'une carte mère socket AM3 neuve (up to date), une AsRock justement, qui m'a fait le même coup.
J'ai vite compris que c'était un problème matériel, car quelque soit la distribution que je lui installait, c’était la même chose (nécessité de redémarrer 3-4 fois).
Un tech de chez matériel.net l'a fait expertiser chez AsRock, ça venait d'un composant qui avait besoin de chauffer pour fonctionner :roll:
Une autre fois, même symptôme avec une alime seasonic, le top du top, la rolls des alimes, une titanium. Changement de l'alim et tout est rentré dans l'ordre.
Et pourtant le même tech n'y croyait pas, il disait que c'était pas possible sur du matériel de ce prix la...

donc ne te focalise pas sur les dernières versions, vu que ça fonctionne bien chez certains avec des version inférieures. Tu as de la chance que ton 4.17 rc fonctionne bien, c'est toujours risqué d'utiliser les rc.
Je dirai laisse tombé le côté software et penche toi sur le hardware. (je sais, c'est pas facile, ça nécessite de remplacer chaque élément l'un après l'autre jusqu'a tomber sur celui qui fout le broll :l )
Image
In a world without walls and fences, who needs windows and gates?

Madeba
Messages : 7
Enregistré le : dim. 13 mai 2018 15:27

Re: Mint 18.3 : installation Ok mais PC parfois bloqué durant le boot [Ryzen 3 2200G]

Messagepar Madeba » ven. 18 mai 2018 12:51

alain a écrit :Suite à ma lecture du lien que tu as donné dans ton 1er message et aux recherches que nous avons effectué (oui on s'y est mis à plusieurs ;) ).


Il ne fallait pas ! :oops:

alain a écrit :Il apparaît que ce micro processeur est bien géré par les noyaux 4.15 et donc 4.16, et les versions de mesa et du micro code sont OK aussi.

Pour le processeur, oui, mais la partie GPU est encore mal gérée, le problème est connu. Je suis encore tombé hier sur ce sujet, où des gens avec différentes configs et différentes distributions ont exactement le même problème (blocage au boot).
Ce problème a été également rapporté par Phoronix.
alain a écrit :Toi même tu dis que quand c'est démarré ça fonctionne super bien...donc si pb de noyau ou version mesa, ça ne fonctionnerai pas... cqfd.


je pencherais plutôt pour le firmware :)
alain a écrit :Un tech de chez matériel.net l'a fait expertiser chez AsRock, ça venait d'un composant qui avait besoin de chauffer pour fonctionner :roll:
Une autre fois, même symptôme avec une alime seasonic, le top du top, la rolls des alimes, une titanium. Changement de l'alim et tout est rentré dans l'ordre.
Et pourtant le même tech n'y croyait pas, il disait que c'était pas possible sur du matériel de ce prix la...Je dirai laisse tombé le côté software et penche toi sur le hardware. [i](je sais, c'est pas facile, ça nécessite de remplacer chaque élément l'un après l'autre jusqu'a tomber sur celui qui fout le broll :l )

J'espère que ce n'est pas ça, car ce pc est en fait un cadeau et je ne l'aurais plus entre les mains la semaine prochaine. La seule solution que je vois, c'est d'y ajouter une vieille carte graphique externe pour court circuiter le GPU intégré (alors que je l'avais acheté pour le GPU intégré...).

alain a écrit : c'est toujours risqué d'utiliser les rc.


La roulette russe du Geek :)
Asrock AB350M (Desktop), Bios 4.50, Ryzen 3 2200G (GPU intégré vega 8, Raven), SSD Samsung 850/ 256 Go,
Linux Mint 18.3, noyau 4.17rc5, Mesa 18.2-devel, DRM 3.25.0, pilote amdgpu, LLVM 6.0


Retourner vers « Installation »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité