Problème de démarrage en dual-boot MX17.1 et Mint17.3

Tout concernant les autres distributions
domkb
Messages : 180
Enregistré le : mer. 7 oct. 2015 16:56

Problème de démarrage en dual-boot MX17.1 et Mint17.3

Message par domkb » mar. 22 janv. 2019 11:57

Bonjour

Ayant réussi l'install de MX17, seul sur un disque dur, je me suis décidé à l'installé sur un plus gros disque, et tant qu'à faire, prévoir un endroit pour une deuxième distri, Mint 17.3-xfce.

J'ai suivi le tuto de Débitant "triple boot" mais, comme il l'annonçait, les boites de dialogues peuvent être différentes. J'ai probablement fait de mauvais choix au moment de l'installation de MX17 sur les partitions fraîchement créées.

Je me suis retrouvé avec "grub rescue". ......... :evil:

J'ai redémarré sur un dvd boot repair, en mode safe, cliqué sur "réparer". et à la fin, lancé le pastebin proposé.
http://paste.ubuntu.com/p/KxTynZKJKK/

J'accède maintenant au grub de MX, mais ça coince ensuite, en mode normal, comme en mode recovery. (freeze)
Je suppose que, encore une fois, je ne suis pas loin du but.

Voici capture du disque en question, vu par gparted. j'ai l'impression qu'il manque quelque chose qui indiquerait root ou autre barbarisme :oops:
Image

Merci pour votre aide.
Modifié en dernier par domkb le mar. 22 janv. 2019 12:36, modifié 1 fois.
mint 13 maya MATE Packard Bell 2xintel core2 6300 1,86GHz 1600MHz
cm MSI 7301 N1996 ram 3GHz chipset VIA P4M890 cg NVIDIA geforce 7300SE 64M
dd seagate 320go pour le moment
mint 17 sur Dell mini inspiron 1012 (installé en 30 minutes en usb live)
Un peu d'indulgence sera bienvenue. Les barrettes mémoires de ma tête sont déficientes et je fais comme je peux avec.

Avatar du membre
arghlub
modérateur
Messages : 6700
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Dual boot MX17 et Mint 17.3-xfce

Message par arghlub » mar. 22 janv. 2019 12:12

Salut,

Démarre en session-live sur USB puis monte la partition sdb1 (rootMX17.1) puis ouvre son fichier «/etc/default/grub» et donne-nous son contenu (en le collant ici entre balises "code") pour voir ta configuration de grub.


PS : pourrais-tu modifier ton titre (dans ton premier message) pour quelque chose de plus explicite, par exemple «Problème de démarrage en dual-boot MX17.1 et Mint17.3» ;)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3GHz | tripleBoot : Debian 10 | MXlinux | LMint 19.2 Tina | XFCE
Portable Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LMint 18.3 Sylvia | MXlinux | LMint 19.2 | XFCE
+ autres PCs + RaspberryPis + VMs ...
─────( pour une informatique libre ! -membre de l' April.org )────────────────

mézig
Messages : 1842
Enregistré le : mar. 14 nov. 2017 14:40

Re: Dual boot MX17 et Mint 17.3-xfce

Message par mézig » mar. 22 janv. 2019 12:27

Bonjour

/etc/default/grub est dans son lien Pastebin

@domkb
Mint 17.3-xfce.n'est pas encore installé , peut etre qu'en installant celui ci ça résoudrait le probleme

pourquoi Mint 17 et pas 19 ?...
Modifié en dernier par mézig le mar. 22 janv. 2019 12:42, modifié 2 fois.
Intel Pentium Dual CPU E2140 -- Nvidia GF108 -- 4 Go de RAM -- Ubuntu 18.10 -- DEEPIN 15.11
Intel Pentium CPU 4405U @ 2.10GHz × 4 -- Intel HD Graphics 510 (Skylake GT1) -- 4 Go de RAM -- Ubuntu 19.04 -- Ubuntu 18.04 -- DEEPIN 15.11 avec partition de données commune

Avatar du membre
arghlub
modérateur
Messages : 6700
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Dual boot MX17 et Mint 17.3-xfce

Message par arghlub » mar. 22 janv. 2019 12:30

@mézig : oui je viens juste de lire son pastebin :oops:
et le /etc/default/grub me paraît tout à fait normal (c'est la config par défaut du grub MX quand on a une Swap)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3GHz | tripleBoot : Debian 10 | MXlinux | LMint 19.2 Tina | XFCE
Portable Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LMint 18.3 Sylvia | MXlinux | LMint 19.2 | XFCE
+ autres PCs + RaspberryPis + VMs ...
─────( pour une informatique libre ! -membre de l' April.org )────────────────

domkb
Messages : 180
Enregistré le : mer. 7 oct. 2015 16:56

Re: Problème de démarrage en dual-boot MX17.1 et Mint17.3

Message par domkb » mar. 22 janv. 2019 12:45

Content de trouver du monde !

Quand je veux monter la partition "root MX17.1", dans le gestionnaire de fichiers, je n'arrive pas à m'authentifier.
J'utilise toujours les mêmes mots de passe partout, j'ai bien installé en français et démarré la session live en français, et en qwerty c'est pas mieux.

Je laisse tomber ça et je tente de rajouter le mint 17.3 ?
mint 17 parce que c'est ce qui freeze le moins pire. et encore, la 17.1 passait en nomodeset mais le dvd d'xfce que j'ai est une 17.3 et je me demande si y'a pas un changement de noyau qui va me créer d'autres déboires.
mint 13 maya MATE Packard Bell 2xintel core2 6300 1,86GHz 1600MHz
cm MSI 7301 N1996 ram 3GHz chipset VIA P4M890 cg NVIDIA geforce 7300SE 64M
dd seagate 320go pour le moment
mint 17 sur Dell mini inspiron 1012 (installé en 30 minutes en usb live)
Un peu d'indulgence sera bienvenue. Les barrettes mémoires de ma tête sont déficientes et je fais comme je peux avec.

domkb
Messages : 180
Enregistré le : mer. 7 oct. 2015 16:56

Re: Problème de démarrage en dual-boot MX17.1 et Mint17.3

Message par domkb » mar. 22 janv. 2019 13:10

Si je tente d'installer mint 17.3 dans la partition que j'ai prévue pour lui, je vais encore me retrouver avec des boites de dialogue pour placer des trucs à certains endroits pour coller au grub déjà installé ? dans la partition "rootMx17.1" ?
mint 13 maya MATE Packard Bell 2xintel core2 6300 1,86GHz 1600MHz
cm MSI 7301 N1996 ram 3GHz chipset VIA P4M890 cg NVIDIA geforce 7300SE 64M
dd seagate 320go pour le moment
mint 17 sur Dell mini inspiron 1012 (installé en 30 minutes en usb live)
Un peu d'indulgence sera bienvenue. Les barrettes mémoires de ma tête sont déficientes et je fais comme je peux avec.

Avatar du membre
arghlub
modérateur
Messages : 6700
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Problème de démarrage en dual-boot MX17.1 et Mint17.3

Message par arghlub » mar. 22 janv. 2019 13:19

Si tu installes LMint (sur sdb2) après MX, LMint te demandera où installer le grub.
Sélectionne alors le disque sdb (et non une partition sdb1 ou sdb2). Le grub de LM prendra le dessus sur le grub de MX (mais on pourra mettre celui de MX par la suite si tu veux).
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3GHz | tripleBoot : Debian 10 | MXlinux | LMint 19.2 Tina | XFCE
Portable Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LMint 18.3 Sylvia | MXlinux | LMint 19.2 | XFCE
+ autres PCs + RaspberryPis + VMs ...
─────( pour une informatique libre ! -membre de l' April.org )────────────────

domkb
Messages : 180
Enregistré le : mer. 7 oct. 2015 16:56

Re: Problème de démarrage en dual-boot MX17.1 et Mint17.3

Message par domkb » mar. 22 janv. 2019 13:30

ok, merci arghlub, je fais ça. :)
mint 13 maya MATE Packard Bell 2xintel core2 6300 1,86GHz 1600MHz
cm MSI 7301 N1996 ram 3GHz chipset VIA P4M890 cg NVIDIA geforce 7300SE 64M
dd seagate 320go pour le moment
mint 17 sur Dell mini inspiron 1012 (installé en 30 minutes en usb live)
Un peu d'indulgence sera bienvenue. Les barrettes mémoires de ma tête sont déficientes et je fais comme je peux avec.

mézig
Messages : 1842
Enregistré le : mar. 14 nov. 2017 14:40

Re: Problème de démarrage en dual-boot MX17.1 et Mint17.3

Message par mézig » mar. 22 janv. 2019 14:07

C'est bizarre que tu ne puisses t'identifier avec ton mot de passe , certainement perdu les droits , si c'est le cas après l'installation de LM tu pourras réinstaller MX comme tu le fais pour LM en prenant aussi sda6 comme home commun
perso je préférerais sda6 comme /data, enfin c'est toi qui vois
Intel Pentium Dual CPU E2140 -- Nvidia GF108 -- 4 Go de RAM -- Ubuntu 18.10 -- DEEPIN 15.11
Intel Pentium CPU 4405U @ 2.10GHz × 4 -- Intel HD Graphics 510 (Skylake GT1) -- 4 Go de RAM -- Ubuntu 19.04 -- Ubuntu 18.04 -- DEEPIN 15.11 avec partition de données commune

domkb
Messages : 180
Enregistré le : mer. 7 oct. 2015 16:56

Re: Problème de démarrage en dual-boot MX17.1 et Mint17.3

Message par domkb » mar. 22 janv. 2019 14:22

comme préconisé par arghlub j'installe mint à suivre.
17.3 xfce freeze même en mode recovery je me rabats vers un autre dvd 17.1 mate.

comme je prévoyais ça passe mais j'ai une boite de dialogue qui me laisse perplexe.

capture post suivant puisque je jongle avec deux pc. ma live session est en qwerty et je n'ai que des propositions de langues en anglais.
mint 13 maya MATE Packard Bell 2xintel core2 6300 1,86GHz 1600MHz
cm MSI 7301 N1996 ram 3GHz chipset VIA P4M890 cg NVIDIA geforce 7300SE 64M
dd seagate 320go pour le moment
mint 17 sur Dell mini inspiron 1012 (installé en 30 minutes en usb live)
Un peu d'indulgence sera bienvenue. Les barrettes mémoires de ma tête sont déficientes et je fais comme je peux avec.

Répondre