Résolu le 15-06-19 Impossible d'ouvrir le terminal

Questions concernant les lignes de commandes
Verrouillé
EmericMglt
Messages : 7
Enregistré le : mer. 12 juin 2019 14:03

Impossible d'ouvrir le terminal

Message par EmericMglt » sam. 15 juin 2019 20:28

Bonjour,
Étant un débutant sous Linux je pense avoir cassé mon ordinateur aha!
En effet je ne peux plus lancer de terminale, ni le gestionnaire de logiciel.
Je suis sous Linux Mint Sarah.
Je pense que cela vient que j’ai voulu remettre les paramètres par défauts et 48 paquets ont été corrompus. Depuis je ne peux plus ouvrir mon terminale et mon gestionnaire de logiciel.
Si quelqu’un à le temps pour m’aider, je le remercie d'avance.
Bonne journée !
Linux Mint 18 Cinnamon 64 bit/ Cinnamon 3.0.7/ Noyau 4.4.0.21 - generic/ Intel core i7 860 @ 2.80GHz x 4/ 7.8 GO mémoire vive / Nvidia GTS 250

Avatar du membre
arghlub
modérateur
Messages : 6288
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Impossible à ouvrir terminale

Message par arghlub » sam. 15 juin 2019 20:59

Salut,

Tu as toujours Synaptic dans ton menu pour installer les logiciels ?
Si oui, lance-le et vas dans son menu «Édition>Réparer les paquets cassés».

Et ouvre une console TTY en faisant le raccourci-clavier Ctrl+Alt+F1 (ou F2...F6), "logue"-toi (nom d'utilisateur puis mot de passe) et saisis ces commandes :
  1. Mettre à jour le cache des dépôts et faire les mises à jour :

    Code : Tout sélectionner

    sudo apt update && sudo apt upgrade
  2. Reconfigurer les paquets dont la config n'est pas complète :

    Code : Tout sélectionner

    sudo dpkg --configure -a
  3. Réparer les dépendances qui pourraient être cassées :

    Code : Tout sélectionner

    sudo apt install -f
  4. Réinstaller le gestionnaire de logiciels :

    Code : Tout sélectionner

    sudo apt install mintinstall
  5. Pour revenir à l'interface graphique : raccourci-clavier Ctrl+Alt+F7
Et pour le terminal, il faudrait savoir quel est ton environnement de bureau (Cinnamon, Mate, XFCE ou KDE ? ) pour reinstaller le terminal par défaut ...
Pour plus de clarté dans le suivi de ton sujet et pour une aide la plus efficace possible, merci de mettre ton système d'exploitation (+environnement de bureau) et la configuration de ton matériel dans la signature.
Pour cela Aide pour une signature utile
;)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3GHz | tripleBoot : Debian 9 | MXlinux | LMint 19.1 Tessa | XFCE
Portable Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LMint 18.3 Sylvia | MXlinux | LMint 19.1 | XFCE
+ autres PCs + RaspberryPis + VMs ...
─────( pour une informatique libre ! -membre de l' April.org )────────────────

EmericMglt
Messages : 7
Enregistré le : mer. 12 juin 2019 14:03

Re: Impossible à ouvrir terminale

Message par EmericMglt » sam. 15 juin 2019 21:54

Je tiens à te remercier car depuis l'ouverture de mon terminale est possible.
J'ai fait ce que tu m'as demandé et mon environnement c'est Cinnamon.
Malgré tout j'ai vu pas mal de messages d'erreur mais ça a fonctionné on dirait!
Plus tard, je nettoierai mon pc car je pense avoir mit pleins de bêtises dedans.
Merci encore!

Edit : Impossible toute fois d'ouvrir le gestionnaire de logiciel.
Edit 2 : Suite à la premier ligne de code.

Code : Tout sélectionner

Ign :1 http://mint.remi.lu sarah InRelease
Atteint :2 http://archive.canonical.com/ubuntu xenial InRelease                
Atteint :3 http://mint.remi.lu sarah Release                                   
Atteint :4 http://fr.archive.ubuntu.com/ubuntu xenial InRelease                
Atteint :5 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease        
Atteint :6 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease      
Réception de :7 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]
Réception de :9 http://fr.archive.ubuntu.com/ubuntu xenial/main Translation-fr [597 kB]
Réception de :10 http://fr.archive.ubuntu.com/ubuntu xenial/restricted Translation-fr [2 824 B]
Réception de :11 http://fr.archive.ubuntu.com/ubuntu xenial/universe Translation-fr [2 524 kB]
Réception de :12 http://fr.archive.ubuntu.com/ubuntu xenial/multiverse Translation-fr [105 kB]
3 339 ko réceptionnés en 2s (1 654 ko/s)                                 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
1 paquet peut être mis à jour. Exécutez « apt list --upgradable » pour le voir.
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 hplip : Dépend: libhpmud0 (= 3.17.10+repack0-5) mais 3.16.3+repack0-1 est installé
         Dépend: printer-driver-hpcups (= 3.17.10+repack0-5) mais 3.16.3+repack0-1 est installé
         Dépend: libsane1 (>= 1.0.24) mais il n'est pas installable
 libapt-pkg-perl : Dépend: perlapi-5.22.1
 libcairo-perl : Dépend: perlapi-5.22.1
 libclone-perl : Dépend: perlapi-5.22.1
 libdata-alias-perl : Dépend: perlapi-5.22.1
 libfile-fcntllock-perl : Dépend: perlapi-5.22.1
 libgail-3-0 : Dépend: libgtk-3-0 (= 3.18.9-1ubuntu3.3) mais 3.22.30-1ubuntu3 est installé
 libglib-perl : Dépend: perlapi-5.22.1
 libgnome2-canvas-perl : Dépend: perlapi-5.22.1
 libgnome2-perl : Dépend: perlapi-5.22.1
 libgnome2-vfs-perl : Dépend: perlapi-5.22.1
 libgtk2-perl : Dépend: perlapi-5.22.1
 libhtml-parser-perl : Dépend: perlapi-5.22.1
 libio-pty-perl : Dépend: perlapi-5.22.1
 liblist-moreutils-perl : Dépend: perlapi-5.22.1
 liblocale-gettext-perl : Pré-Dépend: perlapi-5.22.1
 libnet-dbus-perl : Dépend: perlapi-5.22.1
 libnet-dns-perl : Dépend: perlapi-5.22.1
 libnet-libidn-perl : Dépend: perlapi-5.22.1
 libnet-ssleay-perl : Dépend: perlapi-5.22.1
 libpango-perl : Dépend: perlapi-5.22.1
 libperlio-gzip-perl : Dépend: perlapi-5.22.1
 libpurple0 : Dépend: perlapi-5.22.1
 libreoffice-avmedia-backend-gstreamer : Dépend: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial7) mais 1:6.0.7-0ubuntu0.18.04.6 est installé
 libreoffice-base : Dépend: libreoffice-base-core (= 1:6.0.7-0ubuntu0.18.04.6) mais 1:5.1.6~rc2-0ubuntu1~xenial7 est installé
                    Dépend: libreoffice-base-drivers (= 1:6.0.7-0ubuntu0.18.04.6) mais 1:5.1.6~rc2-0ubuntu1~xenial7 est installé
 libreoffice-base-core : Dépend: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial7) mais 1:6.0.7-0ubuntu0.18.04.6 est installé
 libreoffice-base-drivers : Dépend: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial7) mais 1:6.0.7-0ubuntu0.18.04.6 est installé
 libreoffice-calc : Dépend: libreoffice-base-core (= 1:6.0.7-0ubuntu0.18.04.6) mais 1:5.1.6~rc2-0ubuntu1~xenial7 est installé
                    Dépend: liborcus-0.13-0 (>= 0.13.3) mais il n'est pas installable
 libreoffice-core : Dépend: libgpgmepp6 (>= 1.10.0) mais il n'est pas installable
                    Dépend: libhunspell-1.6-0 mais il n'est pas installable
                    Dépend: liborcus-0.13-0 (>= 0.13.3) mais il n'est pas installable
                    Dépend: libpoppler73 (>= 0.62.0) mais il n'est pas installable
                    Dépend: libxmlsec1 (>= 1.2.25) mais il n'est pas installé
                    Dépend: libxmlsec1-nss (>= 1.2.25) mais il n'est pas installé
 libreoffice-gnome : Dépend: libreoffice-gtk3 mais il n'est pas installé
 libreoffice-gtk : Dépend: libreoffice-gtk2 mais il n'est pas installable
 libreoffice-math : Dépend: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial7) mais 1:6.0.7-0ubuntu0.18.04.6 est installé
 libreoffice-sdbc-firebird : Dépend: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial7) mais 1:6.0.7-0ubuntu0.18.04.6 est installé
 libreoffice-sdbc-hsqldb : Dépend: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial7) mais 1:6.0.7-0ubuntu0.18.04.6 est installé
 libreoffice-writer : Dépend: libreoffice-base-core (= 1:6.0.7-0ubuntu0.18.04.6) mais 1:5.1.6~rc2-0ubuntu1~xenial7 est installé
                      Dépend: libabw-0.1-1 mais il n'est pas installable
                      Dépend: libepubgen-0.1-1 (>= 0.1.0) mais il n'est pas installable
 libsocket6-perl : Dépend: perlapi-5.22.1
 libsub-identify-perl : Dépend: perlapi-5.22.1
 libsub-name-perl : Dépend: perlapi-5.22.1
 libtext-charwidth-perl : Dépend: perlapi-5.22.1
 libtext-iconv-perl : Dépend: perlapi-5.22.1
 libtext-soundex-perl : Dépend: perlapi-5.22.1
 libuuid-perl : Dépend: perlapi-5.22.1
 libwebkitgtk-1.0-0 : Dépend: libjavascriptcoregtk-1.0-0 (= 2.4.11-0ubuntu0.1) mais 2.4.11-3ubuntu3 est installé
                      Dépend: libwebkitgtk-1.0-common (>= 2.4.11) mais il n'est pas installé
 libxml-parser-perl : Dépend: perlapi-5.22.1
 libyaml-libyaml-perl : Dépend: perlapi-5.22.1
 perl : Dépend: perl-modules-5.26 (>= 5.26.1-6ubuntu0.3) mais il n'est pas installable
        Dépend: libperl5.26 (= 5.26.1-6ubuntu0.3) mais il n'est pas installable
 pidgin : Dépend: perlapi-5.22.1
 python3-cryptography : Dépend: python3 (< 3.6) mais 3.6.7-1~18.04 est installé
E: Dépendances manquantes. Essayez d'utiliser l'option -f.
Linux Mint 18 Cinnamon 64 bit/ Cinnamon 3.0.7/ Noyau 4.4.0.21 - generic/ Intel core i7 860 @ 2.80GHz x 4/ 7.8 GO mémoire vive / Nvidia GTS 250

Avatar du membre
arghlub
modérateur
Messages : 6288
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Impossible d'ouvrir le terminal

Message par arghlub » sam. 15 juin 2019 22:33

Comme te le dit une ligne d'erreur de ton retour terminal :

Code : Tout sélectionner

Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Donc, il faut lancer cette commande (en mode administrateur avec un "sudo") :

Code : Tout sélectionner

sudo apt-get -f install
en fait, c'est un "synonyme" de la commande que je t'ai demandé de faire :

Code : Tout sélectionner

sudo apt install -f
relance cette commande (celle que tu veux des deux, c'est les mêmes) pour résoudre les dépendances cassées ;)


Pour ton terminal si tu ne l'as pas retrouvé, sous l'environnement Cinnamon c'est le paquet «gnome-terminal» qu'il faut :

Code : Tout sélectionner

sudo apt install gnome-terminal
;)
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3GHz | tripleBoot : Debian 9 | MXlinux | LMint 19.1 Tessa | XFCE
Portable Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LMint 18.3 Sylvia | MXlinux | LMint 19.1 | XFCE
+ autres PCs + RaspberryPis + VMs ...
─────( pour une informatique libre ! -membre de l' April.org )────────────────

EmericMglt
Messages : 7
Enregistré le : mer. 12 juin 2019 14:03

Re: Impossible d'ouvrir le terminal

Message par EmericMglt » sam. 15 juin 2019 22:38

Voici le résultat :

Code : Tout sélectionner

apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... a échoué.
Les paquets suivants contiennent des dépendances non satisfaites :
 hplip : Dépend: libhpmud0 (= 3.17.10+repack0-5) mais 3.16.3+repack0-1 est installé
         Dépend: printer-driver-hpcups (= 3.17.10+repack0-5) mais 3.16.3+repack0-1 est installé
         Dépend: libsane1 (>= 1.0.24) mais il n'est pas installable
 libapt-pkg-perl : Dépend: perlapi-5.22.1
 libcairo-perl : Dépend: perlapi-5.22.1
 libclone-perl : Dépend: perlapi-5.22.1
 libdata-alias-perl : Dépend: perlapi-5.22.1
 libfile-fcntllock-perl : Dépend: perlapi-5.22.1
 libgail-3-0 : Dépend: libgtk-3-0 (= 3.18.9-1ubuntu3.3) mais 3.22.30-1ubuntu3 est installé
 libglib-perl : Dépend: perlapi-5.22.1
 libgnome2-canvas-perl : Dépend: perlapi-5.22.1
 libgnome2-perl : Dépend: perlapi-5.22.1
 libgnome2-vfs-perl : Dépend: perlapi-5.22.1
 libgtk2-perl : Dépend: perlapi-5.22.1
 libhtml-parser-perl : Dépend: perlapi-5.22.1
 libio-pty-perl : Dépend: perlapi-5.22.1
 liblist-moreutils-perl : Dépend: perlapi-5.22.1
 liblocale-gettext-perl : Pré-Dépend: perlapi-5.22.1
 libnet-dbus-perl : Dépend: perlapi-5.22.1
 libnet-dns-perl : Dépend: perlapi-5.22.1
 libnet-libidn-perl : Dépend: perlapi-5.22.1
 libnet-ssleay-perl : Dépend: perlapi-5.22.1
 libpango-perl : Dépend: perlapi-5.22.1
 libperlio-gzip-perl : Dépend: perlapi-5.22.1
 libpurple0 : Dépend: perlapi-5.22.1
 libreoffice-avmedia-backend-gstreamer : Dépend: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial7) mais 1:6.0.7-0ubuntu0.18.04.6 est installé
 libreoffice-base : Dépend: libreoffice-base-core (= 1:6.0.7-0ubuntu0.18.04.6) mais 1:5.1.6~rc2-0ubuntu1~xenial7 est installé
                    Dépend: libreoffice-base-drivers (= 1:6.0.7-0ubuntu0.18.04.6) mais 1:5.1.6~rc2-0ubuntu1~xenial7 est installé
 libreoffice-base-core : Dépend: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial7) mais 1:6.0.7-0ubuntu0.18.04.6 est installé
 libreoffice-base-drivers : Dépend: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial7) mais 1:6.0.7-0ubuntu0.18.04.6 est installé
 libreoffice-calc : Dépend: libreoffice-base-core (= 1:6.0.7-0ubuntu0.18.04.6) mais 1:5.1.6~rc2-0ubuntu1~xenial7 est installé
                    Dépend: liborcus-0.13-0 (>= 0.13.3) mais il n'est pas installable
 libreoffice-core : Dépend: libgpgmepp6 (>= 1.10.0) mais il n'est pas installable
                    Dépend: libhunspell-1.6-0 mais il n'est pas installable
                    Dépend: liborcus-0.13-0 (>= 0.13.3) mais il n'est pas installable
                    Dépend: libpoppler73 (>= 0.62.0) mais il n'est pas installable
                    Dépend: libxmlsec1 (>= 1.2.25) mais il n'est pas installé
                    Dépend: libxmlsec1-nss (>= 1.2.25) mais il n'est pas installé
 libreoffice-gnome : Dépend: libreoffice-gtk3 mais il n'est pas installé
 libreoffice-gtk : Dépend: libreoffice-gtk2 mais il n'est pas installable
 libreoffice-math : Dépend: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial7) mais 1:6.0.7-0ubuntu0.18.04.6 est installé
 libreoffice-sdbc-firebird : Dépend: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial7) mais 1:6.0.7-0ubuntu0.18.04.6 est installé
 libreoffice-sdbc-hsqldb : Dépend: libreoffice-core (= 1:5.1.6~rc2-0ubuntu1~xenial7) mais 1:6.0.7-0ubuntu0.18.04.6 est installé
 libreoffice-writer : Dépend: libreoffice-base-core (= 1:6.0.7-0ubuntu0.18.04.6) mais 1:5.1.6~rc2-0ubuntu1~xenial7 est installé
                      Dépend: libabw-0.1-1 mais il n'est pas installable
                      Dépend: libepubgen-0.1-1 (>= 0.1.0) mais il n'est pas installable
 libsocket6-perl : Dépend: perlapi-5.22.1
 libsub-identify-perl : Dépend: perlapi-5.22.1
 libsub-name-perl : Dépend: perlapi-5.22.1
 libtext-charwidth-perl : Dépend: perlapi-5.22.1
 libtext-iconv-perl : Dépend: perlapi-5.22.1
 libtext-soundex-perl : Dépend: perlapi-5.22.1
 libuuid-perl : Dépend: perlapi-5.22.1
 libwebkitgtk-1.0-0 : Dépend: libjavascriptcoregtk-1.0-0 (= 2.4.11-0ubuntu0.1) mais 2.4.11-3ubuntu3 est installé
                      Dépend: libwebkitgtk-1.0-common (>= 2.4.11) mais il n'est pas installé
 libxml-parser-perl : Dépend: perlapi-5.22.1
 libyaml-libyaml-perl : Dépend: perlapi-5.22.1
 perl : Dépend: perl-modules-5.26 (>= 5.26.1-6ubuntu0.3) mais il n'est pas installable
        Dépend: libperl5.26 (= 5.26.1-6ubuntu0.3) mais il n'est pas installable
 pidgin : Dépend: perlapi-5.22.1
 python3-cryptography : Dépend: python3 (< 3.6) mais 3.6.7-1~18.04 est installé
E: Erreur, pkgProblem::Resolve a généré des ruptures, ce qui a pu être causé par les paquets devant être gardés en l'état.
E: Impossible de corriger les dépendances
Linux Mint 18 Cinnamon 64 bit/ Cinnamon 3.0.7/ Noyau 4.4.0.21 - generic/ Intel core i7 860 @ 2.80GHz x 4/ 7.8 GO mémoire vive / Nvidia GTS 250

Avatar du membre
arghlub
modérateur
Messages : 6288
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Impossible d'ouvrir le terminal

Message par arghlub » sam. 15 juin 2019 22:50

:shock: houlalaaa, t'as un sacré nombre de dépendances qui ne doivent pas correspondre à tes versions de logiciels (hplip pour imprimante HP, libreOffice, etc....) :?

Alors perso, plutôt que d'essayer de rétablir ton système (ça risque de durer un certain temps pour trouver des soluces qui seront forcément un peu bancales vu que tu ne te rappelles plus de ce que tu as bidouiller auparavant) .....
Pour ne pas te prendre la tête, fais une réinstallation .... ça dure 20minutes +un peu de config. En n'oubliant pas de sauvegarder ton /home sur un autre support et tant qu'à faire passe à la version LM18.3.
Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3GHz | tripleBoot : Debian 9 | MXlinux | LMint 19.1 Tessa | XFCE
Portable Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LMint 18.3 Sylvia | MXlinux | LMint 19.1 | XFCE
+ autres PCs + RaspberryPis + VMs ...
─────( pour une informatique libre ! -membre de l' April.org )────────────────

EmericMglt
Messages : 7
Enregistré le : mer. 12 juin 2019 14:03

Re: Impossible d'ouvrir le terminal

Message par EmericMglt » sam. 15 juin 2019 22:55

Merci bien, c'est un vieux pc qui était sous un autre système d'exploitation donc je pense que c'est lié.
Je vais chercher un peu comment faire une réinstallation, je suis une bille niveau informatique.
Merci de toute votre aide ! :)
Linux Mint 18 Cinnamon 64 bit/ Cinnamon 3.0.7/ Noyau 4.4.0.21 - generic/ Intel core i7 860 @ 2.80GHz x 4/ 7.8 GO mémoire vive / Nvidia GTS 250

Avatar du membre
zeb
Administrateur du site
Messages : 14704
Enregistré le : ven. 19 juin 2015 22:13
Localisation : Au pays du mistral

Re: Impossible d'ouvrir le terminal

Message par zeb » dim. 16 juin 2019 09:45

Salut ;)
EmericMglt a écrit :
sam. 15 juin 2019 22:55
Je vais chercher un peu comment faire une réinstallation
http://www.cjoint.com/doc/16_10/FJnhkRy ... nnamon.pdf ;)
Réinstallation et installation avec formatage de l'ancien système est pareil ;)
A lire absolument avant de poster sur le forum (et pas que le titre...)
Le RTFM des forums Linux
Merci !

panpan
Messages : 3
Enregistré le : sam. 12 août 2017 16:11

Re: Impossible d'ouvrir le terminal

Message par panpan » sam. 6 juil. 2019 17:59

Et peut-être qu'un do-release-upgrade te permettrait de passer à la version suivante
Librement

Verrouillé