Résolu le 13-07-19 Comment installer l'émulateur Xroar (doit-on lancer avec un fichier ".sh " ?)

Installation, configuration et utilisation des logiciels que vous souhaitez installer.
Avatar du membre
MegaMatMan
Messages : 173
Enregistré le : jeu. 20 juin 2019 04:22

Re: Comment lancer un fichier ".sh " ?!

Message par MegaMatMan »

Dernier message de la page précédente :

cyrille a écrit :
jeu. 11 juil. 2019 14:50
je dois placer les BIOS de la machine dans le répertoire de l'émulateur... mais je n'ai aucune idée où est ce répertoire ?!
Bah bon courage :l :l :l

Plus sérieusement, file le(s)s message(s) d'erreur exact(s)
Salut Cyrille j'ai les BIOS là n'est pas le problème & il n'y pas de messages d'erreur puisque XRoar se lance, mais sans les BIOS impossible de lancer un jeu... normalement les applications s'installent dans /opt non ?! Il doit bien y avoir une fonction recherche sous Mint pour trouver un répertoire non ?!

Autre question si je peux me permettre, l'icône de XRoar est toute vide toute moche, comment y ajouter un logo ou une image ?

Merci :)
Linux Mint Cinnamon 19.2 Tina - Pentium(R) Dual-Core CPU E6300 @ 2.80GHz - nVidia GT 1030 - 8 Go DDR2-800

Avatar du membre
arghlub
modérateur
Messages : 8071
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Comment installer l'émulateur Xroar (doit-on lancer avec un fichier ".sh " ?)

Message par arghlub »

MegaMatMan a écrit :
jeu. 11 juil. 2019 16:14
Il doit bien y avoir une fonction recherche sous Mint pour trouver un répertoire non ?!
Pas uniquement sous Mint mais sous tout Unix/Linux.
Dans un terminal avec la commande «locate» ou la commande «find» par exemple :
Mettre à jour l'indexation des fichiers de tout le système :

Code : Tout sélectionner

sudo updatedb
Rechercher un fichier ou répertoire :

Code : Tout sélectionner

locate Nom_Fichier
pour savoir où est installé un logiciel (c'est très souvent dans le dossier «/usr/bin») :

Code : Tout sélectionner

whereis Nom_Logiciel
Plus d'infos :
Tour1 (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.3 | XFCE
Tour2 (custom)CM Gigabyte | CPU AMD Athlon 5200+ | CG Nvidia GTX 560 | RAM 6Go | FreeBSD 12.1 | XFCE
Portable1 MSI GF75 Thin 9SC | CPU Intel I7-9750H | CG Nvidia GTX 1650 | RAM 32Go | LMint 19.3 | XFCE
Portable2 Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot : LMint 18.3 | MXlinux 19 | LMint 19.3 | XFCE
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Avatar du membre
MegaMatMan
Messages : 173
Enregistré le : jeu. 20 juin 2019 04:22

Re: Comment installer l'émulateur Xroar (doit-on lancer avec un fichier ".sh " ?)

Message par MegaMatMan »

OK merci arghlub

avec la commande

Code : Tout sélectionner

megamatman@IMF:~$ locate xroar
j'ai trouvé ceci

Code : Tout sélectionner

/usr/bin/xroar
/usr/share/applications/xroar.desktop
/usr/share/doc/xroar
/usr/share/doc/xroar/README.gz
/usr/share/doc/xroar/changelog.Debian.gz
/usr/share/doc/xroar/changelog.gz
/usr/share/doc/xroar/copyright
/usr/share/info/xroar-screens.png
/usr/share/info/xroar-timebandit-af.png
/usr/share/info/xroar.info.gz
/usr/share/man/man1/xroar.1.gz
/usr/share/menu/xroar
/var/lib/dpkg/info/xroar.list
/var/lib/dpkg/info/xroar.md5sums
/var/lib/dpkg/info/xroar.postinst
/var/lib/dpkg/info/xroar.postrm
Je pense que l'exécutable est dans /usr/bin/xroar... mais quand je veux copier mes BIOS dans le répertoire bin depuis mon explorateur de fichiers, j'ai une interdiction... il faut les droits d'administrateur comme d'habitude j'imagine... & je ne sais pas copier en ligne de commande...
Linux Mint Cinnamon 19.2 Tina - Pentium(R) Dual-Core CPU E6300 @ 2.80GHz - nVidia GT 1030 - 8 Go DDR2-800

Avatar du membre
arghlub
modérateur
Messages : 8071
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Comment installer l'émulateur Xroar (doit-on lancer avec un fichier ".sh " ?)

Message par arghlub »

Lu dans le fichier compressé «/usr/share/doc/xroar/README.gz» (ou ici https://www.6809.org.uk/xroar/doc/xroar ... ompilation) :
ROM images should be placed either in your home directory as '~/.xroar/roms/', or under the installation _prefix_ as '_prefix_/share/xroar/roms/'.
Donc dans ton /home il faut créer un répertoire caché «.xroar» et un sous-répertoire «roms».
Tu peux faire ça avec ton gestionnaire de fichiers ou plus rapidement avec cette commande en terminal :

Code : Tout sélectionner

mkdir -p ~/.xroar/roms
Et tu places tes roms dans ce répertoire (pour afficher le dossier caché «.xroar» dans ton gestionnaire de fichiers : raccourci-clavier Ctrl+h).
Tour1 (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.3 | XFCE
Tour2 (custom)CM Gigabyte | CPU AMD Athlon 5200+ | CG Nvidia GTX 560 | RAM 6Go | FreeBSD 12.1 | XFCE
Portable1 MSI GF75 Thin 9SC | CPU Intel I7-9750H | CG Nvidia GTX 1650 | RAM 32Go | LMint 19.3 | XFCE
Portable2 Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot : LMint 18.3 | MXlinux 19 | LMint 19.3 | XFCE
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Avatar du membre
arghlub
modérateur
Messages : 8071
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Comment installer l'émulateur Xroar (doit-on lancer avec un fichier ".sh " ?)

Message par arghlub »

MegaMatMan a écrit :
jeu. 11 juil. 2019 16:14
Autre question si je peux me permettre, l'icône de XRoar est toute vide toute moche, comment y ajouter un logo ou une image ?
On est un chouia horsSujet ... on se disperse, ça fait beaucoup de questions pour un seul sujet :l
... mais voilà comment faire ...
Fais un clic-droit sur le Menu puis «Configurer».
Dans la fenêtre qui s'ouvre tu vas dans l'onglet «Menu» et clic sur «Ouvrir l'éditeur de menu».
Puis tu recherches l'application xroar et clique sur «Propriétés».
Et enfin pour sélectionner un autre icône, tu cliques sur l'icône.

Capture faite dans une machine virtuelle avec LM19.1 Cinnamon en prenant pour exemple la calculatrice (mais sélectionne Xroar bien entendu) :
Image
;)
Tour1 (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.3 | XFCE
Tour2 (custom)CM Gigabyte | CPU AMD Athlon 5200+ | CG Nvidia GTX 560 | RAM 6Go | FreeBSD 12.1 | XFCE
Portable1 MSI GF75 Thin 9SC | CPU Intel I7-9750H | CG Nvidia GTX 1650 | RAM 32Go | LMint 19.3 | XFCE
Portable2 Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot : LMint 18.3 | MXlinux 19 | LMint 19.3 | XFCE
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Avatar du membre
cyrille
Messages : 4856
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Comment installer l'émulateur Xroar (doit-on lancer avec un fichier ".sh " ?)

Message par cyrille »

Code : Tout sélectionner

man find 
il existe aussi un utilitaire clicodrome avec un drôle de nom dont je ne me rappelle plus
mais find fait très bien l'affaire
Exemple

Code : Tout sélectionner

$ find /usr/share -type d -name man4
donc syntaxe : find OU ? -type d --> on cherche que les repertoires -name MOTIF DU NOM

Et sinon regarde du coté de menulibre pour personnaliser tes lanceurs
# Laptops DELL Latitude : FreeBSD 12.1 xfce / Openbox ; DEBIAN SID xfce / Fluxbox # Work : parc de laptop Mint 18.3 xfce
# VPS : 1 vCore 2 GHz , SSD, RAM 4Go, Local RAID, DEBIAN OLDSTABLE # Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE
[ GIT : https://github.com/CyrilleBiot | Site : https://cbiot.fr ]

Avatar du membre
alain
Messages : 7903
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: Comment installer l'émulateur Xroar (doit-on lancer avec un fichier ".sh " ?)

Message par alain »

@ Cyrille : Tu veux peut être parler de "catfish"? Mais c'est pas drôle comme nom, si? :D
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 19.3 Tricia Xfce 4.14.1 | K: 4.15.0-88
PC2 :Core2 Quad Q9650 @ 3 GHz | CG: Radeon HD 4850 | OS: LM 19.3 Xfce 4.14.1 | K: 5.3.0-42
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: emmade3 Xfce 4.12.4 | K: 4.19.0-6
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM17.3 KDE | K : 3.19

In a world without walls and fences, who needs windows and gates?

Avatar du membre
cyrille
Messages : 4856
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: Comment installer l'émulateur Xroar (doit-on lancer avec un fichier ".sh " ?)

Message par cyrille »

tout à fait Alain, juste pas très éponyme de la commande find ...
un peu comme si un frontend à apt se nommait tomato ...
# Laptops DELL Latitude : FreeBSD 12.1 xfce / Openbox ; DEBIAN SID xfce / Fluxbox # Work : parc de laptop Mint 18.3 xfce
# VPS : 1 vCore 2 GHz , SSD, RAM 4Go, Local RAID, DEBIAN OLDSTABLE # Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STABLE
[ GIT : https://github.com/CyrilleBiot | Site : https://cbiot.fr ]

Avatar du membre
DEADMAN57
Messages : 110
Enregistré le : jeu. 10 août 2017 08:13
Contact :

Re: Comment installer l'émulateur Xroar (doit-on lancer avec un fichier ".sh " ?)

Message par DEADMAN57 »

moi j ai fait comme dans le manuel et cela fonctionne chez moi. voici le lien https://www.6809.org.uk/xroar/doc/xroar.shtml
Linux Mint 19 Mate 64-bit : 3.6.6
Noyau Linux : 4.13.14-041314-gen Pentium CPU G3420 3.20GHz x 2
Disques durs : SURPRISE Go
Mémoire vive : 15.6 Go
Carte graphique : NVIDIA Corporation GP107 [GeForce GTX 1050 Ti]

Avatar du membre
MegaMatMan
Messages : 173
Enregistré le : jeu. 20 juin 2019 04:22

Re: Comment installer l'émulateur Xroar (doit-on lancer avec un fichier ".sh " ?)

Message par MegaMatMan »

Bonsoir à tous & merci pour vos réponses :)

Message pour arghlub:

Merci pour ton aide j'ai créé le répertoire caché avec ta commande

Code : Tout sélectionner

mkdir -p ~/.xroar/roms
& placé les BIOS dedans tout fonctionne super :B

Par contre je n'ai pas compris comment mettre une image pour XRoar ?!
arghlub a écrit :Fais un clic-droit sur le Menu puis «Configurer». Dans la fenêtre qui s'ouvre tu vas dans l'onglet «Menu» et clic sur «Ouvrir l'éditeur de menu».
De quel menu tu parles je ne vois pas du tout ?!

Message pour DEADMAN57:

Tu as réussi à trouver les BIOS ???
Linux Mint Cinnamon 19.2 Tina - Pentium(R) Dual-Core CPU E6300 @ 2.80GHz - nVidia GT 1030 - 8 Go DDR2-800

Avatar du membre
arghlub
modérateur
Messages : 8071
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: Comment installer l'émulateur Xroar (doit-on lancer avec un fichier ".sh " ?)

Message par arghlub »

Salut,
MegaMatMan a écrit :
sam. 13 juil. 2019 00:58
Par contre je n'ai pas compris comment mettre une image pour XRoar ?!
P't'être en allant dans le menu «File > Run ... ou Load» :
Image

Je ne connais pas cet émulateur de console-dinosaure ...
Je l'ai installé par curiosité et histoire de tenter de te débrouiller, mais bon, je ne peux t'en dire plus :?

──────────────────────────────
MegaMatMan a écrit :
sam. 13 juil. 2019 00:58
Message pour arghlub:
[...] tout fonctionne super :B
On dit que c'est "résolu" ou on continue pendant 51pages ?????
Si le sujet est résolu, merci de mettre un attribut de sujet (résolu), voir tuto ici

de toute façon, j'ai les clés dans ma poche qui me démangent :l ...
Prochaine page je verrouille le sujet.
(déjà 5-10 questions, on va pas faire un cours complet de nuNux sur un seul sujet -qui je le rappelle était nommé «Comment lancer un fichier ".sh " ?!» au départ ) :roll: :l

@++ ;)
Tour1 (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go | tripleBoot : Debian 10 | MXlinux 19 | LMint 19.3 | XFCE
Tour2 (custom)CM Gigabyte | CPU AMD Athlon 5200+ | CG Nvidia GTX 560 | RAM 6Go | FreeBSD 12.1 | XFCE
Portable1 MSI GF75 Thin 9SC | CPU Intel I7-9750H | CG Nvidia GTX 1650 | RAM 32Go | LMint 19.3 | XFCE
Portable2 Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot : LMint 18.3 | MXlinux 19 | LMint 19.3 | XFCE
─────( pour une informatique libre ! -membre de l' April.org )────────────────

Verrouillé