En cours Linux Mint non présent dans le Bios, mais se lance....

Assistance concernant Linux Mint
Astriah
Messages : 11
Enregistré le : mer. 25 mars 2020 14:34

Linux Mint non présent dans le Bios, mais se lance....

Message par Astriah »

Bonjour à tous et à toutes,

J'ai installé Linux sur un SSD Crucial, aucun problème à ce niveau :). J'ai ensuite installé Windows sur un SSD Sandisk et là aussi, aucun problème (besoin pour le taf).

Au démarrage, par défaut, c'est Windows 10 qui se lance. J'aimerais qu'au démarrage, on me demande sur quel disque je souhaite démarrer sans devoir passer par le Bios.

En allant dans le bios (dans avancé, démarrage), je vois que je peux régler les priorités de lancement. Or, je ne vois que le disque Sandisk avec Windows dans les possibilités, et non mon Crucial O_o. Les deux disques sont branchés en Sata 6gb, j'ai testé d'inverser les connec, rien à faire.

Le disque SSD Crucial avec Linux Mint est présent plus bas, dans "autres périphériques" et si je fais Enter, Linux se lance.

Donc, actuellement, je dois obligatoirement aller dans le Bios pour lancer Linux, ce qui est chiant au possible :/

Serait-il possible d'empêcher Windows de se lancer par défaut ? Pourquoi le SSD Crucial n'est-il pas détecté dans les Boots possible (là où il me propose le Sandisk), quelle manipulation dois-je faire ? Ai-je raté quelque chose lors des installations ? Comment puis-je vérifier mon système Linux actuel afin de vous communiquer les informations dont vous auriez besoin pour m'éclairer ? :/

En ce qui concerne les installations, Linux et Windows ont été installés via Clef Usb et de mémoire, j'avais débranché l'autre SSD à chaque fois.

Merci :)

Astriah
Système d'exploitation: Linux Mint 19.3 Cinnamon
Version: 4.4.8
Mémoire vive: 7.8 GO
Processeur: Intel© Core™ i7-2600K CPU @ 3.40GHz × 4
Carte Graphique: NVIDIA Corporation GF110 [GeForce GTX 580]

Astriah
Messages : 11
Enregistré le : mer. 25 mars 2020 14:34

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par Astriah »

Rebonjour,

Pour je ne sais quelle raison, à présent je vois mes deux SSD :D et j'ai pu mettre Linux en Boot principal et Windows en deuxième position (mais pas encore testé de booter dessus depuis. mais normalement ca devrait aller).

Du coup je n'ai plus qu'une question. Est-il possible de ne pas passer par le Bios pour booter windows ? (ex, avoir un ecran au démarrage qui me demande sur quel SSD booter ?).

D'avance merci,

Astriah
Système d'exploitation: Linux Mint 19.3 Cinnamon
Version: 4.4.8
Mémoire vive: 7.8 GO
Processeur: Intel© Core™ i7-2600K CPU @ 3.40GHz × 4
Carte Graphique: NVIDIA Corporation GF110 [GeForce GTX 580]

zeb
Messages : 16496
Enregistré le : ven. 19 juin 2015 22:13
Localisation : plus ici

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par zeb »

Bonjour,
Astriah a écrit :
mer. 25 mars 2020 14:45
J'ai ensuite installé Windows
Boulette :D en général c'est l'inverse, windows et ensuite linux ;)
Quelqu'un pourra sûrement t'aider...

Astriah
Messages : 11
Enregistré le : mer. 25 mars 2020 14:34

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par Astriah »

Ah, merci :/

J'ai installé Grub Customiser aussi, mais n'ai rien fait pour le moment via ce logiciel.

Bref, toujours au même point, passage obligé vers le Bios (mais boot Linux par défaut, même si le démarrage est un tantinet plus long qu'avant).

:/
Système d'exploitation: Linux Mint 19.3 Cinnamon
Version: 4.4.8
Mémoire vive: 7.8 GO
Processeur: Intel© Core™ i7-2600K CPU @ 3.40GHz × 4
Carte Graphique: NVIDIA Corporation GF110 [GeForce GTX 580]

zeb
Messages : 16496
Enregistré le : ven. 19 juin 2015 22:13
Localisation : plus ici

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par zeb »

Astriah a écrit :
mer. 25 mars 2020 17:06
J'ai installé Grub Customiser
Essaye plutôt Boot-Repair ;)

Astriah
Messages : 11
Enregistré le : mer. 25 mars 2020 14:34

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par Astriah »

Bonjour,

J'ai installé ce que tu as indiqué (boot repair).

Voici le message d'erreur qui s'affiche quand je lui demande de corriger les problèmes:

"La session actuelle est en mode Legacy. Veuillez redémarrer l'ordinateur, et utiliser ce logiciel dans une session EFI. Cela vous permettra d'utiliser cette fonctionnalité. Par exemple, utilisez un live-USB de Boot-Repair-Disk-64bit (www.sourceforge.net/p/boot-repair-cd), après avoir vérifié que votre BIOS est réglé pour démarrer l'USB en mode EFI."

=> comment que je fais O_o (si tu as des détails, je suis preneur. Je suis très proche du noob "parfait" :D).

Merci

Astriah
Système d'exploitation: Linux Mint 19.3 Cinnamon
Version: 4.4.8
Mémoire vive: 7.8 GO
Processeur: Intel© Core™ i7-2600K CPU @ 3.40GHz × 4
Carte Graphique: NVIDIA Corporation GF110 [GeForce GTX 580]

capdeframint
Messages : 1331
Enregistré le : jeu. 2 juin 2016 08:57

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par capdeframint »

Tu ne dois vraisemblablement pas avoir une seule partition de boot sur le premier disque mais une sur chaque disque, celle de Windows sur le disque de Windows et celle de Linux sur l'autre. Il te faudrait réinstaller correctement un menu Grub dans la partition de boot (sans doute EFI dans ton cas) du disque qui a déjà Windows. Il est possible que Boot Repair y parvienne mais je n'ai jamais essayé avec ce genre de double config.
Au vu de ton message précédent, c'est encore pire puisque tu as installé Windows en EFI et Linux en LEGACY. Le mieux risque donc d'être le choux d'une réinstallation complète de Linux, en EFI cette fois.
PC1: ordi tour Packard Bell iXtreme M5140, proc AMD Phenom II 1035TX6,Ram12 Go,1 SSD de 250 Go+1 disque HDD de 1 To.Carte Video NVidia. LMDE4 XFCE
Double boot: Windows 10 Family (en totalité sur le SSD) + LMDE4 XFCE (/ sur le SSD et Home sur le HDD)
PC2:portable HP Pavilion DV7-3125ef, proc Intel i3, Ram8 Go, 1 SSD de 240 Go+ 1 disque HDD de 640 Go.Carte video NVidia GT218M, LM20 Cinnamon
Double boot: Windows 10 Pro (sur le SSD) et LM20 (/ sur le SSD et Home sur le HDD).

Astriah
Messages : 11
Enregistré le : mer. 25 mars 2020 14:34

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par Astriah »

Ayant entièrement paramétré mon OS linux (ça prend du temps :/ ), réinstaller Linux m'ennuierait beaucoup :(

Si quelqu'un a des idées sur des manipulations possibles sous Windobe ou Linux pour régler le problème (choix de l'OS au démarrage sans passer par le Bios, éventuellement vérifier si le Grub est bon, accélérer le démarrage), je suis preneur :)

P.S: merci pour vos réponses :)
Système d'exploitation: Linux Mint 19.3 Cinnamon
Version: 4.4.8
Mémoire vive: 7.8 GO
Processeur: Intel© Core™ i7-2600K CPU @ 3.40GHz × 4
Carte Graphique: NVIDIA Corporation GF110 [GeForce GTX 580]

Astriah
Messages : 11
Enregistré le : mer. 25 mars 2020 14:34

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par Astriah »

Au cas ou, le fichier généré par l'analyse du logiciel "réparateur de démarrage":

https://paste.ubuntu.com/p/KHDBnJgwtv/
Système d'exploitation: Linux Mint 19.3 Cinnamon
Version: 4.4.8
Mémoire vive: 7.8 GO
Processeur: Intel© Core™ i7-2600K CPU @ 3.40GHz × 4
Carte Graphique: NVIDIA Corporation GF110 [GeForce GTX 580]

capdeframint
Messages : 1331
Enregistré le : jeu. 2 juin 2016 08:57

Re: Linux Mint non présent dans le Bios, mais se lance....

Message par capdeframint »

Et bien les deux premières lignes suffisent à confirmer que tu as le boot de Windows sur le secteur de boot du premier disque (SDA) et le Grub de Linux installé sur le secteur de boot du second disque (SDB), d'où le bordel que tu constates.
Il te faut réinstaller proprement le Grub sur le secteur de boot de Sda, le même que celui pour Windows actuellement, de façon à ce que le Grub prenne en charge tes deux systèmes d'exploitation, Windows et Linux.
PC1: ordi tour Packard Bell iXtreme M5140, proc AMD Phenom II 1035TX6,Ram12 Go,1 SSD de 250 Go+1 disque HDD de 1 To.Carte Video NVidia. LMDE4 XFCE
Double boot: Windows 10 Family (en totalité sur le SSD) + LMDE4 XFCE (/ sur le SSD et Home sur le HDD)
PC2:portable HP Pavilion DV7-3125ef, proc Intel i3, Ram8 Go, 1 SSD de 240 Go+ 1 disque HDD de 640 Go.Carte video NVidia GT218M, LM20 Cinnamon
Double boot: Windows 10 Pro (sur le SSD) et LM20 (/ sur le SSD et Home sur le HDD).

Répondre