Résolu le 12-11-20 HP Deskjet 3630 refuse de fonctionner

Questions concernant les composants
Répondre
Avatar du membre
elekaj34
Messages : 5
Enregistré le : jeu. 12 nov. 2020 10:00

HP Deskjet 3630 refuse de fonctionner

Message par elekaj34 »

Bonjour,

Je viens d'installer Linux Mint 20 sur ma becane, tout fonctionne bien sauf l'imprimante une HP Deskjet 3630
En mode imprimante, la tache apparaît bien dans la queue d'impression, mais il ne se passe rien et aucune notification d'erreur (à l'écran, j'ai pas vérifier les logs systèmes).
En mode scanner, le scanner est bien trouvé sous le nom 'HP Deskjet_3630_series' mais quand je veux numériser j'ai l'erreur :

Code : Tout sélectionner

Impossible de se connecter au périphérique de numérisation
Après quelques lectures sur ce forum (notamment viewtopic.php?f=18&t=8774) je tente un

Code : Tout sélectionner

hp-setup
Mais rien de mieux (en fait c'est exactment la même chose), alors je tente un hp-doctor :

Code : Tout sélectionner


HP Linux Imaging and Printing System (ver. 3.20.3)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.


HP Linux Imaging and Printing System (ver. 3.20.3)
Self Diagnse Utility and Healing Utility ver. 1.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

 

Checking for Deprecated items....
No Deprecated items are found


Checking for HPLIP updates....
error: Failed to locate hp-upgrade utility


Checking for Dependencies....
warning: linuxmint-20 version is not supported. Using linuxmint-19.3 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.4.0-53-generic #59-Ubuntu SMP Wed Oct 21 09:38:44 UTC 2020 GNU/Linux
 Host: kepler
 Proc: 5.4.0-53-generic #59-Ubuntu SMP Wed Oct 21 09:38:44 UTC 2020 GNU/Linux
 Distribution: linuxmint 20
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.20.3
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro  20 version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.20.3

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.20.3
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[last_used]
device_uri = hp:/usb/DeskJet_3630_series?serial=CN6663H667067P
printer_name = DeskJet_3630

[installation]
date_time = 11/12/20 10:43:14
version = 3.20.3


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

 error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.50            OK         -
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.29          OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.16         OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 network              network -wget                                                OPTIONAL        -               1.20.3          OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -

------------------------
| General Dependencies |
------------------------

 libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
 cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               OK         -
 cups-image           CUPS image - CUPS image development files                    REQUIRED        -               -               OK         -
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.31'         OK         -
 error: libusb        libusb - USB library                                         REQUIRED        -               1.0             MISSING    'libusb needs to be installed'
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 sane-devel           SANE - Scanning library development files                    REQUIRED        -               -               OK         -
 error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           -               MISSING    'libnetsnmp-devel needs to be installed'
 libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.8.5           OK         -
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               MISSING    'python3-notify2 needs to be installed'
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             -               MISSING    'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.16          OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.9           OK         -
 error: python3-devel Python devel - Python development files                      REQUIRED        2.2             3.8.5           MISSING    'python3-devel needs to be installed'
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               7.0.0           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.5.34          OK         -

--------------
| COMPILEDEP |
--------------

 libtool              libtool - Library building support services                  REQUIRED        -               2.4.6           OK         -
 error: gcc           gcc - GNU Project C and C++ Compiler                         REQUIRED        -               9.3.0           MISSING    'gcc needs to be installed'
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.2.1           OK         -

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.20.3          OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.20.3          OK         -

----------------------
| Scan Configuration |
----------------------

'/etc/sane.d/dll.d/hpaio' not found.
 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.20.3          OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.20.3          OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/usb/DeskJet_3630_series?serial=CN6663H667067P' is a Hewlett-Packard DeskJet_3630_series all-in-one


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                                         Model                                          
  -------------------------------------------------  -----------------------------------------------
  hp:/usb/DeskJet_3630_series?serial=CN6663H667067P  HP DeskJet 3630 series                         

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 


Type: Printer
Device URI: hp:/usb/DeskJet_3630_series?serial=CN6663H667067P
error: Unable to communicate with device (code=12): hp:/usb/DeskJet_3630_series?serial=CN6663H667067P
error: Device not found
error: Communication status: Failed



Type: Unknown
Device URI: implicitclass://DeskJet_3630_series_CN6663H667067P_/


--------------
| PERMISSION |
--------------

USB             DeskJet_3630                   Required        -        -        OK       Node:'/dev/bus/usb/003/003' Perm:'  root  lp rw- rw- rw- rw- r--'
Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing or 'cups' service is not running.
error: 'libusb-1.0.0-dev' package is missing/incompatible 
error: 'python3-pyqt4' package is missing/incompatible 
error: 'python3-dev' package is missing/incompatible 
error: 'build-essential' package is missing/incompatible 
Missing Optional Dependencies
-----------------------------
error: 'python3-notify2' package is missing/incompatible 
error: 'mate-notification-daemon' package is missing/incompatible 
error: 'python3-dbus.mainloop.qt' package is missing/incompatible 
Missing Commands
----------------
error: 'sudo DEBIAN_FRONTEND=noninteractive apt-get --assume-yes install libsnmp-dev' is missing
error: 'sudo apt-get --assume-yes install snmp-mibs-downloader' is missing


ENTER SUDO PASSWORD
-------------------
Please enter the sudoer (alain)'s password: 
 

Checking Permissions....


Checking for Configured Queues....
error: PPD /etc/cups/ppd/.ppd file not found
warning:  is not HP Device.
warning: Fail to read ppd=/etc/cups/ppd/.ppd file
warning: Insufficient permission to access file /etc/cups/ppd/.ppd
warning: Could not complete Queue(s) configuration check


Checking for HP Properitery Plugin's....
No plug-in printers are configured.
 

Checking for Printer Status....
error: '' Printer is either Powered-OFF or Failed to communicate.
Turn On Printer and re-run hp-doctor

Diagnose completed...
Au vu de la fin du message, l'imprimante est correctement connectée (j'ai essayé 3 cables USB différents qui fonctionnent sur d'autres périphériques) et qu'elle est bien allumée ;)

Mais l'imprimante est-elle compatible Linux Mint 20 ?

Code : Tout sélectionner

warning: linuxmint-20 version is not supported. Using linuxmint-19.3 versions dependencies to verify and install...
[...]
warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro  20 version 
Quelques tentatives de diagnostics :

Code : Tout sélectionner

ll /etc/cups/ppd/
total 56
-rw-r--r-- 1 root lp 31199 nov.  12 09:50 DeskJet_3630.ppd
-rw-r--r-- 1 root lp 21383 nov.  12 09:53 DeskJet_3630_series_CN6663H667067P_.ppd
Alors en effet pas de fichier .ppd, mais des permissions qui me semblent acceptables (mais je ne saurais en dire plus si c'est OK ou pas)

Plus étrange, cups ainsi que cups-client, cups-bsd, libcups2, gcc libusb etc... sont bien installés :

Code : Tout sélectionner

ii  cups                                       2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - PPD/driver support, web interface
ii  cups-browsed                               1.27.4-1                            amd64        OpenPrinting CUPS Filters - cups-browsed
ii  cups-bsd                                   2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - BSD commands
ii  cups-client                                2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - client programs (SysV)
ii  cups-common                                2.3.1-9ubuntu1.1                    all          Common UNIX Printing System(tm) - common files
ii  cups-core-drivers                          2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - driverless printing
ii  cups-daemon                                2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - daemon
ii  cups-filters                               1.27.4-1                            amd64        OpenPrinting CUPS Filters - Main Package
ii  cups-filters-core-drivers                  1.27.4-1                            amd64        OpenPrinting CUPS Filters - Driverless printing
ii  cups-ipp-utils                             2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - IPP developer/admin utilities
ii  cups-pk-helper                             0.2.6-1ubuntu3                      amd64        PolicyKit helper to configure cups with fine-grained privileges
ii  cups-ppdc                                  2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - PPD manipulation utilities
ii  cups-server-common                         2.3.1-9ubuntu1.1                    all          Common UNIX Printing System(tm) - server common files
ii  libcups2:amd64                             2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - Core library
ii  libcupsfilters1:amd64                      1.27.4-1                            amd64        OpenPrinting CUPS Filters - Shared library
ii  libcupsimage2:amd64                        2.3.1-9ubuntu1.1                    amd64        Common UNIX Printing System(tm) - Raster image library
ii  printer-driver-hpcups                      3.20.3+dfsg0-2                      amd64        HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
ii  python3-cups                               1.9.73-3build1                      amd64        Python3 bindings for CUPS
ii  python3-cupshelpers                        1.5.12-0ubuntu1                     all          Python utility modules around the CUPS printing system
[...]
ii  gcc                                        4:9.3.0-1ubuntu2                    amd64        GNU C compiler
ii  gcc-10-base:amd64                          10.2.0-5ubuntu1~20.04               amd64        GCC, the GNU Compiler Collection (base package)
ii  gcc-10-base:i386                           10.2.0-5ubuntu1~20.04               i386         GCC, the GNU Compiler Collection (base package)
ii  gcc-9                                      9.3.0-17ubuntu1~20.04               amd64        GNU C compiler
ii  gcc-9-base:amd64                           9.3.0-17ubuntu1~20.04               amd64        GCC, the GNU Compiler Collection (base package)
ii  libgcc-9-dev:amd64                         9.3.0-17ubuntu1~20.04               amd64        GCC support library (development files)
ii  libgcc-s1:amd64                            10.2.0-5ubuntu1~20.04               amd64        GCC support library
ii  libgcc-s1:i386                             10.2.0-5ubuntu1~20.04               i386         GCC support library
[...]
ii  libusb-1.0-0:amd64                         2:1.0.23-2build1                    amd64        userspace USB programming library
ii  libusb-1.0-0-dev:amd64                     2:1.0.23-2build1                    amd64        userspace USB programming library development files
ii  libusb-1.0-doc                             2:1.0.23-2build1                    all          documentation for userspace USB programming
Et enfin, cups semble bien lancé et actif :

Code : Tout sélectionner

$ ps axf | grep cups
   1201 ?        Ss     0:00 /usr/sbin/cupsd -l
   1446 ?        S      0:00  \_ /usr/lib/cups/notifier/dbus dbus://
   1447 ?        S      0:00  \_ /usr/lib/cups/notifier/dbus dbus://
   1291 ?        Ssl    0:00 /usr/sbin/cups-browsed
$ sudo netstat -tanup | grep LISTEN
tcp        0      0 127.0.0.1:631           0.0.0.0:*               LISTEN      1201/cupsd          
tcp        0      0 127.0.0.1:60000         0.0.0.0:*               LISTEN      1267/ippusbxd       
tcp6       0      0 ::1:631                 :::*                    LISTEN      1201/cupsd          
tcp6       0      0 ::1:60000               :::*                    LISTEN      1267/ippusbxd       
Bref désolé pour ce long post et je ne vois pas quoi faire de plus pour la faire fonctionner :?

Ah oui j'oubliais, sur ma précédente install d'Ubuntu 18.04 LTS elle fonctionnait sans que je n'ai rien eu à faire :D

Merci d'avance pour votre aide ;)
Modifié en dernier par elekaj34 le jeu. 12 nov. 2020 18:47, modifié 1 fois.
Alain
Linux Mint 20 Ulyana | Cinnamon 4.6.7 | 5.4.0-53-generic | Intel Core i7-4770K | 32Go DDR3 | GTX 1070

Avatar du membre
cyrille
modérateur
Messages : 8858
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: HP Deskjet 3630 refuse de fonctionner

Message par cyrille »

As tu essayé depuis un hplip du site officiel (desinstalle celui des repos avant). Prendre le plus récent

Installer les dependances manquantes éventuellement

Code : Tout sélectionner

sudo apt-get install -f
Pour le scanner.
As tu essayé avec les droits roots

Code : Tout sélectionner

sudo sane-find-scanner
Que donne un lsusb ? Est il reconnu ?


Est il enfin branché sur de l'USB2 ou 3. Il semble que le branchement sur USB3 puisse dans certains cas poser soucis.
# apt install anarchism

Debian SID - FreeBSD - https://cbiot.fr -- https://framagit.org/CyrilleBiot -- Il est grand temps que l’anarchie remette de l’ordre dans le chaos ! (Karim B. -LV88)

Avatar du membre
elekaj34
Messages : 5
Enregistré le : jeu. 12 nov. 2020 10:00

Re: HP Deskjet 3630 refuse de fonctionner

Message par elekaj34 »

Bonsoir,

J'ai oublié de le préciser dans mon premier message mais l'imprimante était bien vue par lsusb.
Le port se lequel elle est connecté est bien un OSB 2 (et non 3).

Mais finalement, installer le hplip officiel de HP a résolu le problème. J'avoue que vu que la version de hplip était supérieure à la version mini exigée par HP j'avais pas jugée nécessaire d'installer le paquet officiel.

Merci encore pour l'aide
Alain
Linux Mint 20 Ulyana | Cinnamon 4.6.7 | 5.4.0-53-generic | Intel Core i7-4770K | 32Go DDR3 | GTX 1070

Avatar du membre
alain
modérateur
Messages : 12633
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: HP Deskjet 3630 refuse de fonctionner

Message par alain »

Bonjour.

Sujet archivé (en lecture seule) car résolu.
Si besoin de rouvrir faire un MP à un membre de l'équipe ;)
PC1 : CM : ASRock 990FX | CPU: AMD FX 8350-8 cores, 4 GHz | RAM: 16 Go DDR3 1600 MHz | CG: ATI RX 580-8 Go | OS : LM 20.3 Uma Xfce 4.16 | K: 5.4
PC2
:Core2 Quad Q9650 @ 3 GHz | CG: Nvidia GTX 650TI | OS: LM 20.3 Xfce 4.16| K: 5.4
PC3 :Core i7-2600 @ 3,5 GHz | CG: ATI HD 4650 | OS: Emmade4 Xfce 4.16.0 | K: 5.10
PC4 :Core2 Quad Q9650 @ 3 GHz | CG: GT 630 | OS : LM20.3 XFCE 4.16 | K : 5.4
In a world without walls and fences, who needs windows and gates?

Répondre