[RESOLU] Décocher "Autoriser l'exécution du fichier comme un programme" sous NTFS (+ infos sur les permissions en NTFS)

Assistance concernant Linux Mint
Avatar du membre
Rémi123
Messages : 38
Enregistré le : dim. 19 mars 2017 13:25

[RESOLU] Décocher "Autoriser l'exécution du fichier comme un programme" sous NTFS (+ infos sur les permissions en NTFS)

Messagepar Rémi123 » lun. 20 mars 2017 23:16

Bonjour tout le monde,


Alors voilà: je décide de passer mon PC fixe à Linux - je l'utilise presque exclusivement pour la musique, les vidéos et flâner sur Internet.

Ca c'était pour le contexte. Après diverses péripéties de newbie je parviens à lire mes chères vieilles playlists .m3u, à les ouvrir automatiquement avec le bon logiciel, et même à créer un lanceur qui ouvre tout seul mon dossier de playlists. Je m'initie doucement à Mint, quoi.


J'en viens au fait. Le problème est quand je double-clique sur les fichiers .m3u de playlists. Il me met systématiquement un écran comme ça:
Image
(Désolé, je gère encore mal l'insertion d'images... le message c'est "Voulez-vous lancer 'nom de fichier' ou afficher son contenu?", avec pour options "lancer dans un terminal", "afficher", "cancel" et "lancer".)

C'est en sélectionnant "afficher" (bizarrement) que ça fonctionne.

Mon but est de pouvoir double-cliquer sur mon fichier .m3u sans cet écran intermédiaire: je veux que la playlist se lance tout de suite.


Mais j'ai un peu mieux cerné le problème. C'est une question de permissions.
Pour que ça lance directement le fichier, il faut que dans les propriétés du fichier, dans l'onglet "permissions", la case derrière "exécuter" soit décochée (cf. image ci-dessous).

Image
(Zut on n'y voit rien. Derrière "exécuter", la case que je voudrais décocher est "Autoriser l'exécution du fichier comme un programme".)

En faisant des essais sur d'autres fichiers je me suis rendu compte que je peux décocher cette case quand, toujours dans "permissions" (cf. image ci-dessus), je sélectionne "lecture seule" derrière les deux dernières lignes "accès" (rubrique "groupe" et rubrique "autres").

Mais voilà, pour mon fichier de playlists, pour une raison que je ne comprends pas, il m'est impossible de passer de "lecture et écriture" à "lecture seule". Quand je sélectionne "lecture seule" ça remet immédiatement en "lecture et écriture". J'ai essayé de refaire la manip en ouvrant le dossier en tant qu'administrateur, marche pas.

Donc voilà: quelqu'un saurait pourquoi je ne peux pas passer en "lecture seule", et éventuellement comment pouvoir le faire?
Ou plus généralement comment être certain de décocher cette case "autoriser l'exécution du fichier comme un programme"?


Je sais bien qu'il doit y avoir une réponse du type "mais tu as bien vérifié que c'est branché?", mais soyez compréhensifs, je débute...

Merci!

Rémi
Modifié en dernier par Rémi123 le mer. 19 avr. 2017 21:46, modifié 4 fois.
Mint 18.1 Serena Mate

Avatar du membre
mpat
Messages : 5707
Enregistré le : mar. 25 août 2015 21:12
Localisation : Sambreville (Belgique)

Re: Certains fichiers ne peuvent pas être basculés en "lecture seule"

Messagepar mpat » lun. 20 mars 2017 23:20

salut.
pour changer les permissions tu dois être en root
Asus x53sd, I5- 2.5/3.1 ghz, 8go ram,
dual gpu Intel/Nvidia, ssd 256 + hdd 750
Lmint 18 - Cinnamon 64-bit, kernel 4.10.8-041008

Avatar du membre
Rémi123
Messages : 38
Enregistré le : dim. 19 mars 2017 13:25

Re: Certains fichiers ne peuvent pas être basculés en "lecture seule"

Messagepar Rémi123 » lun. 20 mars 2017 23:31

Merci mpat!

Mais alors pourquoi j'ai réussi à changer les permissions pour d'autres fichiers?
Qu'est-ce qui fait qu'on a besoin ou pas besoin d' "être en root"?

Mais au fait, que veut dire "être en root" et comment on devient "en root"?
C'est le truc de "sudo ....", ou je confonds?
Modifié en dernier par Rémi123 le lun. 20 mars 2017 23:44, modifié 2 fois.
Mint 18.1 Serena Mate

Avatar du membre
mpat
Messages : 5707
Enregistré le : mar. 25 août 2015 21:12
Localisation : Sambreville (Belgique)

Re: Certains fichiers ne peuvent pas être basculés en "lecture seule"

Messagepar mpat » lun. 20 mars 2017 23:37

dans un terminal

gksudo + le nom de ton gestionnaire de fichiers
Asus x53sd, I5- 2.5/3.1 ghz, 8go ram,
dual gpu Intel/Nvidia, ssd 256 + hdd 750
Lmint 18 - Cinnamon 64-bit, kernel 4.10.8-041008

Avatar du membre
Rémi123
Messages : 38
Enregistré le : dim. 19 mars 2017 13:25

Re: Certains fichiers ne peuvent pas être basculés en "lecture seule"

Messagepar Rémi123 » lun. 20 mars 2017 23:51

Ah, merci : )

Bon, j'ai un peu de mal. Quand je fais ça, ça m'ouvre un dossier qui s'appelle root, qui ne contient rien d'autre qu'un dossier vide qui s'appelle desktop.
Si depuis ce dossier je vais dans mon dossier de playlists et en sélectionne une, pareil: impossible de changer les permissions.

Alors j'ai l'impression aussi que c'est sur mon disque système (mon bureau) que je peux changer les permissions, alors que sur mon disque externe je ne peux pas.
Y'a moyen de dire à Mint "reconnais ce disque jusqu'à la fin de tes jours et autorise tous les changements de permissions"? Ou mieux: "autorise toujours à tout le monde dans tous les cas tous les changements de permissions", voire "ouvre-moi toujours tout en tant qu'administrateur + root + tout ce qui est utile"?

Héhé. J'y arriverai. Grâce à vous!
Mint 18.1 Serena Mate

Avatar du membre
WarLocG
Messages : 96
Enregistré le : mer. 20 avr. 2016 18:39
Localisation : Belgique

Re: Certains fichiers ne peuvent pas être basculés en "lecture seule"

Messagepar WarLocG » mar. 21 mars 2017 00:11

Salut,

Comme je ne suis pas trop fan de la partie graphique, je laisserai cela aux autres helpers.

Je voulais surtout te demander, par rapport à ta deuxième image, celle avec les permissions. Il y a onglet juste après "ouvrir avec", dedans, est-ce que tes fichiers en .m3u sont associés à une application (comme par exemple vlc) ? Si ce n'est pas le cas, désigne une application par défaut pour cette extension (vlc fera l'affaire).

Bien à toi.

Avatar du membre
Rémi123
Messages : 38
Enregistré le : dim. 19 mars 2017 13:25

Re: Certains fichiers ne peuvent pas être basculés en "lecture seule"

Messagepar Rémi123 » mar. 21 mars 2017 00:20

Pas de souci, je suis déjà assez impressionné par la rapidité des réponses. Ca fait chaud au coeur.

Oui oui, c'est Clementine qui ouvre par défaut les fichiers .m3u, aucun problème de ce côté.

J'en profite pour préciser que quand, depuis mon dossier de playlists qui est dans mon disque dur externe, je copie une playlist sur mon bureau (qui lui est sur mon disque dur système), là j'arrive à changer les permissions sans problème, à décocher la case fatidique, et le problème disparaît: je double-clique et ma playlist se lance.

Merci à toi WarLocG, et encore une fois à mpat!
Mint 18.1 Serena Mate

Avatar du membre
WarLocG
Messages : 96
Enregistré le : mer. 20 avr. 2016 18:39
Localisation : Belgique

Re: Certains fichiers ne peuvent pas être basculés en "lecture seule"

Messagepar WarLocG » mar. 21 mars 2017 00:32

Je vois, c'est que ton disque dur externe a été monté en read-only (mount avec -o ro), ca peut se gérer dans /etc/fstab mais j'attend de voir si quelqu'un connaît une manière de faire "graphique" (avec un GUI) pour t'aider la dessus. :)

Bien à toi.

Avatar du membre
Rémi123
Messages : 38
Enregistré le : dim. 19 mars 2017 13:25

Re: Certains fichiers ne peuvent pas être basculés en "lecture seule"

Messagepar Rémi123 » mar. 21 mars 2017 23:37

Je veux bien du GUI en effet!

Mais je suis prêt à tous les compromis depuis que j'ai appris qu'on peut lancer du code par double-clic avec un lanceur, et lancer automatiquement n'importe-quel lanceur au démarrage: il me suffit de connaître le code pour monter mon disque dur externe de la bonne manière. Non?
Mint 18.1 Serena Mate

Avatar du membre
alain
Messages : 1847
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles

Re: Certains fichiers ne peuvent pas être basculés en "lecture seule"

Messagepar alain » mer. 22 mars 2017 04:14

Bonjour Rémi123.

Il existe "Disques" un petit utilitaire graphique (GUI) qui permet de gérer le montage des disques et de modifier les options de montage.
Mais avant de te lancer dans de telles manipes, il est préférable que tu sois bien sur de toi (risque de te tromper de disque, d'options, etc...).
La première chose à faire c'est de sauvegarder ton fichier "fstab", renseigne toi comment faire, ça te fera de l’entraînement. Regarde sur le forum
je pense que tu pourrais trouver des réponses. Sinon fait une recherche plus élargie sur internet.
Si tu as un doute n'hésites pas à poser la question ici.
Ensuite, quand le fstab est sauvegardé, ouvre "Disques" et familiarises toi avec sans appliquer de modifications.
Et vraiment si tu te sent (questionne ici au moindre doute), Vas y...

Sinon en une commande c'est fait (2 avec la sauvegarde préalable) :D . Je suis certain que WarLocK, se fera une joie de te la donner, si maniper avec le GUI n'est pas concluant.
PC1: CM : ASRock 990FX Extreme9 / CPU :AMD FX 8350-8 coeurs, 4 Ghz / RAM : Corsair 16 Go DDR3 1600 MHz
CG :Sapphire Radeon R9 290 Dual-X OC- 4 Go / SSD : Sandisk-120 Go / HDD : WD Red - 1To
ALIM : Corsair AX860W-Modulaire – Platinium / DVD : Samsung SH-224FB
OS : LMDE2 Betsy KDE / KERNEL : Linux 3.16.0-4
PC2 : Intel core 2 Duo E8500 @3.2 GHz, Linux Mint 17.3 Rosa KDE
PC3 : AMD Athlon 64 X2 4600+ @2.4 GHz, Debian 8.7 Jessie KDE


Retourner vers « Générale »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité