Résolu le 8-02-19 résolution max a 1024x768 sur une VM LMDE3 dans un hôte LMDE2 virtualbox

Assistance Générale
Avatar du membre
alain
Messages : 5791
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

résolution max a 1024x768 sur une VM LMDE3 dans un hôte LMDE2 virtualbox

Message par alain » ven. 1 févr. 2019 05:50

Bonjour à tous.

J'ai installer une VM virtualbox LMDE3 cinnamon, dans le but de la XFCEiser.
Ceci afin de voir si ça me conviendrait pour mon future OS principal.
Cette VM est faite dans un hôte LMDE2 cinnamon KDEisé, virtualbox 5.0.2.

Mon problème est que malgré tout mes efforts elle reste en résolution 1024x768 alors que j'ai un écran 1920x1080.

Après avoir appliqué les mises à jour j'ai tenté d'ajouter les additions invités:

Code : Tout sélectionner

Verifying archive integrity... All good.
Uncompressing VirtualBox 5.0.2 Guest Additions for Linux............
VirtualBox Guest Additions installer
Removing installed version 5.0.2 of VirtualBox Guest Additions...
Removing existing VirtualBox DKMS kernel modules ...done.
Removing existing VirtualBox non-DKMS kernel modules ...done.
Copying additional installer modules ...
Installing additional modules ...
Removing existing VirtualBox DKMS kernel modules ...done.
Removing existing VirtualBox non-DKMS kernel modules ...done.
Building the VirtualBox Guest Additions kernel modules
The headers for the current running kernel were not found. If the following
module compilation fails then this could be the reason.

Building the main Guest Additions module ...fail!
(Look at /var/log/vboxadd-install.log to find out what went wrong)
Doing non-kernel setup of the Guest Additions ...done.
Installing the Window System drivers
Warning: unknown version of the X Window System installed.  Not installing
X Window System drivers.
 ...done.
Installing graphics libraries and desktop services components ...done.
Press Return to close this window...
Je vois bien qu'il y a un problème de : "headers", oui mais le/les quel/s ?
celui de la VM?

Pour info:

Code : Tout sélectionner

alain@lmde3:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      61.00* 
   800x600       61.00  
   640x480       60.00
et:

Code : Tout sélectionner

alain@lmde3:~$ gtf 1920 1080 60
  # 1920x1080 @ 60.00 Hz (GTF) hsync: 67.08 kHz; pclk: 172.80 MHz
  Modeline "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
et:

Code : Tout sélectionner

alain@lmde3:~$ xrandr --newmode "1920x1080_60.00"  172.80  1920 2040 2248 2576  1080 1081 1084 1118  -HSync +Vsync
xrandr: Failed to get size of gamma for output default
et enfin, j'ai tout de même tenté sans y croire:

Code : Tout sélectionner

alain@lmde3:~$ xrandr --addmode HDMI1 "1920x1080_60.00"
xrandr: Failed to get size of gamma for output default
xrandr: cannot find output "HDMI1"
Je n'ai pas activé cette résolution, ça ne servait a rien, vu les retours :l

A noter qu'avec mes 5 autres VMs je n'ai pas ce soucis.

Pour vous donner une idée du problème, quelques captures:

Voyez, il y a de la marge :l . je ne peux raisonnablement faire mes tests dans de pareilles conditions, non? :roll:
Image

Image

Image

même en mettant 128Mo c'est pareil...
Image

Je suis a votre disposition, pour plus amples informations. Toutefois je ne serai pas très dispo
ce WE, ce qui vous laisse 3 jours entiers pour cogiter la dessus :l :D

Dans l'attente de vos propositions de solutions.
Bien cordialement.
Votre dévoué, alain.

PS: je ne tiens pas à changer de version de virtualbox, car cela m'obligerai à refaire toutes
mes VMs qui elles fonctionnent bien. (Oui car j'ai tenté, un vdi fait sur 5.0.2, ne fonctionne pas sur
une version supérieure...)
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2018/09/ ... 8c173d.png

Avatar du membre
cyrille
Messages : 2034
Enregistré le : mar. 19 sept. 2017 08:49
Localisation : Nord - Avesnois
Contact :

Re: résolution max a 1024x768 sur une VM LMDE3 dans un hôte LMDE2 virtualbox

Message par cyrille » ven. 1 févr. 2019 08:48

Salut Alain,
Pour ta réso avec VB tu peux essayer un truc du style :

Code : Tout sélectionner

 "VBoxManage controlvm "NomDeMachineVirtuelle" setvideomodehint 1024 600 32"

afin de forcer la réso.
Par contre, pas sûr de moi...
# Perso : Laptop DELL Latitude E5430, SSD, 64-bit, RAM 8Go [ FreeBSD 12.0, xfce / Openbox ; DEBIAN SID via VirtualBox]
# ---
# Serveur HP ProLiant ML 310e Gen 8 v2, DEBIAN STRETCH 9.4, 64-bit
# Parc de Laptops DELL LATITUDE E6*** sous LINUX MINT, 18.3 Sylvia, 64-bit, XFCE.

Avatar du membre
L5d
Messages : 842
Enregistré le : sam. 25 juil. 2015 01:14
Localisation : Entre le clavier et la chaise
Contact :

Re: résolution max a 1024x768 sur une VM LMDE3 dans un hôte LMDE2 virtualbox

Message par L5d » ven. 1 févr. 2019 23:04

Bonjour Alain,
pour ton soucis, je testerais les réglages suivants :
dans l'écran de ta 4ème capture :
Mémoire vidéo : 12 Mo (pour du 1920*1080, il faut au moins 2 Mo en noir et blanc, 6 Mo pour de la couleur car chaque pixel est codé sur 256 niveaux en RGB).
Accélération : cocher 2D, tester aussi en décochant 3D.
Mon micro de Bureau :
Linux Mint 17.3 Rosa 64 Cinnamon, Kernel: 3.13.0-139-lowlatency ou 4.4.0-22 patché pour SBZ ou 4.4.0-98-generic, CG Zotac GTX 750 Ti (pilote NVidia 384.98), Canon MG7150, SSD 240 Go, DD 2 To, HDD externe 320 Go, Boot aussi sur Win 7 Pro 64 sp1, Scanner à plat Relisys Scorpio fonctionnel sous Mint 17.3 --- https://www.lilo.org/fr et https://www.mobicoop.fr/

Avatar du membre
alain
Messages : 5791
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: résolution max a 1024x768 sur une VM LMDE3 dans un hôte LMDE2 virtualbox

Message par alain » sam. 2 févr. 2019 04:45

Salut Cyrille et L5d.

Cyrile, je teste ça dès que j'ai la possibilité de démarrer l'ordi et la VM concernés. Merci ;)

L5d, j'ai testé avec ou sans 3D, avec 2D en plus, sans 2D, enfin toutes les combinaisons
Possibles: Idem.
En revanche, je n'ai fait que d'augmenter la mèmoire vidéo, il ne m'est pas venu à l'idée
de la baisser (je me disais, qui peut le plus , peut le moins :l ). Donc idem que ma réponse
à Cyrille, je teste dès que possible. ( ça me parrait étrange quand même de diminuer la mémoire
pour que ça marche mieux, mais bon c'est une idée ;)
). merci ;)

Tous: Je rappelles que j'ai un problème avec les additions invité, voir les retours de l'installation:
alain a écrit :
ven. 1 févr. 2019 05:50
Après avoir appliqué les mises à jour j'ai tenté d'ajouter les additions invités:

Code : Tout sélectionner

Verifying archive integrity... All good.
Uncompressing VirtualBox 5.0.2 Guest Additions for Linux............
VirtualBox Guest Additions installer
Removing installed version 5.0.2 of VirtualBox Guest Additions...
Removing existing VirtualBox DKMS kernel modules ...done.
Removing existing VirtualBox non-DKMS kernel modules ...done.
Copying additional installer modules ...
Installing additional modules ...
Removing existing VirtualBox DKMS kernel modules ...done.
Removing existing VirtualBox non-DKMS kernel modules ...done.
Building the VirtualBox Guest Additions kernel modules
The headers for the current running kernel were not found. If the following
module compilation fails then this could be the reason.

Building the main Guest Additions module ...fail!
(Look at /var/log/vboxadd-install.log to find out what went wrong)
Doing non-kernel setup of the Guest Additions ...done.
Installing the Window System drivers
Warning: unknown version of the X Window System installed.  Not installing
X Window System drivers.
 ...done.
Installing graphics libraries and desktop services components ...done.
Press Return to close this window...
Je vois bien qu'il y a un problème de : "headers", oui mais le/les quel/s ?
celui de la VM?
J'ai fort l'impression que les deux sont liés...
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2018/09/ ... 8c173d.png

Avatar du membre
L5d
Messages : 842
Enregistré le : sam. 25 juil. 2015 01:14
Localisation : Entre le clavier et la chaise
Contact :

Re: résolution max a 1024x768 sur une VM LMDE3 dans un hôte LMDE2 virtualbox

Message par L5d » sam. 2 févr. 2019 20:15

Bonsoir Alain,
Dans la VM LMDE3, peux-tu faire un retour de "inxi -G" , et pareil dans une autre de tes VM qui fonctionnent sur la même LMDE2 ?
pour LMDE3, il te faut peut-être une option "-nomodeset" au démarrage, ou un "-forcevesa" (je ne te fait pas l'affront de te dire comment et où mettre ça :l , tu le sais mieux que moi) :mrgreen: .
Mon micro de Bureau :
Linux Mint 17.3 Rosa 64 Cinnamon, Kernel: 3.13.0-139-lowlatency ou 4.4.0-22 patché pour SBZ ou 4.4.0-98-generic, CG Zotac GTX 750 Ti (pilote NVidia 384.98), Canon MG7150, SSD 240 Go, DD 2 To, HDD externe 320 Go, Boot aussi sur Win 7 Pro 64 sp1, Scanner à plat Relisys Scorpio fonctionnel sous Mint 17.3 --- https://www.lilo.org/fr et https://www.mobicoop.fr/

Avatar du membre
alain
Messages : 5791
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: résolution max a 1024x768 sur une VM LMDE3 dans un hôte LMDE2 virtualbox

Message par alain » mar. 5 févr. 2019 06:58

Bonjour.

@ Cyrille. J'ai entré ta commande:

Code : Tout sélectionner

alain@lmde2 ~ $  VBoxManage controlvm lmde3 setvideomodehint 1920 1080 60
VBoxManage: error: Machine 'lmde3' is not currently running
j'ai donc démarré la VM:

Code : Tout sélectionner

alain@lmde2 ~ $  VBoxManage controlvm lmde3 setvideomodehint 1920 1080 60
alain@lmde2 ~ $ 
Mais rien ne se passe, aucun changement dans les paramètres de la VM :?
Arrêt, puis redémarrage: Idem...

@L5d: j'ai tenté de mettre seulement 12 Mo de mémoire vidéo : Idem
J'ai aussi réessayé avec 2D coché avec ou sans 3D : Idem

Inxi-G sur la VM LMDE3:

Code : Tout sélectionner

alain@lmde3:~$ inxi -G
Graphics:  Card: InnoTek Systemberatung VirtualBox Graphics Adapter
           Display Server: X.Org 1.19.2 drivers: vesa (unloaded: modesetting,fbdev)
           Resolution: 1024x768@61.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.9, 128 bits)
           GLX Version: 3.0 Mesa 13.0.6
alain@lmde3:~$ 
Inxi -G sur la VM solydX (la plus proche de lmde):

Code : Tout sélectionner

alain@solydxk:~$ inxi -G
Graphics:  Card: InnoTek Systemberatung VirtualBox Graphics Adapter
           Display Server: X.Org 1.19.2 drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x949@59.96hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.9, 128 bits)
           GLX Version: 3.0 Mesa 13.0.6
alain@solydxk:~$ 
Je vois que la différence est au niveau de vesa et modesetting...

J'ai contrôlé les deux grub, celui de la lmde3 et celui de la solydX, ils sont totalement identiques.

Du coup j'ai essayé de modifier le grub en supprimant "quiet splash" (chose que je fait sur mes installes en dur,
car j'aime quand ça cause) et en ajoutant : modeset=1, nomodeset...Rien n' y fait et inxi -G me renvoit toujour vesa
en driver...

La nuit prochaine, je vais essayer d'autre modifs du grub de la VM, mais vous voulez que je vous dise le fond
de ma pensé? Et bien, je pense que ce problème de résolution et de driver graphique utilisé, vient du fait
que je n'arrive pas a installer les additions invité, donc peut être le driver virtualbox qui va avec...M'enfin, c'est
qu'une idée, je peux me tromper... :l
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2018/09/ ... 8c173d.png

Avatar du membre
Mia88
Messages : 529
Enregistré le : ven. 18 nov. 2016 08:42
Localisation : Lorraine

Re: résolution max a 1024x768 sur une VM LMDE3 dans un hôte LMDE2 virtualbox

Message par Mia88 » mar. 5 févr. 2019 11:57

Bonjour Alain,
alain a écrit :
mar. 5 févr. 2019 06:58
Et bien, je pense que ce problème de résolution et de driver graphique utilisé, vient du fait
que je n'arrive pas a installer les additions invité, donc peut être le driver virtualbox qui va avec...M'enfin, c'est
qu'une idée, je peux me tromper... :l
Je ne pense pas que tu te trompes, j'ai souvent rencontré ce genre de soucis avec additions invités, ils devraient être intégrés à partir du noyau 4.16, ça évitera bien des prises de tête
https://www.linuxrouen.fr/wp/logiciels- ... -16-21090/

Il y a ces commandes qui fonctionnent parfois, mais tu les as sans doute déjà essayées :

Code : Tout sélectionner

apt-get install linux-headers-$(uname -r)
ou encore

Code : Tout sélectionner

sudo apt-get install build-essential linux-headers-`uname -r` dkms
et celle-ci que je n'ai jamais testée :

Code : Tout sélectionner

sudo apt-get update && sudo apt-get install build-essential linux-headers-$(uname -r) module-assistant -y && sudo apt-get -q -y -f build-dep virtualbox-guest-x11 && sudo m-a prepare
PC 1 - Mint Cinnamon 19.1 64-bits / Intel Xeon CPU E3-1270 V2 3.5GHz x 4 / Ram 15.6 Go / CG NVIDIA GF106GL [Quaro 2000]
PC 2 - Mint Cinnamon 18.3 64 bits / Intel Core i7-2600 CPU @ 3.40GHz x 4 / Ram 15.6 Go / CG Advanced Micro Devices, inc. [AMD/ATI] Hawaii XT [Radeon R9 290X] (prog-if 00[VGA controller])
VB : LMDE3, openSUSE, Solus, Nutyx, Slackware, Manjaro, TrueOS BSD, MX-17, Peppermint, Calculate, DFLinux, Debian, Mageia, ArchLinux, Antix, Fedora, Deepin, SolydX, Q4OS

Avatar du membre
alain
Messages : 5791
Enregistré le : dim. 11 oct. 2015 23:41
Localisation : Chelles
Contact :

Re: résolution max a 1024x768 sur une VM LMDE3 dans un hôte LMDE2 virtualbox

Message par alain » mar. 5 févr. 2019 19:03

Bonjour Mia.
Mia88 a écrit :
mar. 5 févr. 2019 11:57
Je ne pense pas que tu te trompes
Merci ;) . Enfin quelqu'un qui me comprend, ça fait plaisir :D

Donc oui comme dit depuis mon premier post, je suspectais aussi le "header".
J'avais contrôlé sa non-présence et installé.
Mais ayant un doute sur le numéro de version, j'ai fait tes commandes, avec le "uname -r" au moins
on est sur de la version.
Les deux premières m'ont répondu que le header était bien installé, je n'avais pas fait d'erreur.

Quand à ta troisième commande, je vois quelle installe des trucs en plus du header: "module-assistant" ET
"virtualbox-guest-x11". C'est la que le bât blesse, car si "module-assistant" semble bien s'installer, pour "virtualbox-guest-x11"
ça me répond qu'il me manque le dépôt nécessaire.
Je me suis dit, que vu qu'il n' y a pas de problème avec solydX, je vais comparer les sources.list.
Voici ce que ça donne:

Code : Tout sélectionner

alain@lmde2 ~/linux/debian-LMDE $ cat sources-solydx.list
deb https://repository.solydxk.com solydxk-9 main upstream import
deb http://deb.debian.org/debian stretch main contrib non-free
deb http://security.debian.org stretch/updates main contrib non-free
deb http://deb.debian.org/debian stretch-updates main contrib non-free

alain@lmde2 ~/linux/debian-LMDE $ cat official-package-repositories.list
deb http://packages.linuxmint.com cindy main upstream import backport #id:linuxmint_main
deb https://deb.debian.org/debian stretch main contrib non-free
deb https://deb.debian.org/debian stretch-updates main contrib non-free
deb http://security.debian.org stretch/updates main contrib non-free
deb http://www.deb-multimedia.org stretch main non-free
alain@lmde2 ~/linux/debian-LMDE $ 

Comme on peut le voir, au niveau des dépôts debian, c'est identique, il n' y a que les dépôts spécifiques,
"solidX" et "linuxmint" de différents (plus celui pour les codecs proprio sur la lmde3).
Donc, nous avons le droit de supposer que ce qui manque dans les dépôts de LMDE3 est dans ceux
de spécifiques à solydX.
Oui...Mais quoi?
Est-ce que je peux/dois installer "virtualbox-guest-x11", à la main, sachant qu'il n'est pas dans les dépôts LMDE3?
In a world without walls and fences, who needs windows and gates?
Image
Taille réelle : https://www.fflmpics.fr/images/2018/09/ ... 8c173d.png

Avatar du membre
Mia88
Messages : 529
Enregistré le : ven. 18 nov. 2016 08:42
Localisation : Lorraine

Re: résolution max a 1024x768 sur une VM LMDE3 dans un hôte LMDE2 virtualbox

Message par Mia88 » mer. 6 févr. 2019 12:31

Bonjour Alain,
alain a écrit :
ven. 1 févr. 2019 05:50
PS: je ne tiens pas à changer de version de virtualbox, car cela m'obligerai à refaire toutes
mes VMs qui elles fonctionnent bien. (Oui car j'ai tenté, un vdi fait sur 5.0.2, ne fonctionne pas sur
une version supérieure...)
Je ne suis pas très compétente, je vais sûrement dire des bêtises...

Dans le terminal que tu as posté on peut lire :

- vérif de l'archive
- décompression des Additions 5.0.2

- suppression version 5.0.2 des Additions --> c'était la même version
- suppression des modules DKMS et non-DKMS existants

- copie et installation de modules additionels
- suppression des modules DKMS et non-DKMS --> encore ?!

- construction des modules des Additions
- et là les entêtes ne sont pas trouvées

Puis il t'es demandé de voir ce qui se passe dans /var/log/vboxadd-install.log, tu n'as rien remarqué de particulier ?
Si ça peut t'aider, je viens d'ajouter une VM LMDE3 dans Mint Cinnamon 19.1 que j'ai récupérée depuis mon autre pc sous Mint 18.3.
Il y a ça dans le fichier (pas pu faire autrement pour les balises code) :

Image
alain a écrit :
mar. 5 févr. 2019 19:03
Est-ce que je peux/dois installer "virtualbox-guest-x11", à la main, sachant qu'il n'est pas dans les dépôts LMDE3?
Désolée, mais je n'ai pas les compétences pour te répondre :oops:
Au pire tu peux essayer et restaurer une sauvegarde si ça n'a pas fonctionné.

Puisque tu évoques Solydxk, j'ai ajouté la même VM SolydK sur 2 pc et malgré l'aide de la communauté, elle buggait à l'ouverture sur l'un d'eux (celui qui possède une carte radeon et apparemment c'est la raison). SolydX passait par contre, moins capricieux que KDE.

Si tu veux que je fasses des essais dans ma VM, n'hésite pas, mais vu que l'hôte est différent du tien, ça risque de ne pas être très utile.
PC 1 - Mint Cinnamon 19.1 64-bits / Intel Xeon CPU E3-1270 V2 3.5GHz x 4 / Ram 15.6 Go / CG NVIDIA GF106GL [Quaro 2000]
PC 2 - Mint Cinnamon 18.3 64 bits / Intel Core i7-2600 CPU @ 3.40GHz x 4 / Ram 15.6 Go / CG Advanced Micro Devices, inc. [AMD/ATI] Hawaii XT [Radeon R9 290X] (prog-if 00[VGA controller])
VB : LMDE3, openSUSE, Solus, Nutyx, Slackware, Manjaro, TrueOS BSD, MX-17, Peppermint, Calculate, DFLinux, Debian, Mageia, ArchLinux, Antix, Fedora, Deepin, SolydX, Q4OS

Avatar du membre
arghlub
modérateur
Messages : 5514
Enregistré le : dim. 21 mai 2017 08:19
Localisation : Provence
Contact :

Re: résolution max a 1024x768 sur une VM LMDE3 dans un hôte LMDE2 virtualbox

Message par arghlub » mer. 6 févr. 2019 21:49

Salut Alain ;)

Après avoir installé les "guest-additions", as- tu essayé de configurer VBox via le menu «Fichier>Paramètres» (avec la VM LMDE3 lancée) ?
Dans la fenêtre qui s'ouvre, dans l'onglet «Affichage», pour «Taille d'écran de l'invité maximale» enlève «Automatique» et mets «Aucune» ou «Indication».

Ensuite l'affichage de LMDE3 devrait s'adapter à la taille de la fenêtre de virtualBox.
En tout cas chez moi ça marche :
Image
quelquesPCs : Tour (custom)CM MSI Z270 M3 | CPU Intel I7-7700K | CG Nvidia GTX 1080 | RAM 16Go DDR4 3GHz | tripleBoot : Debian 9 | MXlinux | LMint 19.1 Tessa | XFCE
Portable Lenovo G50-80 (boosté RAM+SSD) | CPU Intel I3-4005U | RAM 8Go | tripleBoot avec “/data” commune : LMint 18.3 Sylvia | MXlinux | LMint 19.1 | XFCE (pour les 3)
────────────────────────────────────
... pour une informatique libre ! -membre de l'April

Répondre